Ergebnis 1 bis 12 von 12

Thema: Immer wieder Bluescreens und Abstürze

  1. #1
    Garrettx40
    kennt sich schon aus

    Immer wieder Bluescreens und Abstürze

    Hallo Zusammen,

    ich melde mich heute noch einmal an euch, da die Probleme aus meinem vorigen Beitrag leider wieder aufgetreten sind. Mein PC gibt mir immer wieder Bluescreens oder friert einfach direkt ein. Es gibt auch keine bestimmten Aktionen die als Auslöser in Frage kämen, die Bluescreens kommen vollkommen willkürlich. Folgende Maßnahmen wurden schon von mir unternommen:

    - Virenprüfung mit TotalAV ergab keine Treffer
    - Malware und Adware wurden ebenfalls überprüft
    - Memtest lief Problemlos und zeigte selbst nach 3 Stunden (3x Parallel) keine Errors
    - Grafikkartentreiber ist auf dem neuesten Stand (mehrmals deinstalliert und neu installiert)
    - Windows 10 upgrade aufgespielt (ehemals Win 7)

    Alle notwendigen Dateien (DXDiag, minidump etc. befinden sich im Anhang.
    Angehängte Dateien Angehängte Dateien

  2.   Anzeige

     
  3. #2
    Ari45
    gehört zum Inventar Avatar von Ari45

    AW: Immer wieder Bluescreens und Abstürze

    Guten Morgen @Garrettx40!
    Die drei neuesten Dumpfile weisen einen Fehler mit einem USB-Gerät auf.
    Beispiel aus Dumpfile 081020-13593-01.dmp, Auszug aus dem Stack:
    usbohci!OHCI_ProcessDoneAsyncTd+0x36
    Die nächste Funktion ist
    nt!KiGeneralProtectionFault+0x320

    Beispiel aus Dumpfile 081020-18031-01.dmp, Auszug aus dem Stack:
    usbehci!EHCI_sMode_PollEndpointSlot+0x78 // Zugriff auf den USB-Port
    USBPORT!USBPORTSVC_MapHwPhysicalToVirtual+0x17f26
    nt!KeBugCheckEx // die Folge ist der Absturz

    Da sind mindestens noch zwei weitere Dumpfiles, die einen USB-Fehler ausweisen.

    Allerdings könnten die Fehler hausgemacht sein:
    In Dumpfile 081020-12656-01.dmp war die Absturzursache des Driverbooster:
    verborgener Text:
    !thread
    THREAD ffffd20d4bdb2500 Cid 1d60.2368 Teb: 00000000002ad000 Win32Thread: ffffd20d55e72d20 RUNNING on processor 1
    Not impersonating
    GetUlongFromAddress: unable to read from fffff8022222ca14
    Owning Process ffffd20d564f5080 Image: DriverBooster.
    Attached Process N/A Image: N/A
    fffff78000000000: Unable to get shared data
    Wait Start TickCount 3138
    Context Switch Count 8269 IdealProcessor: 2
    ReadMemory error: Cannot get nt!KeMaximumIncrement value.
    UserTime 00:00:00.000
    KernelTime 00:00:00.000
    Win32 Start Address 0x000000000077f724
    Stack Init ffffa40aff787fd0 Current ffffa40b024ae790
    Base ffffa40aff788000 Limit ffffa40aff782000 Call 0000000000000000
    Priority 11 BasePriority 8 PriorityDecrement 2 IoPriority 2 PagePriority 4


    Driverbooster ist immer eine sehr schlechte Idee, wie alle anderen Treiber-Tools. Diese jubeln einem auch ganz gern mal falsche oder "kastrierte" Treiber unter.
    Treiber holt man immer direkt und persönlich beim Hersteller der Hardware ab.

    Als nächstes:
    Es wird AVIRA benutzt. Bekanntermaßen bereiten Drittanbieter-AV-Software unter Windows 10 Probleme.
    Wahrscheinlich hat dir AVIRA sogar die letzten Windows-Updates verhindert, denn dein Windows ist keinesfalls aktuell.
    Installiert ist : 10.0.18362.1034
    Aktuell ist : 10.0.19041.423
    Bitte deinstalliere AVIRA und benutze anschließend das Bereinigungstool von AVIRA.
    Avira RegistryCleaner: Download der Software | Avira
    (nicht erschrecken, der Download läuft sofort los)
    Geändert von Ari45 (10.08.2020 um 08:26 Uhr) Grund: mehrere Schreibfehler beseitigt

  4. #3
    skorpion68
    gehört nicht zum Inventar Avatar von skorpion68

    AW: Immer wieder Bluescreens und Abstürze

    Zitat Zitat von Ari45
    Wahrscheinlich hat dir AVIRA sogar die letzten Windows-Updates verhindert, denn dein Windows ist keinesfalls aktuell.
    Auch dieser Aussage kann ich nicht zustimmen, installiert ist Build 18363.959 (KB4565483, 15.07.2020). Hier sei erwähnt, dass viele Nutzer bislang noch gar nicht auf Windows 10 2004 aktualisieren können da sie folgenden Screen unter Windows Update zu sehen bekommen:



    Für Windows 10 1909 gilt derzeit folgendes:

    - Serviceende, 11. Mai 2021 - Informationsblatt zum Lebenszyklus von Windows - Windows Help

    - Hardwareebene = 24. März 2020 – KB4541335 (Betriebssystembuilds 18362.752 und 18363.752)
    - Sicherheitsebene = 14. Juli 2020 – KB4565483 (Betriebssystembuilds 18362.959 und 18363.959)
    - Vorschauebene = 21. Juli 2020 – KB4559004 (BS-Builds 18362.997 und 18363.997)

    PS: Hatte dies aber bereits hier AW: kann uefi nicht erreichen und hier AW: Keine automatisierte Anmeldung mit schon einmal erwähnt.

  5. #4
    Garrettx40
    kennt sich schon aus

    AW: Immer wieder Bluescreens und Abstürze

    Selbstverständlich gab es einen Lerneffekt... anderer Virenscanner, keinerlei AVG Programme mehr und gegen den USB Fehler kann ich nichts machen, da alle Treiber auf dem neuesten Stand sind und keins der USB Anschlüsse einen Defekt aufweist.
    Ich freue mich über jede Hilfe, aber bitte keinen unangebrachten Unterstellungen.
    Die Festplatten wurden alle schon mehrfach durchgetestet und einzelnd abgesteckt, fallen also als Fehlerquelle raus (die Kabel werde ich aber trotzdem ersetzen, danke für den Tipp).

    Was kann ich denn gegen diese USB-Fehler unternehmen? Laut Geräte Manager werden mir 12 verschiedene USB Geräte angezeigt und keines davon mit Ausrufezeichen.

    Andere Frage: Ein Bluescreen mit "PAGE_FAULT_IN_NONPAGED_AREA" hat mit der Registry zu tun oder? Kann man diese irgendwie reparieren? (minidump im Anhang)
    Angehängte Dateien Angehängte Dateien
    Geändert von Garrettx40 (15.08.2020 um 11:57 Uhr)

  6. #5
    Ari45
    gehört zum Inventar Avatar von Ari45

    AW: Immer wieder Bluescreens und Abstürze

    Hallo @Garrettx40!
    Wie kommst du darauf, dass "PAGE_FAULT_IN_NONPAGED_AREA mit der Registry zu tun hat?
    Hier die kurze Beschreibung von MS zu diesem Stoppfehler:
    PAGE_FAULT_IN_NONPAGED_AREA (50)
    Invalid system memory was referenced. This cannot be protected by try-except.
    Typically the address is just plain bad or it is pointing at freed memory.
    Also ein fehlerhafter Aufruf des System-Memory. In der Regel passiert das durch falsche oder fehlerhafte Treiber.
    Hier mal ein Auszug aus dem Debugger-Log
    verborgener Text:
    PROCESS_NAME: svchost.exe
    // also ein Dienst hat den Fehler verursacht, denn svchost.exe ist der zugehörige Prozess
    ...
    TRAP_FRAME: ffff848a6ee52ff0 -- (.trap 0xffff848a6ee52ff0)
    NOTE: The trap frame does not contain all registers.
    Some register values may be zeroed or incorrect.
    rax=ff00f8040b925d70 rbx=0000000000000000 rcx=ffffcd090f63b850
    rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000000
    rip=fffff8040b9512f9 rsp=ffff848a6ee53188 rbp=ffff848a6ee53310
    r8=ffffcd0907fb6e01 r9=0000000000000000 r10=0000ff00f8040b92
    r11=ffffd479ce200000 r12=0000000000000000 r13=0000000000000000
    r14=0000000000000000 r15=0000000000000000
    iopl=0 nv up ei pl nz ac pe nc
    fffff804`0b9512f9 4d0fa313 bt qword ptr [r11],r10 ds:ffffd479`ce200000=????????????????
    Das ist der auslösende Stackframe. Man sieht, dass aus den Datensegment Speichermüll ausgelesen (???????) wurde
    ....
    // und hier der vollständige Stack; von unten nach oben lesen
    STACK_TEXT:
    ffff848a`6ee52d48 fffff804`089ecf1a : nt!KeBugCheckEx
    ffff848a`6ee52d50 fffff804`0885875f : nt!MiSystemFault+0x1c5aba
    ffff848a`6ee52e50 fffff804`089d041e : nt!MmAccessFault+0x34f
    ffff848a`6ee52ff0 fffff804`0b9512f9 : nt!KiPageFault+0x35e
    // wegen auslesen von Speichermüll kommt es zum Speicherseitenfehler
    und in der Folge zum SystemFault

    ffff848a`6ee53188 fffff804`0b8e35c9 : 0xfffff804`0b9512f9
    // der Filtermanager setzt diese Funktion in Bewegung, die wahrscheinlich zu einen Antivirenprogramm gehört
    ffff848a`6ee53190 fffff804`0b8e5680 : FLTMGR!FltpPassThroughCompletionWorker+0x2e9
    ffff848a`6ee53210 fffff804`0b91cd27 : FLTMGR!FltpLegacyProcessingAfterPreCallbacksCompleted+0x200
    ffff848a`6ee53290 fffff804`08899ed9 : FLTMGR!FltpCreate+0x307
    // der Treiber beauftragt den Filtermanager
    ffff848a`6ee53340 fffff804`08898f94 : nt!IofCallDriver+0x59
    ffff848a`6ee53380 fffff804`08e04cab : nt!IoCallDriverWithTracing+0x34
    // ein Treiber wird aufgerufen
    ffff848a`6ee533d0 fffff804`08e0bc7f : nt!IopParseDevice+0x62b
    ffff848a`6ee53540 fffff804`08e0a0e1 : nt!ObpLookupObjectName+0x78f
    ffff848a`6ee53700 fffff804`08e884f6 : nt!ObOpenObjectByNameEx+0x201
    // ein Objekt wird angesprochen
    ffff848a`6ee53840 fffff804`089d3c18 : nt!NtQueryAttributesFile+0x1e6
    ffff848a`6ee53b00 00007fff`2fe7c814 : nt!KiSystemServiceCopyEnd+0x28
    // ein Systemdienst wird aufgerufen
    0000006f`673fe0e8 00000000`00000000 : 0x00007fff`2fe7c814

    Es ist also zu sehen, dass der Dienst Filtermanager eine Suche filtern soll und dann durch falsche Aufrufparameter zum Stoppfehler kommt.

    In der Modulliste habe ich gesehen, dass immer noch AVIRA installiert. Dieses beauftragt den Filtermanager nach bestimmten Kriterien zu suchen. Und wie man weiter oben sieht, wird Speichermüll übergeben.
    Es muss also zum Absturz kommen.
    Nochmal meine Bitte aus Antwort #2: bitte deinstalliere AVIRA mit dem zugehörigen Bereinigungs-Tool von AVIRA.

  7. #6
    Garrettx40
    kennt sich schon aus

    AW: Immer wieder Bluescreens und Abstürze

    Avira Bereinigungstool runtergeladen und arbeiten lassen. Auch wenn ich mir sicher bin, dass kein Avira auf dem Rechner ist.

    Hier nochmal die aktuellen von heute... USB Bugcode
    Angehängte Dateien Angehängte Dateien

  8. #7
    Porky
    gehört zum Inventar Avatar von Porky

    AW: Immer wieder Bluescreens und Abstürze

    Problemkinder könnten die beiden Etron EJ168 USB3.0 Host Controller sein, für die ich bis jetzt keinen Windows 10 Treiber gefunden habe. Möglicherweise sind da die Windows 7 Treiber übernommen worden. Deinstalliere die mal mit gesetztem Häkchen „Treibersoftware löschen”. Danach Neustart. Vielleicht funktionieren die mit dem nativen Windows 10 Treiber.

  9. #8
    Ari45
    gehört zum Inventar Avatar von Ari45

    AW: Immer wieder Bluescreens und Abstürze

    Guten Abend zusammen!
    In Dumpfile 082620-14703-01.dmp von 18:17 Uhr war eine fehlerhafte USB-Adresse die Ursache.
    verborgener Text:
    BUGCODE_USB_DRIVER (fe)
    USB Driver bugcheck, first parameter is USB bugcheck code.
    Arguments:
    Arg1: 0000000000000005, USBBUGCODE_INVALID_PHYSICAL_ADDRESS The host controller is
    using a physical memory address that was not allocated by
    the USBport driver.
    Arg2: ffff8b8f22db01a0, Device extension pointer of the host controller
    Arg3: 0000000010024396, PCI Vendor,Product id for the controller
    Arg4: ffff8b8f252aeb38, Pointer to Endpoint data structure
    ....
    PROCESS_NAME: Update.exe
    ....
    // der letzte Stack
    kn
    # Child-SP RetAddr Call Site
    00 fffff805`54091a48 fffff805`58eaf356 nt!KeBugCheckEx
    01 fffff805`54091a50 fffff805`58f25ff0 USBPORT!USBPORTSVC_MapHwPhysicalToVirtual+0x17f26
    02 fffff805`54091aa0 fffff805`58e91653 usbehci!EHCI_PollEndpoint+0x140
    03 fffff805`54091b00 fffff805`58e91159 USBPORT!USBPORT_iSetGlobalEndpointStateTx+0x1b3
    04 fffff805`54091b60 fffff805`58e976fd USBPORT!USBPORT_Core_UsbHcIntDpc_Worker+0x309
    05 fffff805`54091bc0 fffff805`4ee5070a USBPORT!USBPORT_Xdpc_Worker_HcIntDpc+0x17d
    06 fffff805`54091c40 fffff805`4ee4fd5f nt!KiExecuteAllDpcs+0x30a
    07 fffff805`54091d80 fffff805`4efc93c5 nt!KiRetireDpcList+0x1ef
    08 fffff805`54091fb0 fffff805`4efc91b0 nt!KxRetireDpcList+0x5
    09 fffff881`240fbac0 fffff805`4efc8a65 nt!KiDispatchInterruptContinue
    0a fffff881`240fbaf0 fffff805`4efc36f1 nt!KiDpcInterruptBypass+0x25
    0b fffff881`240fbb00 00000000`73b8d6df nt!KiChainedDispatch+0xb1
    0c 00000000`0118e0d4 00000000`00000000 0x73b8d6df

    Beim Update wurde für einen USB-Port eine falsche Adresse angegeben.
    Die fehlerhafte Funktion ist usbehci!EHCI_PollEndpoint+0x140
    Also entweder der USB-Port-Treiber ist korrupt oder ein angeschlossenes USB-Gerät ist defekt.

    In Dumpfile 082620-16718-01.dmp von 17:52 Uhr hat der AMD-Prozessortreiber den Fehler verursacht.
    verborgener Text:
    DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1)
    An attempt was made to access a pageable (or completely invalid) address at an
    interrupt request level (IRQL) that is too high. This is usually
    caused by drivers using improper addresses.
    If kernel debugger is available get stack backtrace.
    Arguments:
    Arg1: ffffa2fdbba00038, memory referenced
    Arg2: 00000000000000ff, IRQL
    Arg3: 0000000000000025, value 0 = read operation, 1 = write operation
    Arg4: fffff8032a3093b2, address which referenced memory
    ....
    TRAP_FRAME: fffff8032568a590 -- (.trap 0xfffff8032568a590)
    NOTE: The trap frame does not contain all registers.
    Some register values may be zeroed or incorrect.
    rax=fffff8032a3093e1 rbx=0000000000000000 rcx=ffffa086ca1e2b70
    rdx=0000000000000001 rsi=0000000000000000 rdi=0000000000000000
    rip=fffff8032a3093b2 rsp=fffff8032568a728 rbp=0000000000000000
    r8=fffff8032568a760 r9=fffff8032568a768 r10=0000fffff8032a30
    r11=ffffa2fdbba00000 r12=0000000000000000 r13=0000000000000000
    r14=0000000000000000 r15=0000000000000000
    iopl=0 nv up di pl zr na po nc
    amdppm!PerfSelectionPTStates+0x32:
    fffff803`2a3093b2 4d8b4338 mov r8,qword ptr [r11+38h] ds:ffffa2fd`bba00038=????????????????
    // der AMD-Prozessortreiber hat Speichermüll (?????) aus dem Datensegment ausgelesen
    // hier der zugehörige Stack

    kn
    # Child-SP RetAddr Call Site
    00 fffff803`2568a448 fffff803`213d41e9 nt!KeBugCheckEx
    01 fffff803`2568a450 fffff803`213d0529 nt!KiBugCheckDispatch+0x69
    02 fffff803`2568a590 fffff803`2a3093b2 nt!KiPageFault+0x469
    03 fffff803`2568a728 00000000`00000000 amdppm!PerfSelectionPTStates+0x32


    Entweder der Prozessortreiber amdppm.sys ist defekt oder der RAM ist fehlerhaft, also defekt.

    Zitat Zitat von Garrettx40
    Avira Bereinigungstool runtergeladen und arbeiten lassen. Auch wenn ich mir sicher bin, dass kein Avira auf dem Rechner ist.
    AVGNtflt.sys = Avira AntiVir Guard Network Minifilter Driver
    AviPBb.sys = Avira Antivirus Program Backbone Driver
    avkmgr.sys = Avira Manager Driver
    Diese drei AVIRA-Treiber sind auch in der Modulliste der letzten Dump-File (082620-14703-01.dmp) zu finden.
    Also sind doch noch Reste von AVIRA auf dem System.

  10. #9
    Silver Server
    gehört zum Inventar Avatar von Silver Server

    AW: Immer wieder Bluescreens und Abstürze

    Es ist immer noch Avira auf dem Rechner.
    Avira deinstallieren.
    Reste des Programm mit dem Entfernungstool beseitigen.
    Avira AntiVir RegistryCleaner 2.0.2.7 - Download - COMPUTER BILD

    beziehungsweise sind Windows 7 Treiber auf dem Rechner.
    Ich rate erst mal zu clean Installation von Windows 10.

  11. #10
    Porky
    gehört zum Inventar Avatar von Porky

    AW: Immer wieder Bluescreens und Abstürze

    Das Avira-Bereinigunstool sollte im abgesicherten Modus ausgeführt werden, sonst wird nicht Alles entfernt. Kontrollieren kannst du das mit Autoruns: Autoruns for Windows - Windows Sysinternals | Microsoft Docs
    Die 3 von Ari45 genannten Treiber sollten dann da nicht mehr zu finden sein. Falls doch, die Häkchen entfernen (Run as administrator bestätigen). Danach Neustart.

  12. #11
    tkmopped
    gehört zum Inventar Avatar von tkmopped

    AW: Immer wieder Bluescreens und Abstürze

    Total AV und nicht Antivir ist installiert gewesen. So steht das im Garett-PC Text.txt
    Lies mal das hierzu:
    Total AV: ein Produkt, das einem Betrug naher kommt als ein Antivirus? - Logitheque Deutsch

    Wenn du das gelesen hast sollte die totale Ernüchterung einsetzen. Sich sowas freiwillig auf den PC zu holen - hmm!

    Vorher oder gleichzeitig Avira ?


    Die Einstellungen:
    CPU auf Höchstleistung - generell problematisch insbesondere mit dem FX8350!
    Deine Speicher F3-12800CL9-4GBXL laufen mit 803MHz (DDR4 1600) allerdings nicht im gleich schnellen XMP sondern mit SPD von 800MHz CL11.
    Das Board ist wohl nicht die ältere Version Rev. 1.x und sondern die überarbeitete Rev. 3.0
    Laut Bios ist FD installiert wobei es noch ein aktuelleres FEh von 2014 gäbe.
    An der Grafik hängen zwei Monitore deren Einstellung mit jeweils 1920x 1040? nicht dem möglichen FHD entspricht.
    Acer S273HL und LG E2442
    Deine OCZ SSD
    Retired Block Count : Real value 9
    Reallocation Event Count: Real value 9 nicht mehr ganz taufrisch
    Die Samsung 860 EVO sieht da einiges besser aus.
    Die Hitachi HDD ist unauffällig.
    Dein Gateway-Server hat eine seltsame IP-Adresse (Gateway server 192.168.42.129)

    Soweit die Zustandsbeschreibung was mir aufgefallen ist.
    Mit deinem FX 8350 ist generell immer mit einem ableben der Boards zu rechnen. Irgendwann ist eben schluß damit. Das fängt mit nicht nachvollziehbaren Abstürzen an, die sich dann immer weiter häufen. Ein Board mit 990FX wäre der CPU angemessener gewesen. Allerdings auch teurer. Im Profil Höchstleistung bleibt auch wenig Luft dem System etwas Zeit zur Erholung gegönnt zu haben. Der FX könnte wohl noch 10 Jahre laufen, das Board aber nicht.

    Warum auf der Supportseite dem FX 8350 ein Bios FB genügen soll, der gleich alte FX 8370 aber mit gleichen Leistungswerten das FEh benötigt, ist mir schleierhaft. Die einzigen, die das bräuchten, wären die mit einem E in der Bezeichnung .
    Geändert von tkmopped (27.08.2020 um 10:42 Uhr)

  13. #12
    Garrettx40
    kennt sich schon aus

    AW: Immer wieder Bluescreens und Abstürze

    Soooo, ich möchte mich auf jeden Fall für jeden einzelnen Hilfebeitrag bedanken. Das Problem ist jetzt endgültig gelöst und der Beitrag kann geschlossen werden.
    Allerdings war das Problem bzw. die Lösung deutlich einfacher als gedacht. Softwares wie Avira und diverse Treiber spielten dabei nämlich überhaupt keine Rolle...
    Meine CPU hatte einen defekt. Nach austauschen durch ein (leider schwächeres) Ersatzteil einen Freundes läuft der Rechner jetzt wieder Stabil wie eh und je.

    Trotzdem vielen Dank an jeden einzelnen der versucht hat zu helfen

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •