Ergebnis 1 bis 2 von 2
Thema: Excel Mehrere Werte Suchen und in einer Zelle ausgeben Hallo zusammen, komme grad mit Excel nicht weiter. Folgende Matrix habe ich vor mir liegen: Ich möchte nun in der ...
  1. #1
    opamast
    kennt sich schon aus

    Excel Mehrere Werte Suchen und in einer Zelle ausgeben

    Hallo zusammen,
    komme grad mit Excel nicht weiter. Folgende Matrix habe ich vor mir liegen:

    Excel Mehrere Werte Suchen und in einer Zelle ausgeben-test-fuer-upload.png

    Ich möchte nun in der Spalte B alle Zellen mit dem Wert 2 finden und anschließend die dazugehörigen ID's aus Spalte A in einer Zelle ausgeben, so wie manuell in B9 gemacht. Über die WENN/DANN Funktion komme ich soweit, dass ich die ID's jeweils einzeln in einer Spalte ausgebe mit =WENN(B2:B6=2; A2:A6; ""). Aber ich würde die gerne alle direkt in einer Zelle haben. Natürlich könnte ich das bei dieser recht kleinen Matrix auch manuell machen, aber würde die Formel dann später auch auf größere Matrizen anwenden. Wenn jemand des Rätsels Lösung weiß, bitte melden.

    Vielen Dank im Voraus

  2. #2
    .Bernd
    gehört zum Inventar Avatar von .Bernd

    AW: Excel Mehrere Werte Suchen und in einer Zelle ausgeben

    Das ist nur mit VBA möglich. Man könnte wohl verschiedene Suchen miteinander verbinden, aber selbst bei deinem Beispiel wäre die Formel schon endlos lang, ist IMO auch nicht machbar (WVerweis). MfG

Lesezeichen


  • An Google übertragen Google
  • -->

    Berechtigungen

    • Neue Themen erstellen: Nein
    • Themen beantworten: Nein
    • Anhänge hochladen: Nein
    • Beiträge bearbeiten: Nein
    •  

    1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163