Guten Abend!

Ich habe mir eine iTunes-Bibliothek angelegt, die ich auf mehreren Rechnern verwenden kann. Das Ganze funktioniert darüber, dass die Bibliothek auf einer externen Festplatte an Rechner 1 (Windows 7) unter E:\ liegt.
Diese Festplatte habe ich im Netzwerk freigegeben.
Auf Rechner 2 (Windows 8) habe ich die freigegebene Festplatte als Netzlaufwerk (ebenfalls unter E:\) eingebunden.

So weit, so gut. Die Verbindung ist erfolgreich, alle möglichen Programme finden die Platte auch unter E:\, wenn ich eine Datei öffnen möchte. Das funktionierte jetzt auch wochenlang mit iTunes. Seit heute allerdings hat iTunes keinen Zugriff mehr auf E:\. Auf die Songs erhalte ich nur Zugriff, wenn ich die "fehlenden Dateien" (mit ! markiert) unter "Netzwerk" im Explorer auswähle. Leider habe ich eine sehr große Bibliothek und iTunes findet die Songs nicht automatisch, wenn man den Pfad zu einem fehlenden Song angibt.
Wichtiger Hinweis: Ich sortiere meine Musik manuell. Nur wenige Ausnahmen befinden sich im von iTunes verwalteten Ordner (Käufe aus dem iTunes Store) - die werden problemlos gefunden. Ich möchte und werde aber nicht meine gesamte Bibliothek von iTunes organisieren lassen.

Was ich bereits probiert habe:
- Beide Rechner neugestartet
- Netzlaufwerk getrennt und neu verbunden
- iTunes deinstalliert, inkl. Dateien in den AppData-Untervezichnissen

Mich wundert es am meisten, dass das einfach von heute auf morgen passiert ist, ohne dass ich Einstellungen oder etwas anderes verändert habe.

Google hat mir weder in deutschen noch in englischen Foren weiterhelfen können. Ich hoffe, heir kann mir jemand helfen.


//Edit: Beispielhaft hier der Vergleich des Öffnen-Dialogs im VLC und dann in iTunes:

VLC:
iTunes erkennt Netzlaufwerk nicht-fehler-vlc.png
iTunes:
iTunes erkennt Netzlaufwerk nicht-fehler-itunes.png