Seite 1 von 2 1 2 LetzteLetzte
Ergebnis 1 bis 15 von 20
Danke Übersicht24Danke
Thema: SSD M.2 auf PCIe lässt sich nicht als Systempartition einrichten Liebe Gemeinde, dies ist mein erster Post in einem Computerforum. Ich bitte um Nachsicht wenn es um meine fachliche Kompetenz ...
  1. #1
    Teci
    Herzlich willkommen

    SSD M.2 auf PCIe lässt sich nicht als Systempartition einrichten

    Liebe Gemeinde,

    dies ist mein erster Post in einem Computerforum. Ich bitte um Nachsicht wenn es um meine fachliche Kompetenz geht und um einen freundlichen Hinweis, wenn ich unwissentlich irgendwo anecke. Ich habe bereits mehrere Stunden gegoogelt und bin einerseits von der Fülle an ähnlichen Problemen erschlagen und von der fehlenden Lösung meines spezifischen Problems zunehmend frustriert. Ich würde mich über Unterstützung aus der Community sehr freuen.

    Mein System:
    • Dell Optiplex 990 SFF
    • Aktuellstes BIOS (A19)
    • 2x4 GB Ram
    • Intel(R) Core(TM) i5-2500 CPU @ 3,3 GHz


    Mein Vorhaben:
    Ich möchte meinen Dell Optiplex 990 mit einer SSD für das System betreiben und eine HDD für die Daten nutzen. Ich habe mir dafür eine 960 EVO NVMe M.2 SSD von Samsung und einen entsprechenden PCIe-Adapter gekauft. Als Betriebssystem möchte ich Windows 10 64bit nutzen. Die große HDD soll später kommen.

    Mein Problem:
    Die SSD im BIOS bei der PCI Information mit „Mass Storage“ angezeigt, aber sie erscheint nicht in der UEFI Boot Sequence. Die SSD funktioniert als Speicher einwandfrei, wenn man Windows 10 auf der HDD installiert. Der aktuellste Treiber von Samsung installiert. Somit ließe sich auch ein bestehendes System auf die SSD klonen. Aber booten geht leider nicht.

    Was habe ich probiert:
    • Die SSD auf GPT partitioniert, damit sie auf UEFI läuft
    • Ein aktuellen BOOT-Stick für Windows 10 erstellt.
    • Im UEFI Modus den Stick gebootet und versucht Windows zu installieren
    • Die SSD wird dann im Installationsprozess gelistet aber beim Auswählen der Festplatte erfolgt die Fehlermeldung: „Es konnte keine neue Partition erstellt oder eine vorhandene Partition gefunden werden. Weitere Informationen finden Sie in den Protokolldateien zum Setup“ Dieses Setup Log habe ich mir noch nicht herausgesucht, da es für mich als Laie kompliziert aussah, diese herauszusuchen (gäbe das Log Aufschluss?)
    • Die HDD aus dem Computer ausgebaut, damit nur noch eine Festplatte, nämlich die SSD drin ist. Leider gleicher erfolgloser Ablauf. SSD wird nicht als Bootoption aufgeführt
    • HDD wieder eingebaut und Windows 10 darauf installiert. SSD ist als Speicherplatz nutzbar.
    • Neueste Treiber von Samsung installiert und auf extra Stick gesichert
    • Bei Neuinstallation versucht über Treibersuche die entsprechenden Treiber vom Stick zu installieren. Weiß nicht warum, aber das wollte er nicht. Mittlerweile glaube ich aber auch nicht mehr, dass ein fehlender Treiber das Problem ist, weil Samsung auf der SSD eine kleine Systempartition hat, wo das drauf sein müsste
    • System mit aktuellsten Treibern von HDD auf SSD mit der Klonsoftware von Samsung geklont. Aber keine SSD als Bootoption angezeigt



    Ich vermute bzw. hoffe, dass ich einfach zu blöd bin den richtigen Haken im Bios zu setzen. Oft wird auch was von AHCI Modus bei SATA geschrieben. Der war bei mir schon drin. Aber ich denke, dass das keinen Einfluss hat, da ich die SSD ja über einen PCIe Steckplatz laufen lasse. Ich habe auch gelesen, dass die SSD erst nach einer erfolgreichen Installation im Bios / UEFI sichtbar ist. Aber soweit komme ich bekanntlich nicht.
    Bei offiziellen Seiten von Samsung, Dell und Microsoft habe ich auch nichts Passendes gefunden.
    Wer kann mir helfen?

  2. #2
    Silver Server
    gehört zum Inventar Avatar von Silver Server

    AW: SSD M.2 auf PCIe lässt sich nicht als Systempartition einrichten

    Was hat den der Rechner sonst für Anschlüsse für Festplatten? SATA? IDE?

  3. #3
    tomto-07
    Gast

    AW: SSD M.2 auf PCIe lässt sich nicht als Systempartition einrichten

    ....Somit ließe sich auch ein bestehendes System auf die SSD klonen. Aber booten geht leider nicht.
    Klonen von HDD auf SSD m.2 PCI- Riegel geht ......nur System Bootet dann nicht.
    Siehe auch hier. U.a. in #6 und #11
    KnSN bedankt sich.

  4. #4
    tofuschnitte
    Fremdgeher mit nem S8 :( Avatar von tofuschnitte

    AW: SSD M.2 auf PCIe lässt sich nicht als Systempartition einrichten

    da kannste lange dödeln, das Board wird einfach nicht über den PCI Express Slot booten können (was 99% aller Boards nicht können)

    Gib den Kram zurück und kauf dir ne normale SATA SSD, den Unterschied zwischen PCIe NVMe Übertragung und SATA/AHCI merkst du sowieso nicht im normalen Betrieb
    KnSN und Terrier! bedanken sich.

  5. #5
    John Sinclair
    gehört zum Inventar Avatar von John Sinclair

    AW: SSD M.2 auf PCIe lässt sich nicht als Systempartition einrichten

    Guten Tag, bei mir war es so, das man nur ein Bootfähiges System darauf bekommt wenn man es NICHT als UEFI installiert.
    Den USB Bootstick der als Installation´s Medium benutzt wird darf nicht als UEFI Stick gestartet werden.
    Dann wird die normale Bios Installation genommen.

  6. #6
    KnSN
    Side Channel Attacker Avatar von KnSN

    AW: SSD M.2 auf PCIe lässt sich nicht als Systempartition einrichten

    Dafür braucht 's die Fähigkeit von PCIe ROM.

    IDE ist kein Anschluss - IDE ist ein Protokoll! Der Nachfolger ist AHCI, RAID ist ein erweitertes AHCI-Protokoll.

    Die Plattform ist Cougar Point oder Panther Point, darauf gibt 's bestimmt noch 'n PATA-Port, aber wer braucht den schon und vor allem, was nützt er für diesen Einsatzzweck?

    Was soll das überhaupt bezwecken, PCIe(M.2)-SSD auf einer solch betagten Plattform? Schon die herkömmlichen SATA-SSDs führen auf solch betagten Plattformen zum Problem, weil der Controller den Burst nicht erbringen kann, folglich stecken alle diejenigen, welche aufgrund ihrer unzureichenden Fachkenntnis das Falsche für ihren PC erworben haben, beim Windows-Boot am BSOD fest, dann hilft nur noch das zuvor erwähnte IDE-Protokoll, weil die SSD den SATA-Controller per AHCI-Protokoll zu aggressiv anspricht.
    Silver Server, tomto-07 und Terrier! bedanken sich.

  7. #7
    andy1954
    gehört zum Inventar
    Kommt bei der SSD vor der Meldung "Es konnte keine neue Partition erstellt oder eine vorhandene Partition gefunden werden." im Menü die Möglichkeit die SSD komplett zu löschen? Erst danach konnte ich meine M.2 SSD im UEFI-Modus auf einem Board mit Z97 Chipsatz installieren.

  8. #8
    Klabautermann
    SSD Spezi ;-) Avatar von Klabautermann

    AW: SSD M.2 auf PCIe lässt sich nicht als Systempartition einrichten

    Hallo Teci
    Ich habe einen Beitrag zur M.2 SSD geschrieben und es mit Bildern versehen.
    Schaue dir doch einfach mal die Bios Bildchen dazu an, vielleicht hilft dir das etwas weiter.
    Das Bios deines Dell Optiplex 990 SFF, muss dafür bereit sein. Sonst funktioniert die M.2 SSD nicht.
    Den Bericht dazu findest du hier: Meine erste M.2 SSD Samsung SSD 950PRO

    Viel Glück.
    KnSN und tomto-07 bedanken sich.

  9. #9
    tofuschnitte
    Fremdgeher mit nem S8 :( Avatar von tofuschnitte

    AW: SSD M.2 auf PCIe lässt sich nicht als Systempartition einrichten

    meine güte Leute, der verschissene 6 Jahrte alte Q67 Chipsatz von der alten Möhre weiß nicht mal was NVMe ist! Selbst wenn das Board in der Lage wäre über den PCI Express Slot zu booten (WAS ES NICHT IST) funktioniert es nicht!
    KnSN und Terrier! bedanken sich.

  10. #10
    KnSN
    Side Channel Attacker Avatar von KnSN

    AW: SSD M.2 auf PCIe lässt sich nicht als Systempartition einrichten

    Es soll angeblich auch AHCI gehen, aber ob das nicht eher mit SATAe in Verbindung gebracht wird, keine Ahnung.
    Er wird sowieso ein mechanischen PCIe 2.0 x16 mit angebundenen und frei verfügbaren x8 Lanes brauchen, weil die Spezifikation von x4 für 3.0 gilt, andernfalls brauche er einen Converter auf SATAe, also zugleich die Anbindung auf SATA.

    Es ist letztendlich bloß die Theorie, denn in der Praxis macht es sowieso mehr Probleme als es vom Nutzen ist.
    Per SATA mit normaler SSD wird er es vergessen können, denn in vielen Fällen erfüllt der alte Controller bei AHCI die Anforderung nicht und wer weiß, was für ein Problem bei IDE aufwartet, denn dazu hatten wir auch schon einen Fall, dass es darüber *nicht immer* reibungslos läuft, auch wenn Windows vernünftig aufstartet, kann die SSD bei normalem Betrieb noch 'n Abflug machen.

  11. #11
    tofuschnitte
    Fremdgeher mit nem S8 :( Avatar von tofuschnitte

    AW: SSD M.2 auf PCIe lässt sich nicht als Systempartition einrichten

    AHCI geht bei SATA M2 SSDs, nicht bei NVMe denn NVMe ersetzt SATA AHCI als Schnittstelle! Daher funktionieren auch keine M2 NVMe SSDs in SATA M2 Slots
    Teci und KnSN bedanken sich.

  12. #12
    KnSN
    Side Channel Attacker Avatar von KnSN

    AW: SSD M.2 auf PCIe lässt sich nicht als Systempartition einrichten

    Auf den AMD-Plattformen (bis AM3+ / bis FM2+) kommt zudem hinzu, dass der SATA-Controller abwürgt und/oder rumzickt, sobald der Prozessor hochgetaktet ist, egal ob per Referenztakt, was die Burstrate anhebt, oder per Multiplikator, was trotz gleich bleibender Busrate die Baudrate anhebt, weil deren Teiler die Oszillation aus dem Prozessor-Multiplikator ist, beziehungsweise ihn überhaupt erst ergibt.

    Über die Ryzen-Plattform weiß ich noch nicht viel, denn was genau sich hinter der Konstellation aus Data Fabric Scalability und Control Fabric Scalability verbirgt ist mir noch unklar, denn es sieht so aus, als habe AMD das realisiert, woran Intel seit Jahren scheitert, einen einheitlichen Zweileiterbus, der den Subcore direkt an den Plattform-Controller anbindet (Baud), ohne mit dem Intercore zwischen den Prozessor und den Arbeitsspeicher (Burst) zu korrelieren.
    Hier liegt wahrscheinlich die Komplikation, die Ryzen derzeit mit vielen Brettern zur RAM-Tsundere macht, aber auch die Lösung, dass Ryzen scheinbar stärker vom RAM profitiert als bspw. Kaby Lake.

  13. #13
    build10240
    gehört zum Inventar

    AW: SSD M.2 auf PCIe lässt sich nicht als Systempartition einrichten

    Zitat Zitat von andy1954 Beitrag anzeigen
    Erst danach konnte ich meine M.2 SSD im UEFI-Modus auf einem Board mit Z97 Chipsatz installieren.
    Der hier betroffene Rechner hat aber einen Q67-Chipsatz, das sind drei Generationen Unterschied. Der Rechner wird, wie schon von tofuschnitte in #4 geschrieben, sehr wahrscheinlich nicht von einer PCIe-SSD booten können. Noch dazu ist die SSD der absolute Overkill auf dem Board, weil das nur PCIe2.0 unterstützt. Genauso Overkill ist für die meisten Nutzer die Geschwindigkeit einer m.2-SSD.
    KnSN, Teci und Terrier! bedanken sich.

  14. #14
    Teci
    Herzlich willkommen

    AW: SSD M.2 auf PCIe lässt sich nicht als Systempartition einrichten

    Vielen Dank für Eure anregenden Beiträge.

    @Silver Server: neben AHCI gibt es nur noch folgende Möglichkeiten: Disabled, ATA und Raid
    @tofuschnitte u. KnSN, danke für eure klaren Ansagen zu meiner Illusion die SSD über den PCIe Steckplatz booten zu wollen. Eure Aussagen, ob eine SATA SSD in meinem Optiplex funzen würde, interpretiere ich unterschiedlich. Worauf müsste ich dann achten, damit ich nicht noch einmal einen Fehlgriff mache?
    @John Synclair: Die Installation über Legacy funzt nicht. zwar komme ich weiter bei der Installation aber beim ersten Neustart sucht er auch die SSD als Bootmedium vergeblich. Vermutlich liegt es eben an dem "so alten" Rechner.
    @Andy u. Klabautermann: Danke für Eure Ideen. Ja man kann am Punkt der Fehlermeldung nochmal die Platte formatieren, bring aber nix. Dieser Kompatibilitätsmodus (CSM) für Legacy und UEFI ist bei meinem Bios noch nicht drauf.
    @KnSN, ja sicher ich bin da sehr naiv herangegangen. Aber ich habe eben diesen Rechner zur Verfügung und wollte daraus mit einen finanziell vertretbaren Aufwand einen Miniserver machen. SSD für System und große HDD für die Daten. Da die SFF die Größe und somit die Hardwaremöglichkeiten begrenzt, war ich einfach entzückt von der Idee den freien PCIe Steckplatz mit einer kleinen Systemplatte bestücken zu können.

    Nun überlege ich zwei verschiedene Varianten:
    1. 2,5'' Platten zu installieren. 1x SDD und 1x HDD.
    2. Auch wenn es wie build10240 es nannte die SSD der absolute Overkill ist. Macht es Sinn neben einer kleinen SSD oder gar permanenten Stick als System die PCIe-SSD für oft genutzte Programme zu verwenden? Beim Benchmarking hat die SSD selbst auf dem langsamen PCIe etwa 10x schneller gelesen und geschrieben. 8O
    KnSN bedankt sich.

  15. #15
    KnSN
    Side Channel Attacker Avatar von KnSN

    AW: SSD M.2 auf PCIe lässt sich nicht als Systempartition einrichten

    Zitat Zitat von Teci Beitrag anzeigen
    @John Synclair: Die Installation über Legacy funzt nicht. zwar komme ich weiter bei der Installation aber beim ersten Neustart sucht er auch die SSD als Bootmedium vergeblich. Vermutlich liegt es eben an dem "so alten" Rechner.
    N-N-Ne'! Treffend ausgedrückt liegt es daran, dass PCIe-ROM fehlt oder deaktiviert ist.
    Das, was Du brauchst, ist ein Adapter von PCIe und SATA (SATA-Express) auf M.2. Es ist keine Garantie dafür, dass es gelingt, doch die Anbindung an SATA müsse ausreichen, um die SSD bootfähig zu machen, ohne dass die Bandbreite von PCIe wegfällt, theoretisch erhöht es sogar die Bandbreite, insoweit der Chipsatz nicht limitiert.

    Zitat Zitat von Teci Beitrag anzeigen
    @KnSN, ja sicher ich bin da sehr naiv herangegangen. Aber ich habe eben diesen Rechner zur Verfügung und wollte daraus mit einen finanziell vertretbaren Aufwand einen Miniserver machen. SSD für System und große HDD für die Daten. Da die SFF die Größe und somit die Hardwaremöglichkeiten begrenzt, war ich einfach entzückt von der Idee den freien PCIe Steckplatz mit einer kleinen Systemplatte bestücken zu können.
    Man muss hier und da immer eine Einschränkung hinnehmen. Der Datendurchsatz von einer SSD fordert "die Legacy-Controller" nun mal heraus - Es kann funktionieren, es muss aber nicht! Letztendlich kann auch die Speicherschnittstelle limitieren: Das ist dann so, also komme das Mainboard mit dem SLI/CFX nicht nach, ergo Frame-Drops. Doch soweit befindest Du Dich noch nicht. Suche im BIOS die obene genannte Funktion unter dem Reiter <Advanced> - Sie muss nicht explizit so lauten, deshalb lasse Deiner Phantasie freien Lauf!

Seite 1 von 2 1 2 LetzteLetzte

Lesezeichen


  • An Google übertragen Google
  • -->

    Berechtigungen

    • Neue Themen erstellen: Nein
    • Themen beantworten: Nein
    • Anhänge hochladen: Nein
    • Beiträge bearbeiten: Nein
    •  

    1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163