Anzeige

Am Puls von Microsoft

Anzeige

Frage Öffnen mit geht nicht mehr bei allen Programmen

mbarnick

kennt sich schon aus
Hallo,
seit dem neusten Update kann ich bestimmte Dateien nicht mehr mit allen Programmen mit "rechter Maustaste - Öffnen mit ..." öffnen.
Da sind z.B. die txt-Dateien, für die ich seit Jahren den Textpad.com verwende oder die .jpg - Dateien, die ich immer mal in den SmartPhotoEditor reinladen muss.
Wenn ich das Programm normal starte und die Dateien im Öffnen-Dialog öffne, klappt alles normal, aber das Öffnent mit ... geht bei manchen Programmen nicht mehr.
Auch eine Neuinstallation dieser Programme hat nicht geholfen.
Woran kann das liegen und wie repariere ich das? Ich tippe auf einen verkorksten Registry-Eintrag.
Danke.
 
Anzeige

Sonnschein

gehört zum Inventar
Vielleicht reicht es schon, wenn du in der Eingabeforderung mit Administrator rechten sfc /scannow eingibst und es durchlaufen lässt.
 

IngoBingo

gehört zum Inventar
seit dem neusten Update kann ich bestimmte Dateien nicht mehr mit allen Programmen mit "rechter Maustaste - Öffnen mit ..." öffnen.

Warum kannst du es nicht? Sind die Menüpunkte nicht mehr da? Sind sie da, aber lassen sich nicht auswählen? Lassen sie sich auswählen, aber passiert nichts? Lassen sie sich auswählen, aber kommen Fehler?

"kann ich nicht" ist leider so eine typische Fehlerbeschreibung wie "geht nicht". Kann niemand was mit anfangen. ;)
 

PeterK

eben noch da
Ja, das kann schon mal passieren, was steht denn bei dir in der Eigenschaften der jeweiligen Dateien .txt und .jpg unter "öffnen mit"?
Kannst du das ändern, anpassen?
Screenshot 2022-09-30 152821.png
 

mbarnick

kennt sich schon aus
Genauer:
wenn ich eine Textdatei doppelklicke soll sie mit textpad.com aufgehen. Tut sie aber nicht. Programm lädt aber.
wenn ich eine Textdatei mit rechte Maustaste + Öffnen mit textpad auswähle, wird der Text nicht in Textpad geladen.
Wenn ich z.B. in DAZStudio die Logdatei (Fehlerlog) betrachten will, so wird normalerweise die log.txt an das eingestellte Textprogramm übergeben und geöffnet. Hier textpad.com. Geht seit einiger Zeit plötzlich nicht mehr. Textpad lädt, aber Textdatei wird nicht geladen.
Problem liegt anscheinend bei Textpad, habe das Programm aber neu installiert. Hat nicht geholfen.

wenn ich eine jpg - Datei doppelklicke, geht sie mit Photoshop auf, was sie auch soll.
wenn ich eine jpg - Datei mit rechter Maustaste + Öffnen mit und dann den SmartPhotoEditor auswähle, lädt sie dort nicht. In anderen Programmen wie Paint oder Gimp jedoch schon.

Es scheint so dass in einigen Fällen die Übergabe nicht mehr klappt.
Stehe vor einem Rätsel.

Es wurden übrigens keine Integritätsverletzungen gefunden.
 

PeteM92

gehört zum Inventar
Du benutzt aber schon TextPad in der Version 8.12.0? Oder hast Du noch Version 7.6.4 aus 2017?
Und auch bei Deinen anderen Programmen sind die Versionen aktuell?
 

mbarnick

kennt sich schon aus
Du benutzt aber schon TextPad in der Version 8.12.0? Oder hast Du noch Version 7.6.4 aus 2017?
Und auch bei Deinen anderen Programmen sind die Versionen aktuell?
ich hab die neuste Version downgeladen. Mit anderen Programmen kann ich txt mit rechter Maustaste öffnen. Problem liegt also anscheinend bei Textpad bzw. in der Verbindung von TP mit Windows.
Der SmartPHotoEditor ist die aktuellste Version

Hallo, schaue mal ob du mit diesem Beitrag weiter kommst ? ;)


( Programmeintrag noch im Cache ) ?

Gruß 😷
Danke für den guten Tipp, aber bei mir steht anscheinend nix Falsches drin. (imho)
 

Anhänge

  • 2022-10-01 14_59_21-Window.jpg
    2022-10-01 14_59_21-Window.jpg
    52,3 KB · Aufrufe: 31
  • 2022-10-01 14_57_51-Window.jpg
    2022-10-01 14_57_51-Window.jpg
    48,8 KB · Aufrufe: 28
  • 2022-10-01 14_57_43-Window.jpg
    2022-10-01 14_57_43-Window.jpg
    24 KB · Aufrufe: 26

Gismon

gehört zum Inventar
mache mal Folgendes:

1) Windowstaste + R
2) control /name Microsoft.DefaultPrograms /page pageFileAssoc
3) dann diesen Dateityp reinschreiben, den du ändern willst - z.B. .txt
4) und dann dein Programm suchen

Windows 11 (bei dir sollte es ähnlich funktionieren)
1664630717029.png
 

PeteM92

gehört zum Inventar
In Windows 10 muß man etwas anders vorgehen.
Einstellungen aufrufen, Apps auswählen, dann Standard Apps.
Rechts hinunterscrollen bis zu dieser Anzeige

1664633092410.png


Standard-App nach Dateityp wählen, im nächsten Fenster hinunterscrollen bis zu .txt.
Dann rechts Editor anclicken und im Aufklappfenster TextPad auswählen (gilt für das installierte TextPad 8.12)

1664633220590.png


Ab jetzt öffnet sich eine .txt-Datei beim Doppelclick mit TextPad.
 

mbarnick

kennt sich schon aus
Vielen Dank für den guten Tipp.
Allerdings war da schon Textpad eingestellt.
Ich hab dann mal auf Wordpad geändert und damit lassen sich dann die Textdateien öffnen.
Habe dann wieder auf Textpad gestellt und es klappt weiterhin nicht.
Der Fehler scheint also nicht an dieser Stelle zu liegen.
Ich könnte jetzt sagen, na dann liegt's halt bei Textpad, aber das Öffnen mit rechter Maustaste geht ja bei jpg mit dem SmartPhotoEditor auch nicht mehr.
Also liegt der Verdacht nahe, dass es doch an der Registry liegt, aber halt wo anders. Nur wo ...
 

Gismon

gehört zum Inventar
@mbarnick

Versuche mal Folgendes:

1) hangele dich in der Regedit zum gelb markierten Pfad (siehe 1)
2) klicke links auf den Eintrag ".txt" (siehe 2)
3) füge rechts eine neue "Zeichenfolge" hinzu namens "Application" mit dem Wert "TextPad.exe" (siehe 3)
4) einen Neustart machen bzw. im Task-Manager den Windows-Explorer neustarten, damit die Änderung wirksam wird
5) anschließend mal einen Doppelklick auf irgendeine *.txt-Datei machen, ob diese dann mit TextPad.exe geöffnet wird oder nicht.

Oder wie auch immer diese *.exe-Datei lautet.

1664813379623.png
 
Zuletzt bearbeitet:

mbarnick

kennt sich schon aus
hab ich gemacht. Bei mir sieht man leider nicht die Spalten Typ und Daten, kann mich aber erinnern, dass die früher schon mal sichtbar waren.
Hab im Taskmanager den Explorer neu gestartet, aber vielleicht muss ich auch den Rechner neu starten.
Das wirds aber wohl nicht sein. Siehe Screenshot. Textpad steht drin, wenn auch unsichtbar, funktioniert aber weiterhin nicht.
Interessanterweise kann ich *.php - Dateien mit rechter Maustaste und Doppelklick mit dem Textpad öffnen, die ja auch nur Text sind.
Liegt also wirklich irgendwo an der txt-Zuordnung.
 

Anhänge

  • r1.jpg
    r1.jpg
    138 KB · Aufrufe: 26

mbarnick

kennt sich schon aus
also der Eintrag bei php ist gleichartig. Der bei html aber völlig anders.
Beide Dateiarten lassen sich mit Doppelklick und rechter Maustaste öffnen.

Ich hab immer so Probleme, die auch Google nicht kennt ;)
 
Anzeige
Oben