[gelöst] 300MBit WLAN langsamer als 10MBit LAN?

ph13

treuer Stammgast
Hallo Leute,

ich habe mal wieder eine Frage an euch!
Und zwar habe ich zu Hause ein NAS von Synology und habe mich immer wieder gefragt, warum die Datenrate so langsam ist...Vielleicht könnt ihr mich da etwas erleuchten!

Also folgende Konstellation ist vorhanden:

NAS -[LAN]- Fritzbox 7390 -[WLAN-N]- ASUS U30JC

Die Technischen Daten findet ihr hier

Die Netzwerkkarte ist somit eine 10MBit Karte
Die WLAN-Karte unterstützt den N-Standard (bis 300MBit)

Ich habe z.B. versucht ein Video von der NAS zu laden mit LAN habe ich eine Ungefähre Datenrate von 10MB/s...
Wenn ich die gleiche Datei mit WLAN ziehe, sind es nur noch (nach langem optimieren) ungefähr 7MB/s...

Ist das Normal? Die Synology und die Fritzbox haben Gigabit Ports also an denen darf das nicht liegen! Wenn ich auf den WLAN Status gehe steht da auch 150MBit/s, also theoretisch sollte doch deutlich mehr drin sein als bei der 10MBit LAN Karte?

Der Fritz steht ca. 5m von Notebook und den habe ich auch schon wie gesagt mit dem Funkkanal uns. so weit optimiert das ich jetzt schon immerhin ca. 7MB/s habe - vorher waren es nur ca. 4,5MB/s.

Ich hoffe ihr habt da ein paar ideen und Hinweise für mich! Bin auf jeden Fall dankbar für JEDE Hilfe!!!
 
Anzeige
D

DrEricCartman

Gast
Ich kann dir nur die Standard Tipps geben:
- Firmware der Fritz! Box aktualisieren
- NAS / Laptop Mainboard (Chipsatz) Treiber & BIOS aktualisieren
WLAN Leistungs-Schwankungen und eine generell niedrigere Leistung als LAN,
haben oftmals Störfrequenzen & Überlagerrungen mit anderen WLANs als Ursache.
Ich habe dir mal ein richtig gutes und aktuelles Sonderheft zum Thema hochgeladen
gab es neulich hier als Tipp, ist offiziell nicht mehr verfügbar,
ab Seite 22 gibt’s was spezielles zu deinem Anliegen.
 

dachsteiner

gehört zum Inventar
Hier ist immer von 10Mbit LAN die Rede... gibt's das ueberhaupt? Jedenfalls kann man darueber keine 10 MByte/s erreichen. Auch wenn es in dem von dir verlinkten Artikel steht, macht ein 10 Mbit/s Gigabit Ethernet Controller keinen Sinn :)

So wie du deine Konstellation beschreibst, spielt das LAN vom Laptop eh keine Rolle...

Guck mal hier.
 

FAT32

Bit-Zähler
MBit ist nicht MB (Megabyte).
MBit geteilt durch 8 sind MB.

Du ziehst mit 100Mbit (12,5 MB/s maximal, in der Praxis 11MB/s~), bei WLAN hast du mit 150MBit (300 MBit bekommst du nur hin, wenn du das Universum verschwinden lässt, damit auch jede mögliche Strahlung nicht existiert) von N-WLAN 18,75 MB/s, wozu es perfekte Bedingungen braucht.
Je schlechter das Signal, desto langsamer.

Auf der Seite

http://www.notebookcheck.com/Test-Asus-U30JC-A1-QX043V-Notebook.31549.0.html

ist außerdem ein Schreibfehler. Es wird gesagt dass in dem Laptop eine Gigabit-LAN-Karte verbaut ist, die 10 MBit können dann nicht stimmen.
 

ph13

treuer Stammgast
Okay, dann habe ich also eine GigaBit LAN Karte (Gut zu wissen...:angel) Trotzdem habe ich da nur ca. 10MB/s - wenn in der Praxis ein 100MBit LAN ca. 11MB/s hat...? Dann ist es bei mir doch zu langsam...

Und sind die 8MB/s über WLAN jetzt in Ordnung? Habe schon einen Kanal eingestellt, der von keinem anderen WLAN in der Umgebung genutzt wird.

@DrEricCartman: Danke - habe ich runtergeladen - werde ich mir mal zu Gemüte führen...!
@Dachsteiner: Deinen Link natürlich auch!
@FAT32: Danke für die Aufklärung...

________________________

Edit:
So, die Einstellungen in der Fritzbox wurden nach dem Update wirklich zurückgesetzt (Wie im Link von Dachsteiner beschrieben), umgestellt auf GigaBit LAN und passiert ist nichts... Jetzt wird zwar immerhin im Status 1000Mbit angezeigt, aber der Datendurchsatz ist immer noch bei ~10MB/s.

WLAN schwankt zwischen 5 und 8 MB/s
 
Zuletzt bearbeitet:

dachsteiner

gehört zum Inventar
Mal zur Sicherheit: du verwendest auch den LAN-Anschluss, der auf 1000Mbit gesetzt ist (die FB hat ja 4 davon, die separat umgestellt werden koennen)? Evtl. FB rebooten? Und: Das NAS haengt auch wirklich per LAN-Kabel an der FB, nicht per USB? Welche Einstellungen (bzw. Einstellmoeglichkeiten) hat das NAS?

Ein 100Mbit-LAN erreicht in der Praxis keine 11 MByte/s, da es noch Protokolloverhead gibt. 10MB/s sind da voellig in Ordnung.

Wenn du nach "Datenrate WLAN" googlest, findest du einige interessante Artikel. Da erfaehrst du z.B., dass bei 150Mbit/s brutto max. 9 MByte/s netto uebertragen werden koennen (haengt auch vom Empfaenger ab, nicht nur von der FB!). Auch da liegst du also durchaus im unauffaelligen Bereich.
 
R

Rheinhold

Gast
Erst mal sind das alles Brutto Werte die in der Praxis nie erreicht werden.
Auch bei den Übertragunsraten bist du mit der Hälfte dieser Werte als Netto gut bedient.
Davon sind dann noch Synchronisierung; Protokoll; fehlerhafte Übertragungen durch " Störungen " ( die dann Wiederholt werden müssen ) noch ab zu ziehen.
Z.B. bei einer g Standard Verbindung max. Brutto 50 MB so die Theorie.
Bei n Standard 300 MB, was wirklich läuft, siehe Bild:
Wenn der Client zu langsam ist, dann nutzt das schnellste NAS und Netzwerk auch nichts.
Störungen die bremsen:
schlechte Kabel
Störungen durch elektromagnetische Strahlung (bei schlechter Abschirmung).
Störungen durch andere Funkquellen (andere WLANs, DECT-Telefone, Babyfone).
Hardwareinkompatibilitäten (Chipsätze von NIC, Router, Switch).
Virenscanner, Firewalls.
Art der zu übertragenden Daten (5000 Dateien zu 1 MB dauern wesentlich länger als eine Datei mit 5000 MB, aufgrund des Verwaltungsaufwands für die Lese-/Schreiboperationen).
Dateisystem von Server/Client.
Jumboframes (nur GB-LAN).
Caches, Proxies.
Selbst der neuste Standard ( ac ) verspricht viel wie`s wird....
http://www.heise.de/ct/artikel/Gigabit-Funker-1673483.html
 

Anhänge

  • W-Lan Übertragung.jpg
    W-Lan Übertragung.jpg
    99,5 KB · Aufrufe: 236

corvus

gehört zum Inventar
Ein NAS sollte alle Schnittstellen voll ausreizen, dann limitiert das WLAN. Ich habe persönlich noch nie mehr als 7mbyte/s auf dem 650mbit 5ghz WLAN und 5mbyte/s bei 2.4Ghz (450mbit).
Bei 5ghz könnte aber was Anderes limitieren.
Meine persönliche Theorie ist, welche sich auch beweisen ließe, wenn man sich die Platine von einem Router mal genau anschaut:
Router haben keine USB Hostcontroller, die Schnittstellen werden über Universalports an den SoCs per Firmware emuliert. Das lastet bei Zugriffen den ganzen Router voll aus, und trotzdem wird nur ein Bruchteil der üblichen Bandbreite erreicht. Mein Linksys E4200 schaffte max. 2,5mbyte/s, die FB3390 bis zu 7mbyte/s über USB2(Cardreader mit mSD Class10 UHS I. Die Sd hat gem Class 10 eine garantierte Mindesttransferrate von 10mbyte/s, dank UHS I ist sie sogar noch höher, daran liegts also nicht).
Deswegen taugen Router nicht als NAS, es sei denn man hat viel Zeit. Als Medienserver reicht das aber, man sollte die HDs halt nicht per LAN/WLAN befüllen.
Phones und Tablets werden zwecks Stromsparen massiv ausgebremst, das sind effektiv kaum mehr als 2mbyte/s drin. Daran rumzuspielen auf meinen Androiden mit Root ist witzlos, denn Akkulaufzeit habe ich nirgends im Überfluß. Meine Gadgets haben alle Wlan N, teils 5ghz, Linkspeeds von max 54, 72 oder 200 mbit, und alle arbeiten effektiv gleich schnell(2mbyte/s).
 
Zuletzt bearbeitet:
Oben