Anzeige

Am Puls von Microsoft

Anzeige

Ad-Hoc-Netzwerk mit Windows 7 und Windows Vista

Marco1976

Bin (fast) immer da
Tach Mädels und Jungs:),

hab n kleines Netzwerkproblem; würde sehr gerne (oder besser gesagt: Brauche ganz superargdringend) Meinen Läppi unter Mein System mit dem vor kurzem aufgetauten Läppi mit Vista über ein Ad-Hoc-Netzwerk miteinander verbinden; wenn möglich mit Internetzugriff auf mein UMTS-Internet. Bemerkt sei, dass ich (noch) keinen Router, o.Ä. habe.
Hab bei Tante Google nix Gescheites gefunden und bin netzwerktechnisch n Bissel nicht so ganz fit, daher frage ich mal Euch:D.
Ich hab's schon soweit fertig gebracht, dass die zwei beiden Läppis sich erkennen, bloß mit dem Zugriff funzt überhaupt nix, es kommt immer das hier Netzwerkproblem.png. Hab's schon mit festen IP-Adressen versucht, aber, was geb ich dann da für ne DNS-Serveradresse ein:unsure:s:unsure:?
Frage zudem bleibt noch: Muss ich bei nem Ad-Hoc auch den "Partner-User" vom anderen Läppi anlegen, dass der sich anmelden kann, oder aber, was passiert, wenn ich das "Kennwortgeschützte Freigeben" deaktiviere, hat dann n böser Bube, der mit meinem UMTS-Anbieter ebenfals verlinkt ist, Zugriff auf mein Zeugs, da das UMTS-Netzwerk öffentlich ist? Das will ich natürlich nicht:rolleyes:.

Hat eine(r) von Euch dafür ggf. n Tutorial gebastelt, oder gefunden?

Sorry, wenn ich nicht sofort gegenantworten kann, weil bin im Moment n Bissel gestresst und die (Miss-)Erfolgsmeldungen können sich daher etwas ziehen:angel.
 
Anzeige

corvus

gehört zum Inventar
AW: Ad-Hoc-Netzwerk mit Win7 und Vista

Beim UMTS-Modem muß "Gemeinsame Nutzung der Internetverbindung" oder ähnlich aktiviert sein.
Weiß nicht ob es vllt. auch eleganter geht, aber ich mußte Virtual Wifi in der Konsole mit dem "netsh wlan"-Befehl konfigurieren(Kennwort etc.). Ferner läßt es sich nur mit "netsh wlan start hostednetwork" starten, das schreibt man am besten in ein Textfile und gibt ihm die *.BAT-Endung. Außerdem muß die Internetverbindung stehen, bevor man das Batchfile ausführt, was den Autostart ein bißchen kompliziert(ich mach´s einfach von Hand).
Edit: Fehler von mir, ein Adhoc-Netz geht einfacher, ich mußte das aber so machen, weil Android keine AdHoc-Netze kennt. So geht es aber in jedem Fall auch, und Satz 1 gilt auch fürs Adhocnetz.
 

FAT32

Bit-Zähler
AW: Ad-Hoc-Netzwerk mit Win7 und Vista

Erstmal stell bitte alle Netzwerkkarten wieder auf "Adresse automatisch beziehen".

Danach gehst du auf den "UMTS"-Laptop in das Netzwerk- und Freigabecenter und dann auf "Adaptereinstellungen ändern".

Jetzt in den Eigenschaften des UMTS-Sticks, im Reiter "Freigabe", den Haken für die Internetfreigabe setzen und dann die W-LAN-Karte als Weiterleitung auswählen und mit OK alles bestätigen.

Nun schauts in der W-LAN-Karte nach, welche IP sie zugewiesen bekommen hat, diese muss/soll von dem UMTS-Stick gesetzt werden, damit dieser mitbekommt, das Daten für ihn ankommen. Als Beispiel: 192.168.137.1

Wenn du die IP hast, gehts du zum anderen Laptop, gibst diesem die IP "192.168.137.2", Subnetz-Maske automatisch bestimmen, Gateway "192.168.137.1", DNS-Server "192.168.137.1" und nun sollte im Ad-Hoc Internet zur Verfügung stehen.

Bei dem Zugriffsproblem bin ich etwas ratlos, da ich auch dieses Phänomän hatte, PC1->PC2: kein Problem, aber PC2->PC1: Problem.
 

Marco1976

Bin (fast) immer da
Sö, nü, ich hab's:D, Zugriff von Jedem geht auf Jeden und die Internetgeschichte auch:smokin.
Frag mich jetzt aber bloß Keiner, wie, denn das weiß ich auch nicht; zum Schluss hat bloß noch der Kaspersky rumgemurkst, aber dem hab ich dann n Bissel in die Eier getreten und jetzt funzt alles:laola:D.
 

Marco1976

Bin (fast) immer da
Aktualisierung: Die Funktionalität ist äußerst fragwürdig; mal funzts (jetzt gerade) und dann mal wieder stundenlang nicht, hab vorhin fast nen Tobsuchtsanfall bekommen, wegen dem Sch...; MS könnte sich da mal was einfallen lassen, um die Netzwerkkacke einfacher zu machen:motz.
Zusammenfassung: Hab das AdHoc beim Win7 64Bit-Läppi eingerichtet, es als Arbeitsplatznetzwerk deklariert (weil Vista das mit den Heimnetzwerken wohl nicht kann).
Anschließend mein UMTS-"Modem" für den Internetzugriff frei gegeben (das ist auch so ne Sch..., denn die Drahtlosnetzwerkverbindung ist da nicht auszuwählen). Dann das Vista 32Bit-Läppi mit meinem AdHoc verbunden; hatte dann wenigstens mal Zugriff von Jedem auf Jeden, bloß das Internet geht am Vista-Läppi nicht (UMTS hängt am Win7). Danach die Internetfreigabe wieder weggenommen und sie dann wieder freigeschaltet; jetzt taucht die Drahtlosnetzwerkverbindung, die ja den Internetzugriff verteilen soll, komischerweise auf:unsure: und alles funzt.
Was mich heute schier zum Wahnsinn getrieben hat, war aber, dass beim Win7-Läppi das AdHoc-Netwerk ein nicht Identifizierbares gewesen war und somit als öffentlich abgestempelt wurde, ändern kann man das nicht und Gruppenrichtlinien gibts bei HomePremium nicht, sonst hätte ich es vielleicht hiermit Lösungen für "Nicht identifiziertes Netzwerk. Kein Internetzugriff." | WindowsPro gelöst bekommen, aber nix wars:(.
Warum das manchmal so ist, :unsure:s:unsure:.

Werde den Kack jetzt mal ein paar Tage testen und durchprobieren und ggf. n kleines Tut hier dranhängen, mit Screens usw. (Voraussetzung, wenn ich das selbst erroriert bekomme:unsure:s); ich habe das "Gelöst" mal wieder weg gemacht, denn das ist das Prob nicht permanent, sondern nur mal zeitweise.
Wenn wer dafür, vor Allem die Geschichte mit 1. der Internetfreigabe und 2. dem Mist mit dem nicht identifiziertem Netzwerk hat, nur her damit:D.
 
Anzeige
Oben