[gelöst] Anmeldeprobleme Win- Linux

Status
Dieses Thema wurde gelöst! Lösung ansehen…

hw2504

nicht mehr wegzudenken
Hallo, ich habe mir einen neuen Laptop mit 2 SSD FP kaufen müssen, alles vom Alten hierher bekommen und mich als Admin angemeldet. Es ging einige Zeit recht gut, bis mein Sohn sich damit beschäftigt hat und auf einer SSD Linux installiert hat. Mit F2 bei Neustart sind wir ins Bios gelangt, haben dort Linux an erste Stelle gesetzt, sind mit F7 ins erweiterte BIOS (EZ Modus), im Reiter Boot angeklickt, Fast Boot auf Disabled gestellt und mit F10 gesichert.
Es ging auch ein paar Wochen gut. Beim Start konnte ich zwischen Linux und Win auswählen. Win ist bis zum Sperrbildschirm gestartet, mit Enter bin ich zur Eingabe von einer PIN aufgefordert worden, diese eingegeben und alles war gut.
Jetzt wollte ich den Start ohne Sperrbildschirm und ohne PIN hin bekommen, habe alles ( Win*R-netplwiz-Häkchen bei Anmeldung entfernt usw) .
Bei jedem Start von Win steht jetzt was von "Nicht erkannt-Netzwerk oder so ähnlich" , es tauchen 2 Anmelde konten auf, obwohl ich nur als Admin angemeldet bin.
Ich hoffe das ihr mit diesem Durcheinandergeschreibe klar kommt und könnt mir helfen was ich falsch mache bzw machen kann?

Grüße
 
Anzeige

Diophant

nicht mehr wegzudenken
Hallo,

was genau da schief läuft, weiß ich auch nicht, da ich diese Startoption ohne Sperrbildschirm und PIN noch nie ausprobiert habe. Grundsätzlich ist die geschilderte Vorgehensweise für ein Nebeneinander von Linux und Windows problematisch. Wahrscheinlich wurde bei der Linux-Installation auch nicht darauf geachtet, wo der Linux-Bootloader installiert wurde? Oft sitzt dieser auch in der EFI-Partition von Windows, und damit fangen die Probleme dann an.
Ich betreibe auch ein Dual-Boot-System, aber ich habe das anders realisiert. Ich achte darauf, dass die Linux-Installation eine eigene EFI-Partition auf der Linux-Platte bekommt und der Linux-Bootloader dort installiert wird und setze im Bios die Windows-Installation an die erste Position*. Das hat einen Nachteil (der allerdings für mich keiner ist, da ich mit Linux seltener arbeite als mit Windows): wenn ich den Rechner einschalte und nichts weiter tue, dann startet Windows. Will ich Linux starten, muss ich über das Bootmenü des UEFI-Bios gehen (in meinem Fall beim Start F8 drücken). Das ist aber auch der einzige Nachteil, ansonsten bringt es nur Vorteile.
Seit ich das so mache, hat es noch nie Probleme gegeben. Nur: nicht jede Linux-Distribution unterstützt diese Vorgehensweise. Insbesondere die beiden beliebten Distributionen Ubuntu und Linux-Mint bieten bei der Installation im Partitionierungstool zwar die Option an, den Speicherort der EFI-Partition selbst zu bestimmen. Nur wird der Bootloader dann trotzdem auf das Windows-Laufwerk geschrieben.
Zwei Distributionen, bei denen die geschilderte Vorgehensweise seit Jahren zuverlässig funktioniert, sind OpenSUSE (beide Varianten) und Fedora. Ich verwende letzteres.

Von daher halte ich das geschilderte Problem für die logische Konsequenz aus der geschilderten Konfiguration. Ich könnte mir vorstellen, dass es bei einer Konfiguration wie der von mir geschilderten klappen könnte. Denn der Vorteil ist hier: Windows "weiß" sozusagen nichts von dieser Linux-Installation.

Gruß, Diophant

* Das muss man noch nichteinmal tun. Man kann auch Linux im Bios an die erste Stelle setzen. Und dann hat man auch hier das übliche Verhalten: im GRUB2-Bootloader wird Windows bei mir nämlich auch als Startoption angeboten (und das funktoniert auch). Linux weiß also von der Existenz der Windows-Installation, andersherum ist es aber nicht der Fall.
 
Zuletzt bearbeitet:

hw2504

nicht mehr wegzudenken
Ich werde da nicht so richtig schlau draus. Schnellstart Hybridmodus aktivieren deaktivieren oder verkleinern Windows 10 Deskmodder Wiki hier ist doch alles für Win 7 beschrieben oder????
Ich bin so vorgegangen:
  • Windows-Taste + R drücken netplwizeingeben und starten
    • Oder Startmenü Startbildschirm öffnen und Benutzerkonten eintippen und starten
  • In dem neuen Fenster Benutzerkonten den Haken entfernen "Benutzer müssen Benutzernamen und Kennwort eingeben".
  • Jetzt das Benutzerkonto markieren und auf Übernehmen klicken
  • In dem neuen Fenster nun das aktuell verwendete Passwort eingeben und darunter bestätigen
  • Auf OK drücken.
Außerdem:
  • Im neuen Fenster nun oben auf: Einige Einstellungen sind momentan nicht verfügbar anklicken.
  • Nun wird unten bei "Einstellungen für das Herunterfahren" der Haken bei
  • Schnellstart aktivieren (Empfohlen) anklickbar.
Nun kann man den Haken entweder entfernen oder setzen.


Beim Start öffnet sich ein Fenster wo ich zwischen Linux und Windows entscheiden kann.
Linux startet normal, ohne Sperrbildschirm oder Nachfrage einer PIN.
Nach anklicken von der Windowszeile öffnet sich Win mit der og. Meldung. Dort muß ich ein Kennwort von Microsoft eingeben und komme zum Admin(ist eigentlich nur ein Konto vorhanden) hier muß ich mein von mir gewählte Passwort eingeben und alles ist OK.
 
Zuletzt bearbeitet:

PeteM92

gehört zum Inventar
hier ist doch alles für Win 7 beschrieben oder????
Diese Anleitung ist für Windows 10 (Windows 7 auf dieser Seite ist ein Tippfehler) *)
Du mußt in Windows 10 den Schnellstart deaktivieren, sonst gibt es Probleme im Dualboot.
Wenn Du Windows 10 ohne die Eingabe eines PINs oder eines Passworts starten willst, kannst Du das mit netplwiz einstellen.
Falls in Deinem netplwiz das markierte Kästchen nicht zu sehen sein sollte, kannst Du das nach dieser Anleitung wieder sichtbar machen.

1612957022258.png


*) ich hatte mit irritieren lassen mit diesem Windows 7. Aber es heißt ja korrekt:
In einem Dual Boot System mit Windows 7, wobei das andere System ja Windows 10 ist.
 
Zuletzt bearbeitet:

Diophant

nicht mehr wegzudenken
Hallo,

noch mal in aller Kürze: das Problem liegt vermutlich an der Art und Weise, wie Linux hier installiert wurde. Dann kann man es innerhalb von Windows wahrscheinlich auch nicht lösen...

Installiert man Linux als Zweitsystem wie von mir geschildert, dann gibt es zum einen keinerlei Probleme mit dem Windows-Schnellstart und vermutlich tritt das hier geschilderte Problem dann auch nicht auf.

Gruß, Diophant
 

hw2504

nicht mehr wegzudenken
Meine Linux-Installation hat eine eigene EFI-Partition auf der Linux-Platte und der Linux-Bootloader wurde dort installiert.
Im Bios ist die Windows-Installation an die 2. Position gesetzt, habe es aber auch schon gewechselt. Hat aber keine Änderung gebracht.
Die anderen Hinweise wie:
Im Windows 10 den Schnellstart deaktivieren, mit netplwiz das Häkchen entfernt usw usf. ausgeführt, es funktioniert nicht.
 

Diophant

nicht mehr wegzudenken
Hallo,

Meine Linux-Installation hat eine eigene EFI-Partition auf der Linux-Platte und der Linux-Bootloader wurde dort installiert.

Ok. Aber was macht dich da so sicher? Ich habe erst kürzlich Ubuntu 20.10 installiert und das bei der Installation auch so eingestellt. Die EFI-Partition wurde auch auf dem Linux-Laufwerk angelegt. Der Bootloader war nur leider in der EFI-Partition von Windows. Einige zeit vorher ist mir exakt das gleiche mit Linux Mint passiert.
Du könntest ja einmal von dem installierten Linux aus nachsehen, was sich da in der EFI-Partition von Windows so befindet (aber natürlich nur nachsehen, nichts ändern...).

Wenn es jetzt ein großer Desktop-PC gewesen wäre, hätte ich gesagt: klemme mal die Linux-Platte ab und schaue was passiert. Aber das kommt in diesem Fall wohl nicht infrage...

Was für eine Distribution ist es denn?

Gruß, Diophant
 

hacke

kennt sich schon aus
@hw2504
Nimm es mir bitte nicht übel. Ich habe kein Verständnis für solche unbedarften Vorgehensweisen. Wenn ich nicht genau weiß, was ich tue, dann lasse ich es lieber.

Du könntest jetzt mal ein Bild von der Datenträgerverwaltung unter Windows von beiden SSDs hier zeigen.
Mit einer Windows DVD/Stick könnte man wohl eine Bootreparatur machen.

Wenn Du Linux nicht dringend brauchst, dann kannst Du das auch erst einmal (die ganze SSD) löschen oder vorher Backup.

In einem NB hätte ich ungern mehrere Systeme, weil ich bei einer Installation immer nur die Platte für das neue System angeschlossen habe, damit ich einen anderen Bootloader nicht zerschießen kann.
der Linux-Bootloader wurde dort installiert.

Da könnte vielleicht das helfen:
sudo update-grub

Dann kann man Windows wenigsten aus GRUB heraus starten.
Reparatur GRUB

Und wer vor einer Zweitinstallation kein Backup macht...

Die Sache mit den PIN in Windows. Naja, wer alles haben will oder muss, hat dann manchmal gar nichts. Ich lasse mich nicht auf alles ein.
 

hw2504

nicht mehr wegzudenken
Könnt ihr hiermit was anfangenß

[email protected]:~$ sudo update-grub
[sudo] Passwort für linux:
Quelldatei `/etc/default/grub'
Quelldatei `/etc/default/grub.d/50_linuxmint.cfg'
Quelldatei `/etc/default/grub.d/init-select.cfg'
GRUB-Konfigurationsdatei wird erstellt …
Linux-Abbild gefunden: /boot/vmlinuz-5.8.0-43-generic
initrd-Abbild gefunden: /boot/initrd.img-5.8.0-43-generic
Linux-Abbild gefunden: /boot/vmlinuz-5.8.0-41-generic
initrd-Abbild gefunden: /boot/initrd.img-5.8.0-41-generic
Linux-Abbild gefunden: /boot/vmlinuz-5.8.0-40-generic
initrd-Abbild gefunden: /boot/initrd.img-5.8.0-40-generic
Linux-Abbild gefunden: /boot/vmlinuz-5.8.0-38-generic
initrd-Abbild gefunden: /boot/initrd.img-5.8.0-38-generic
Linux-Abbild gefunden: /boot/vmlinuz-5.8.0-36-generic
initrd-Abbild gefunden: /boot/initrd.img-5.8.0-36-generic
Linux-Abbild gefunden: /boot/vmlinuz-5.4.0-65-generic
initrd-Abbild gefunden: /boot/initrd.img-5.4.0-65-generic
Linux-Abbild gefunden: /boot/vmlinuz-5.4.0-64-generic
initrd-Abbild gefunden: /boot/initrd.img-5.4.0-64-generic
Linux-Abbild gefunden: /boot/vmlinuz-5.4.0-62-generic
initrd-Abbild gefunden: /boot/initrd.img-5.4.0-62-generic
Linux-Abbild gefunden: /boot/vmlinuz-5.4.0-60-generic
initrd-Abbild gefunden: /boot/initrd.img-5.4.0-60-generic
Linux-Abbild gefunden: /boot/vmlinuz-5.4.0-58-generic
initrd-Abbild gefunden: /boot/initrd.img-5.4.0-58-generic
Windows Boot Manager auf /dev/[email protected]/EFI/Microsoft/Boot/bootmgfw.efi gefunden
Startmenüeintrag für UEFI-Firmware-Einstellungen wird hinzugefügt
erledigt
[email protected]:~$


Jetzt begebe ich mich mal zu Win und schau:
 

Anhänge

  • Datenspeicherverwaltung.PNG
    Datenspeicherverwaltung.PNG
    174,6 KB · Aufrufe: 34
Zuletzt bearbeitet von einem Moderator:

hacke

kennt sich schon aus
Der Bootloader war nur leider in der EFI-Partition von Windows.

Ob das daran liegt, dass bei der zweiten Insatallation das alte System an erster Stelle im Bios/UEFI als Bootgerät steht? Man kann ja bei der Zweitinstallation über eine F-Taste auswählen, dass man nur momentan von DVD/Stick booten will. Der Installer vom zweiten System wäre dann wohl so schlau, nachzuschauen, was im Bios steht. Wie gesagt, etwas Überblick sollte man schon haben.
 

hacke

kennt sich schon aus
Also geht es so für Dich erst einmal? Ich würde vielleicht mal in einem Linux-Forum fragen, ob und wie man die vielen Kernel mal aufräumen sollte. Oder lieber alles so lassen, statt wieder etwas zu beschädigen.

(Es gibt für Linux so Tools... Bleachbit, Synaptic, im Terminal wohl apt...

Alle installierten Kernelversionen anzeigen und die älteren desinstallieren


 
Zuletzt bearbeitet:

MSFreak

gehört zum Inventar
Sollte es lediglich an dem geforderten Windows-Passwort liegen, so kann ich nur das Autologon empfehlen da Microsoft das Autologin in Windows 10 sowieso abschafft.
Autologon - Windows Sysinternals
Ich musste es auch in einigen VMs anwenden da es dort kein Autologin mehr gab (das Häkchen war nach Updates in netplwiz nicht mehr vorhanden).
Und mein Tipp (da du vermutlich im Dualboot nicht fit bist), ich verwende dafür virtuelle Maschinen die auf einer separaten SSD installiert sind.
 

hw2504

nicht mehr wegzudenken
Ich sollte das Häkchen doch entfernen und danach eine Anmeldung ohne Kennwort vornehmen können?
Oder habe ich da was falsch verstanden???

Ich bin bei Win10, das Kästchen fürs Häkchen ist noch vorhanden.
 

MSFreak

gehört zum Inventar
Das ist auch korrekt so, nach dem Entfernen wirst du aufgefordert das Windows-Passwort einzugeben, aber bitte nicht die PIN.
Danach Windows neu starten und gut ist's.
 

PeteM92

gehört zum Inventar
Oder habe ich da was falsch verstanden???
Du hast das zumindest mißverstanden. Du brauchst für die Windows-Anmeldung nach wie vor ein Passwort. Wenn Du das Häkchen herausmachst, mußt Du nur bei der Windows-Anmeldung Dein Passwort nicht mehr eingeben. Windows startet dann ohne weitere Eingaben direkt zum Desktop durch.
 

.Manfred

It's me
Stört sich keiner daran das D: in RAW ist?
 
Status
Dieses Thema wurde gelöst! Lösung ansehen…
Oben