Anzeige

Am Puls von Microsoft

Anzeige

Autologon: Benutzer automatisch anmelden

Martin

Webmaster
Teammitglied
Man kennt das Verhalten von WindowsXP: So lange nur ein einziger Benutzer ohne Passwort angelegt ist, wird dieser beim Hochfahren des Computers automatisch eingeloggt.

Wird ein zweites Konto angelegt, wird der Autologon deaktiviert, lässt sich aber leicht wieder einrichten.

Unter Vista ist das Verhalten identisch, wenn es nur einen Benutzer gibt.
Ab dem zweiten Benutzer hilft ein Eintrag in der Registry, der allerdings nicht ganz frei von Risiken ist:

Den Registry-Editor öffnen und zum Schlüssel

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\Current Version\WinLogon

Nun den Wert AutoAdminLogon auf "1" ändern

Anschließend im rechten Fensterteil auf die freie Fläche mit der rechten Maustaste klicken und Neu -> Zeichenfolge wählen.
Diese bekommt den Namen DefaultUserName
Die Prozedur wiederholen und eine Zeichenfolge mit dem Namen DefaultPassword erstellen.

Die Werte, die da einzutragen sind, dürften klar sein - DefaultUserName ist der Benutzername und DefaultPassword dessen Kennwort.

Hier sieht man auch schon, wo das Sicherheitsrisiko liegt - das Kennwort liegt nun im Klartext lesbar in der Registrierung, und da der PC beim Einschalten direkt durchstartet, kann sich jeder Zugriff darauf verschaffen.
Diese Einstellung sollte also nur in Umgebungen verwendet werden, wo man sich sicher ist, dass dies keine Gefahr darstellt.
 
Zuletzt bearbeitet:
Anzeige
Das geht auch einfacher über das Benutzermenu dort wählt man einen Benutzer aus welcher automatisch angemeldet werden soll, insofern dieser Passwortgeschützt ist muss man es dann zur Bestätigung eingeben.
 
Das kannst Du unter Vista auch einfacher haben:

mit der Tastenkombi Win+R den "Ausführen" Dialog öffnen

in die Eingabezeile die Anweisung netplwiz eingeben

in dem sich öffnenden Fenster im Register den Haken vor der Option "Benutzer müssen Benutzernamen und Kennwort eingeben" entfernen

Allerdings sollte jedem klar sein, dass diese Möglichkeit nicht grundlos "versteckt" wurde und die automatische Anmeldung gewisse Risiken birgt.

Übrigens bin ich mir nicht sicher, ob die Vorgehensweise für alle Vista-Varianten durchführbar ist, oder ob die Home Editionen außen vor bleiben - würde mich über einen entsprechenden Hinweis freuen :)
 
Auf jeden Fall sind jetzt drei Methoden genannt, und eine davon sollte immer funktioneren. Danke für die Ergänzungen (y)
 
Über die Benutzerkonten dem Konto was angemeldet werden soll ein Passwort vergeben.

1. Start>Ausführen>control userpasswords2>Enter
2. Hier das Konto markieren
3. Den Haken raus bei "Benutzer müssen Benutzernamen und Kennwort eingeben"
4. Übernehmen
5. Passwort 2x eingeben
6. Übernehmen und OK.
7. Neustart

Ist zwar das selbe wie beim Post vorher aber wer mehrere Konten hat zwecks Netzwerk mit dem dazugehörenden Zugriff wegen der Freigaben, sollte so vorgehen > Konto markieren vor Haken entfernen. Funzt auch unter XP Pro und Home so. Sollte dann auch bei allen Vista Versionen funzen. Die Basic lass ich mal aussen vor (Eh total sinnlos diese Version).
 
Aber nur die erste Methode funktioniert auch, wenn das Gerät Domänenmitglied ist (z. B. für eine automatische lokale Anmeldung).
 
Also bei mir funktioniert das alles nicht. Ich habe Vista Ultimate 64. Woran kann das jetzt noch liegen?
 
Ich hab es, glaub ich hingekriegt. Ich weiß nicht, ob es die effektivste Methode ist und will es momentan auch nicht wissen. Also:
Alles so machen, wie oben beschrieben. Was aber fehlt, ist der Eintrag "DefaultPassword"
im Regedit-Key "HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\Current Version\WinLogon". Den kann man nur erfolgreich setzen, wenn man sich vorher die Rechte dafür gibt: Auf "WinLogon" rechts klicken, "Berechtigungen..." auswählen und voll auf "Vollzugriff" klicken. Dann kann man das berühmte "DefaultPassword" in Ruhe auf "gott" oder "geheim" oder was man auch immer für ein Passwort hat, setzen.
Bei mir hat das zunächst auch nicht funktioniert. Mußte erst nochmal das netplwiz-Ding machen. Aber jetzt funktionierts.
... Und das alles nur, um von einem anderen System auf die Vista-Kista zugreifen zu können. Ich glaub, ich steige demnächst um - irgendwas mit Obst...
 
Hallo Leute, ich habe ein Problem welches gar nicht so einfach ohne Hilfe zu lösen ist. Nämlich habe ich mir die Sache mit dem Autologon auch gemacht aber seid dem bekomme ich eine Fehlermeldung auf dem Anmeldebildschirm "Sie müssen einen Benutzer angeben" oder so und an der Stelle wo normalerweise mein Bild ist, ist jetzt ein Leeres Bild und ich steh an der Stelle wo normalerweise ja das Gastkonto ist.
Dazu muß ich sagen das ich für diese Sache mal etwas im Netz gefunden habe welches mir die Arbeit in der Registry abgenommen hat aber durch ein Crash (?) ist es damit jetzt auch vorbei...
Ich hänge mal 2 Shots an!
 

Anhänge

  • mnb.JPG
    mnb.JPG
    102,5 KB · Aufrufe: 1.480
  • autologon.JPG
    autologon.JPG
    57,8 KB · Aufrufe: 1.403
Ich kann zu dem Script nichts sagen, zumal man das ja sowieso nicht braucht.
Aber diese Werte solltest Du ändern:

AutoAdminLogon: 1
DefaultUserPassword: Schlüssel komplett löschen

Ob das alleine schon die Lösung ist, wird man dann sehen.
 
Ich habe die beiden Werte wie oben geändert ! Leider bleibt es dabei wenn ich mein Rechner starte und eigentlich die Anmeldebestätigung kommt habe ich vorher eine Fehlermeldung und wie beschrieben ein leeres Userkästchen an meiner Stelle und ich als 2ter Anmelder.
:unsure::confused:
 
Verpass deinem Benutzerkonto ein Passwort.

Dann:

Start > Ausführen > control userpasswords2 > Enter

Dein Konto markieren und darüber den Haken raus bei Benutzer müssen....

Übernehmen, Passwort eingeben und 2x OK. Abmelden und neu anmelden.
 
Hallo Roberto,
ich muß mich trotzdem immer noch anmelden/Passwort eingeben!
Obwohl ich kein Häkchen in dem Kästchen gemacht habe.
Wenn irgendwas an Infos zum Fehler gebraucht wird ... kein Thema hab mal ein Screen Shot drangehängt.
 

Anhänge

  • Benutzerkonto.JPG
    Benutzerkonto.JPG
    55,6 KB · Aufrufe: 1.396
Ich habe alles probiert und nichts hat funktioniert: doch dann habe ich es doch geschaft! habe folgendes gemacht: 1.Systemsteuerung/ 2.Mobil-PC/ 3.Energieoptionen/ 4.Kennwort für Reaktivierung erforderlich/ 5.Kennwort ist nicht erforderlich/ Anklicken und Speichern! Fertig. ohne neustart sofort verfügbar!
 
Das automatische Anmelden WIN 7 bei mir hat erst durch Win Optimizer 2015 ( ein Tool davon ) bisher richtig funktioniert !
 
Anzeige
Oben