Anzeige

Am Puls von Microsoft

Anzeige

[gelöst] BSOD - Bluescreen Invalid MDL Range bei Installation von Programmen

DerPwny

Herzlich willkommen
Hallo!

Ich bekomme immer wieder einen Bluescreen beim Installieren von Programmen.
Als Bezeichnung steht da "Invalid MDL Range".
Das tritt aber nicht bei kleinen Programmen auf, sondern nur immer gegen Ende der Installation, wenn die Installation länger als 3 Minuten dauert in etwa.
Ich nutze Windows 10 (1703) mit aktuellen Updates.
Alle Treiber sind aktuell, ich habe aber nochmal alle wesentlichen Herstellertreiber neugeladen und neuinstalliert, ebenfalls habe ich einen Systemfilecheck und Chkdsk ausgeführt. Auffälligkeiten gab es keine.
Einen Virus habe ich auch nicht (Avira und Malwarebytes).
Ich habe einen selbst zusammengestellten PC mit i7 4790K 4 Ghz, 16 GB Ram, einer GTX 970 und ein Asus Z97 Pro Gamer. Bisher ging alles ohne Probleme, der PC ist in etwa 2 Jahre alt, frisch entstaubt.

Keine AHnung wo das so plötzlich herkommt, bisher war das nie ein problem.

Hat jemand eine Idee was die Ursache für den Fehler sein könnte?

Das geht mir langsam ziemlich auf den Keks :(
 
Anzeige

Silver Server

gehört zum Inventar
Im Ordner D:/Windows/Minidump liegen die Informationen vom Stopp Fehler.
Die letzten 5 Files auf den Desktop kopieren.
Mit rar oder zip verpacken.
Hier im Forum hoch laden.
 

DerPwny

Herzlich willkommen
Meinst du es liegt daran? Wieso?
Ich habe einen USB/MicroSDHC Card Adapter im PC stecken gehabt, den habe ich aber gar nicht benutzt.
Kann der das trotzdem hervorrufen?
 

Ari45

gehört zum Inventar
Guten Morgen! Willkommen im Forum, @DerPwny! :)
Ich knüpfe an die Antwort von @Silver Server in #5 an:
Als erstes der Stackinhalt der Dumpfile
Code:
INVALID_MDL_RANGE (12e)
STACK_TEXT:  
ffffa580`5ae8d2c8 fffff801`44e4d063 : 00000000`0000012e ffffbd83`c9a49540 ffffbd83`d0c632a0 00000000`00000000 : nt!KeBugCheckEx
ffffa580`5ae8d2d0 fffff800`92d41eb3 : ffffbd83`d0dad7b0 ffffbd83`d1402010 ffffbd83`d0dad7b0 ffffa580`5ae8d400 : nt!IoBuildPartialMdl+0xcd0d3
ffffa580`5ae8d310 fffff800`92d41934 : ffffbd83`d0dad703 ffffbd83`d0d14a80 ffffe702`0007f000 ffffa580`5ae8d430 : exfat!FppMultipleAsync+0x127
ffffa580`5ae8d390 fffff800`92d51d2b : 00000000`00000000 00000000`00000000 ffffbd83`d0dad7b0 ffffbd83`d0dad7b0 : exfat!FppNonCachedIo+0x624
ffffa580`5ae8d530 fffff800`92d1a61b : ffffbd83`d0dad7b0 ffffbd83`d1402010 ffffbd83`ce961300 ffffe702`00000000 : exfat!FppCommonRead+0x79f
[COLOR="#FF0000"]ffffa580`5ae8d690 fffff800`8be6563d : ffffbd83`c9fc2b80 ffffbd83`d1402010 ffffa580`5ae8e000 ffffa580`5ae88000 : exfat!FppFsdRead+0x17b[/COLOR]
[COLOR="#008000"]Der Treiber exfat.sys wurde gefunden und dieser löst zwei Stackframes weiter
einen BugCheck aus.[/COLOR]
ffffa580`5ae8d720 fffff800`8be634d6 : ffffa580`5ae8d7b0 ffffbd83`d1cbc788 00000000`00000000 ffffbd83`cab9f200 : FLTMGR!FltpLegacyProcessingAfterPreCallbacksCompleted+0x18d
ffffa580`5ae8d790 fffff800`92d91fd1 : ffffbd83`d1402010 ffffbd83`ce191440 ffffbd83`d0054ee0 fffff800`92d9bf6d : FLTMGR!FltpDispatch+0xb6
[COLOR="#FF0000"]ffffa580`5ae8d7f0 fffff800`92d9eb4b : ffffbd83`d0fdd3a0 ffffbd83`d0fdd303 00000000`00000001 00000000`00000800 : vhdmp!VhdmpiFileWrapperCallDriver+0x291[/COLOR]
[COLOR="#008000"]Dieser VHD Miniport beauftragt den Filtermanager nach einem Treiber zu suchen[/COLOR]
ffffa580`5ae8d870 fffff800`92e2925d : ffffbd83`d0fdd320 00000000`00000007 ffffbd83`d1c2c500 ffffbd83`d0fdd300 : vhdmp!VhdmpiCallDriverWithoutBlocking+0xab
ffffa580`5ae8d8d0 fffff800`92dc2b82 : ffffbd83`d0fdd320 ffffbd83`d1c2c570 ffffbd83`d1c2c4e0 fffff800`92dc1a0c : vhdmp!RmwiAlignNonAlignedIO+0x69
ffffa580`5ae8d900 fffff800`92e292cd : ffffbd83`d0fdd320 00000000`00000000 ffffbd83`d1c2c400 ffffbd83`d1c2c4e0 : vhdmp!RmwiConsumeStateActivating+0x32
ffffa580`5ae8d930 fffff800`92dc30c6 : ffffbd83`d0fdd320 fffff801`ffffffff ffffbd83`d1cbcb00 ffffbd83`d14d7900 : vhdmp!RmwiConsumeNonAlignedQueue+0x25
ffffa580`5ae8d960 fffff800`92db178d : 00000007`ecb78000 ffffbd83`d1cbc2c0 ffffbd83`d1cbc2c0 ffffbd83`d1c2c4e0 : vhdmp!RmwiTriageIO+0x1c2
ffffa580`5ae8d9a0 fffff800`92d9ea26 : ffffbd83`d1c2c4e0 ffffbd83`ce0b6a80 ffffbd83`d0054ee0 ffffbd83`d1c2c570 : vhdmp!memset+0x10d
ffffa580`5ae8d9e0 fffff800`92d9ca2d : ffffbd83`ce191440 ffffbd83`c9da4010 ffffbd83`c99e0180 ffffbd83`c99e0140 : vhdmp!VhdmpiIssueIrpContext+0x1fa
ffffa580`5ae8da20 fffff800`92dbf595 : ffffbd83`ce191440 fffff800`00000000 00000000`00080000 ffffbd83`ce191630 : vhdmp!VhdmpiSrbPartReportPresent+0x33d
ffffa580`5ae8da90 fffff800`92d9e53a : 00000000`00000000 00000000`00000000 fffff801`00080000 00000000`00000000 : vhdmp!VhdmpiIsoStartSrbPart+0x35
ffffa580`5ae8dae0 fffff800`92d9e46e : ffffbd83`ce191440 ffffbd83`d13cec48 ffffbd83`ce191440 fffff800`92e07b90 : vhdmp!VhdmpiProcessParseThreadContext+0xaa
ffffa580`5ae8db10 fffff800`92e07bb9 : 00000000`00000000 fffff801`45087380 ffffbd83`d0fdd360 fffff800`92e292f0 : vhdmp!VhdmpiStartSrbExtensionAfterRct+0x5e
[COLOR="#FF0000"]ffffa580`5ae8db50 fffff801`44cccca8 : ffffbd83`c99e0040 fffff801`44eab900 fffff801`4500d4e0 00000000`00000000 : vhdmp!VhdmpiSrbExtensionWorkerRoutine+0x29[/COLOR]
[COLOR="#008000"]Es ist ein "VirtuelleHD MiniPort" installiert[/COLOR]
ffffa580`5ae8db80 fffff801`44d6bac7 : fffff801`43918180 00000000`00000080 ffffbd83`c8e99680 ffffbd83`c99e0040 : nt!ExpWorkerThread+0xd8
ffffa580`5ae8dc10 fffff801`44e00946 : fffff801`43918180 ffffbd83`c99e0040 fffff801`44d6ba80 6f004d00`63007400 : nt!PspSystemThreadStartup+0x47
ffffa580`5ae8dc60 00000000`00000000 : ffffa580`5ae8e000 ffffa580`5ae88000 00000000`00000000 00000000`00000000 : nt!KiStartSystemThread+0x16
Es ist nicht ganz eindeutig, ob der Treiber vhdmp.sys oder exfat.sys der wirkliche Verursacher ist. Beide sollten erneuert werden, entweder eine neue Version installieren oder die bestehende Version entfernen und neu herunterladen.

Darüber hinaus ist zu bedenken, dass der Stoppfehler bei der Installation eintrat und da war sicher AVIRA aktiv. Die meisten Softwarehersteller empfehlen, Sicherheitsprogramme während der Installation zu deaktivieren.

Wenn das Problem weiterhin besteht, sollte auch AVIRA entfernt und anschließend mit dem Registrycleaner von AVIRA Reste entfernt werden.
https://www.avira.com/de/support-for-home-knowledgebase-detail/kbid/902

Nachtrag:
Ich habe mir jetzt auch die restlichen drei Dumpfiles noch angesehen. In allen 4 Dumpfiles genau die gleiche Absturzursache, sogar der gleiche Stackinhalt.
 
Zuletzt bearbeitet:

DerPwny

Herzlich willkommen
Danke euch.
Es war der Adapter, den ich komplett hinten am PC vergessen habe :ROFLMAO:
Warum der mir jetzt bei der Installation dazwischen funkt, versteh ich nicht ganz, aber kaum war er weg, geht wieder alles.
Naja, mein Fehler, aber danke fürs Helfen :)
 
Anzeige
Oben