Anzeige

Am Puls von Microsoft

Anzeige

[gelöst] BSODs, zu scheinbar zufälligen Zeitpunkten, ntoskernel.exe laut bluescreenview

Status
Dieses Thema wurde gelöst! Lösung ansehen…

Humbled0re

bekommt Übersicht
Hi, bin mittlerweile mehr als ratlos und verzweifelt. Seit Ende letzen Jahres bekommt ich sporadisch immer mal wieder bluescreens. Anfangs wirklich sporadisch, also maximal 1-2 mal im monat, dann etwa ein Mal pro Woche. Seit Ende Juli habe ich täglich 1-2 Bluescreens mit automatischem Neustart.
Leider kann ich es auch nicht auf eine bestimmte Tätigkeit festnageln. Mal passiert es beim Zocken, mal wenn ich nur im Browser unterwegs bin und z.B. einen Tab schließe. Ein paar mal ist es direkt nach dem Anschließen eines USB-Headsets passiert, ein paar mal in einem MS Teams-Meeting.

Die BSOD-Meldungen waren meistens MEMORY_MANAGEMENT, STORE_DATA_CORRUPTION oder FAULTY_HARDWARE_CORRUPTED_PAGE. Bluescreenview zeigt mir bei allen Minidump-files an, das der Treiber "ntoskernel.exe" wohl das Problem verursacht hat, mit dem Anhängsel "+3f7130". Nur habe ich leider keine Ahnung, was mir das genau sagt bzw. wie mir das weiterhilft.

Mein System:
OS: Win 10 Home 64bit

CPU: Ryzen 5 3600

GPU: NVIDIA GTX 1050ti

RAM: G.Skill RipJaws V DDR4-2300 CL16-18-36 (2x 8GB) (hier grad nur 1x8GB, weil memtest64 beim anderen über 1000 Fehler gefunden hat)

Motherboard: ASRock B450m Pro4 (BIOS Version P3.90)

PCU: bequiet! System Power 8 (400W)

Samsung EVO 850 250GB (the one with Windows on it)

Samsung EVO 860 500GB

2TB HDD, die nur zum Speichern von Dokumenten, Musik, Filmen etc. dient. Ist die meiste Zeit auf standby.

Was ich schon gemacht habe:
- die neusten Windows-Updates
- Graka Updates (über GeForce Experience)
- Bitdefender deinstalliert (habe aktuell nur den Windows Defender)
- MullvadVPN deinstalliert (hab da haupts. nach nem Strohhalm gegriffen, weil ich das in irgendnem Forum gelesen habe)
- Schnellstart deaktiviert
- Ruhemodus deaktiviert
- CHKDSK-Befehl
- scf/scannow Befehl
- Prüffunktion von Windows bei allen Festplatten (die über Eigenschaften ->Tools)
- DSIM-Befehle Scanhealth, checkhealth und restorehealth
- Memtest64 für beide RAM Riegel zusammen, dann jeweils einzeln: Hier wurden auf einem RAM-Riegel über 1000 Fehler gefunden, auf dem an anderen 0.
Hab den fehlerhaften Riegel mal rausgelassen und war schon optimistisch, damit das Problem gelöst zu haben...das war aber wohl nicht der einzige Fehler. Der letzte Bluescreen ist ca. 2 Stunden her, dieses mal war es SYSTEM_SERVICE_EXCEPTION.

Da fällt mir noch ein: Bei manchen Abstürzen war ich auch gar nicht im Raum. Kam nach 5-10 Minuten Abwesenheit zurück und auf einmal war der PC wieder im Anmeldescreen. Danach im Browser die Frage, ob Seiten nach nicht korrektem Schließen erneut geöffnet werden sollen, daher schloss ich auf ein automatische neustarten nach Bluescreen. Zum Teil konnte ich in den Situationen auch im EventView von Windows bzw. in Bluescreenview gar keinen "BSOD-Code" wie z.B. MEMORY_MANAGEMENT finden. Vielleicht hilft euch diese Beobachtung..


ZIP mit den aktuellsen minidump-files hänge ich an.

Ich danke euch ganz herzlich fürs Lesen meines Hilfegesuchs und hoffe inständig, dass ihr mir helfen könnt.

Viele Grüße

Humbled0re

PS: Mir fällt grad ein, dass ich, ungefähr seit der Zeit seit der sich die BSODs wirklich häufen (täglich), auch immer mal wieder in chrome diesen "aaw snap" fehler, bei dem einzelne Seiten praktisch abstürzen. Der Browser selbst ist dabei nicht ganz abgestürzt. Irgendwie hab ich das aus bisheriger Erfahrung mit Arbeitsspeicher in Verbindung gebracht, weil ich weiß, dass Chrome davon oft viel beansprucht (vor allem bei vielen gleichzeitig geöffneten Tabs). Kann das mit dem Problem zusammenhängen?
 

Anhänge

  • 2021-08-11_Minidump.zip
    751,9 KB · Aufrufe: 37
Anzeige

Webwatcher

gehört zum Inventar
Ruf mal "Zuverlässigkeitsverlauf anzeigen" auf (einfach in die Suche zuver eingeben)

zeigt eine Übersicht mit Hinweisen über Unregelmäßigkeiten der vergangenen Tage auf
 

Porky

gehört zum Inventar
Willkommen im Forum!
Als erste Maßnahme aktualisiere das steinalt zu nennende BIOS. Inzwischen gibt es 7 neuere Versionen.
Dann bitte einen solchen Screenshot von HWiNFO Free Download HWiNFO Sofware | Installer & Portable for Windows, DOS
Als Absturzursache sehe ich da mehrmals memory corruption und memory compression, also Probleme mit dem Arbeitsspeicher.
Ist Software von Asus installiert? Ich sehe da einen Treiber, der unter Anderem von der AI Suite verwendet wird.
 

Anhänge

  • HWiNFO.png
    HWiNFO.png
    151,5 KB · Aufrufe: 20
Zuletzt bearbeitet:

rusticarlo

gehört zum Inventar
puh
einen Ryzen Matisse Prozessor mit einem B450 Einsteiger Mainboard zu "verheiraten" geht gar nicht

dann defekter RAM, den du übrigens als komplettes Kit reklamieren muß, G.Skill ersetzt keine einzelnen Module

das Netzteil ist auch etwas zu schwach

da braucht man sich die Dumpfiles kaum noch anschaun, um zu wissen, das dies nicht so wirklich zusammengeht
 

Ari45

gehört zum Inventar
Hallo @Humbled0re! Willkommen im Forum! 🙋‍♂️
Ich habe mir trotzdem mal die drei neuesten Dumpfiles angesehen.
Alle Drei weisen einen Fehler im Memory aus:
einmal in virtuellen Memory (Arg1: 0000000000041790, A page table page has been corrupted)
einmal bei der Übergabe der virtuellen Adresse (Arg1: ffffffffc00002c4, virtual address mapping the corrupted page)
einmal direkt im Memory ( 0x3B_c0000005_nt!SwapContext)

Der dritte Fehler ist der Stoppfehler von heut. Hier gab es ein Speicherzugriffsfehler (9xc0000005) beim Wechsel von einen Thread zu einem anderen (SwapContext).
Der erste Fehler ist aus Dumpfile 080921-6062-01.dmp. Die korrupte Seite der PageTabelle kann seine Ursache sowohl um Memory, als auch im virtuellen Memory (Pagefile.sys) haben.

Wie meine Vorschreiber schon schrieben, ist als erstes der RAM als Kit zu tauschen, also nicht nur ein RAM-Modul sondern beide.
Da sich mindestens ein Fehler auf den virtuellen Speicher (Pagefile.sys) bezog, ist nach dem Speicherwechsel die System-Festplatte zu überprüfen.
 

Humbled0re

bekommt Übersicht
Hi zusammen, schon mal vielen Dank für die rasanten Antworten!

@Webwatcher Da hab ich eben mal reingeschaut. Werde daraus als Laie leider auch nicht schlauer, außer dass ich jetzt auch graphisch sehe, wie instabil mein Rechner scheinbar läuft :(
edit: Hab noch screenshots von der Zuverlässigkeitsanzeige beigefügt. Sorry, dachte du meintest das wäre nur für mich zum selber anschauen empfohlen 🙃

@Porky Hach ich dachte um BIOS-Update komme ich drum rum. Hab ich noch nie gemacht und ehrlich gesagt etwas Schiss vor. Bisher hieß es in jedem Tutorial dazu "solange es kein Problem damit gibt lass das mit dem Update, denn wenn was dabei schiefläuft ist die Chance hoch, dass der Rechner geschrottet ist"...hab einfach gehofft, es liegt an was anderem. Sollte ich die anderen Sachen zuerst probieren, sprich ein neues RAM-Kit kaufen, neue Systemfestplatte?
HWiNFO-Screenshot habe ich angehängt. Von Asus habe ich nichts wissentlich installiert. Kann da mit dem Motherboard irgendwas gekommen sein? Ist ASRock nicht irgendwie mit Asus verbunden?
Wie überprüfe ich sowas am besten, außer in der Systemsteuerung bei "Programme deinstallieren" schauen bzw. es in die Suchleiste bei Windows eingeben? 😅

@rusticarlo Hm, mit dem ersten Satz kann ich leider wenig anfangen. Das Motherboard wurde mir damals eben als Einsteigermodell für den Ryzen 5 3600 empfohlen. Daraus habe ich als Laie natürlich nicht geschlossen, dass diese Kombo ein no-go sein könnte.
Vielen Dank für den Tipp mit dem RAM, ich dachte ich könnte einfach einen Riegel mit gleichen Spezifikationen nachkaufen. Sofern ich auf die G.Skill RipJaws noch Garantie habe versuche ichs mal mit ner Reklamation.
Was für ein Netzteil würdest du für so ein System empfehlen? Auch hier wurde mir nämlich anfangs versichert, dass solch "stromsparenden Komponenten" wie der Prozessor und die Grafikkarte mit 400W zufrieden seien.

@Mark O. kann bei solch normalem Gebrauch (bisschen WoW/LoL zocken/surfen/office) die "Standardkühlung" (Standard CPU-Kühler, Standard Grafikkartenkühler, Gehäuselüfter vorne unten (zieht rein), Gehäuselüfter hinten oben (bläst raus)) schon so arg überfordert sein?

@Ari45 Vielen Dank dafür, dass du dir die Dumpfiles angesehen hast :) Alles klar, dann werd ich mir ein neues RAM-Kit bestellen bzw. das bestehende reklamieren. Mit Systemfestplatte ist hier die SSD gemeint, auf der Windows installiert ist, oder? Macht es da Sinn, auf einer neuen SSD eine Art "Systemabbild" (hoffe das ist die richtige Bezeichnung) zu machen, um sich Arbeit zu ersparen? Oder kopiert man sich da im Zweifel Software-Fehler mit auf die neue Platte?🙃
 

Anhänge

  • HWiNFO.PNG
    HWiNFO.PNG
    189,7 KB · Aufrufe: 30
  • 2021-08-11_Zuverlässigkeitsverlauf_1.PNG
    2021-08-11_Zuverlässigkeitsverlauf_1.PNG
    110 KB · Aufrufe: 28
  • 2021-08-11_Zuverlässigkeitsverlauf_2.PNG
    2021-08-11_Zuverlässigkeitsverlauf_2.PNG
    124,8 KB · Aufrufe: 24
  • 2021-08-11_Zuverlässigkeitsverlauf_3.PNG
    2021-08-11_Zuverlässigkeitsverlauf_3.PNG
    122,7 KB · Aufrufe: 24
Zuletzt bearbeitet:

Porky

gehört zum Inventar
Laut G.Skill ist das Dual Kit F4-3200C16D-16GVGB mit deinem Mainboard kompatibel. Hast du im BIOS das XMP geladen oder Timings und Spannung manuell eingetragen?
 

Humbled0re

bekommt Übersicht
@Porky
Bisher hatte ich dort alles auf "auto", habe es aber am Dienstag abend mal auf XMP 2.0 gestellt. Dadurch wurde die Frequenz auf 3200 mhz und die Spannung auf 1.35 Volt erhöht (von vorher 1.2 Volt) wenn ich das richtig verstanden habe. Soll ich mal versuchen, die Werte händisch einzutragen?
 
Zuletzt bearbeitet von einem Moderator:

Porky

gehört zum Inventar
XMP 2.0 ist genau richtig. Nichts weiter ändern. Möglicherweise funktioniert jetzt das System auch mit beiden RAM-Riegeln stabil, also testen.
 

Humbled0re

bekommt Übersicht
@Porky sehr gut, dann kann ich das schonmal von der to-do Liste streichen :D

Nach "SYSTEM_SERVICE_EXCEPTION" gestern Abend gab es heute Mittag in meiner 10-minütigen Abwesenheit einen "PFN_LIST_CORRUP" Fehler. Den ganzen Vormittag von 7:30 bis 13 Uhr konnte ich ohne Probleme arbeiten.

Hab heute Mittag ein RAM-Kit bestellt, das in den nächsten Tagen ankommen sollte. Reklamation will ich schon auch noch versuchen, aber mit zurückschicken und auf Ersatz warten könnte ich dann einige Tage meinen PC überhaupt nicht nutzen...und trotz der BSODs will ich ungern "lindnern", wie manche Leute vielleicht sagen würden ("besser gar nicht benutzen, als falsch/schlecht benutzen") 🤡

In der Zuverlässigkeitsüberwachung habe ich noch gesehen, dass zwei Stunden vor dem heutigen crash ein nicht mehr funktionsfähiger "Antimalware Service Executable" als kritisches Ereignis drin steht. Laut google hängt das mit dem Windows Defender zusammen. Kann das ein Überbleibsel von einem nicht korrekt deinstallierten Antivirenprogramm kommen? Mehr als den Windows Defender habe ich aktuell nicht.
 

tkmopped

gehört zum Inventar
Dein 3.90 er Bios auf dem Board geht nur bis zum Pinnacle Ridge. Es ist mir ein Rätsel wie du das seit einem dreiviertel Jahr betrieben haben willst. Unterstützung für die 3000er Zen2 gibt es erst ab Bios 4.20. Weil alle AM4 Boards für Win11 fit gemacht wurden empfiehlt sich das aktuellste zu installieren, das auf der Supportseite steht. Das 5.20 hebt zusätzlich den AGESA-Code auf Version 1.2.0.3.b.
Wenn dein Bios so aussieht wird dein Chipsatztreiber nicht viel besser sein. Direkt von AMD laden, Version x.x.x.506 bringt den aktuellsten ins System. Zickt der bei der Installation muß der PSP erstmal a bgewählt werden. Kann man später nachholen.
Ist Bios und der Chipsatz aktzuell sollte das gehen.
Dumpfile kann ich gerade nicht reinschauen. Mit IPad geht sowas nicht.
Speicher, der in Memtest fehler zeigt, kann nicht weiter verwendet werden. Soweit klar.War das ein Speicherkit, sollten beide gegen ein anderes komplettes Dualkit getauscht werden. Es besteht die Gefahr, das beim tausch nur eines Riegels, dieser mit einem gleichlautenden (Typnummer) einer anderen Charge nicht zusammenarbeiten kann. Im Handel sind die Hersteller der Speicherchips auf den Modulen nur selten dokumentiert.
 
Zuletzt bearbeitet:

Humbled0re

bekommt Übersicht
@tkmopped Vielen Dank für die Tipps, dann probiere ich das mal. Kann ein BIOS-Update auch getrost von einem Laien wie mir durchgeführt werden? 🙃 Hab da schon Horrorstorrys von "gebrickten" Rechnern gehört, bei denen beim BIOS-Update etwas schief gegangen ist...

Zum Chipsatztreiber, macht es daeinen Unterschied, ich bezüglich Mainboard nach "b450" oder "b450m" suche?
Und was ist PSP? 😅

Edit: Danke auch für den Hinweis mit dem RAM-Kit. Nach den vorherigen Kommentaren war mein Plan ohnehin, dass ich dann das komplette neu bestellt Kit benutze, und nicht nur einen zu dem grad verwendeten dazu stecke. Das alte Kit werde ich als ganzes reklamieren.
 
Zuletzt bearbeitet:

tkmopped

gehört zum Inventar
Bios wie auf der Supportseite angegeben ist nicht problematisch, wenn du geduldig bist und den Strom nicht abstellst. Seit vielen Jahren macht das keine Probleme mehr. Biosdatei auf USB-Stick, ins Bios starten (Entf oder F2 ) und dort EZ-Flash oder so ähnlich auswählen. Wie genau das bei Asrock heißt steht im Handbuch.
Chipsatztreiber ist von AMD identisch für alles was AM4 im Namen trägt. Du kannst zwar B450 eingeben aber derzeit ist dA kein Unterschied bei allen Versionen.
IdR. Wird die 64Bit Version installiert.
 

Humbled0re

bekommt Übersicht
@tkmopped Vielen vielen Dank!! Das werde ich am Wochenende direkt ausprobieren.

Nehme an das ist dann wahrscheinlich auch unabhängig von dem RAM-Austausch eine sinnvolle Sache :D
 

Humbled0re

bekommt Übersicht
@tkmopped Gestern ist mir noch die Frage gekommen:
Sollte ich BIOS vor Chipsatztreiber installieren, oder ist die Reihenfolge egal?

Und hat es irgendeinen Nachteil, wenn ich davor schon den neuen RAM einbaue? Also könnte der, falls das Problem nicht nur bei BIOS/Chipsatztreiber/dem defekten alten RAM liegt, irgendwie bei der ganzen Sache in Mitleidenschaft gezogen werden?

Sorry für das gespamme, bin leider etwas nervös wegen der ganzen sache 😅
 

Ari45

gehört zum Inventar
@tkmopped scheint nicht online zu sein. Deshalb versuche ich mal, dir zu antworten:
-> in der Regel aktualisiert man das BIOS als erstes, weil der gesamte Rechner hardwareseitig auf dem BIOS aufbaut.
-> nach dem BIOS sollte man als nächstes sofort die Chipsatz-Treiber aktualisieren, weil die für die richtige Ansteuerung der CPU und der anderen Hardware zuständig sind. Vorausgesetzt ist natürlich, dass Windows überhaupt läuft.
-> die RAM-Module baust du ein, sobald sie da sind. Bis dahin betreibst du den Rechner mit dem einen, funktionierenden Modul.

Nochmal zum BIOS:
@tkmopped hat es zwar schon geschrieben, aber doppelt hält besser:
Das BIOS-Update ist kein Hexenwerk, wenn man es aus dem BIOS heraus macht. Da gibt es eine Funktion "QFlash".
Bei meinem UEFI ist der Button rechts unten.
UEFI_QFlash.jpg
Man könnte auch theoretisch das Update aus Windows heraus machen, aber mir persönlich ist das zu gefährlich. Wenn sich Windows verschluckt, ist das BIOS Schrott und es bedarf enormer Anstrengungen, das wieder hin zu biegen.
 

Ari45

gehört zum Inventar
Noch ein Tip:
Bei den meisten BIOS-Updates gibt es eine Option "altes BIOS sichern" (oder so ähnlich).
Das sollte man machen, denn wenn, aus welchem Grund auch immer, das neue BIOS nicht (richtig) funktioniert, kann man zum alten BIOS zurück.
 
Status
Dieses Thema wurde gelöst! Lösung ansehen…
Anzeige
Oben