Datei Explorer Fokus-"Diebstahl" abstellen?

Mav99

bekommt Übersicht
Bis jetzt konnte ich keine funktionierende Lösung finden, vielleicht hat ja hier jemand einen Tipp:

Vor Windows 10 mir das nie so extrem aufgefallen, aber jetzt nervt es mich extrem: Wenn man Dateien kopiert und dann irgendetwas anderes macht springt der Explorer, sobald er fertig ist, ungefragt in den Vordergrund und stiehlt dabei den Fokus.
Man ist gerade beim Tippen oder Klicken und plötzliche landen die Eingaben unvermittelt beim Explorer, der dann plötzlich auch mal Ordern oder Dateien löschen oder sonstigen Unsinn anstellen möchte, je nachdem was man gerade in einem anderen Programm machen wollte. Das ist außerordentlich lästig.

Kann man das irgendwie unterbinden?

Die alte Focus-Stealing Option aus XP gibt es leider nicht mehr und ansonsten habe ich online nur unbrauchbare Tipps gefunden.
Tools die ein Programm per TopMost-Flag im Vordergrund halten sind auf jeden Fall keine Option, dazu wechsle ich zu viel zwischen Programmen hin und her. Das wäre natürlich auch für andere Programme sinnvoll aber beim Explorer nervt es halt am meisten weil es so oft vorkommt...
 
Anzeige

Iskandar

Einfacher Nutzer
Wollte dies gleich mal nachvollziehen und hab von meiner Ex-Festplatte eine Datei in den Dokumente-Ordner im Notebook kopiert.
In der Zwischenzeit hab ich weiter in diesem Forum gesurft und rumgeklickt.
Im Taskmanager wurde mir der Fortschritt der Übertragung laufend angezeigt und stoppe dann beim Ende einfach, so dass ich dort erst draufklicken musst um das Resultat im Explorer zu begutachten.
Deine Erfahrung kann ich also nicht bestätigen. Bei mir - Windows 10 pro, aktuelle Insiderversion 21H2 - passiert so was nicht .
Vielleicht solltest du mal deine Einstellungen zu den Win-Benachrichtigungen überprüfen.
Warum nennst du das "Diebstahl"?
 
Zuletzt bearbeitet:

Mav99

bekommt Übersicht
Bei mir ist es Win10 Pro 20H2. Und nach dem Abschluss jedes Kopiervorgangs springt der Explorer - nicht der Kopierdialog - wieder in den Vordergrund. Ich habe mich über dieses Verhalten schon mehrfach bei Microsoft beschwert. Andere vermutlich auch. Vielleicht hat das wirklich was gebracht?!?

Wäre jedenfalls toll, wenn künftige Windows Versionen das endlich abstellen.
Mit den Benachrichtigungen hat das übrigens nichts zu tun.

Wie würdest Du Focus-Stealing für ein deutsches Forum übersetzen?
 

_Sabine_

gehört zum Inventar
@Mav99 Kann dir leider keine Lösung bieten, aber kenne das leider auch nur zu gut. Ist eine sehr nervige Sache. Ich habe den Dateimanager gewechselt, um das Problem zu "beheben".
 

Jürgen

Moderator
Teammitglied
Kann es auch sein dass Du durch Win+E den Explorer ungewollt aufrufst? ich versuche schon seit deinem 1 Beitrag den Fehler zu simulieren, oder klemmt die Win-Taste?
 

areiland

Computer Legastheniker
Also ich kenne das auch nur so, dass der Kopiervorgang im Hintergrund läuft und nach Abschluss einfach nur der Dialog geschlossen wird, ohne dass der Explorer sich nochmal in den Vordergrund drängelt. Gerade ausprobiert - der "Kopieren" Dialog wurde einfach nur geschlossen und verschwand aus der Taskleiste, ohne dass der Explorer nochmal in den Vordergrund kam.

Es dürfte doch was mit den Benutzereinstellungen und installierten Tools zu tun haben, wenn sich der Explorer nur bei einigen so verhält. Die mir bekannten Klagen über dieses "Phänomen" reduzieren sich nämlich auf genau diesen einen Forenthread in diesem einen Forum - von etlichen, in denen ich mich regelmässig tummle.
 

_Sabine_

gehört zum Inventar
Gerade in einer frisch aufgesetzten VM getestet. Kein Tools drauf und 100% offline. Problem genauso vorhanden.

Davon ab finde ich durchaus Treffer dazu im Netz. Etwa:
Windows Explorer stealing focus after done copying - Windows 10 Help Forums
Can I stop Explorer from stealing focus after copying or moving a file?

Und hier sogar von 2015 mit einer Lösung:
Problem in all Windows Explorer instances. Focus jumps to top
Man soll die Auto-Akzentfarbe deaktivieren. Ist nur leider schon so (default).

Edit #3: Ich habe doch noch eine - blöde Lösung - gefunden. Deaktiviere ich den Transparenzeffekt (Einstellung -> Personalisierung -> Farbe), dann habe ich den Fehler nicht mehr. :eek:
 
Zuletzt bearbeitet:

Lappo

...
Hmmm , ich minimieren generell das 'Kopieren-Fenster' und habe dadurch besagten Effekt nicht.

Lasse ich das besagte Fenster im Vordergrund (oder ändere nichts manuell an der Einstellung)
'nervt' das Ende des Vorganges jedesmal , egal was ich gerade im Explorer mache 🥸
 

Iskandar

Einfacher Nutzer
Hallo Mav99
Ach so, hab grad gelernt,"Focus Stealing" bezeichnet etwa "die Show stehlen", sich vordrängeln und in den Focus stellen.
Alles klar.
Schon etwas älter aber vielleicht hilft es dir. Hat offenbar mit "Focus Assist"in deinen Einstellungen zu tun.
Change Focus Assist Automatic Rules in Windows 10 | Tutorials (tenforums.com)
Bei mir ist das immer auf OFF !
focus.png
 

Mav99

bekommt Übersicht
@Lappo
Das mit dem Minimieren ist eine gute Idee, muss ich mal probieren und beobachten.

Vielleicht liegt es auch daran, wie ich kopiere. Üblicherweise habe ich mehrere Explorer-Fenster mit Quell- und Ziel-Ordnern offen. Es aktiviert sich nach Abschluss des Kopierens oder Verschiebens immer das Ziel-Fenster automatisch und zeigt die kopierten/verschobenen Dateien/Ordner markiert an.


@Iskandar
Danke für den Versuch, aber das hat damit leider gar nichts zu tun. "Focus Assist" heißt in der deutschen Version "Benachrichtigungsassistent" (früher wohl "Ruhezeiten"). Dabei geht es darum welche Benachrichtigungen im Info-Center angezeigt werden und Off/Aus bedeutet alle.

Bei meinem Problem geht es darum, das das gerade aktive Programm den Eingabe-"Fokus" hat, d.h. es erhält (fast) alle Tastatureingaben und Mausklicks in sein Fenster. Normalerweise ist das das gerade aktive, vordere Fenster.
Und dann passiert es mir regelmäßig das der Datei-Explorer nach Abschluss eines Kopiervorgangs das Zielfenster ungefragt nach Vorne holt und damit auch sofort den Eingabe-Fokus für die Tastatur und Maus übernimmt - den Fokus stiehlt.
Man ist z.B. gerade am tippen und der Explorer springt einfach unvermittelt nach Vorne und sofort landet alles was man tippt nicht mehr im vorher aktiven Fenster sondern beim Explorer, der je nach Taste(n ) darauf irgendwie reagiert. Besonders schön bei der Del/Entf Taste. ;)
Oder man klickt in einem Fenster oder verschiebt irgendetwas per Drag&Drop und - plop - landen der Klick oder der Drop im plötzlich einfach nach vorne gesprungenen Explorer. Und das ist extrem lästig.


P.S.: "Taste(n )" muss man hier tatsächlich mit Leerzeichen vor der Klammer schreiben weil Klammer-n-Klammer sofort in das hier (n) umgewandelt wird. Auch irgendwie lästig. ;)
 

Lappo

...
Vielleicht liegt es auch daran, wie ich kopiere. Üblicherweise habe ich mehrere Explorer-Fenster mit Quell- und Ziel-Ordnern offen. Es aktiviert sich nach Abschluss des Kopierens oder Verschiebens immer das Ziel-Fenster automatisch und zeigt die kopierten/verschobenen Dateien/Ordner markiert an.

Das wird es (m.M.n.) sein.
Das Fenster mit dem abgeschlossenen Vorgang wird aktualisiert und in den Vordergrund gestellt.

P.S.: "Taste(n )" muss man hier tatsächlich mit Leerzeichen vor der Klammer schreiben weil Klammer-n-Klammer sofort in das hier (n) umgewandelt wird. Auch irgendwie lästig.

dito ;)
 

Mav99

bekommt Übersicht
Ich habe das inzwischen noch ein bisschen getestet und eine meiner SSDs mit sinnlosen Kopiervorgängen gequält.
Bleibt das Zielfenster nur im Hintergrund springt es sofort nach Vorne. Minimiert man es, passiert das nicht. (y)

Wechselt man im Zielfenster in einen anderen Ordner bleibt das Fenster auch im Hintergrund, aber das ist ja nicht Sinn der Sache. Das erklärt aber vielleicht, warum das Problem bei Vielen gar nicht auftritt.

Alles nicht ideal - das Minimieren vergesse ich sicher des öfteren -, aber das ist zumindest eine temporäre Lösung des lästigen Problems. Vielen Dank für den Tipp! :)

Ich hoffe trotzdem, das Microsoft sich vielleicht doch mal des Themas annimmt. Warum sie die in XP mal vorhandene Option dazu entfernt haben wissen sie vermutlich selber nicht...
 

SlashRose

gehört zum Inventar
Also ich kenne das auch nur so, dass der Kopiervorgang im Hintergrund läuft und nach Abschluss einfach nur der Dialog geschlossen wird, ohne dass der Explorer sich nochmal in den Vordergrund drängelt. Gerade ausprobiert - der "Kopieren" Dialog wurde einfach nur geschlossen und verschwand aus der Taskleiste, ohne dass der Explorer nochmal in den Vordergrund kam.
Funzt bei mir auch ganz Normal.
 
Oben