Anzeige

Am Puls von Microsoft

Anzeige

Ethernet-Verbindung

achim1152

kennt sich schon aus
Hallo,

ich will ein neues Gerät über ein Ethernet-Kabel mit meinem PC verbinden. Ich versuchte, die neue IP-Adresse einzutragen, was aber misslang. Siehe Anlage.
Warum kann ich die neue Adresse nicht speichern?

Danke für Eure Hinweise.

Joachim

ethernet2.jpg
 
Anzeige
Warum füllst du die anderen Felder nicht aus?
Du schließt tatsächlich ein weiteres Gerät am PC an? Hast du zwei Netzwerkkarten?
 
Normalerweise macht man eine Verbindung von PC zu einem Gerät über den Router. Der Router sorgt mit DHCP dafür, dass alle Geräte im Netzwerk eine passende IP-Adresse erhalten.
Eine manuelle Einstellung der IP-Adresse ist fehlerträchtig und nicht zu empfehlen.

Weitere Hilfe kann man besser geben, wenn alle Geräte (dieses neue Gerät, der Roter, der PC) mit Hersteller und Typenbezeichnung genannt werden.
 
Es handelt sich um ein GC1e, ein Treiber für ein CAN-Bus-Netz. Dieser muss über ein Ethernetkabel mit meinem PC gekoppelt werden. Wie geht das?
 
Der Link von @PeteM92 aus Post 8 ist schon mal goldrichtig. Da wird ja auch einiges erklärt zu der festen IP, die das Gerät hat (192.168.0.200). Wie @achim1152 auch schon richtig gelesen hat, muß sich der zugreifende PC im selben Subnetz befinden. Es wird ja auch die IP 192.168.0.101 mit Subnet 255.255.255.0 empfohlen. Speichern kannst Du das wohl nur, wenn Du auch DNS und Gateway einträgst. Versuche die IP des Geräts einzutragen, andernfalls die IP deines Routers (dürfte für die Verbindung egal sein). Wurde auch in Post 3 schon empfohlen.
Ich würde die IP des Geräts dann aber umgehend an dein Heimnetz anpassen.
 
Hallo Pete,
ich habe die Software Rocrail installiert, sonst nichts. Die Software des GC1e ist ja schon auf dem Controller drauf.
Muss da noch etwas installiert werden?

Ich vermute das Problem im PC. Die Fehlermeldung in Rocnet bezieht sich auf die IP-Adresse der Ethernet-Schnittstelle des PC. Ich habe unter WIN10 bei Netzwerkverbindungen --> Ethernet -->Adapteroptionen ändern -->Ethernet3 --> Internetprotokoll Version 4 die Adresse 192.168.100.200 und die Subnetzmaske 255.255.255.0 eingetragen.
Der GC1e hat die Adresse 192.168.100.201.

Trotzdem kommt keine Verbindung zustande.
Was kann ich tun?
Joachim
 
Was hast du unter Gateway und DNS stehen? Dort muß etwas rein!

Wo ist dein Dingens angeschlossen? Vorher weißt du diese beiden Adressen nicht.
Nochmal: Wie sind deine Geräte miteinander verkabelt? Mal es auf!
 
Warum? Die beiden Adressen braucht man nur, wenn man aus dem Intranet raus ins Internet will oder muss. Für das lokale Netzwerk sind diese IPs nicht nötig. Wenn das MS Installationsmenu eine IP fordert, um weiter zu kommen, würde ich da die/eine localhost-Adresse wie 127.0.0.1 eintragen, damit die Geräte nicht im Internet stehen.
 
Zuletzt bearbeitet:
Warum? Weil du sonst aus dem Fenster in #1 nicht raus kommst. :cool:

Wenn das Dingens an der Fritz.Box hängt, muß dort die 192.168.178.1 rein.

Leider werden auch auf Anfrage keinerlei Angaben zur Struktur gemacht.
 
Hallo Nokiafan,

da gibt es nichts aufzumalen. Ich habe meinen Laptop und von dem geht ein Ethernetkabel zur Schnittstelle des CAN-Bus, dem GC1e. Das Internet spielt dafür keine Rolle, es ist ein LAN zwischen den beiden Geräten. Aber sie verstehen sich nicht...
 
Ich vermute das Problem im PC. Die Fehlermeldung in Rocnet bezieht sich auf die IP-Adresse der Ethernet-Schnittstelle des PC. Ich habe unter WIN10 bei Netzwerkverbindungen --> Ethernet -->Adapteroptionen ändern -->Ethernet3 --> Internetprotokoll Version 4 die Adresse 192.168.100.200 und die Subnetzmaske 255.255.255.0 eingetragen.
Der GC1e hat die Adresse 192.168.100.201.
Zitat aus der Anleitung: "Die Standard-IP-Adresse des CAN-GC1e ist 192.168.0.200"
 
Anzeige
Oben