WernerKra

Herzlich willkommen
Hallo VSchD,
der Hinweis, dass die SID nicht mehr aktuell ist, hat mich auf die Idee gebracht, einfach mal die Registryeintäge der SID und der CLSID (vorher Systemsicherung!!) aus der Registry zu löschen. Dazu die beiden Einträge mit Admin-Rechten übernehemen und dann entfernen. (Evtl. die Einträge noch vorher sichern!).
Und siehe da: Seitdem sind die Fehlermeldungen weg. Es tauchen auch keine zusätzlichen anderen Fehlermeldungen (bis jetzt) auf.

Also noch einmal Danke!
Werner:)
 
Anzeige

build10240

gehört zum Inventar
Mal davon abgesehen, daß solche Löschungen in der Registry auf Verdacht nicht zu empfehlen sind, wird die Fehlermeldung höchstwahrscheinlich in einigen Tagen bis Wochen wieder auftauchen. Möglicherweise hast Du Dein System durch das Löschen in einen kritischen Zustand versetzt, dessen Folgen erst nach einiger Zeit sichtbar werden.

Wie in diesem und anderen Threads zum Thema schon des Öfteren angemerkt, ist die hier vorgestellte Lösung nur eine temporäre. Die Ereignisanzeige ist eine Sammlung von Meldungen verschiedener Anwendungen und Dienste. Nicht alles, was dort als Fehler vermerkt ist, bedarf eines Eingriffs des Benutzers. Daß derartige Meldungen nahezu auf allen Windowssystemen und in allen Versionen von XP bis 10 zu finden sind, zeigt doch, daß es nicht unbedingt ein Fehler ist, der vom Nutzer beseitigt werden sollte oder überhaupt beseitigt werden könnte. Wenn schon sollte das Ziel sein, die Ursache der Fehlermeldung zu beseitigen und nicht die Fehlermeldung zu verhindern.

Solange man sich also mit dem System nicht auskennt und nicht definitiv weiß, daß mit den Löschungen auch die Ursache beseitigt wird, sollte man die Finger davon lassen, weil durch Änderungen in der Registry mehr Schaden als Nutzen angerichtet werden könnte.
 

VSchDa

kennt sich schon aus
Ich habe aus anderen Gründen vor einigen Tagen eine komplette Neuinstallation Windows gemacht. Seitdem sind bei mir diese DCOM-Fehler weg. Es gibt zwar noch einige, aber bei weitem nicht mehr in der Häufung
 

SlashRose

gehört zum Inventar
wie schon build10240 sagt, die werden nach einigen Tagen wieder kommen, dass war immer so, egal was ich gemacht habe, egal nach welcher Anleitung!
 

VSchDa

kennt sich schon aus
Hallo Slashrose und build10240, genauso ist es. Ich habe das System vor 10 Tagen mit clean install neu aufgesetzt. Der Fehler 10016 mit Bezug auf Cortana war weg. Vorgestern hatte Cortana (SearchUI) einen MoAppCrash - keine Ahnung, warum. Danach kommt der 10016-Fehler wieder regelmäßig. Noch nicht so häufig wie vorher - aber das kann ja noch werden. Offensichtlich sind doch in den Apps von Microsoft noch viele Macken.
 

Bowser

Erster Beitrag
Hallo,

ich habe Windows 10. Leider sehen die Menüs da etwas anders aus und ich weiß nicht, was alles zu aktivieren ist.
Ich habe die Registry schon geöffnet, den Schlüssel gewählt und bin ins Berechtigungs-Menü gegangen. Dann habe ich wie beschrieben auf "Erweitert" geklickt. Nun bin ich auf Besitzer Ändern gegangen. Muss hier nun immer Administrator gewählt werden, oder sollte das der 10016-Ereignismeldung angepasst werden? Dann soll ja das Feld "Besitzer der Objekte und untergeordneten Container ersetzen" aktiviert werden. Muss zusätzlich auf das Feld: "Alle Berechtigungseinträge für untergeordnete Objekte durch vererbbare Berechtigungseinträge von diesem Objekt ersetzen" aktiviert werden?? Wenn ich nun noch Administratoren markiere und dort auf bearbeiten gehe, muss ich dort neben "Vollzugriff" auch das Feld "Berechtigungen nur für Objekte und/oder Container und diesen Container übernehmen" aktivieren?

Danke!
 

DrSuperMan

kennt sich schon aus
genauso wie bei mir.
ich komme auch nicht mehr weiter, wenn eine helfende hand uns aus diesem schlamassel helfen könnte...
 

SlashRose

gehört zum Inventar
Lasst lieber das rumfummeln am OS, es bringt leider nichts, der Fehler ist nicht dauerhaft weck zu bekommen!
 

Ringo2070

Herzlich willkommen
Hi, danke für die Anleitung, ist gut beschrieben.
Leider komme ich aber ab Punkt 8 nicht weiter, aber zu erst einmal zu meinem Problem.
Habe einen neuen Rechner, betrieben wird der mit Win10 Pro. Alles scheint normal zu funktionieren bis auf ein Spiel.
Anno 2070 läuft grundsätzlich normal, aber nach einer bestimmten Zeit, meistens zwischen 30-40min, gestern sogar 15min, hängt sich das Spiel auf und mir bleibt nix anderes übrig als mich abzumelden, was anderes geht nicht (Taskmanager-Taskbeenden).
Ein blick in die Ereignisanzeige zeigt zum Zeitpunkt des Hängers den hier beschrieben Fehler, nur eben mit nem anderen Code bzw Auslöser.
Nun habe ich diese Anleitung hier befolgt und komme beim Punkt 8 nicht weiter wo man den Wert vom Schlüssel Prüfen muss.
Hier wird der Localservice und IPBustEnum beschrieben, bei mir steht RunAS und Interactive User. Jetzt muss man ja unter comexp.msc/DCOM Konfiguration, IPBustEnum oder halt in meinem Fall Interactive User suchen, diesen Ordner gibt es aber nicht!
Was nun? Habe ich was Falsch gemacht? Oder gibt es dafür ein speziellen Lösungsweg?

Wäre schön wenn jemand helfen könnte, da kauft man sich so eine teure Maschine mit teurem Betriebssystem und da geht mein Lieblingsspiel nicht :(

Übrigens mein Win10 ist kein Updatete, sondern so gekauft.

Und hier nochmal der Fehler:

"Durch die Berechtigungseinstellungen für "Anwendungsspezifisch" wird dem Benutzer "NT-AUTORITÄT\SYSTEM" (SID: S-1-5-18) unter der Adresse "LocalHost (unter Verwendung von LRPC)" keine Berechtigung vom Typ "Lokal Aktivierung" für die COM-Serveranwendung mit der CLSID
{8D8F4F83-3594-4F07-8369-FC3C3CAE4919}
und der APPID
{F72671A9-012C-4725-9D2F-2A4D32D65169}
im Anwendungscontainer "Nicht verfügbar" (SID: Nicht verfügbar) gewährt. Die Sicherheitsberechtigung kann mit dem Verwaltungstool für Komponentendienste geändert werden."


Lg
 
Zuletzt bearbeitet:

Ari45

gehört zum Inventar
Hallo @Ringo2070! Willkommen im Forum! :)
Auch wenn ich nicht davon überzeugt bin, dass der DCOM-Fehler für dein Spiele-Problem verantwortlich ist, will ich dir helfen.
Zuerst:
es gibt massenweise Threads zum Fehler Ereignis-ID 10016 und 10017. In den allermeisten Fällen machte der Fehler keine spürbaren Probleme. Und nach Behebung des Fehlers war er in der Regel nach 3 bis 5 Tagen wieder da.
(Microsoft sagt dazu: kann ignoriert werden)

Aber ich hatte ja versprochen, dass ich dir helfen werde:
1. Fehler -> die AppID {F72671A9-012C-4725-9D2F-2A4D32D65169} zeigt nicht auf ein Objekt sondern auf einen User. In dem Fall darf man nicht den User suchen, sondern muss im Komponentendienst diese AppID suchen und so bearbeiten, als wäre es ein Ordner.
2. Die Bearbeitung geht aber nicht, weil die Optionsfelder "ausgegraut" sind. Du hast keine Berechtigung, diese AppID zu bearbeiten und musst dir diese Berechtigung erst in der Registry holen.
3. Jetzt wird es kompliziert: man muss von dem Registryschlüssel {F72671A9-012C-4725-9D2F-2A4D32D65169} den Besitz übernehmen. Dann muss man sich die notwendige Berechtigung erteilen. Dann öffnet man mit "Als Administrator ausführen" den Komponentendienst und dort den AppID-Schlüssel. Nach Klick auf "Eigenschaften" kann man die notwendige Änderung vornehmen.
4. Wenn das erledigt ist, schließt man den Komponentendienst und öffnet wieder Regedit mit "Als Administrator ausführen" und ändert den Besitzer des AppID-Schlüssels {F72671A9-012C-4725-9D2F-2A4D32D65169} wieder auf TrustedInstaller
Dazu ist in das Besitzerfenster des Schlüssels einzutragen NT SERVICE\TrustedInstaller (bitte genau so eingeben).

So und nun entscheide selbst, ob der zweifelhafte Erfolg den Aufwand rechtfertigt.

Wenn du dich doch dazu entschließen solltest, vergiß nicht, bevor du anfängst, in der Registry zu arbeiten, den übergeordneten Schlüssel zu exportieren. Wenn etwas schief geht, kann man dann den Schlüssel wieder zurück kopieren.
 

Ringo2070

Herzlich willkommen
Vielen Dank für deine Antwort Ari45. Klingt echt sehr kompliziert die ganze Sache. Du meinst du glaubst es könnte einen anderen Grund für die Hänger im Spiel geben. Meinst du, du könntest die Uhrsache aus einem DxDiag Eintrag lesen? Könnte dir ne PN schreiben wenn es zu Offtopic wird, wenn du möchtest. Wäre jedenfall sau nett, scheinst mir extrem kompetent in der Sache zu sein, ich glaube du bist der einzige der mir helfen könnte^^.
 

Ari45

gehört zum Inventar
Guten Morgen @Ringo2070!
Bitte keine PN zu Problemlösungen, diese werden ohnehin nicht beantwortet (siehe meine Signatur).
Ich weiß nicht, ob das DxDiag-Protokoll uns weiter bringt. Fakt ist, dass ich da keine besonders große Hilfe bin, da ich kein "Spieler" bin.
Aber hänge es ruhig als Textdatei-Anhang an. Vielleicht kann doch einer etwas rauslesen.
Schau auch mal in den Zuverlässigkeitsverlauf. Dort werden Problemprogramme benannt und manchmal auch eine Lösung angeboten.

ot:
Da alle Weitere mit dem Tutoroial nichts mehr zu tun hat, habe ich deine Frage in #30 an das Team gemeldet, mit der Bitte, eventuell daraus ein eigenes Thema zu machen. In einem Thread zu einem Tutorial sollen ja nur Fragen zum Tutorial selbst gestellt werden. Also nicht wundern, wenn eventuell dein Thema verschoben wird.
 

Ringo2070

Herzlich willkommen
OK danke Ari45, habe bisher über mein Smartphone geschrieben, da ist mir deine Signatur nicht aufgefallen, entschuldige ;).
Hoffe jemand kann vllt. anhand der DxDiag was verdächtiges finden, danke im voraus.
 

Anhänge

  • DxDiag.txt
    74 KB · Aufrufe: 374

rgbigel

Igel-Soft
AW: Fehler 10016: Quelle DistributedCOM - Problemlösung -- fast, jedenfalls --

Weiß nicht wie man einen Beitrag wieder löscht aber 3 Posts drüber steht schon die Antwort
Zum Registrierungsschlüssel {F72671A9-012C-4725-9D2F-2A4D32D65169}

Änderungen wie beschrieben durchgeführt, noch nicht getestet, weil folgendes Problem aufgetaucht ist:

Besitzer wieder auf TrustedInstaller setzen geht bei mir nicht (wg. W10??), einen solchen Nutzer kennt Windows nicht -- muss man da evtl mit einer GUID oder SID arbeiten? Und wenn ja -- wie?

Rolf
 
Zuletzt bearbeitet:

frankyLE

gehört zum Inventar
Herzlich willkommen im Forum Dr. Windows @rgbigel.


Fehlers war er in der Regel nach 3 bis 5 Tagen wieder da.

Lies nochmal #31 komplett. Diesen Eintrag in der Fehleranzeige gibt es seit Jahren auch vor W10. Die Mühe diesen zu beseitigen, sehe ich als Schönheitsoperation. Einfach ignorieren.

Oder geht es dir um etwas anderes als DistributedCOM Fehler?
 

Ari45

gehört zum Inventar
Besitzer auf TrustedInstaller setzen:
-> wie der Dialog zum Besitzer Wechseln aufgerufen wird, weißt du ja
-> in den Dialog das Folgende hinein kopieren NT SERVICE\TrustedInstaller
-> übernehmen und fertig
 

rgbigel

Igel-Soft
...
Lies nochmal #31 komplett.
...
Oder geht es dir um etwas anderes als DistributedCOM Fehler?

Herzlich willkommen im Forum Dr. Windows @rgbigel.




Lies nochmal #31 komplett. Diesen Eintrag in der Fehleranzeige gibt es seit Jahren auch vor W10. Die Mühe diesen zu beseitigen, sehe ich als Schönheitsoperation. Einfach ignorieren.

Oder geht es dir um etwas anderes als DistributedCOM Fehler?

Danke (wo habt Ihr eigentlich den Button dazu versteckt?) für schnelle Antwort, hatte aber sogar #31 gelesen. Scheint ein Fehler zu sein, der seine eigene Reparatur überlebt (kennt man sonst nur aus SF). Wenn dieser Fehler es nicht tut, stirbt die Hoffnung zuletzt.

In der Tat ist der 10016 nur ein Indiz. Mein eigentliches Problem recherchiere ich über das Event Log, wo ich halt festgestellt habe, dass der Fehler 10016 regelmäßig zeitnah zu folgendem Problem auftritt (übrigens dann immer kurz vor Fehler 10000, der da sagt:

Ein DCOM-Server konnte nicht gestartet werden: {14286318-B6CF-49A1-81FC-D74AD94902F9}. Fehler:
"2"
Aufgetreten beim Start dieses Befehls:
"C:\Program Files (x86)\Microsoft Office\Root\VFS\ProgramFilesCommonX86\Microsoft Shared\OFFICE16\CSISYNCCLIENT.EXE" -Embedding

und der hat vermutlich irgendwas mit dem DCOM 10016 zu tun?

o.T. mein eigentliches Problem ist, dass seit dem W10-Pre-Release 14942.161003, nach einer geplanten oder durch Schlaftaste ausgelösten PC-Pause (Energiesparmodus) der Laggel manchmal gleich, aber immer innerhalb von ca. 10 Minuten, einfach neu startet -- allerdings mit schwarzem Bildschirm und komplett unbedienbar, keine Maus, kein Affengriff, tot, aber vom Lüfter aus würde ich sagen, er tut irgendwas. Drückt man lange die Power Taste, geht er für 1/2 Sekunde(!!) aus und bootet aber sofort wieder (oft, aber nicht immer, sogar 2x, vielleicht bekomme ich den Finger nicht schnell genug von der Powertaste runter). Das Event Log kurz vor dem Herunterfahren zeigt nicht einmal den Versuch an, in den Schlafmodus zu wechseln, und keine zeitnahen Warn- oder Fehlermeldungen!

Wenn man es schafft, den PC in dem Zeitintervall, wo er noch nicht selber aufgewacht ist, aufzuwecken
murkelt das Event-Log, dass der Rechner vor dem letzten Neustart nicht richtig heruntergefahren wurde :)dafür war er aber recht friedlich:). Fährt man den PC komplett herunter, startet er ganz friedlich, ohne Event 10016, aber mit 10000 und dann einem ganzen Zoo von Events: 10114 WUDFPf, UMDF, 212 von Kernel-PNP (die aber nur 12 mal, dann herrscht Friede), dann beruhigende Meldungen von Ntfs (98) dass keine Laufwerke beschädigt sind, sowie ein ganz böser Bube, Event 3 vom CoreSystem-InitMachineConfig, der den IMC hive nicht entladen kann.

Habe festgestellt, dass der sleep mode offenbar nicht komplett erreicht wird, obwohl der PC sich ja (wenn auch nur kurz) schlafen gelegt hat. Ursache noch völlig unklar, aber gerade hat sich Windows update gemeldet mit Preview 14946, vielleicht geht das Problem ja "im Schlaf" wieder weg. Wenn nicht, versuche ich nach weiteren Analysen eine vernünftige Frage zu posten.

Danke für die Geduld
Rolf
 

Ari45

gehört zum Inventar
@rgbigel
Das hier ist ein Tutorial und da sollte es in den Beiträgen auch ausschließlich um das Tutorial gehen.
Meinen Beitrag #37 könnte man noch (mit etwas gutem Willen) auf das Tutorial bezogen nennen.
In #38 machst du aber mit einer Problemdiskussion weiter. Das sollte in einem Tutorial-Thread nicht sein.
Bitte führe dein Problem in deinem ursprünglichen Thread fort.
Danke
 

Ensolo

bekommt Übersicht
Hallo @Ringo2070! Willkommen im Forum! :)
Auch wenn ich nicht davon überzeugt bin, dass der DCOM-Fehler für dein Spiele-Problem verantwortlich ist, will ich dir helfen.
Zuerst:
es gibt massenweise Threads zum Fehler Ereignis-ID 10016 und 10017. In den allermeisten Fällen machte der Fehler keine spürbaren Probleme. Und nach Behebung des Fehlers war er in der Regel nach 3 bis 5 Tagen wieder da.
(Microsoft sagt dazu: kann ignoriert werden)

Aber ich hatte ja versprochen, dass ich dir helfen werde:
1. Fehler -> die AppID {F72671A9-012C-4725-9D2F-2A4D32D65169} zeigt nicht auf ein Objekt sondern auf einen User. In dem Fall darf man nicht den User suchen, sondern muss im Komponentendienst diese AppID suchen und so bearbeiten, als wäre es ein Ordner.
2. Die Bearbeitung geht aber nicht, weil die Optionsfelder "ausgegraut" sind. Du hast keine Berechtigung, diese AppID zu bearbeiten und musst dir diese Berechtigung erst in der Registry holen.
3. Jetzt wird es kompliziert: man muss von dem Registryschlüssel {F72671A9-012C-4725-9D2F-2A4D32D65169} den Besitz übernehmen. Dann muss man sich die notwendige Berechtigung erteilen. Dann öffnet man mit "Als Administrator ausführen" den Komponentendienst und dort den AppID-Schlüssel. Nach Klick auf "Eigenschaften" kann man die notwendige Änderung vornehmen.
4. Wenn das erledigt ist, schließt man den Komponentendienst und öffnet wieder Regedit mit "Als Administrator ausführen" und ändert den Besitzer des AppID-Schlüssels {F72671A9-012C-4725-9D2F-2A4D32D65169} wieder auf TrustedInstaller
Dazu ist in das Besitzerfenster des Schlüssels einzutragen NT SERVICE\TrustedInstaller (bitte genau so eingeben).

So und nun entscheide selbst, ob der zweifelhafte Erfolg den Aufwand rechtfertigt.

Wenn du dich doch dazu entschließen solltest, vergiß nicht, bevor du anfängst, in der Registry zu arbeiten, den übergeordneten Schlüssel zu exportieren. Wenn etwas schief geht, kann man dann den Schlüssel wieder zurück kopieren.

Hallo Ari45,
Bei mir ist es ebenfalls der Fall, dass ein USer hinter dem Schlüssel steckt. Das Problem ist nun, dass ich bei den Start und Aktivierungsberechtigungen kein "SYSTEM" habe. Ausserdem haben alle anderen Gruppen schon die erforderliche Berechtigung. Hast du/habt ihr eine Idee?

Screenshot (15).png
 
Oben