Anzeige

Am Puls von Microsoft

Anzeige

Firefox umgeht Hosts-Datei auf Windows 8.1

Michael54

kennt sich schon aus
Hallo,
ich habe eine umfangreiche und gepflegte HOSTS_datei, mit der ich unerwünschte WEB-Seiten aussperre, erwünschte Kontakte direkt anspiele, in internen Netzen nutzt ja auch ein DNS-Server nichts. Seit langer Zeit das System upgedated, nichts funktioniert mehr. Zwangsweise bin ich wieder zweigleisig im Netz. Mein Laptop mit W 8.1 und aktuellem FF, der Tower mit W XP, dem ich gerade eine uralt-Version von FF aufgezwungen habe (die trotzdem versucht, bei jeder noch so kleinen Pause upzudaten.....)
Frage:
Da muß es doch auch eine Lösung für W 8.1 und den aktuellen FF geben?
 
Anzeige

Michael54

kennt sich schon aus
Das Sperren von Webseiten ist aber nur ein Punkt von vielen. Es gibt ja auch Computer, deren Adresse nicht im DNS Server hinterlegt ist. Ich bin z.B. Mitglied einer Dieselschrauber-Gesellschaft. Ich will hier mal keine Adressen öffentlich machen, daher nehme ich mal eine, die jeder kennt. Tippe ich oben in den Browser z.B. 216.58.207.67 ein, lande ich bei google com. Natürlich habe ich nicht alle Adressen im Kopf. Dafür gibt es die HOSTS Datei. Die steht bei Windows 95 bis Windows 8.1 (bei den neuen BS weiß ich das nicht) im Verzeichnis c:\windows\system32\drivers\etc. Hier tippe ich (mit notepad.exe oder edit.com) z.B. ein 127.0.0.1 YouTube oder 0.0.0.0 YouTube ein, wenn ich verhindern will, daß irgendjemand von meinem Rechner aus youtube.com aufruft, oder ich tippe ein 216.58.207.67 Google wenn ich will, daß mein PC die Seit von Google ausschließlich über diese Adresse aufruft. Ich kann aber auch eigene Adressen vergeben, sagen wir mal als Phantasiebeispiel 255.56.78.90 Francisco. Wie kann ich Firefox zwingen, zunächst die HOSTS datei anzugucken?????
 

MSFreak

gehört zum Inventar
Hast du schon in den Verbindungs-Einstellungen die entsprechenden Optionen ausprobiert ?

screenshot.1.jpeg
 

Michael54

kennt sich schon aus
Ich habe das alles ausprobiert. Zusätzlich habe ich noch in about:config keyw.enable von true auf false gesetzt. Kein Erfolg. Dann habe ich probeweise auf dem XP-Rechner Firefox auf ESR52 upgedated. Sie da, das gleiche Problem.

Jetzt habe ich festgestellt, daß bei allen Seiten, die irgendetwas mit google, mozilla oder microsoft zu tun haben, die hosts-Datei umgangen wird. Diese Seiten kann ich nicht sperren. Deswegen konnte ich auch youtube nicht sperren. Das Anwählen von befreundeten Computern durch Hinterlegung der Adresse in der Hosts-Datei funktioniert jetzt. Die Gesamtheit machts: kein Proxy, DNS über HTTPS, keyw enabled false.

Das ganze gefällt mir so nicht, und mit dem nächsten Update geht die Bastelei vielleicht wieder los. Ich will auf beiden Rechnern den Browser wechseln. Der Windows 8.1 Laptop, ein Easynote TE69KB bringt nicht besonders viel Leistung, zusätzlich ist meine Internet-Verbindung hier auch noch langsam. Bei Youtube kann ich keinen kurzen Film gucken. Ich klicke den Film an, dann startet der Video download helper und ich gehe erstmal staubsaugen, abwaschen, Kaffee kochen, was ich mir an Arbeit für diesen Zweck aufgehoben habe eben, wenn ich wieder komme kann ich entweder Film gucken oder der Rechner hat abgebrochen..... Welchen schlanken und schnellen Browser könnt ihr mir empfehlen?
 

build10240

gehört zum Inventar
Hier läuft schon so viel falsch, daß man gar nicht weiß wo man anfangen soll. Firefox umgeht die hosts Datei sicher nicht, denn das ist eine Funktion von Windows. Wenn dann macht hier Windows den "Fehler". Du wirst mit einer solchen Einstellung ("Seit langer Zeit das System upgedated") hier aber kaum Hilfe erwarten können. Ein System, das nicht aktuell ist, wird auch nicht unterstützt.

Da das Problem auch auf XP besteht, dürfte der Fehler sowieso an anderer Stelle zu suchen sein, denn weder XP noch die dort laufende alte Firefox-Version können DoH, DoT oder irgendetwas ähnliches. Schon gar nicht gibt es in einem Firefox 52 plötzlich eine Funktion, die die DNS-Abfrage des Betriebssystem umgeht.

Ich würde mal probieren, ob ipconfig /flushdns das Problem löst.

Ansonsten ist hier nur zu sagen, daß man mal veraltete Verfahren wie die Hosts-Datei zugunsten modernere Lösungen aufgeben sollte.

Und nein, der Firefox hat keine geheime Funktion, um bestimmte URLs auch ohne DNS aufzulösen, das kann man leicht anhand der Protokolle bzw. mit Sperren in Pi-Hole oder DNSCrypt herausfinden. Selbst die Telemetrie-Domains von Firefox lassen sich einfach sperren, ohne daß Firefox das versucht zu umgehen.
 

Lillecca1994

treuer Stammgast
Dafür gibt es die HOSTS Datei. Die steht bei Windows 95 bis Windows 8.1 (bei den neuen BS weiß ich das nicht) im Verzeichnis c:\windows\system32\drivers\etc.

Unter Windows 95, 98, 98SE und Windows ME ist die Datei als "hosts.sam" unter C:\Windows\ bekannt und müsste sofern diese verwendet werden soll, dann in "hosts" (ohne Dateiendung) umbenannt werden.

Unter W10 ist die Hosts-Datei ebenfalls in c:\windows\system32\drivers\etc
 
Zuletzt bearbeitet:

nokiafan

gehört zum Inventar
Ansonsten ist hier nur zu sagen, daß man mal veraltete Verfahren wie die Hosts-Datei zugunsten modernere Lösungen aufgeben sollte.
Was ist denn die Alternative?

Eine Datei für den ganzen Rechner, wer kann das schon?
 
G

Gelöschtes Mitglied 78250

Gast
Firefox umgeht die hosts Datei sicher nicht, denn das ist eine Funktion von Windows.

Wie bereits genannt umgeht DoH und auch DoT mit der direkten DNS-Abfrage. Aber:
Hier läuft schon so viel falsch, daß man gar nicht weiß wo man anfangen soll.
genau das. Firefox 52 kennt DoH überthaup nicht und DoH ist nicht per Standard aktiviert, ist mit einem neuen Profil nachweisbar.

Über XP werde ich mich nur einmal auslassen: blöde Idee! Und vor allem absolut kontraproduktiv, wenn man auf der einen Seite von Sicherheit jammert, die man mit XP überhaupt nicht mehr hat. XP ist auch mit HOSTS-Datei anfällig an allen Ecken

:wand

Seit langer Zeit das System upgedated, nichts funktioniert mehr. Zwangsweise bin ich wieder zweigleisig im Netz. Mein Laptop mit W 8.1 und aktuellem FF, der Tower mit W XP, dem ich gerade eine uralt-Version von FF aufgezwungen habe

Da muß es doch auch eine Lösung für W 8.1 und den aktuellen FF geben?
Welches System wurde denn aktualisiert? Windows 8.1? Das kann nicht sein, wüsste ich dann nämlich.

DoH-Aktivierung in Firefox
DNS-uber-HTTPS (DoH) FAQs | Hilfe zu Firefox
1573840 - Staged Rollout of DoH to US Users
DNS over HTTPS (DoH) ab Ende September fur erste Firefox-Nutzer - camp-firefox.de

Die Einstellung zu DoH findet man in den Internet-Einstellungen zu Firefox (wo auch Proxy verwaltet wird).

Wenn das alles kontrolliert wurde und die HOSTS dennoch übergangen wird, ist das System beschädigt oder kompromittiert worden, da beisst die Maus keinen Faden ab.
Was ist denn die Alternative?
Direkt und lokal - wüsste keine ausser der Windows Firewall und Adressen sperren. Oder ein lokaler DNS-Resolver/-Proxy, zB
Acrylic DNS Proxy

Die HOSTS-Datei ist nur extrem leicht zu füttern.
 

Michael54

kennt sich schon aus
Ich habe jetzt mal auf dem XP-Rechner FF komplett gelöscht und dann FF 32 (eine Uraltversion, ich weiß) installiert. Mit dieser Installation akzeptiert FF die Hosts Datei in allen Punkten bei allen Adressen. Also ist es zumindest kein Windowsfehler, sondern liegt am FF. Oder aber, beide meine Rechner sind kompromittiert und ich habe rein zufällig das Problem entfernt.
Jetzt will ich aber lieber mit dem 8.1 Rechner mich beschäftigen. Bernd schreibt "Welches System wurde denn aktualisiert? Windows 8.1? Das kann nicht sein, wüsste ich dann nämlich." Woher weißt du denn, wann und ob ich mein System aktualisiere? Falls das interessiert: Bis vor einiger Zeit hatte ich Windows 8 auf dem Laptop, genauso wie ich ihn damals gekauft habe. Aus bestimmten Gründen habe ich dann (zum 1000sten Mal) das Betriebssystem neu installiert, meine externen Festplatten einem Bekannten zum Virusscan weggegeben, mein System auf 8.1 aktualisiert und alle Updates runtergeladen, incl FF, die es gab. Und natürlich installiert. Dann haben wir beide Rechner einmal mit CLAMAV und zweimal unter laufender Internetverbindung gescannt. Natürlich von einer CD gestartet, dann von einer sauberen Festplatte Fehlendes nachgeladen. Zumindest vor ungefähr sechs Wochen war alles, was ich hatte definitiv sauber und nichts kompromittiert. Allerdings habe ich eine zeitlang die Adressen in der Hosts Datei nicht genutzt. Die Verbindung ist sowieso schlecht, also ist mir zunächst auch nichts aufgefallen.

Ich habe ja schon geschrieben, was ich alles bei FF gemacht habe. Ich will bei 8.1 jetzt nicht in der Form experimentieren, daß ich uralt Browser installiere und probiere was passiert. Ich habe zwar das Betriebssystem extern gesichert, aber seit dem Update auf 8.1 läuft der Laptop stabil, das will ich nicht zerstören. Jetzt lese ich erstmal die Links durch, die ihr mir geschickt habt,
 
G

Gelöschtes Mitglied 78250

Gast
Vielleicht ist es bei dir nicht angekommen. DoH wurde erst mit Firefox 69 angeschaltet und auch nur für die USA. Ansonsten schau in deine Einstellungen. Ansonsten ist dein System bereits kompromittiert. Jedenfalls gibt es bei beiden Punkten keinen Diskussionsbedarf bei mir.
 

MSFreak

gehört zum Inventar
Ich habe jetzt mal auf dem XP-Rechner FF komplett gelöscht und dann FF 32 (eine Uraltversion, ich weiß) installiert.
... Kopfschütteln (n)(n)
XP mit uralten Fx und dann Internet ! Ob sich bei dir Trojaner & Co breitmachen ist uns sch...egal, aber im Falle einer Kompromittierung hast du nicht nur selbst das Problem, sondern stellst auch anderen Usern im Internet eine Gefahr dar. Informiere dich bitte mal über das Botnet:
Was ist ein Botnet? Zombie-PC-Netzwerke | G DATA
 

Michael54

kennt sich schon aus
security.enterprise_roots.enabled habe ich jetzt auf true gestellt.


@MSFreak: mit dieser gefährlichen Kombi habe ich lediglich etwas getestet: in die Hosts datei etwas eingetragen, flshdns Neustart und dann geguckt, ob die Website erreichbar ist. Ergebnis: Schreibe ich in die Hosts 127.0.0.1 YouTube ist youtube bei FF 32 nicht mehr erreichbar, unter FF52 (Windows XP) und unter FF76 (Windows 8.1)ist youtube trotzdem erreichbar.

Was ein Botnet ist, weiß ich.

Die Hilfeseiten von Mozilla habe ich durchgearbeitet.

Jetzt gucke ich mal den Acrylic DNS Server an.
 
Zuletzt bearbeitet von einem Moderator:

build10240

gehört zum Inventar
Ich kann nichts zur Hosts-Datei sagen und schon gar nichts zu Windows XP oder Windows 8.1 oder Deinen diversen Firefoxversionen der Marke Asbach-Uralt, aber unter Windows 10 mit einem aktuellen Firefox wird der lokale DNS-Server nach YouTube befragt, wenn man YouTube aufruft und vorher den Cache gelöscht hat. Da ein Firefox mit Standardeinstellungen sich zwecks Namensauflösung an Windows wendet und Windows dabei seit jeher dieselbe Reihenfolge anwendet - siehe https://support.microsoft.com/de-de/help/172218/microsoft-tcp-ip-host-name-resolution-order - und damit auch die Hosts-Datei berücksichtigt, muß der Fehler schon in Deinem System liegen.

Vielleicht steckt der Fehler auch in der Hosts-Datei, vielleicht ist Dein Windows verkonfiguriert. Letzteres ist nicht unbedingt fernliegend, wenn man in Deinen Beiträgen zwischen den Zeilen liest.
 
G

Gelöschtes Mitglied 78250

Gast
ist youtube bei FF 32 nicht mehr erreichbar, unter FF52 (Windows XP) und unter FF76 (Windows 8.1)ist youtube trotzdem erreichbar.
Bei soviel Beratungsresistenz bin ich raus. Da sind 20ct in jede Parkuhr besser investiert, hier schreibt man für die Wand.
security.enterprise_roots.enabled habe ich jetzt auf true gestellt.
Unterstreicht nur, dass hier mit viel blindem Aktionismus und Unwissenheit hantiert wird, statt auf die Antworten zu hören.
 
Anzeige
Oben