Anzeige

Am Puls von Microsoft

Anzeige

Geänderte Systempfade in Windows Vista

Martin

Webmaster
Teammitglied
Unter Vista wurden verschiedene Systempfade geändert.
Die bisher bekannten Namen sind noch vorhanden und werden im Explorer wie
Verknüpfungen angezeigt, auf die man jedoch keinen Zugriff hat.
Das ist natürlich sehr verwirrend, wenn man den Grund dafür nicht kennt.
Diese Verknüpfungen sind NTFS-Links und bezwecken, dass ältere Anwendungen
oder Verweise, die sich auf diese Pfade beziehen, nicht ins Leere zeigen.
Man kann diese Verknüpfungen also getrost ignorieren und sich umständliche
Besitzübernahmen und dergleichen schenken.

Eine weitere Neuerung: Durch die grundsätzliche Mehrsprachigkeit erscheinen
bestimmte Ordner in alternativen Dateimanagern mit ihren englischen Namen.
So erscheint im Explorer zum Beispiel C:\Programme oder C:\Benutzer, während
der Total Commander diese Ordner als "Program Files" und "Users" anzeigt.

Geändert haben sich zum Beispiel:

\Dokumente und Einstellungen bzw. \Documents and Settings
wurde ersetzt durch
\Users

Unterhalb von \Users ist auch fast nichts mehr so, wie es mal war,
zum Beispiel:

\Dokumente und Einstellungen\<username>\Anwendungsdaten
wurde ersetzt durch
\Users\<username>\AppData

Unterhalb von AppData gibt es drei weitere Verzeichnisse:
Local
LocalLow
Roaming
Pfade, die direkt auf die alte Namenskonvention verweisen, bleiben aber weiterhin gültig.

\Dokumente und Einstellungen\All Users\
wurde ersetzt durch
\Users\Default

\Dokumente und Einstellungen\<username>\Eigene Dateien
wurde ersetzt durch
\Users\<username>\Documents

Einen ausführlichen Artikel dazu findet man in MIL´s Blog:
Kein Zugriff auf Verzeichnisse unter Windows Vista? [MIL]
 
Anzeige

it-rat

Herzlich willkommen
Tipp für umtata: Schreib mal Programme mit zwei "m".

Siehst Du ihn im Explorer nicht oder wenn Du eingibst "dir c:\programme" ?
 

Shadow1988

gehört zum Inventar
Versuche es mal bei dir mit Program Files. "Früher hießen die zwei Ordner bei mir auch Program Files und Program Files x86, nur neuerdings sind diese bei mir "eingedeutscht" worden, warum auch immer.
 

it-rat

Herzlich willkommen
Sorry, jetzt hab' ich Deinen Screenshot gesehen. Sehr merkwürdig.

Bei mir gibt es (wenn ich Systemfiles sichtbar mache), den "normalen" Ordner "Programme" und den NTFS-Link "Programme" und noch einen System-Ordner (kein Link) "ProgramData".

Ich hatte allerdings noch keine XP-Software installiert, die möglicherweise erst das anlegen dieser XP-kompatiblen Pfade bzw. Links bewirkt.

Will da mal grade nachholen. Melde mich dann wieder.

Jetzt habe ich mal mein Uralt-Schach Proggy Fritz 5 installiert.
Bei der Installation habe ich den Ordner "C:\Program Files\Chessbase" bestätigt.
Installation hat fehlerlos geklappt und Programm läuft.

Jetzt kommt das Witzige:
In meinem Explorer - mit allen Systemfiles eingeblendet - sehe ich immer noch keinen Ordner oder Link namens "Program Files".

In der Eingabeaufforderung kann ich aber eingeben Dir "C:\Program Files\Chessbase"
und sehe alle Unterordner, die das Programm da angelegt hat.
(lt. Explorer in C:\Programme\Chessbase").

Wie "findet" die Eingabeaufforderung (und natürlich auch das Programm) dahin?
Ich kann's mir noch nicht erklären.
Zumindest müsste doch da ein NTFS-Link namens "Program Files" inzwischen existieren.
Oder liegt der nicht im Stammverzeichnis, statt dessen sonstwo auf der Platte?
 
Zuletzt bearbeitet von einem Moderator:

Shadow1988

gehört zum Inventar
Vllt. liegt es wirklich an der Übersetzung vom Englischen ins Deutsche. Die Kommandozeile arbeitet ja auch noch mit englischen Kommandos.
 

Roberto

gehört zum Inventar
Nein, das ist vollkommen korrekt.

Vista ist im Grunde genommen englisch. Durch das deutsche Language Pack siehst du C:\Programme.
 

it-rat

Herzlich willkommen
Aber wie macht das der Explorer?

Eine on-the-fly Übersetzung mit Hilfe des Language Packs,
welches mir statt z.B. "users" "Benutzer" anzeigt,
kann es ja wohl nicht sein.

Denn wenn ich in meinem Dokumente-Ordner einen Unterordner "users" anlege,
bleibt der "users", auch wenn ich in der Adresszeile mit der Maus klicke.

Es muss wohl doch irgendwie beim Ordner-Objekt users (im Stammverzeichnis)
eine Zuordnung zum deutschen "Benutzer" existieren.
Richtig übersetzen wie Babelfisch kann Windows ja wohl noch nicht.
 

Roberto

gehört zum Inventar
Denn wenn ich in meinem Dokumente-Ordner einen Unterordner "users" anlege,
bleibt der "users", auch wenn ich in der Adresszeile mit der Maus klicke..
Alles was du selbst neu erstellt und benennst bleibt auch so.

Was stört dich eigentlich an der ganzen Sache? So braucht Microsoft nicht mehr für jede Sprache die Updates anpassen. Es gibt nur noch Updates für 32 und 64 bit und die passen auf jedem Vista. Die englischen Bezeichnungen tauchen auch nur auf, wenn man alle Dateien und Ordner sichtbar macht. Ansonsten merkt man davon überhaupt nichts.
 

it-rat

Herzlich willkommen
Stören tut's mich ja nicht. Im Gegenteil.

Will nur den Mechanismus verstehen.
Schadet ja nicht, wenn man's weiß, oder?
 

umtata

Herzlich willkommen
Tipp für umtata: Schreib mal Programme mit zwei "m".

Bist du ein Lehrer? Abrrr, wenn es dir gut tut: Programme.


WinRar sieht Program Files/Programme(leer), Users, aber kein Benutzer. Documents and Settings/Dokumente und Einstellungen sieht mein Explorer nicht(Bild oben).

 
Zuletzt bearbeitet:
Anzeige
Oben