Anzeige

Am Puls von Microsoft

Anzeige

Frage [gelöst] Batch Datei verzögerte Netzlaufwerkeinbindung

Goifalracer

kennt sich schon aus
Hallo,
ICH hab ein kleines Problem mit meinen Batches die ich für meine Netzlaufwerke geschrieben habe,um die Netzlaufwerke 15 s nach Sytemstart einzubinden,damit kann sich in Ruhe der Rechner mit dem Router verbinden und es kommt zu keinen Fehlermeldungen!!! Hat lange Zeit wunderbar funktioniert bis ich die Freigaben von meinem neuen Homeserver als Netzlaufwerk verbunden habe, kommt es immer beim Start zu der Fehlermeldung ( Es konnten nicht alle Netzlaufwerke verbunden werden) am Anfang ist an den Laufwerkssymbolen noch das rote kreuz dran geht aber nach den 15 s weg und die Laufwerke laufen tadelos nur die dumme Fehlermeldung kommt!!??? Meine Vermutung das mit der Spielerei mit dem Server das dafür veranwortliche Programm durcheinander gekommen ist!! Weiss von euch jemand was das sein könnte ?????

MFG
 
Anzeige

metacom

MS-DarT enhanced user
AW: Batch Datei verzögerte Netzlaufwerkeinbindung

Hallo,
Das sind, etwas offen gesagt, recht dürftige Info´s zu deinem Problem.
Welcher server !? + was für spielerreien hast du gemacht !?
wie sieht deine batch datei aus ... und warum mapst du die bei "jedem neustart"

Es reicht auch, bsp windows das Mappen zu überlassen da ja die laufwerke "da sind"
warum also nicht die verbindung dorthin "prüfen lassen"

In meinem Office habe ich hierfür lediglich

dir Z:
quit

angelegt und das reicht auch aus.
l.g.
 

Goifalracer

kennt sich schon aus
AW: Batch Datei verzögerte Netzlaufwerkeinbindung

Hallo danke für die schnelle Antwort!! Das Problem ist wenn ich Windows selbst einbinden lasse geht das so schnell,das die Internetverbindung noch nicht richtig aufgebaut ist,somit ist das einbinden nicht möglich trotz statischer IP!! Deshalb hab ich die Batches geschrieben um das einbinden zu verzögern,wie gesagt hat lange mit dem Laufwerk das am Usb der Fritz Box hängt funktioniert,seit die Freigaben vom Server als Netzlaufwerk hinzugefügt wurden geht auch das nicht mehr richtig!! BS. = Windows 7 Home Premium Server = Ubuntu 10.04.2 mit samba
Batches sehen wie folgt aus=
@echo off
ping -n 15 localhost > nul
if not exist X: net use X: \\fritz.box\fritz.nas PASSWORT/persistent:no

Das selbe mit noch zwei Laufwerken!!

Durch das einbinden der Samba Laufwerke ist irgendwie der Wurm drin weil ab da hat das Laufwerk von Der Fritz Box auch nicht mir funktioniert???
 

metacom

MS-DarT enhanced user
AW: Batch Datei verzögerte Netzlaufwerkeinbindung

Sorry für das länger nicht melden, die arbeit hält mich ganzschön auf trap gerade :D

Wenn du Windows 7 Als Client benutzt reicht das "normale mappen" absolut aus da Windows 7 (endlich) egal ist ob die verbindung schon steht.
Windows 7 meldet dir zwar am login das nicht alle laufwerke verbunden werden konnten, aber ein klick im Arbeitsplatz und die laufwerke sind da.

Hast du mal probiert den "dns" faktor auszuschließen ?
sprich - bau statt den \\fritz.box\fritz.nas
doch einfach \\ip.zur.fritz.box\fritz.nas
und stelle sicher das der dienst "DNS Cache" beendet und deaktiviert ist

(start ausführen - services.msc => DNS Cache -Starttype Disabled)

Der grund für das verzögern könnte auch der sein das Windows7 erst den namen auflösen muss. und wer windows kennt, weis das dass auch mal dauern kann :D

Das Händische vergeben der IP in windows7 empfinde ich schon als unpraktikabel da die meisten router, anhand der mac addr. die IP dauerhaft reservieren können (und das auch die fritzbox so macht) zu dem hättest du dann auch eine IPv6 verbindung, die du sicher "noch nicht von hand vergeben hast" auch zum server.

l.g.
 

Goifalracer

kennt sich schon aus
AW: Batch Datei verzögerte Netzlaufwerkeinbindung

Hallo danke für die Antwort!!
Habs jetzt hinbekommen,hab dank der super recovery Funktion unter Win7 den Rechner in einen früheren Zustand versetzt,jetzt macht das Skript wieder das was es machen soll!! Ja ich weiß das Windows das trotz der Fehlermeldung und dem roten Kreuz am Laufwerk es nach dem anklicken sauber mappt aber mich nervt einfach die Fehlermeldung,die kommt jetzt auch nimma!Problem gelöst !!
Vielen Dank für deine Mühe !!!!

MFG
 
Anzeige
Oben