Anzeige

Am Puls von Microsoft

Anzeige

GPU Problem nach Windows Upgrade auf 20H2

PPine

Herzlich willkommen
Hallo, ich suche nun schon eine Weile nach einer Lösung für mein Problem, habe bisher aber keine zufriedenstellende gefunden und hoffe, dass mir hier jemand helfen kann! Danke schon mal im Voraus.

Ich habe ein Lenovo P53 mit NVIDIA Quadro RTX 3000, angeschlossen via ein Lenovo ThinkPad USB 3.0 Dock an 2 EIZO Monitore mit gemäßigter Auflösung (1920x1200).
Seit dem 20H2 Update hat in dieser Konstellation die GPU Nutzung der NVIDIA nicht mehr funktioniert und ich bekam entsprechende Fehlermeldungen in Photoshop und einer weiteren Foto-Bearbeitungs Software.
Ich habe mittlerweile alle möglichen Treiber aktualisiert, sowohl von Windows, NVIDIA, DisplayLink, Lenovo... nichts hat die benötigte Funktion wieder hergestellt. De-Installation des Updates hat in der Tat geholfen, aber da das Update dann irgendwann mandatory wurde, habe ich es wieder installiert und auf einen patch gehofft.
Hier ein paar Beobachtungen.
  1. Es sieht so aus, als würde nur noch die on-board Intel Graphikkarte durch das Dock durchgeschleift. Selbst wenn ich in der NVIDIA Systemsteuerung explizit angebe, dass PS die NVIDIA nutzen soll, findet er sie nicht
  2. Color Efex Pro startet gar nicht und gibt Fehler wie gpusWmi.size() <= gpusEnum.size()" "Found more GPUs via WMI than EnumDisplayDevices."
  3. auf dem Laptop Bildschirm kann ich das Programm starten und dann auch auf einen der anderen BS schieben und dort benutzen
  4. deaktivieren der internen Intel GraKa hilft, aber ist auch keine wirklich schöne Lösung und bring allerlei andere Nachteile mit sich
  5. ich hatte ja hierauf gehofft: Golem.de: IT-News für Profis, aber das scheint ein anderes Problem gewesen zu sein.
Ich wäre wirklich froh, wenn mir hier noch jemand weiter helfen könnte. Vielen Dank!
Ppine
 
Anzeige

Tekkie Boy

Just a guy
Hallo und Willkommen @PPine

vielleicht kann Dir @Grisu_1968 in dem Fall helfen.
Soweit mir bekannt ist, ist er in der Lenovo Community tätig.
Vielleicht schaut er, nachdem ich ihn ja erwähnt habe, hier rein und meldet sich zum Thema.
Ich drücke die Daumen das Du das Problem gelöst bekommst.

Freundliche Grüße
 

IngoBingo

gehört zum Inventar
Ich habe ein Lenovo P53 mit NVIDIA Quadro RTX 3000, angeschlossen via ein Lenovo ThinkPad USB 3.0 Dock an 2 EIZO Monitore mit gemäßigter Auflösung (1920x1200).
Es sieht so aus, als würde nur noch die on-board Intel Graphikkarte durch das Dock durchgeschleift. Selbst wenn ich in der NVIDIA Systemsteuerung explizit angebe, dass PS die NVIDIA nutzen soll, findet er sie nicht

Wenn das wirklich ein USB 3.0 Dock ist, dann wird da gar nichts durchgeschleift. Die Bildschirme am Dock nutzen ausschließlich die DisplayLink Grafik im Dock.

Nenne doch bitte das genaue Modell, idealerweise die Teilenummer des Docks.
 

PPine

Herzlich willkommen
Moin und vielen Dank für das feedback! ja, das hatte ich auch schon irgendwo gelesen, aber vor dem Windows Update (und nach dem rollback) hat PS die GPU der NVIDIA ja genutzt... also irgendwie muss das funktioniert haben.
Das Dock ist dieses hier: ThinkPad USB 3.0 Dock - Overview - Lenovo Support DE. Ich hatte zwischenzeitlich auch mal dieses hier probiert, aber mit demselben Problem: https://smile.amazon.de/gp/product/B07QJ8H2K4.
Wenn ich die interne Graphikkarte deaktiviere, geht es übrigens auch

1620974380051.png
 

IngoBingo

gehört zum Inventar
Alles beides DisplayLink. Da wird auf keinen Fall irgendwas von den anderen GPUs durchgeschleift.

Das gibts nur, wenn du das interne Display bzw. die externen Monitor-Ports vom Gerät nutzt. Die hängen grundsätzlich an der Intel GPU und die Nvidia liefert nur zu.

War dieser Citrix Adapter vorher auch schon installiert oder ist der neu dazu gekommen?
Du nutzt die Treiber direkt von Intel oder Nvidia oder die von Lenovo für die Grafikkarten? Ich würde letztere Pakete verwenden.

Ansonsten ist das ein aktuelles Lenovo Gerät mit Lenovo Dock. Du solltest da also ggfs. auch mal im offiziellen Lenovo Forum fragen bzw. den Lenovo Support mit dazu holen. Wenn es in verschiedenen Programmen Probleme gibt, obwohl es schon einmal lief, kann das ja kein Problem der einzelnen Programme sein.
 

Grisu_1968

Staatl gepr. Wirtschafter
Ich schaue heute Abend hier noch mal vorbei ob ich helfen kann. Ich muss jetzt erst mal zur Arbeit.
 

Grisu_1968

Staatl gepr. Wirtschafter
Wenn du möchtest das bestimmte Anwendungen (Photoshop) die Grafik der Nvidia nutzen ordne diese Anwendung der Grafik von Nvidia explizit zu das sollte unabhängig von der Dock funktionieren.
Link: Surface Book 2 Tipp: Die Nvidia-Grafikkarte konfigurieren (gilt auch für andere Notebooks)

Alternative wenn du nur die Nvidia Grafik nutzen möchtest kannst du das auch im Bios umstellen auf Discrete Graphics. Da wird dann aber nur noch die Nvidia Grafik verwendet.
Screenshot 2021-05-17 180716.jpg

Screenshot 2021-05-17 180952.jpg

Treiber, Firmware und Software sollte aktuell sein! Da mal sicherheitshalber auf der Supportseite nachsehen. Solltest du als Lenovo Vantage oder System Update verwenden erscheinen da neue Updates erst ein paar Tage später.
Link: Treiber & Software P53 (Type 20QN, 20QQ) Laptop (ThinkPad)
Link: ThinkPad USB 3.0 Dock - Übersicht
 

IngoBingo

gehört zum Inventar
Und das hat Auswirkungen auf eine Grafik am Dock mit eigenständigem DisplayLink Grafikchip?
Ich bezweifle das stark.
 

PPine

Herzlich willkommen
Hallo @Grisu_1968, und @IngoBingo! vielen Dank für Eure Tipps!

Also... Die Einstellungen in der NVIDIA Systemsteuerung hatte ich auch schon probiert, aber das ganze funktioniert nur, wenn das Laptop offen ist, der Laptopbildschirm als primärer Desktop läuft, ansonsten öffnet sich die NVIDIA Systemsteuerung gar nicht :(
Interessanterweise kann ich das Programm auf dem Laptop-BS öffnen und dann auf einen anderen ziehen, ohne dass es abstürzt - ob es dann den Prozessor noch nutzt oder nicht, kann ich allerdings nicht sagen...
Das BIOS Setting wirkt sich vermutlich ähnlich aus wie das Deaktivieren der Intel Graphikkarte, d.h. ich vermute, dass es funktioniert, aber bringt eben ein paar andere Nachteile mit sich - aber ich werde es mal ausprobieren.
Neue Treiber habe ich keine gefunden.
Der Citrix Treiber ist unabhängig davon (Homeoffice). Ach ja und im Lenovo Forum hatte ich auch schon gefragt, aber bisher ohne Erfolg...

Da das ganze vor dem Windows Upgrade ja problemlos funktioniert hat, hatte ich gehofft, dass MS bald ein Update hat, das das Problem behebt...
 

PPine

Herzlich willkommen
p.s. habe jetzt mal
1) Citrix de-installiert - hat das Problem aber nicht behoben
2) die "Discrete Graphics" Einstellung im BIOS aktiviert - damit geht es erst mal, aber das ist natürlich irgendwie nur ein work-around.
 

Grisu_1968

Staatl gepr. Wirtschafter
Einzig was du noch versuchen könntest wenn die Intelgrafik aktiviert ist das noch in der Nvidiasoftware einzustellen (Da deine Nvidia auswählen ).
Screenshot 2021-05-18 063330.jpg

Ok eine andere Lösung habe ich momentan leider nicht.
 
Zuletzt bearbeitet:

PPine

Herzlich willkommen
Guten Morgen, Danke für den Tipp... bei mir sieht das so aus
1621317689867.png

also sieht die Komponente in der Tat nur das Laptop Display - ich bin kurz davor, das 20H2 Update nochmal zu deinstallieren, um zu sehen, ob das vorher anders war...
Im NVIDIA Control panel hab ich einen Hinweis auf die Windows Graphikeinstellungen gefunden und dort die 2 Programme eingetragen - hat aber leider auch nicht geholfen:

1621317898516.png


1621317907696.png
 

PPine

Herzlich willkommen
Also, ich habe jetzt im BIOS die Einstellung auf "discrete Graphics" gesetzt, wie @Grisu_1968 oben vorgeschlagen hat. Werde mal beobachten, ob das irgendwelche nachteiligen Effekte mit sich bringt, bisher funktioniert es. Vielen Dank nochmal für Eure Tipps.
 

Grisu_1968

Staatl gepr. Wirtschafter
Einziger Nachteiliger Effekt ist wenn du das Notebook ohne Netzteil verwendest das der Akku nicht so lange hält weil die Nvidia mehr Strom benötigt als die Intel.
 

PPine

Herzlich willkommen
habe jetzt die Intel in der Systemsteuerung deaktiviert - da kann ich sie ggf. schneller wieder aktivieren, wenn ich das Notebook "solo"verwenden möchte. Lenovo hat gerade ein BIOS update verteilt - leider hat das aber auch nichts geändert.
 
Anzeige
Oben