Anzeige

Am Puls von Microsoft

Anzeige

System Icon Cache vergrößern - wie geht das?

alexam

Herzlich willkommen
Win 7 Ultimate - Icon cash desktop

Ich möchte den cash vergrößern, da beim Starten der Icon Aufbau zu lange dauert.

Gibt es eine einfache Lösung?

Danke im voraus.
 
Anzeige
AW: Win 7 Ultimate - Icon cash desktop

Hallo und willkommen in unsrem Forum, alexam :)

Normalerweise kann man das recht einfach in der Registry ändern

Musst dich nur zum Pfad KEY_LOCAL_MACHINE/Software/Microsoft/Windows/CurrentVersion/Explorer "hangeln"

Da eine neue Zeichenfolge anlegen(wenns es noch nicht da steht) mit dem Namen: Max Cached Icons
und dann entweder den neuen Wert eintragen oder erhöhen auf 4000
 
AW: Windows 7 Ultimate - Icon cash vergrößern

Man kann es auch per Reg-Datei variabel machen - Einstellung dann über Ordneroptionen/Ansicht
Anbei die Reg-Datei - gezippt
 

Anhänge

  • Optionen_IconCache.zip
    524 Bytes · Aufrufe: 3.156
  • Iconcache.jpg
    Iconcache.jpg
    72,8 KB · Aufrufe: 3.697
Sollten bei dir Fehlerhafte Icons dargestellt werden, so kann man dies eventuell beheben
wen man den Icon Cache Vergrößert.

Aber dadurch wird er auch nicht schneller.

Ich gehe auch davon aus das es bei dir einen andere Ursache haben muss
das beim Starten der Icon Aufbau zu lange dauert.

man könnte auch mal falls nötig den Autostart entrümpeln
den die Programme im Autostart werden ja automatisch bei jedem Systemstart geladen
und belasten natürlich das System
in dem sie den Arbeitsspeicher und weitere wichtige Systemressourcen belegen/beanspruchen
was halt dazu führen kann das der Icon Aufbau zu lange dauert.

ot:
Hast du eventuell mal mit TuneUp oder einer ähnlichen Software gearbeitet.
 
Zuletzt bearbeitet:
Hallo Diogenes,
ich habe die von Dir angehängte Registry-Ergänzung erfolgreich auf zwei XP-PCs installieren können.
Bei meinem Windows 7 x64 professional funktioniert das leider nicht. Weißt Du warum das nicht geht?
Auch mit einer anderen Datei - iconcache.reg, Größe 1794k - funktioniert es nicht. Bleibt da nur der händische Eingriff in die Registry?
 
Bei meinem drei Jahre alten System mit 2 GB RAM und einem Board von 2007 war der Iconaufbau auch elend langsam, ich erwarte im Jahre 2011, dass ich sofort beim Hochfahren alle Icons sehe, wie du vermutlich auch. Mit einem schnelleren Board und Prozessor hat sich das bei gleicher Win7-Konfig für mich erledigt. Wenn mehr RAM und/oder ein schnelles Board/CPU der ausschließliche Grund dafür sind, ist das natürlich ein Armutszeugnis für Microsoft, die paar jämmerlichen Bildchen und Links dahinter...
Ich hatte damals auch alles Mögliche probiert: Autostart entrümpeln per CCleaner, IconCache vergrößern, alle USB-Einheiten abkoppeln, hat aber alles nichts genützt. >=o/
 
Zuletzt bearbeitet:
Hallo und herzlich Willkommen bei uns im Forum, :)

du kannst auch probieren, den Default-Icon Cache wiederherzustellen:

Windows Start -> "cmd" eingeben -> Rechts-KLick auf cmd.exe -> Als Administrator ausführen
In der Kommandozeile folgende Befehle nacheinander eingeben und jeweils mit der [Enter]-Taste abschicken:
Code:
taskkill /IM explorer.exe /F
CD /d %userprofile%\AppData\Local
DEL IconCache.db /a
shutdown /r
Nebenbei, woher nimmst du den Wert "1794"?
 
@ Franz: Ich habe zwei Versionen von iconcache.reg mit unterschiedlichen Größen: 1709k und 1794k. Sie sind im Text aber identisch. Habe sie gerade verglichen. Woher der Unterschied kommt, weiß ich nicht.
Das mit dem Default Icon Cache werde ich mal probieren, aber eigentlich war das ganze nur "Spielerei". Ein echtes Problem habe ich nicht. Wolle die Größe nur wie bei XP sehen und einstellbar haben. Aber das funktioniert hier wirklich nicht. Kann das an den 64bit liegen?

Jetzt habe ich den besagten Eintrag in der Registry gefunden! Er liegt nicht dort, wo er eigentlich entsprechend dem kleinen Programm liegen sollte:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Advanced\IconCache]
sondern hier:
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\explorer\Advanced\IconCache]
Das scheint wohl 64-bit spezifisch zu sein. Der Abzweig "Wow6432Node" ist da zusätzlich drin.
Alle anderen Einträge des Scripts sind dann ordentlich vorhanden.
Nur in den "Ordneroptionen" wird die Auswahl nicht angezeigt. Wer hat da ein Problem???
 
Zuletzt bearbeitet von einem Moderator:
Ich habe auch weisse Icons beim Systemstart von Win7 Prof. 32bit, obwohl ich als CPU Intel E8400 mit 3GB, 4 GB Ram und eine Intel Onboard-Grafik G45 habe. Aero habe ich sowieso abgeschaltet und die visuellen Effekte sind auf optimale Lesitung eingestellt. Beim Start gibt es nur zwei Nicht-MS-Dienste (Intel Rapid St. und USBDLM) und neun Autostart-Programme, davon vier von Intel. Das Problem hatte ich auf meinem Rechner auch schon mit WinXP.
 

Anhänge

  • Desktop-Start.jpg
    Desktop-Start.jpg
    11,4 KB · Aufrufe: 781
Kann das an den 64bit liegen?
eigentlich kaum - ich hab ja auch x64

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\explore r\Advanced\IconCache]
Das scheint wohl 64-bit spezifisch zu sein. Der Abzweig "Wow6432Node" ist da zusätzlich drin.
ist bei mir nicht vorhanden

habe zwei Versionen von iconcache.reg mit unterschiedlichen Größen: 1709k und 1794k
wo hast Du die her - meine Reg-Datei hat im Explorer angezeigte 2KB
siehe auch Anhang
 

Anhänge

  • Optionen_IconCache.zip
    524 Bytes · Aufrufe: 592
Das mit den 2KB liegt wohl an der Ungenauigkeit des Explorers. In meinem Totalcomander werden dafür nur 1709 k berechnet! Die andere reg-Datei habe ich auf meinem alten PC gefunden. Wo die her ist, weiß ich nicht mehr.
Hast Du auch Windows 7 64 professional? Vielleicht kommt der Abzweig ja daher. Ist ansonsten schon sehr merkwürdig. Dahinter liegt alles, was mit 64bit zu tun hat. Der Rest ist 32 bit. Die habe ich ja zusätzlich!! Daher sicherlich der Unterschied - und der showstopper -lach-
 
ja - steht auch unter meinem Bild.....

Wer lesen kann, ist echt im Vorteil!!:)

Dann werde ich heute mal nachforschen, wo dieser Abzweig herkommt!
Vielleicht liegt es an der von DELL vorinstallierten OEM Version?
Ich gehe der Sache mal nach und werde berichten.


Hier habe ich schon etwas gefunden, was auf den Unterschied hinweist:
http://support.microsoft.com/kb/305097/de

Da kommt gleich die neue Frage: Die erweiterete iconcache-Regsitrierung hat also nur in der 32bit-Umgebung stattgefunden. Der Prozess "Ordneroptionen" greift auf die 64bit-Registrierung zu und sieht daher die Erweiterung nicht. Wie bekomme ich die beiden zusammen?
 
Anzeige
Oben