[gelöst] IDE-AHCI-Umstellung unter Build 14251 fehlgeschlagen

diet59

gehört zum Inventar
IDE-AHCI-Umstellung unter Build 14257 fehlgeschlagen

Auf meinem Multiboot-System (BIOS, kein UEFI) befinden sich auf einer HDD jeweils auf separaten Partitionen diese x86-Systeme:

- win7
- win 8.1
- win 10 (ehemals win7)
- win 10 IP (Build 14521)
- win Vista
- win 10 (ehemals win8)
- Daten

Weil eine SSD einziehen soll, habe ich von IDE auf AHCI umgestellt, was auf allen Systemen außer win 10 IP funktioniert hat.
Beim Start in win 10 IP kam statt dem gewählten abgesicherten Modus "Windows Diagnose wird ausgeführt" und später der Bluescreen mit "Inaccessible_Boot_Device".
Der kam später immer wieder, egal ob normal oder abgesichert gestartet wurde.

Dann versuchte ich mit einem (auf einem anderen PC selbst erstellten) Build-14257-iso ein Inplace Upgrade, was ebenso mit o.g. Bluescreen scheiterte.
Dann löschte ich die Partition mit dem Windows Setup und versuchte vergeblich sie neu zu erstellen.
Dann erstellte ich aus dem laufenden win 10 eine Partition im freien Bereich.
Beim Windows Setup kommt nach Auswahl "Benutzerdefiniert" (wie beim vorangegangenen Inplace-Versuch) zunächst "kein Datenträger vorhanden" und "Treiber laden", nach Klick auf "Aktualisieren" werden dann alle Partitionen angezeigt.
Das Windows Setup läuft nun normal an (gut 5 GB wurden auf der Partition abgelegt - von anderen Systemen aus gut sichtbar).
Nach dem 1. Reboot kommt aber wieder der Bluescreen mit "Inaccessible_Boot_Device".

Es scheint, als sei der IDE-Modus nur für diese Partition irgendwo festgeschrieben.

Wer hat noch eine Idee?
 
Zuletzt bearbeitet:
Anzeige

tofuschnitte

Fremdgeher mit nem S8 :(
sobald du von IDE auf AHCI umstellst ist kein Windows mehr bootbar, nicht möglich!

Wieder auf IDE stellen, booten, regedit öffnen -> HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msahci den Wert von Start auf 0 setzen. Herunterfahren, auf AHCI stellen. Bootet dann wie gewohnt
 

diet59

gehört zum Inventar
Alle Partitionen löschen will ich natürlich nicht.
Die verschiedenen Umstellverfahren für die jeweiligen Systeme habe ich beachtet.
Sonst würde es nicht bei den meisten funktionieren - außer eben bei win 10 IP.
 

Terrier!

gehört zum Inventar
Booten von Installaionsmedium und die SSD auswählen muss gehen, so installiert man doch eh normal.
Was mit deiner HHD ist und ob du die ganzen Systeme wieder ans laufen bekommst, keine Ahnung.
Verstehe auch nicht warum du überhaupt ein Betriebsystem von einen Windows aus installierst.

Es sollte doch eine SSD zusätzlich einziehen und da war entweder eh nichts drauf oder man löscht alle Partitionen, formatiert nicht und klickt einfach auf weiter.
Na klar bootet man von DVD oder USB Stick.
 

Terrier!

gehört zum Inventar
Vista hat er doch nur XP fehlt, keine Ahnung ob XP noch läuft mit der Hardware, denn dann kann er ja auch noch Win 98 nehmen.
Alle Partitionen löschen will ich natürlich nicht.
Wie nicht alle Partitionen löschen, was ist denn auf der SSD schon drauf?
nur die SSD meine ich doch!
 

diet59

gehört zum Inventar
AW: IDE-AHCI-Umstellung unter Build 14257 fehlgeschlagen

sobald du von IDE auf AHCI umstellst ist kein Windows mehr bootbar, nicht möglich!

Wieder auf IDE stellen, booten, regedit öffnen -> HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msahci den Wert von Start auf 0 setzen. Herunterfahren, auf AHCI stellen. Bootet dann wie gewohnt

Seit win8 heißt der Ertrag nicht mehr ... msahci, sondern ... storahci.

Das Verfahren
AHCI nach der Installation von Windows 10 aktivieren Deskmodder Wiki
hat nicht funktioniert.
Nach jedem Neustart ist der gelöschte Schlüssel "StartOverride" wieder da bzw. der Wert "0" steht wieder auf "3" statt "0", obwohl die Schlüssel Vollzugriff haben.

@ Terrier:
Die SSD kommt erst ins System, wenn alles läuft.
Natürlich versuche ich nicht, "ein Betriebssystem von einem Windows aus zu installieren".
 
Zuletzt bearbeitet:

hansjorg71

gehört zum Inventar
Hallo, hast du mal versucht die Umstellung auf AHCI im Abgesicherten Modus ?

Das entsprechende System (win 10 IP (Build 14521) vorbereiten für den Abgesicherten Modus .
Abgesicherten Modus in Windows 10 starten Deskmodder Wiki

Shutdown und neu starten aber erst im Bios auf AHCI umstellen ! ;)
Das System (win 10 IP (Build 14521) hochfahren den Abgesicherten Modus wieder rückgängig stellen und das System normal starten ! :)

Gruß :)
 

diet59

gehört zum Inventar
@hansjorg71: Die Methode mit abgesichertem Modus hat bei win 10 (eh. win7) funktioniert, nicht aber bei win 10 IP.

@Terrier!: Genau, zum Zeitpunkt des 1. Reboots ist bereits alles vom Stick bzw. von DVD auf die HDD kopiert (~ 5,3 GB).
Die Installation habe ich mittlerweile vollendet, aber im IDE-Modus.
Und da ist die Registry gesperrt.
 

DM-moinmoin

gehört zum Inventar
AW: IDE-AHCI-Umstellung unter Build 14257 fehlgeschlagen

Seit win8 heißt der Ertrag nicht mehr ... msahci, sondern ... storahci.

Das Verfahren
AHCI nach der Installation von Windows 10 aktivieren Deskmodder Wiki
hat nicht funktioniert.
Nach jedem Neustart ist der gelöschte Schlüssel "StartOverride" wieder da bzw. der Wert "0" steht wieder auf "3" statt "0", obwohl die Schlüssel Vollzugriff haben.
Du hast nach der Umstellung in der Registry bist du auch sofort nach dem Neustart ins Bios und hast auf AHCI umgestellt?
Denn wenn Windows den Wert wieder auf 3 stellt, scheinst du die Umstellung nicht gemacht haben.
 

diet59

gehört zum Inventar
AW: IDE-AHCI-Umstellung unter Build 14257 fehlgeschlagen

Du hast nach der Umstellung in der Registry bist du auch sofort nach dem Neustart ins Bios und hast auf AHCI umgestellt?
Denn wenn Windows den Wert wieder auf 3 stellt, scheinst du die Umstellung nicht gemacht haben.

Ja, wobei der Neustart anders als sonst abläuft. Die OS-Liste wird angezeigt, das OS ist entsprechend Vorauswahl (Easy BCD) markiert - und dann erfolgt ein weiterer Reboot.
Vermutlich erfolgt hier das Registry-Rollback.

Was ich nicht verstehe:
Wenn ich die Partition lösche, vom anderen OS aus neu erstelle (weil das Windows Setup "nicht möglich" sagt) und neu installiere, geschieht das im IDE-Modus, obwohl das BIOS auf AHCI steht.
Die Vordefinition dieses HDD-Speicherbereichs als IDE kann nur auf einer anderen Partition eingetragen sein, aber wo?
 

hansjorg71

gehört zum Inventar
Hallo,
Die Vordefinition dieses HDD-Speicherbereichs als IDE kann nur auf einer anderen Partition eingetragen sein, aber wo?

Da gibt es keinerlei Vordefinitionen auf einer HDD !;)

Das einzige was mir momentan noch einfällt , wenn dieses Win 10 Build 14257 keine AHCI-Treiber für deinen PC hat ! :)

Gruß :)
Ps. welchen Type sind denn diese Partitionen ? ;)
Ps. du kannst ja auch mal alle anderen Partitionen verstecken und dann installieren ! :D
http://www.deskmodder.de/wiki/index.php?title=Partition_oder_Festplatte_ausblenden_im_Computer


 
Zuletzt bearbeitet:

diet59

gehört zum Inventar
Das Windows Setup sieht auch versteckte Partitionen.

Aber das mit den Treibern erscheint mir schlüssig, zumal dieser auch bei der Installation angefragt wird - nur in der Form *.sys nicht akzeptiert wird.

Vom laufenden System aus ist ein Austausch oder Umbenennen des storahci.sys nicht möglich, da werden Trusted Installer Rechte verlangt.

Ich werde es mal mit einer Live-CD versuchen.
 

diet59

gehört zum Inventar
Die 2. Ansicht ist aus AOMEI, da sieht man die physische Anordnung der Partitionen.
 

Anhänge

  • Datenträgerverw.jpg
    Datenträgerverw.jpg
    44,6 KB · Aufrufe: 83
  • Datenträger AOMEI.jpg
    Datenträger AOMEI.jpg
    31,6 KB · Aufrufe: 81
Oben