Anzeige

Am Puls von Microsoft

Multimedia: Immer wieder auftretende Bluescreens

Damp2000

Herzlich willkommen
Moin!

Ich habe in der letzten Zeit einige BSODs gehabt und wäre sehr dankbar, wenn mir jemand helfen könnte. Bisher hatte ich vage mein Headset in Verdacht, weil die drei ersten BSODs nur aufgetreten sind, wenn diese angeschlossen war, während der PC zwischendrin wieder eine Woche anstandslos lief.
Jetzt ist allerdings zum erstenmal ein BSOD ohne Headset aufgetreten, so daß ich leider etwas ratlos war. Immerhin steht in der Analyse des dumpfiles etwas von einem audiodg.exe - bedeutet dies möglicherweise, daß die Probleme doch irgendwie aus der Audioecke, vielleicht von einem Treiber stammen?

Ich poste hier mal, was mir WinDebug auspuckt - vielleicht kann das ja jemand etwas genauer interpretieren?

Microsoft (R) Windows Debugger Version 6.2.8229.0 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.


Loading Dump File [C:\Windows\MEMORY.DMP]
Kernel Summary Dump File: Only kernel address space is available

Symbol search path is: srv*D:\Programme\Symbols*http://msdl.microsoft.com/download/symbols
Executable search path is:
Windows 7 Kernel Version 7600 MP (2 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7600.16841.amd64fre.win7_gdr.110622-1503
Machine Name:
Kernel base = 0xfffff800`02a4a000 PsLoadedModuleList = 0xfffff800`02c87e70
Debug session time: Mon Mar 26 16:35:04.294 2012 (UTC + 2:00)
System Uptime: 0 days 8:15:57.531
Loading Kernel Symbols
...............................................................
................................................................
....Page 117ce7 not present in the dump file. Type ".hh dbgerr004" for details
...Page 1142bc not present in the dump file. Type ".hh dbgerr004" for details
.........................
Loading User Symbols
PEB is paged out (Peb.Ldr = 000007ff`fffdb018). Type ".hh dbgerr001" for details
Loading unloaded module list
..................
TRIAGER: Could not open triage file : C:\Program Files (x86)\Windows Kits\8.0\Debuggers\x64\triage\oca.ini, error 2
TRIAGER: Could not open triage file : C:\Program Files (x86)\Windows Kits\8.0\Debuggers\x64\winxp\triage.ini, error 2
TRIAGER: Could not open triage file : C:\Program Files (x86)\Windows Kits\8.0\Debuggers\x64\triage\user.ini, error 2
*******************************************************************************
* *
* Bugcheck Analysis *
* *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 1A, {41287, 30, 0, 0}

Page 117ce7 not present in the dump file. Type ".hh dbgerr004" for details
TRIAGER: Could not open triage file : C:\Program Files (x86)\Windows Kits\8.0\Debuggers\x64\triage\modclass.ini, error 2
Probably caused by : ntkrnlmp.exe ( nt! ?? ::FNODOBFM::`string'+42a65 )

Followup: MachineOwner
---------

1: kd> !analyze -v
*******************************************************************************
* *
* Bugcheck Analysis *
* *
*******************************************************************************

MEMORY_MANAGEMENT (1a)
# Any other values for parameter 1 must be individually examined.
Arguments:
Arg1: 0000000000041287, The subtype of the bugcheck.
Arg2: 0000000000000030
Arg3: 0000000000000000
Arg4: 0000000000000000

Debugging Details:
------------------

Page 117ce7 not present in the dump file. Type ".hh dbgerr004" for details
TRIAGER: Could not open triage file : C:\Program Files (x86)\Windows Kits\8.0\Debuggers\x64\triage\modclass.ini, error 2

BUGCHECK_STR: 0x1a_41287

DEFAULT_BUCKET_ID: WIN7_DRIVER_FAULT

PROCESS_NAME: audiodg.exe

CURRENT_IRQL: 0

TRAP_FRAME: fffff8800a6ea650 -- (.trap 0xfffff8800a6ea650)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000000000000000 rbx=0000000000000000 rcx=00000000ffffffff
rdx=0000000000000008 rsi=0000000000000000 rdi=0000000000000000
rip=fffff80002b9eab1 rsp=fffff8800a6ea7e0 rbp=fffff8800a6ea840
r8=fffff80002a4a000 r9=0000000000000001 r10=0000000fffffffff
r11=0000000000000001 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0 nv up ei pl nz ac po nc
nt!MiResolvePageFileFault+0x10c1:
fffff800`02b9eab1 8b4830 mov ecx,dword ptr [rax+30h] ds:00000000`00000030=????????
Resetting default scope

LAST_CONTROL_TRANSFER: from fffff80002a66b8e to fffff80002aba5c0

STACK_TEXT:
fffff880`0a6ea4e8 fffff800`02a66b8e : 00000000`0000001a 00000000`00041287 00000000`00000030 00000000`00000000 : nt!KeBugCheckEx
fffff880`0a6ea4f0 fffff800`02ab86ae : 00000000`00000000 00000000`fffff8a0 00000000`00000000 00000000`00000000 : nt! ?? ::FNODOBFM::`string'+0x42a65
fffff880`0a6ea650 fffff800`02b9eab1 : fffff8a0`00000070 00000000`ffffffff 00000000`00000000 00000000`00000000 : nt!KiPageFault+0x16e
fffff880`0a6ea7e0 fffff800`02b30641 : 00000000`76f4f60a fffff8a0`00000278 fffffa80`0483f698 fffff880`0a6ea300 : nt!MiResolvePageFileFault+0x10c1
fffff880`0a6ea910 fffff800`02ad640e : 00000000`00000000 00000000`76f4f60a fffff680`003b7a78 fffffa80`0483f698 : nt! ?? ::FNODOBFM::`string'+0x363b4
fffff880`0a6ea9b0 fffff800`02ad4593 : 00000000`00000000 00000000`76f4f60a 00000000`00000000 00000000`00000000 : nt!MiDispatchFault+0x1de
fffff880`0a6eaac0 fffff800`02ab86ae : 00000000`00000008 00000000`00000000 00000000`00000001 00000000`00000000 : nt!MmAccessFault+0x343
fffff880`0a6eac20 00000000`76f4f60a : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiPageFault+0x16e
00000000`001be870 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x76f4f60a


STACK_COMMAND: kb

FOLLOWUP_IP:
nt! ?? ::FNODOBFM::`string'+42a65
fffff800`02a66b8e cc int 3

SYMBOL_STACK_INDEX: 1

SYMBOL_NAME: nt! ?? ::FNODOBFM::`string'+42a65

FOLLOWUP_NAME: MachineOwner

MODULE_NAME: nt

IMAGE_NAME: ntkrnlmp.exe

DEBUG_FLR_IMAGE_TIMESTAMP: 4e02aa44

FAILURE_BUCKET_ID: X64_0x1a_41287_nt!_??_::FNODOBFM::_string_+42a65

BUCKET_ID: X64_0x1a_41287_nt!_??_::FNODOBFM::_string_+42a65

Followup: MachineOwner
---------
 
Zuletzt bearbeitet von einem Moderator:
Anzeige

dwian

Wundert sich
Hallo DAMP2000,

ich bn echt kein Profi, also nimm das was ich schreibe nicht zu wichtig.

Aus dem Debugger geht meiner Meinung nach hervor, dass audiodg einen Speicherüberlauf (-> nt!MmAccessFault+0x343) verursacht.

Kannst du sagen, was du in dem Moment grade getan hast?
 

Damp2000

Herzlich willkommen
Danke schon mal für de Tipp (wobei: was würde das genau bedeuten?) Die Umstände bei den ersten BSODs waren sehr ähnlich - ein Spiel lief, ich habe mein Headset reingestöpselt (USB Headset - der Fehler trat aber auch auf, wenn ich es nicht per usb betrieben habe) und Teamspeak gestartet, nach ca 5 Minuten war Schluß.

Beim dritten Mal lief das Spiel nicht, nur das Headset war angeschlossen und Teamspeak an...bei einem weiteren Test lief Headset und Teamspeak ein paar h reibungslos (ich habe allerdings nicht gesprochen, das headset lag nur rum) als ich dann angefangen habe, es zu verwenden war ganz schnell schluß...vielleicht liegts also am Mikrofoneinsatz?)

Naja und beim letzten bluescreen war weder TS an, noch das Headset verbunden - evtl lief Firefox, vielleicht war ein Word Dokument geöffnet...der kam total aus dem Blauen (wie passend :)
 

Damp2000

Herzlich willkommen
Super, bzw nicht so super..wobei mir auch jede Eingrenzung weiterhilft (Ist das dann ein Zufall, daß es immer etwas aus dem Bereich sound zum auslösen braucht?)
Ich sitze gerade am laptop, werde aber nachher mal meine Systemdaten nachtragen und heute nacht mal einen RAM test laufen lassen -da ist doch memtest86+ geeignet, oder?
 

Damp2000

Herzlich willkommen
So - habe meine Systemdaten nach bestem Wissen und Gewissen angegeben.

Hatte heute einen weiteren Bluescreen. Ich konnte heute einige Stunden lang das Headset verwenden - aber als ich es dann rauszog, kam nach 5 Sekunden der Bluescreen...ich habe wirklich nicht viel Ahnung von der Materie - aber macht dieses gehäufte Auftreten von Problemen rund um das Headset die Hypothese mit dem defekten RAM nicht unwahrscheinlich?
 

Marco1976

Bin (fast) immer da
Hi Damp2000:),

nun, Deine RAM-Bestückung ist n Bissel blöd, verschiedene Hersteller, verschiedene Größen und "nur" 4GB bei 64Bit, Win7 ist bei Mischbestückung sehr mäkelig.
Haste mal nach nem neuen Treiber für das Headset geschaut? Oh, sorry, dafür gibts keine Treiber, hab ich gerade entdeckt.
 

dwian

Wundert sich
Hi Damp,

der Tipp mit dem Speicherproblem ist leider wirklich nicht ganz abwegig. Zudem komme ich bei deinen Beschreibungen aber auch auf den Verdacht, dass es sich um etwas Wärmeabhängiges handeln könnte - Überhitzung, alter Elko oder so.

Ist der Rechner immer schon schön warm, wenn er abschmiet? Und was sagt denn der Speichercheck?
 

Damp2000

Herzlich willkommen
Moin!

Danke für die vielen Rückmeldungen!
Also vor den momentanen Problemen lief der Rechner wunderbar stabil über 2 Jahre lang. Ram Mischmasch kam durchs nachrüsten...meint ihr es wäre besser sich da noch mal ein zweiten Corsair Riegel zu holen?

Was die Temperatur angeht kann ich entwarnen, habe Temperaturen erst letzens alle unter verschiedenen Auslastungen gecheckt - alles im grünen Bereich...außerdem hatte ich ja auch einen bluescreen ohne daß irgendwas aufregendes lief...
Das 4 GB nicht reichen sollen, Stückelung hin oder her, überrascht mich doch etwas - ich habe noch nie gesehen, daß da groß mehr als 2 GB genutzt werden, selbst bei den Spielen, die ich so spiele nicht.

Naja, ich werde mal weiter schauen - RAM Test habe ich auf heute nacht verschoben..mal sehen was da rauskommt...noch mal vielen Dank für die Rückmeldungen bis jetzt
 

areiland

Computer Legastheniker
Ein Ramtest wird nichts bringen, der ist nur statisch. Fehler wie sie Bei Dir auftreten kann der nämlich nicht nachstellen.

Die Mischbestückung wird in der Tat das Problem sein, Windows reagiert äusserst sensibel auf Unterschiede in den Timings der verbauten Riegel.

Deswegen immer in der QVL (Speicherkompatibilitätsliste) des Mainboards nachsehen, ob die eingesetzten Speicherriegel enthalten sind. Ausserdem möglichst immer gleich bestücken und solche Stückelungen wie bei Dir vermeiden.
 

slobofree

gehört zum Inventar
Das 4 GB nicht reichen sollen, Stückelung hin oder her, überrascht mich doch etwas - ich habe noch nie gesehen, daß da groß mehr als 2 GB genutzt werden, selbst bei den Spielen, die ich so spiele nicht.

Beim 32Bit, 2GB genügen schon, aber 64Bit ohne 4GB ist nichts. Und bei der Programm Spielen, wahrscheinlich noch mehr.
 

Damp2000

Herzlich willkommen
Gut - dann werde ich es wohl nochmal mit einem 2ten von diesen 2 GB Riegeln versuchen..ist ja nicht sooo teuer.
Aber nur weil mich das so verblüfft: Wie kann man denn erklären, daß die Probleme immer mit dem Headset / Audioprozessen verbunden sind? Ich glaub das ja mit dem RAM-Problem, aber es interessiert mich doch...wie kann man denn die beiden Beobachtungen unter einen Hut bringen?
Und ist es auch nicht relevant, daß das System so lange in genau dieser Form stabil war?
 

areiland

Computer Legastheniker
@Damp2000
Da reicht das Update eines Treibers, ein Windows Update oder ein Programmupdate.
Es muss sich nur der Speicherbereich verändern, in dem ein Treiber seine Daten unterbringt, damit das ganze labile Kartenhaus anfängt zusammen zu brechen. Genauso können die gerade ansteigenden Umgebungstemperaturen das Problem mit der Mischbestückung zu Tage treten lassen.
 

Damp2000

Herzlich willkommen
Ok, das klingt einleuchtend. Dann müßte es demnach möglich sein, zu Testzwecken die zwei 1 GB Riegel rauszuschmeißen und zu schauen ob das System dann stabil bleibt... (Und jetzt bitte keine Posts mit Win 64 läuft NIE mit 2 GB ;))
Dsa werde ich morgen mal machen und dann mal ein paar Versuche mit dem Headset starten!
 

areiland

Computer Legastheniker
Tu das! Eventuell könnte es auch helfen, wenn Du die Einbaureihenfolge der Riegel umkehrst. Teste es aber erst mal mit nur dem 2 GB Riegel.
 

Damp2000

Herzlich willkommen
Super, so werde ichs machen!
 
Oben