Anzeige

Am Puls von Microsoft

Anzeige

[gelöst] Interne Festplatte wird als Wechseldatenträger erkannt

FelixKeyway

Dr. Hacker
Moin,

Das ist wieder ein sehr altes, leidiges Thema: Meine interne Festplatte die an einem PCIe Express Marvell Controller hängt, wird als Wechseldatenträger erkannt. Auch wenn es jetzt heißen könnte, ignorier das doch einfach, geht nicht: Meine Festplatten sind mit Bitlocker verschlüsselt, da dort wichtige Daten drauf sind, nun wird die Festplatte als Bitlocker to Go-Laufwerk erkannt, das nicht automatisch beim Systemstart entsperrt werden kann, was aber zwingend erforderlich ist. Als Treiber habe ich schon den msahci Treiber installiert und den TreatAsInternal-Flag probiert, der ging nicht, laut diversen Internetquellen wird der seit Windows 8 ignoriert.

Weitere Ideen?

Danke & Gruß,
Felix
 
Anzeige

areiland

Computer Legastheniker
Der Platte im UEFi die Hotplug Funktionalität nehmen, dann sollte das gelöst sein. Denn die Option Hotplug sorgt dafür, dass Windows die Platte als Wechseldatenträger ansieht.
 

FelixKeyway

Dr. Hacker
Danke für eure Antworten, ich melde mich krankheitsbedingt erst jetzt.


Wie gesagt, dort taucht immer wieder der Trick mit dem msahci-Treiber und dem TreatAsInternalPort-Flag auf, das funktioniert seit Windows 8 aber nicht mehr.

Die Hotplug-Fähigkeit im UEFI abschalten, bringt auch nichts, da dass eine Erweiterungskarte ist und die lässt sich nicht über das UEFI steuern und bietet auch keine eigene Konfigurationsmöglichkeit an.

Gruß,
Felix
 

tofuschnitte

Fremdgeher mit nem S8 :(
liegt am Treiber ja, kannste in den meisten Fällen nichts machen. Aber ist ja für den normalen Betrieb auch nicht weiter tragisch. Evtl gibts für die Karte nen Update welche das behebt, aber kann auch durchaus gewollt sein das Verhalten
 

Shiran

Bin schon Groß!!
Hallo Felix :konfetti
Moin,
Meine interne Festplatte die an einem PCIe Express Marvell Controller hängt, wird als Wechseldatenträger erkannt. Auch wenn es jetzt heißen könnte, ignorier das doch einfach, geht nicht: Meine Festplatten sind mit Bitlocker verschlüsselt,....
Ist diese Platte im GPT oder MBR Format?
 

FelixKeyway

Dr. Hacker
Allesamt in GPT, da es sich um zwei 3 TB und eine 4 TB Platte handelt.

@tofuschnitte: Für den normalen Betrieb nicht, stimmt, aber was schon nervig ist, das Windows die Laufwerke dadurch für BitLocker to Go-Laufwerke hält und daher kein automatisches Entsperren beim Systemstart anbietet.

Gruß,
Felix
 
Zuletzt bearbeitet:

Shiran

Bin schon Groß!!
Hilft Dir das >>
71660d1342471198-interne-festplatte-entfernbares-medium-erkannt-anleitung1.jpg
PC-Experience Windows 7, Tipps und Tricks : | Windows 7: Hardware-sicher-entfernen für interne SATA-Laufwerke deaktivieren und/oder ausblenden
 

tofuschnitte

Fremdgeher mit nem S8 :(
wie wärs mit Trick 17? Schmeiß deine DVD-Laufwerke raus, braucht eh kein Mensch mehr und fürn Notfall besorg dirn günstigen externen Brenner. Oder stöpsel die an die Erweiterungskarte (was aber durchaus Probleme machen könnte, musste ausprobieren)
 

FelixKeyway

Dr. Hacker

Dieser Flag wird seit Windows 8 leider ignoriert, unter Windows 7 konnte man sich damit perfekt helfen.

Ich habe jetzt folgendes gemacht: Eines der DVD-Laufwerk muss auf jeden Fall am Mainboard bleiben, damit der UEFI-Boot davon klappt. Das andere habe ich jetzt an den PCIe-Controller angeschlossen -> funktioniert so weit noch, ans Mainboard habe ich jetzt die drei Windows-Platten angeschlossen, Problem gelöst, bis eine neue Platte dazu kommen sollte, die per UEFI booten muss, denn das kann der PCIe-Controller leider nicht.

Gruß,
Felix
 

FelixKeyway

Dr. Hacker
Nochmal ein Update:

hat jemand ne Idee, warum der nun meine Grafikkarte als hotplugging-fähig ansieht? Tritt seit dem 10586.71er-Update gestern auf :D .

Hotplugging GraKa.PNG
 

tofuschnitte

Fremdgeher mit nem S8 :(
hat nichts mit dem 71er Update zu tun, und Google hätte dir sofort 23049230984092384823094 mal gesagt warum.

Liegt an der neuen Treiberversion für deine Grafikkarte, die unterstützten jetzt auch externe Grafiklösungen und das steht so auch dick und fett in den Releasenotes, dass bei manchen Leuten das jetzt auch bei "normalen" Grafikkarten auftaucht. Ich würde dir übrigens anraten (wie auch in den Notes steht) nicht aus Neugier drauf zu klicken!

Wird in der nächsten Treiberversion entfernt sein, falls es dich stört:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\nvlddmkm
SurpriseRemovalSupport auf 0 setzen

Frag mich zwar wer bei NVIDIA für die Benennung der Schlüssel zuständig is, aber der hatte wohl mal wieder Spaß inne Backen...
 

FelixKeyway

Dr. Hacker
Dankeschön, hat geholfen, der Schlüsselnamen passt aber zu gut :D .
 
Anzeige
Oben