Möglichkeiten manueller Windows-Reparatur

Status
Für weitere Antworten geschlossen.

hansjorg71

gehört zum Inventar
Hallo,
DISM /online /cleanup-Image /RestoreHealth

"Dann würde ich DISM Reparaturen allenfalls mit der offline Variante durchführen, also mit der Variation von DISM, bei der die Dateien durch ihre Pendants vom Installationsdatenträger ersetzt werden."

Diese Dism-Befehle gibt es nicht bei Win 7 weder "Online" noch "Offline" ! ;)

Viel besser und aufschlussreich wäre ein Bild von der Datenträgerverwaltung des Win 7 Datenträgers ! :)

Gruß :)
 
Anzeige

Kraftwerk

Gesperrt
Hänge mal nur die win7 HDD an

Boote mit win7 DVD und gehe in die Eingabeaufforderung (DOS - Modus)

Diskpart - Enter

List Disk - enter

List Volume - Enter

Bitte Bild davon. Danke.


Vielen lieben Dank an alle, die inzwischen etwas gepostet haben.
Zu DISM bin ich noch nicht gekommen (vom Zweitsystem aus), werde das aber in Angriff nehmen.

Diskpart hab ich eben gemacht, die Werte lauten wie folgt:

List Disk =
Datengräger 0 Status Online Größe 465GB Frei 2048KB DYN - GPT -

List Volume =
Volume 6 BST E [Name] NTFS Partition 465GB Fehlerfrei Info -

Das war alles, es wurde sonst nichts angezeigt, insbesondere keine Fehler...
 

HerrAbisZ

unbequemer Zeitgenosse
Wo ist Volume 1-5 ?

Ich habe doch um ein Bild gebeten - kannst du uns das nicht lieferen bitte ? Danke.
 

Kraftwerk

Gesperrt
Stimmt, ich kann leider kein Bild machen, da es Dos-Modus und dazu die defekte Windows-Seite ist.
Deshalb hatte ich einfach die Werte gepostet, die mir Diskpart angezeigt hat.

Aber natürlich kann ich vom zweiten System aus dasselbe tun, das habe ich eben gemacht.
Hatte angenommen gehabt, ich müßte dazu unbedingt auf die "defekte" System-HD booten...

Was erhoffst Du Dir denn von dieser Darstellung?
Danke nochmals, Uwe

DiskPart051017.jpg
 

HerrAbisZ

unbequemer Zeitgenosse
Mit dem Handy kannst du kein Foto machen ?

Bitte Bild von Crystal Disk Info Partition E: - Danke

Meiner Meinung nach - nachdem wieder nur die win7 HDD dran hängt folgenden Befehl in die CMD nach booten mit win7 DVD

sfc /scannow /offbootdir=E:\ /offwindir=E:\windows

Eventuelle Fehlermeldungen bitte abfotografieren und posten. Danke.
 

Kraftwerk

Gesperrt
Oje, Du hast natürlich recht, vielen Dank - auf die Handy-Idee wär ich gar nicht gekommen.
Wahrscheinlich weil meines derart alt ist, daß die Fotos, die ich damit machen könnte, nicht gut ankämen bzw. kaum leserlich sind...
Aufgrund Deines Hinweises werde ich nun eine Digitalkamera verwenden, und die Fotos posten sobald ich kann.

Was ich noch gerne wissen würde: was wäre bei Diskpart weiterführend oder nicht gewesen?
Und wie hast Du mein Diskpart-Bild interpretiert?
Frage vor allem, da ich gerne mein Wissen erweitern würde...

P.S.: Von der fraglichen HD habe ich auf Seite 1 bereits ein CrystalDiskInfo-Bild gepostet.
Oder vielleicht verstehe ich etwas nicht richtig?
Danke jedenfalls für Deine Hilfe...
 

HerrAbisZ

unbequemer Zeitgenosse
Ok anscheindend hat sich bei der Darstellung in CDI etwas geändert - früher waren alle Partitionen sichtbar in einer der oberen Zeilen

Diskpart brauche ich um die LW bzw. Partitionsbuchstaben zu sehen - damit ich die CMD Befehle anpassen kann.
 

Ari45

gehört zum Inventar
@HerrAbisZ, die Laufwerkszeile wird auch heute noch angezeigt.
CrystalDiskInfo_Laufwerke.jpg

ot:
Übrigens, das Bild ist ein gutes Beispiel, wie man eine "defekte" HDD wieder benutzbar macht.
Ich hatte vor etwa 1 oder 1,5 Jahren auf diesem hier gezeigten Laufwerk einen "schwebenden Sektor". Dann habe ich die HDD leer geräumt, eine ausführliche Formatierung gemacht und wieder benutzt für "Windows 7" und "Windows 7 Daten" (ist sowieso nur zum Experimentieren).
Der "schwebende Sektor" ist in einen "wieder zugewiesenen Sektor" gewandelt worden. Seitdem keine neuen "schwebenden Sektoren" mehr.
Natürlich kontrolliere ich so etwa aller Vierteljahre mit CrystalDiskInfo.
 

hansjorg71

gehört zum Inventar
@Kraftwerk,
Viel besser und aufschlussreich wäre ein Bild von der Datenträgerverwaltung des Win 7 Datenträgers ! :)

ist so ein Bild ein Problem für dich ? ;)

eventuell ist das "Aktiv" nicht auf der Partition E: denn nur damit könnte eine Startreparation funktionieren ! :)

Gruß :)
Ps. hast du eigentlich die beiden Systeme (Win 7 + Win 8 ) im Multiboot betrieben oder sind diese Systeme komplett einzelsysteme wo du im Bootmanager das jeweilige System (HDD ) auswählst und startest ?? ;)
Das Laufwerk mit dem Win 7 hat nur eine Partition E: also sollte diese Partition aktiv sein !
 

HerrAbisZ

unbequemer Zeitgenosse
@Ari45: Ich habe es auch versucht wieder und es wird bei mir auch mit allen Partitionen angezeigt

Im Gegenteil dazu Anhang 169142 von Kraftwerk in Post #21
 

Ari45

gehört zum Inventar
Hallo @HerrAbisZ!
Zitat aus #16
... beim Hochfahren wurden die von HD2 aus gefundenen Fehler auf HD1 einfach (leider) automatisch "korrigiert", danach lief HD1 nicht mehr.
Mein Win7-System wurde also vom Win8-System aus "kaputtrepariert"...
Wenn nur noch die HD2 erkannt wird, also nur eine HDD, wird wahrscheinlich die Laufwerkszeile unterdrückt. Denke ich mir so :ROFLMAO:
 
M

makodako

Gast
Meiner Meinung nach ist folgendes passiert:
Es gab HD1 mit Betriebssystem WIN7, bootbar.
Es gab HD2 mit Betriebssystem WIN8, bootbar.
Dann wurde von WIN8 aus WIN7 "kaputt repariert", heißt für mich HD1 ist noch da ( Laufwerk E: ) aber nur noch als Datenträger.
 

Kraftwerk

Gesperrt
Leute, ihr seid echt Klasse! Erstmal vielen Dank für die vielen guten Gedanken zu meinem Problem!
Zu den neueren Posts nun meine Antworten, ich hoffe, ich drücke mich einigermaßen richtig oder verständlich aus:

@A-Z (Post28): Danke für die Erklärung.

@Aribert (Post29): Danke für den Hinweis zur regelmäßigen CD-HD-Kontrolle. Wie genau machst Du das?
Ich meine: ich hatte bislang CD-Info nicht für so besonders gehalten, aber ich kann mir durch Deinen Post vorstellen, daß es tatsächlich wichtiger ist, es regelmäßig zu nutzen, als ich dachte. Wenn ich Dich richtig verstehe, reagierst Du dann nur Warnhinweise - oder gibt es noch anderes, woran Du Handlungsbedarf festmachst? (Frage nur sicherheitshalber nach...)

@Hansjörg (Post30): Nein, ein Bild ist kein Problem für mich, nur hatte ich nicht auf der Gehirnfestplatte, daß es ja ganz einfach wäre, einfach mit einem Fotoapparat eines zu machen. Komisch, daß ich nicht selbst auf die Idee gekommen bin, da ich sonst eben immer Screencopies machte...:)
Beide Festplatten sind völlig unabhängig voneinander, nach wie vor. Ich wähle sie ausschließlich übers BIOS aus, d.h. normalerweise läuft der Rechner immer nur auf einer HD. Bislang war er ständig (übers Bios) eingestellt auf Win7-HD. Erst als dort Windows nicht mehr weitergeladen hat als bis zur Fehlerkorrektur (!) habe ich umgestellt (im Bios) auf Win8, und arbeite seitdem dort. Genau dafür war es auch gedacht gewesen, das System so einzurichten, da ich 2001 schonmal einen ähnlichen Crash mit WinXP hatte.
Seitdem verwende ich auch grundsätzlich keine Partitionen mehr, d.h. meine HD's sind immer in voller Größe in Verwendung, und werden nicht aufgeteilt. Das war damals die Lehre, die ich aus dem 2001er-Crash gezogen habe, und dieser Win7-Untergang, den ich jetzt erleben mußte, ist eigentlich der erste seitdem, bei dem ich diesmal zwar zum Glück keine Daten verloren habe, dafür aber ein funktionierendes Betriebssystem. Die Win7-HD bootet übrigens nach wie vor problemlos hoch, nur eben bis zur Win7-Reparaturkonsole, und nicht weiter. Alle dortigen Optionen bleiben auch nach wie vor ohne Erfolg - es funktioniert nichts mehr.
Es werden also nach wie vor beide Festplatten erkannt, und mittlerweile kann ich auch wieder auf die Daten der Win7-HD zugreifen, denn nach dem "Kaputtreparieren" gab's dort ein massives Rechteproblem. Durch Neuvergabe der Rechte von Win8 aus konnten alle dortigen Daten kopiert und somit gerettet werden. (Diese kamen auf eine Offline-HD, so wie regelmäßig bei mir.)

@Makodako (Post34): Du hast es sehr genau gesagt, besser könnte ich es auch nicht darstellen. Danke dafür.
Es ist, um es nochmals klar zu sagen, so, daß bei mir immer ALLE Festplatten angezeigt wurden und werden, das war nicht das Problem. Das Problem ist, daß die Win7-HD zwar erstmal ganz normal anfängt zu booten, wie bisher auch, daß aber dann nicht Windows normal hochfährt, sondern die Ladezeile erstmal nach Vista aussieht (mit dem Ladebalken und den grünen beweglichen Strichen darin) und dann werden wie im Dos-Modus Dateien geladen, und schließlich lande ich auf der Reparaturseite.
Wie gesagt: alle beiden HDs, um die es hier geht, sind völlig autonom und autark, also total unabhängig voneinander, und beide HDs sind nicht partitioniert, d.h. ich meine damit, keine der beiden wurde unterteilt, beide werden jeweils in voller Größe genutzt.
 

Ari45

gehört zum Inventar
@Kraftwerk
Zu #35
Die regelmäßige Kontrolle mit CrystalDiskInfo mache ich natürlich nur, weil ich eine HDD in Betrieb habe, die schon mal "schwebende Sektoren" hatte.
Wenn man das nicht hat, brauch man eine Überprüfung der HDD nur machen, wenn es Fehlermeldungen oder Abstürze gibt, die sich mit einem Datenträger in Verbindung bringen lassen.
Ohne konkreten Verdacht reicht meiner Meinung nach einmal im Jahr.
 

Kraftwerk

Gesperrt
@Aribert:
Danke für Deine hilfreiche Antwort, jetzt verstehe ich es.
Welches Bild fehlt denn meinerseits noch? Ich habe, dachte ich, alles geliefert, was verlangt war?
Oder, anders gesagt: alle Informationen, die notwendig sind, wurden doch meinerseits schon angegeben, oder etwa nicht?
Irgendwie habe ich aber auch in letzter Zeit den Eindruck, daß auf etwas fokussiert wird, was mir wenig weiterzuhelfen scheint.
 
Zuletzt bearbeitet von einem Moderator:

Ari45

gehört zum Inventar
Es geht um den Screenshot von der Datenträgerverwaltung, der in #22 von @hansjorg71 erbeten wurde.
Dieser Screenshot hilft uns sicher besser, als Discpart (zumindest in dieser Situation).
Bitte das Fenster vor dem Screenshot so groß aufziehen, dass alles zu sehen.
 
Zuletzt bearbeitet von einem Moderator:
M

makodako

Gast
Da sieht man mal wieder zu was Missverständnisse führen.
Meiner Meinung nach ist die Bootpartion von WIN7 defekt, daher wird zwar gebootet aber eben nicht komplett. Mein Vorschlag HD2 abklemmen und den Bootsektor von HD1 reparieren. Versuch macht kluch.

Nur wenn man miteinander kommuniziert, kann man Missverständnisse ausräumen. Ein Sorry hat noch keinem wehgetan.
 
Zuletzt bearbeitet von einem Moderator:

hansjorg71

gehört zum Inventar
Hallo,
Das Problem ist, daß die Win7-HD zwar erstmal ganz normal anfängt zu booten, wie bisher auch, daß aber dann nicht Windows normal hochfährt, sondern die Ladezeile erstmal nach Vista aussieht (mit dem Ladebalken und den grünen beweglichen Strichen darin)

da ist der Bootloader von Win7 falsch !
wenn du dies probieren willst, ist vielleicht erfolgreich ? ;) Schaue mal im Windows-System32-Verzeichniss der Win 7 ob du dort diese Einträge hast
winload~1.exe bootres~1.dll winlogon~1.exe winlresume~1.exe und ähnliche können gelöscht werden. Es sind Sicherungskopien, welche bei Änderungen angelegt worden sind.

außerdem sollte ein Ordner en-US + de-DE vorhanden sein !;) diese auch im Windows-Verzeichniss !

Wichtig für das korrekte Booten von Win 7 sind folgende : winload.exe.mui winresume.exe.mui winlogon.exe.mui diese befinden sich Windows>System32>de-DE und en-US

bootres.dll . winload.exe winlogon.exe winresume.exe diese im Windows>System32

am besten wenn du diese Dateien von einem anderen funktionierendem Win 7-System kopierst und in deinem defekten Win 7 (Windows-Verzeichniss ) ersetzt ! :)

ob das ersetzen mit dem Win 8 funktioniert musst du probieren, wenn nicht eineLinux, Ubuntu dvd benützen !

Gruß :)
 
Zuletzt bearbeitet:

Wolfgang

Moderator
Teammitglied
@Aribert:
Danke für Deine hilfreiche Antwort, jetzt verstehe ich es.
Welches Bild fehlt denn meinerseits noch? Ich habe, dachte ich, alles geliefert, was verlangt war?
Oder, anders gesagt: alle Informationen, die notwendig sind, wurden doch meinerseits schon angegeben, oder etwa nicht?
Irgendwie habe ich aber auch in letzter Zeit den Eindruck, daß auf etwas fokussiert wird, was mir wenig weiterzuhelfen scheint.

@Kraftwerk

Ich möchte hier einmal ganz deutlich sagen:
Ponderosa hat nicht aus purer Langeweile nach den Bildern gefragt. Ein Bild sagt mehr als 1000 Worte. Schon in Post #22 wurdest du gebeten einen Screenshot der Datenträgerverwaltung zu liefern. Das ist bis jetzt nicht geschehen. Wenn dann vierzehn Posts später danach gefragt wird ist das doch wohl legitim.
Deshalb musst du nicht jemanden, der dir helfen will, der für dich seine Freizeit opfert, der sich Gedanken zu deinem Problem macht, nicht in dieser rüden Art und Weise angehen.
Man kann anderer Meinung sein und auch kritisieren, aber dann bitte in einem vernünftigen Ton. Wir sind hier in der Regel erwachsene Menschen und haben in der Regel auch eine gute Kinderstube genossen. Insofern hast du nicht mal im Ansatz das Recht, hier in dem Tonfall so rum zu tönen und irgendjemand anderen so zu attackieren.
Entweder du formulierst es sachlich oder du bleibst bitte leise. Danke.
 
Zuletzt bearbeitet von einem Moderator:
Status
Für weitere Antworten geschlossen.
Oben