Anzeige

Am Puls von Microsoft

[gelöst] Microsoft zeigt unsichere TLS Verbindung an - Wie kann ich das Problem beheben?

lukasaz1999

Moderator
Teammitglied
Liebe Community,

ich schlage mich seit einiger Zeit mit einem Problem herum, welches ich mit Microsoft Edge habe.

Und zwar habe ich das Problem, dass beim Aufrufen von verschiedenen Seiten anzeigt wird, dass
die TLS-Verbindung unsicher sein soll.

Ich benutze Windows 10 in der Version 1703 mit der Build (15063.413) und Edge in der Version
40.15063.0.0 .

Was kann ich machen, damit dieser Fehler nicht mehr auftritt?

Ich habe das Problem bei vielen Webseiten und so langsam geht es dann doch auf die Nerven.

Gruß Lukas Z.
 
Anzeige

build10240

gehört zum Inventar
Hast Du mal ein Beispiel für eine solche Webseite? Tritt das auch mit anderen Browsern auf? Meine erste Vermutung wäre ein Virenscanner oder andere Sicherheitsoftware, die sich in die verschlüsselte Verbindung zwischen Webseite und Browser hackt, um die gesendeten Daten auf Malware zu überprüfen. Möglich wäre auch ein Problem durch andere Tools aus dem Bereich Netzwerk.

Zweite Vermutung wäre Malware, insbesondere Adware. Dazu könntest Du mal einen Scan mit AdwCleaner https://toolslib.net/downloads/viewdownload/1-adwcleaner/ und dem Junkware Removal Tool https://de.malwarebytes.com/junkwareremovaltool/ durchführen und die Protokolle hier hochladen. Auch ein Scan mit einem zusätzlichen Virenscanner wie Malwarebytes ist nicht verkehrt.
 

lukasaz1999

Moderator
Teammitglied
Mein Windows 10 ist momentan auch wieder auf dem aktuellsten Stand. Ich habe den Text vorgeschrieben und bin grad eben erst dazu gekommen ihn hier zu posten. Als ich den Text verfasst habe, war eben diese Version aktuell und ich habe grad eben vergessen, dies zu ändern. Nun bin ich mit der aktuellsten Version .447 unterwegs.

Ich habe grad eben in den Internetoptionen geguckt, dort sind TLS 1.0, 1.1 und 1.2 gelistet und auch aktiviert.

Als Virenscanner kommt bei mir der Windows Defender zum Einsatz.

Einen Scan mit dem ADW Cleaner habe ich grad eben auch gemacht, dieser wurde mit der Meldung beendet, dass kein Schadprogramm auf dem PC zu finden sei.

Einen Scan mit dem Junkware Removal Tool habe ich auch gemacht, der Log sieht so aus:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Junkware Removal Tool (JRT) by Malwarebytes
Version: 8.1.3 (04.10.2017)
Operating System: Windows 10 Home x64
Ran by Mein Nutzername (Administrator) on 01.07.2017 at 10:52:47,45
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~




File System: 0




Registry: 0





~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Scan was completed on 01.07.2017 at 10:54:10,50
End of JRT log
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
 

lukasaz1999

Moderator
Teammitglied
Es ist halt rein zufällig. Mal tritt es hier bei DrWindows auf, mal bei WinFuture, mal bei YouTube. Es ist ein ziemliches Lotteriespiel und kann mehr oder weniger überall auftreten.
 

frankyLE

gehört zum Inventar
von verschiedenen Seiten anzeigt wird, dass
die TLS-Verbindung unsicher sein soll.

Wie sieht diese Meldung aus - von was kommt diese Meldung?

Evtl. mal abwarten und die Meldung erscheint ein Screenshot davon hier einstellen.

Hast du in Edge noch etwas zusätzlich, z.B. Adblocker, installiert?
 

build10240

gehört zum Inventar
Habe gerade mal drwindows.de und auch diverse andere HTTPS-Webseiten aufgerufen. Keine Fehler, überall wird ein graues oder grünes Schloss vor der Adresszeile angezeigt. Hier wäre wirklich mal der Screenshot der Meldung interessant. Tritt das Problem zeitgleich auch im Internet Explorer auf? Wer ist Dein Internetprovider? Befindest Du Dich in einem Netzwerk mit eigenem Router oder wird der vom Provider, Vermieter, etc. gestellt?

Habe mich gerade erstmals mit den Zertifikaten in Edge beschäftigt, weil ich sonst wichtige Webseiten nur im Firefox öffne. Die Informationen, die Edge beim Klick auf das Schloß vor der Adresse liefert, sind vgl. mit anderen Browsern dürftig. Bei drwindows.de steht "Webseitidentifizierung The USERTrust Network TM hat diese Webseite identifiziert als www.drwindows.de. Ihre Verbindung mit dem Server ist verschlüsselt.". Falls dort bei Dir im Edge für Dr. Windows etwas anderes steht, könnte das ein Hinweis auf den Austausch der Zertifikate sein. Während in Firefox detaillierte Infos über das Zertifikat angezeigt werden können, zeigt Edge offenbar nur den Namen der obersten Position in der Zertifkatshierachie, so daß man in Edge nicht viel weiter analysieren kann.
 

sneaker

gehört zum Inventar
Hallo Lukas,

Was kann ich machen, damit dieser Fehler nicht mehr auftritt?
Ich habe das Problem bei vielen Webseiten und so langsam geht es dann doch auf die Nerven.

Vor allem: Homebanking, Bestellungen bei Amazon, etc. würde ich erstmal einstellen!

Die Zertifikatsprüfung geschieht bei Edge/ Iexplore lokal gegen die gespeicherte Liste an vertrauenswürdigen Stammzertifikaten von Microsoft. Daher ist es sehr komisch, wenn das Zertifikat mal akzeptiert wird und dann wieder nicht. Hast du mal an Policies (Stammzertifikate) gedreht?

lg sneaker
 
Zuletzt bearbeitet:

lukasaz1999

Moderator
Teammitglied
@frankyLE
Ich habe noch ein paar Erweiterungen in Edge installiert. Unter anderem AdBlock, OneNote Web Clipper, Turn Off The Lights for Microsoft Edge installiert.

@build10240
Beim Surfen mit dem Edge habe ich auch überall graue oder grüne Schlösser vor der Adresszeile. Mir wird bei einem Klick auf das Schloss auch das gleiche angezeigt, was dir angezeigt wird.

Das Problem tritt auch beim Internet Explorer auf.

Wir sind bei der Telekom.

Soweit ich weiß haben wir einen Router von der Telekom bekommen.

@sneaker
Nicht dass ich wüsste. Da müsste eigentlich alles normal sein.


Hier das wäre die Fehlermeldung, die mir angezeigt wird.

Bild 1.png
 

sneaker

gehört zum Inventar
Hallo Lukas,
Kannst du im Internet Explorer bitte mal gehen auf
-> Internet Options/Internet Einstellungen gehen (ich habs grad nur in English da)
-> Advanced /Erweitert
-> fast ganz unten gibts die Einstellungen für SSL3.0/ TLS1.0/ TLS 1.1/ TLS1.2

wie sieht bei dir SSL 3.0 und TLS1.0 aus?
SSL3.0 gilt als gebrochen. TLS 1.0 gilt als quasi gebrochen, trotzdem wird es noch viel zum Verschlüsseln einer Verbindung verwendet und ist auf den Browsern meist noch aktiviert.
Falls TLS1.0 deaktiviert ist, kann ich deine Beschreibung nachvollziehen.
https://www.winfuture-forum.de/ wirft den Fehler (verwendet TLS1.0)
http://www.winfuture-forum.de/ kein Fehler, da keine Verschlüsselung, Signierung

Beim mir ist TLS1.0 noch aktiv. Vielleicht hat es bei dir ein Schutzprogramm schon deaktiviert.
z.B. https://success.trendmicro.com/solution/1116591-tls-1-0-will-be-disabled-on-march-4-2017

Wenn dem so ist, musst du entscheiden, ob du TLS1.0 wieder aktivierst, damit aber auch potentiell unsichere Verbindungen auf Websites akzeptierst.

lg sneaker
 

lukasaz1999

Moderator
Teammitglied
@sneaker
Ich habe grad eben mal in den Internetoptionen, die man beim Internet Explorer finden kann nachgeguckt. TLS 1.0, 1.1 und 1.2 sind aktiviert. Außerdem ist bei mir SSL 3.0 deaktiviert.
 

sneaker

gehört zum Inventar
Sorry, das war die falsche Richtung!
Es liegt gar nicht an deinem Rechner sondern an der Website selbst.

Capture.PNG
Capture1.PNG

Der Websitebetreiber arbeitet mit einem selfsigned Zertifikat, dem natürlich niemand sonst vertraut. Solange man sich dort kein vernünftiges Zertifkat leisten will, kannst du auch kein https für diese Site nutzen.

Nutze
http://www.winfuture-forum.de/
statt
https://www.winfuture-forum.de/
Der Datenverkehr ist halt nicht geschützt.

Firefox und Chrome lehnen selfsigned Zertifikate genauso ab. Früher haben die Browser ein kleines rotes Schloss angezeigt, aber die Seite trotzdem noch geöffnet. Mittlerweile blockieren sie knallhart.

lg sneaker

Nachtrag:
Capture2.PNG
So sieht das vertrauenswürdige Zertifikat von drwindows aus :)
 
Zuletzt bearbeitet:

lukasaz1999

Moderator
Teammitglied
Und was kann man da jetzt machen. Ich ja den ein oder anderen Webseitenbetreiber mal über das Problem informieren und hoffen, dass es dann geregelt wird.
 
Oben