Anzeige

Am Puls von Microsoft

Anzeige

[gelöst] Net.Tcp Listener Adapter und Net.Tcp Port Sharing Service

Algazanth

treuer Stammgast
Hallo Zusammen

Nun ich habe vorhin schon ein Problem mit dem Spiel The Bureau: XCOM Declassified gepostet und dort geschrieben das ich den neuen Grafikkartentreiber installiere. Das hab ich gemacht.

Nach einem Neustart kam folgendes in der Ereignisanzeige:

1. Meldung:
Das Zeitlimit (30000 ms) wurde beim Verbindungsversuch mit dem Dienst Net.Tcp Port Sharing Service erreicht.

2. Meldung:
Der Dienst "Net.Tcp Port Sharing Service" wurde aufgrund folgenden Fehlers nicht gestartet:
Der Dienst antwortete nicht rechtzeitig auf die Start- oder Steuerungsanforderung.

3. Meldung
Der Dienst "Net.Tcp Listener Adapter" ist vom Dienst "Net.Tcp Port Sharing Service" abhängig, der aufgrund folgenden Fehlers nicht gestartet wurde:
Der Dienst antwortete nicht rechtzeitig auf die Start- oder Steuerungsanforderung.

Habe gelesen das Net.Tcp Port Sharing Service standartmässig von Windows nicht automatisch ist. Nun bisher habe vom Fehler nicht bemerkt. Beide sind in "Dienste" nicht gestartet. Obwohl "Net.Tcp Listener Adapter" auf automatisch steht.

Also bevor die Fehlermeldung kam hab ich den neuen AMD Grafikkartentreiber 13.12 installiert.
Hier steht noch was mit Framework.

Nachtrag: Habe den Computer Heruntergefahren und Neugestartet die Dienste sind nun ausgeführt.
Der Fehler kam wen ich vom Windows aus Neustarten ausführte.

Besten Dank für eure Hilfe.

Grüsse Algazanth
 
Zuletzt bearbeitet:
Anzeige

Algazanth

treuer Stammgast
Immer noch so.

Wen ich den PC normal starte ist alles i.O. Sobald ich haber einen Neustart mache (W-Taste - neu Starten) startet Net.Tcp Listener Adapter nicht, obwohl er auf automatisch steht.

Was könnte das sein?

Edit:

Habe auf der engl. Microsoft Support Seite folgendes gefunden:
Hello, by default, when the application pool recycles, the service host is closed. After the application pool finishes recycling, the service host will not be opened automatically. But when the first client tries to invoke the service, the service host will be opened again. If this is not what you see, can you provide more information? For example, are you using a custom service host factory? In this case, can you try to debug the code to see if something is wrong when trying to create the service host?


So wie ich das lese heisst es, wen der erste Client den PC startet, startet auch der Dienst. Wen aber (zB Neustart) ein neuer Client kommt wird der Dienst standartmässig nicht mehr automatisch gestartet. Oder so in der Art.

Frage mich, wenn das so ist, warum in der Ereignisnazeige ein Fehler ausgespuckt wird?

Die Seite von dem obigen Zitat - Hier
Algazanth
 
Zuletzt bearbeitet:

Algazanth

treuer Stammgast
So habe nun mal was von Microsoft ausprobiert. Habe danach einmal einen Neustart gemacht und es scheint zu funktionieren.

1. Systemsteuerung / Programme und Funktionen
2. Microsoft .NET Framework 4.5.1 auswählen
3. Auf obige Schaltfläche Deinstallieren / ändern
4. Beim darauf folgende Fenster auf
" .NET Framework 4.5.1 reparieren und ursprünglichen Zustand wiederherstellen."
5. Fertig.

Schein mal gelöst zu sein obwohl ich nicht ganz sicher bin.

Algazanth
 

Algazanth

treuer Stammgast
Eine weitere Möglichkeit ist das Microsoft .NET Framework Repair Tool auf Download und dann NetFxRepairTool.exe auswählen, wer will noch die RTF Datei.

Das Tool sucht erst nach Fehler und ersetzt sie wen möglich. Bei einigen Hilfeseiten wurde immer wieder von
Microsoft .NET Framework 4 Clien Profil gesprochen, seltsamerweise fand ich nix bei mir. Das Tool hat es nach Installiert und bisher läuft es wieder.

Setzte das Thema mal als gelöst, da es momentan so scheint als ob es in Ordnung wäre.

Grüsse Algazanth
 
Anzeige
Oben