Anzeige

Am Puls von Microsoft

Anzeige

[gelöst] Num-Lock Taste deaktiviert sich dauernd ungefragt von selbst

Dose

gehört zum Inventar
Hallo Forum,

bei dem Laptop, das ich kürzlich für meinen Bruder gekauft habe (Windows 7 Home Premium 64Bit, extra Nummernblock) deaktiviert sich die besagte Taste/Funktion regelmäßig von selbst - sprich wenn man den Nummernblock zur Eingabe von Zahlen nutzen will, muss man mindestens alle 5 Minuten die Num Taste drücken - sehr kurios, habe sowas noch nie erlebt. Woran kann das liegen und wie stelle ich das ab? Am besten, der Ziffernblock wäre immer eingeschaltet.

Danke!
 
Anzeige

Dose

gehört zum Inventar
Danke, werde es morgen gleich ausprobieren und berichten; habe den Laptop jetzt nicht hier.
 

yellow

Moderator
Teammitglied
Hallo Dose:)
ist sie denn per Bios auch aktiviert ?
bei meinem Notebook habe ich diese Option im Bios:)
 

Adelheid71

fühlt sich gut aufgehoben
Hallo.

Ich hoffe, ich darf mich hier ranhängen?
Gibt es hierfür auch schon eine Lösung für Windows 8? Habe alles mir bekannte und im Netz gefundene durch, aber nix hilft.

Es handelt sich um die Rechner aus meiner Signatur, wobei der PC bis vor Kurzem noch Win7 Home Premium hatte und da war noch alles OK. Beim Notebook funktioniert das schon seit dem Kauf Mitte/Ende Januar 2013 nicht.

Das habe ich bisher konkret an meinem PC (Notebook nur teilweise) festgestellt bzw. ausprobiert:

Das Problem besteht seit dem Upgrade auf Win 8 Pro (64bit), dass der Nummernblock der Tastatur nicht dauerhaft aktiviert bleibt.

Beim starten leuchtet das Lämpchen auf der Tastatur für den Nummernblock noch und kurz bevor der 1. Startbildschirm erscheint (den ich dann wegklicken muss, um mich anmelden zu können) geht die Lampe aus und der Nummernblock ist deaktiviert. Sehr nervig, wenn ich mein Passwort eingeben möchte, welches auch Zahlen enthält.

Einstellung im BIOS ist aktiviert und somit habe ich folgendes probiert.

Mein Eintrag in der Registry:

Code:
Windows Registry Editor Version 5.00

[HKEY_USERS\.DEFAULT\Control Panel\Keyboard]
"KeyboardSpeed"="31"
"InitialKeyboardIndicators"="2147483648"
"KeyboardDelay"="1"

Geändert in:

Code:
Windows Registry Editor Version 5.00

[HKEY_USERS\.DEFAULT\Control Panel\Keyboard]
"KeyboardSpeed"="31"
"InitialKeyboardIndicators"="2147483650"
"KeyboardDelay"="1"

Und auch getestet mit:

Code:
Windows Registry Editor Version 5.00

[HKEY_USERS\.DEFAULT\Control Panel\Keyboard]
"KeyboardSpeed"="31"
"InitialKeyboardIndicators"="2"
"KeyboardDelay"="1"

Leider sind beide Möglichkeiten fehlgeschlagen, so dass der Nummernblock auch weiterhin deaktiviert wird, wenn ich den Rechner heruntergefahren und über meine Steckerleiste mit Ein-/Ausschalter vom Stromnetz getrennt habe.

Mir wurde nun geraten, dies über Scancode Map zu lösen, aber ich traue mich da nicht so recht ran, da ich davon recht wenig Ahnung habe und zudem der Ansicht bin, dass das so ja eigentlich nicht im Sinne des Erfinders sein kann oder?

Danke für die Unterstützung.
 
Zuletzt bearbeitet:

McC.

gehört zum Inventar
...schau mal im BIOS nach , dort gibt es eine Einstellung , die NumLock-Taste betreffend . ( die genaue Bezeichnung kann je nach BIOS etwas anders lauten , z.B. : ''Num Lock State at Bootup'' oder ''Num Lock After Boot'' ...

p.s. : es geht doch um deinen PC ? oder um das Notebook ??

mfg McC.
 

hansjorg71

gehört zum Inventar
Hallo, du musst in der Registry bei beiden Einträgen die "2" eintragen ! ( Wichtig ist Hkey-Current-User ) :)

Hkey_Current_User\Control Panel\Keyboard
InitialKeyboardIndicators = 2

HKEY_USERS\.DEFAULT\Control Panel\Keyboard
InitialKeyboardIndicators = 2
sollte aber auch mit dieser Einstellung funktionieren !
InitialKeyboardIndicators = 2147483648

Gruß :)
 

Adelheid71

fühlt sich gut aufgehoben
Hier geht es um meinen PC und das im ersten Beitrag habe ich alles schon durchprobiert, leider ohne Erfolg.
Laut BIOS ist die NumLock-Taste aktiviert, aber ich schaue nochmal nach.
Wie gesagt habe ich das Problem erst seit dem Upgrade auf Windows 8.

Beim Notebook habe ich selbiges Problem, aber noch nicht alles durchgetestet, denn da stört es mich nicht soooooooo sehr, da ich mich (im Normalfall) via FingerPrint anmelde, aber ich hätte doch gerne, dass es auch da klappt und ich den Ziffernblock nicht immer erst manuell aktivieren muss. Allerdings kann ich hier nicht mehr sagen, ob es schon vor dem Upgrade von Windows 8 auf Windows 8 Pro so gewesen ist.

Hier meine Einstellungen laut Registry:

Snap_2013.02.17_004.jpg

Snap_2013.02.17_005.jpg
 

Adelheid71

fühlt sich gut aufgehoben
Hier dann mal ein (recht schlechtes) Handy-Bild von den BIOS-Einstellungen, ich hoffe, es ist einigermaßen erkennbar:

20130217_205504.jpg

Mehr konnte ich bezüglich des NumLock leider nicht finden.
 

hansjorg71

gehört zum Inventar
Hallo, dann nimm mal ein anderes Keyboard , hatte ich auch bei meinem Win 7 mit Keyboard Siemens/Nixdorf PS2 Anschluss hat Jahrelang funktioniert und immer noch, aber nicht bei Win 8 ! :ROFLMAO:

Gruß :)
 

Adelheid71

fühlt sich gut aufgehoben
Danke für den Tipp. Werde ich natürlich versuchen.
Wobei das ein echter Hammer (und fast schon eine bodenlose Frechheit) wäre, denn die betroffene USB-Tastatur von MEDION ist nicht mal ein Jahr alt und zuvor hat sie an genau diesem Rechner mit Win7 noch einwandfrei funktioniert und da gab es dieses Problem nicht. Zumal ich ja auch sehen kann (über die NumLock-Lampe an der Tastatur), dass der Nummernblock bis zum erscheinen des 1. Anmeldebildschirms noch aktiviert ist und dann von "irgendetwas" ausgeschaltet wird.

Langsam komme ich mir von Microsoft echt verschaukelt vor und mag mir gar nicht vorstellen, wie z.B. ältere Menschen mit dieser Problematik umgehen mögen (n)
 
R

Rheinhold

Gast
Dann probier mal noch folgendes.
Starte die Systemsteuerung, gehe zu "Erleichterte Bedienung", dann "Funktionsweise der Tastatur ändern" und setze dort den Haken bei "Texteingabe erleichtern - Umschalttasten aktivieren".

Hast du einen Tastaturtreiber installiert?
Den mal löschen und den Windows Standard verwenden.
 

Adelheid71

fühlt sich gut aufgehoben
Hmmm, habe gerade mal geschaut und da waren 2 Geräte unter "Tastaturen" zu finden, siehe ScreenShots.
Habe beide Geräte deinstalliert, die sich dann aber beide wieder automatisch neu installierten?!
Sieht für mich so aus als seien dies Microsoft-Treiber?

Snap_2013.02.19_009.jpg

Snap_2013.02.19_007.jpg

Snap_2013.02.19_008.jpg

Werde nun noch deinen Tipp bzgl. der Tastatur-Einstellung über die Systemsteuerung testen und dann berichten.
 

Adelheid71

fühlt sich gut aufgehoben
Dann probier mal noch folgendes.
Starte die Systemsteuerung, gehe zu "Erleichterte Bedienung", dann "Funktionsweise der Tastatur ändern" und setze dort den Haken bei "Texteingabe erleichtern - Umschalttasten aktivieren".

Das hat leider nicht "gefruchtet" :cry: Nummernblock wird also auch trotz Änderung der Einstellung kurz vor dem 1. Anmeldebildschirm deaktiviert.

PS:
Sollte ich vielleicht ein neues Thema dazu eröffnen, da dieses als "gelöst" markiert wurde?
 

hansjorg71

gehört zum Inventar
Hallo, gehe mal in die Registry und mache von folgendem Eintrag ein Bild !
Hkey-Local-Machine/System/CurrentControlSet/Enum/USB

Dort wird alles Angezeigt was an den USB`s angeschlossen ist, mit der VID+PID kann genau festgestellt werden welche Geräte es sind ! ;)
Es wundert mich das du zwei HID-Keyboards hast. :)

Gruß :)
 

Marco1976

Bin (fast) immer da
@Adelheid: Schau mal bei den Lenovotreiber für Dein Läppi Lenovo Support - Treiber und Software herunterladen (DE) unter "Software und Utility", da gibts nen Win8 64Bit-Treiber für Hotkey Features Integration for Windows 8(64-bit), 7(32-bit, 64-bit), XP - Notebook; möglich ist, dass durch die Upgraderei der Win7-Treiber (ist anscheinend identisch) durch nen Win8-Standard-Treiber ersetzt wurde.

Warum in Deinem Gerätemanager 2 Tastaturen drin sind, weiß ich auch nicht, möglich, dass die eine eben die normale ist und die zweite eben der Zahlenblock.

Für Deinen Standrechner, die Treiber auf der CSL-Seite sind für den A..., da müsste man wissen, was das wirklich für einer ist, denn den 5756 gibt's da nicht.
 

Adelheid71

fühlt sich gut aufgehoben
@hansjorg71:
Mache ich am Wochenende (y)

@Marco1976:
Hier geht es gerade (noch) NICHT um das Notebook, sondern um meinen PC ;)

Das mit dem "Hotkey Features Integration for Windows 8(64-bit), 7(32-bit, 64-bit), XP - Notebook" hatte ttoelle66 (wegen meines Lenovo NB) ja schon gepostet, aber das habe ich bisher leider noch nicht testen können.

Hmmm, wonach genau soll ich denn bei dem CSL-PC schauen? Ist ja ein "Eigenmarke-Gerät" und trägt somit nur den CSL-Namen.

Warum 2 Treiber/Tastaturen da sind, weiß ich auch nicht. Hatte beide schon mehrfach deinstalliert, aber die installieren sich automatisch kurz danach wieder?!

Nur noch mal zum Verständnis, da es anscheinend etwas Verwirrung auslöst:

Lenovo Notebook => ausgeliefert mit Win8 (Core) 64bit => durch Upgrade jetzt Win8 Pro 64bit mit WMC

CSL PC => ausgeliefert mit Win7 (Home Premium) 64bit => durch Upgrade jetzt Win8 Pro 64bit mit WMC
 

McC.

gehört zum Inventar
Hmmm, wonach genau soll ich denn bei dem CSL-PC schauen? Ist ja ein "Eigenmarke-Gerät" und trägt somit nur den CSL-Namen.

lese z.B. mit ''Speccy'' (das Programm hast du ja ) die Bezeichnung der Hardwarekomponenten (Mainboard , Grafikkarte u.s.w.) aus und suche dann bei den Herstellern der Komponenten nach den aktuellen Treibern für WIN8 .

mfg McC.
 
Anzeige
Oben