Anzeige

Am Puls von Microsoft

Anzeige

Ordner nicht untergeordnet an die Taskleiste anheften

Firefox95

gehört zum Inventar
In Windows 7 kann man Programme einfach an die Taskleiste hängen, indem man
die Vernüpfung an die Taskleiste zieht. Bei Ordnern funktioniert das schon
nicht mehr, da diese gleich an das Explorer-Symbol angehängt werden und man
somit erst einen Rechtsklick auf das Explorer-Symbol machen muss, was ich
extrem nervig finde. Mit folgender Anleitung kann man es umgehen.

Bei normalen Ordnern, die auf einer Festplatte vorhanden sind, ist es noch ganz einfach.

Man muss einfach nur einen Rechtsklick auf einen freien Desktopbereich
machen und über "Neu" eine Verknüpfung erstellen. Hier kann man dann einfach
den Pfad eintragen, wo sich der Ordner befindet. Zum Beispiel "Z:\Musik\.
Danach der Verknüpfung noch einen Namen geben und erstellen.
Bevor man diese anheftet, kann man natürlich noch über Rechtsklick -> Eigenschaften ->
Anderes Symbol das Symbol der Verknüpfung ändern.
Diese zieht man dann in ein leeres Feld in der Superbar.

088w5.jpg


Nur bei Ordnern, die keinen sichtbaren Pfad haben (z.B. Computer, Systemsteuerung,...),
wird es schon schwieriger.
Zunächst öffnet man den gewünschten Ordner. Dann klickt man mit der rechten
Maustaste oben in der Adressleiste auf das Symbol und dann auf "Adresse kopieren".

1zegz.jpg


Nun geht man wieder zum Desktop zurück und erstellt wieder eine neue
Verknüpfung.

2vd84.jpg


Hier fügt man nun als erstes die eben in die Zwischenablage kopierte Adresse
ein.

3vex4.jpg

(Diese Adresse ist für "Computer")

Nur muss man hier noch eine Kleinigkeit ändern. Die Adresse heißt jetzt
Computer"::{20D04FE0-3AEA-1069-A2D8-08002B30309D}".
Nur würde Windows dieses Element nicht finden. Also ändern wir die Adresse in
explorer.exe shell :::{20D04FE0-3AEA-1069-A2D8-08002B30309D}.

4jfgs.jpg


Man muss aus der Adresse alles löschen bis auf die Doppelpunkte, die Klammern
und den Code. Wichtig ist auch dass man die "" entfernt. Jetzt einfach noch
explorer.exe shell:
davorschreiben und auf "Weiter" klicken. Hier der Verknüpfung noch einen
Namen geben und sie erstellen.

5cfg8.jpg


Nachdem man sie an die Taskleiste geheftet hat, kann man sie vom Desktop
löschen. Natürlich kann man auch hier das Symbol ändern. Einfach mit gedrückter
Shift-Taste einen Rechtsklick auf die angehängte Verknüpfung machen und
dann auf Eigenschaften -> Symbol ändern.


Es ist auch möglich die Startseite des Explorers zu verändern. Wenn man auf
das Explorer-Symbol klickt, erscheinen normalerweise die Bibliotheken. Um dies
zu verändern klickt man mit der rechten Maustaste auf das Explorer-Symbol
in der Taskleiste und nochmal mit der Rechten auf "Windows-Explorer". Hier
dann auf Eigenschaften.

62ctc.jpg


Nun kann man unter "Ziel" die jeweilige Adresse eingeben. Da bei mir "Computer"
der meist geöffnete Ordner ist, habe ich einfach
explorer.exe shell:::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
eingefügt und mit OK bestätigt.

75fmx.jpg



Sollte das Anheften nicht funktionieren, könnte das daran liegen, dass ein
Registry-Eintrag verändert wurde. Gehen Sie auf "Start -> Alle Programme ->
Zubehör -> Ausführen" und geben Sie dort "regedit" ein. Suchen Sie dann
den Ordner
HKEY_CLASSES_ROOT/lnkfile und gucken, ob da ein Eintrag ist, der
"AriochIsShortcut" heißt, ist. Wenn ja, tun Sie diesen umbenennen in "IsShortcut" und starten Sie den PC neu.

Hinweis für alle die, die ewig lang die Registry durchsucht haben,
aber doch nichts gefunden haben. Der erste Buchstabe in dem Wort lnkfile
ist ein kleines L und kein großes I. ;)
 
Zuletzt bearbeitet von einem Moderator:
Anzeige
Computer-Ordner an Taskleiste anheften

Hallo Firefox95,

Hatte heute gerade dieses Problem und danke für den ausführlichen Beitrag dazu. Ich hab auch alles soweit nachvollziehen können, bin aber mit dem Ergebnis noch nicht ganz zufrieden.
Wenn ich den Link dann benutze, öffnet sich der Computer-Ordner nicht so, wie es orginal mit der Laufwerksansicht aussieht. Genau das war aber mein Anliegen. Es öffnet sich zwar der gesamte Arbeitsplatz, aber bei mir z.B. mit dem Inhalt der Favoriten und um die Laufwerksansicht zu bekommen, muß man dann erst wieder auf den Ordner Computer klicken.
Ich weiß, daß das jetzt etwas zu pedantisch anmutet, aber ist es irgendwie möglich, diesen Link in der Taskleiste so zu erzeugen, daß die Laufwerksansicht gleich so erscheint, wie unter << Start ->Computer >> ?

Danke für die Hilfe, Gruß John
 
Hallo John,
verstehe jetzt leider nicht genau, was du meinst. Mach am besten mal einen Screenshot und poste ihn hier. Bei mir sieht der Ordner ganz normal aus.
Einfach als Pfad:
explorer.exe shell: ::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
eingeben.
 
Hallo FireFox95,

danke erstmal für die Rückfrage! Hab den Link genauso, wie Du in der Anleitung beschrieben hast in der Taskleiste erzeugt. Er funktioniert auch wunderbar, bis auf das der Focus im geöffneten Ordner nicht auf Computer steht, sondern wie bei Windows eben üblich auf dem obersten Inhalt. Das ist bei mir Favoriten.
Wie schon gesagt, ist etwas pedantisch, denn mein Wunsch ist dann nur noch einen Click auf Computer entfernt. Aber da nun mal die Faulheit die eigentliche Triebkraft aller Weiterentwicklung auch bei mir ist ;), frag ich nur, obs da auch eine Möglichkeit gibt, die Laufwerksübersicht gleich beim Click auf den Link "Computer" zu bekommen.
Hab im Anhang einen Screenshot mit dem Vergleich der beiden Ordneransichten angehängt ( links der von dem neuen Taskleistenlink, rechts der übliche über Start->Computer). Ich meine, der übers Startmenü kann doch auch nur ein Link sein, oder? Gibt es da vielleicht noch irgendwelche Übergabeparameter, die dann gleich auf die Laufwerksanzeige führen ?

( übrigens auch noch mein Kompliment über Eure Webseitenprogrammierung, hab trotz Neuling und meinem schwierigen IT-Alter den Anhang auf Anhieb hinbekommen, woanders nicht unbedingt üblich ! )

Danke im Voraus für die Hilfe, viele Grüße,

John
 

Anhänge

  • Vergleich Computer-Ordner.PNG
    Vergleich Computer-Ordner.PNG
    287,2 KB · Aufrufe: 789
Ich vermute einfach mal, dass du nur den falschen Pfad angegeben hast. Wenn du natürlich nur "explorer.exe shell" eingibst, bekomm ich auch nur "Dokumente" angezeigt. Schreib am besten mal hier, was du als Pfad angegeben hast. Im Post davor hab ich scon die Adresse für "Computer" angegeben. Hast du genau diese eingefügt?

Falls es dann immer noch nicht geht, geh mal auf die Eigenschaften der Verknüpfung und gib unter Ziel:
C:\Windows\explorer.exe shell:::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
ein.
 
Lösung wie meißtens: das problem sitzt vor dem Rechner!

Hallo FireFox95,

Du hattest Recht! hatte zwar das Verknüpfungsziel vollständig eingegeben, aber fälschlicherweise ein Leerzeichen hinter explorer.exe schell vor den Doppelpunkten :eek:. Ließ sich schlecht kontrollieren, da das Windowsfenster die Zeile nicht vollständig anzeigt (s. Anhang ).

vielen Dank für die schnelle Hilfe !

bis zum nächsten Problem

John
 

Anhänge

  • Eigenschaften von Computer.PNG
    Eigenschaften von Computer.PNG
    132,2 KB · Aufrufe: 663
Anzeige
Oben