Anzeige

Am Puls von Microsoft

Anzeige

Ordner umbenennen geht nicht - dieser Patch hilft

dmx

Erster Beitrag
Echt Super Arbeit nach ca. 6monaten habe ich endlich eine sorge weniger beim arbeiten^^
 
Anzeige

AESW

Erster Beitrag
Yo von mir auch fettes thx für den patch. hab schon fast die Hoffnung aufgegeben aber nun funzt allet wieder
 

Speed Pete

Herzlich willkommen
Hallo zusammen!

Wer kann mir noch helfen? Der Patch hilft bei mir nicht. Ebensowenig einige andere Registry-Patches die ich gefunden habe wie zB FD32.reg. Ich finde per Google massenhaft zu dem Problem - teils exakt wie bei mir, teils in Varianten. Vielen hilft solch ein Patch, aber vielen auch nicht. Eine Lösung konnte ich bislang für mich nicht finden.

Das genau Symptom:
- ich lege zB auf D:\ per Rechtsklick->neuer Ordner einen neuen Ordner an
- Vorgegeben ist der Name "Neuer Ordner", der sogleich zum Überschreiben markiert wird.
- Egal was ich nun tippe: sobald ich ich mit Enter bestätige steht da wieder "Neuer Ordner.
- Ebenso lassen sich anscheinend andere Ordner nciht dort hinein ziehen - Dateien schon.

- Bei dem Ganzen Prozedere wird niemals eine Fehlermeldung ausgegeben (a la Ordner sei nicht vorhanden, was es wohl oft gibt)
- Über die Commandozeile per ren-Befehl ist es kein Problem den Ordner umzubennen.
- Ich habe meinem Benutzer, der eh schon Adminrechte hat, nochmal explizit Vollzugriff auf den Ordner gegeben und ihn zum Besitzer gemacht. Hilft alles nichts.

Nun weiß ich nciht mehr recht weiter... Ist hier jemand, demir helfen kann und der Sache auf den Grund gehen will?
Die Installation ist noch recht frisch (und zu anfang ging das mit den Ordnern natürlich). Einzige größere Operation davor war, dass ich die NTFS Berechtigungen für alle meine Partitionen angepasst habe. (Jeder bekam Rechte, damit ich auf einem XP Rechner die Freigaben ordentlich nutzen konnte.) Fakt ist aber: mein Benutzer ist Besitzer und hat volle Rechte und dennoch geht was nicht. :confused:


Ich probiere (fast) alles aus, was zur Lösung des Problems führen kann. Also her mit euren Ideen! :)
 
G

Gast

Gast
Hast du nur die Freigabe erteilt - und hast zu auch unter dem Reiter Sicherheit Vollzugriff gegeben. Vista braucht beide Ebenen.
 

Speed Pete

Herzlich willkommen
Ja - auch unter Sicherheit steht das mein Benutzer Vollzugriff hat. Sowohl für den neuen Ordner, als auch für den übergeordneten (zB D:\).
 

Franz

Moderator
Teammitglied
(und zu anfang ging das mit den Ordnern natürlich) ... Einzige größere Operation davor war, dass ich die NTFS Berechtigungen für alle meine Partitionen angepasst habe. (Jeder bekam Rechte, damit ich auf einem XP Rechner die Freigaben ordentlich nutzen konnte.)
Wie hast du die Berechtigungen gesetzt?
Meinst du die Gruppe "Jeder"?
Hast du Zusatzprogramme (sog. Tuning-Tools) installiert?
Ist der Windows Defender am Start?
Was hast du nach "und zu anfang..." installiert/verändert, außer den berechtigungen?
 

Speed Pete

Herzlich willkommen
Wie hast du die Berechtigungen gesetzt?
Meinst du die Gruppe "Jeder"?

So:
Schritt 1.: Rechtsklick auf eine eurer Partitionen. Eigenschaften und den Tab "Sicherheit". Klickt auf den Knopf "Bearbeiten" und in dem Fenster das sich geöffnet hat auf "Hinzufügen". Jetzt gebt ihr in das untere Eingabefeld das Wort "Gäste" ein und klickt auf "Namen überprüfen". Nun auf "Ok" klicken.
In dem vorherigen Fenster ist jetzt der Eintrag "Gäste" Vorhanden. Unten drunter steht jetzt "Berechtigungen für Jeder" dort müsst ihr alle Checkboxen aktivieren die unter "Zulassen" stehen.

Schritt 2.: Jetzt öffnet ihr euren Arbeitsplatz und klickt in der blauen Leiste auf "Organisieren". In dem Menü klickt ihr auf "Ordner- und Suchoptionen".
Jetzt den Tab "Ansicht" aktivieren und entfernt jetzt den Haken bei "Freigabe-Assistent verwenden".

Schritt 3.: Erstellt jetzt einen neuen Ordner oder nehmt einen bestehenden auf der Partition auf der ihr gerade die NTFS Sicherheits Einstellungen vorgenommen habt.
Auf den gewünschten Ordner jetzt einen rechtsklick machen und "Eigenschaften" auswählen. Dann den Tab "Freigabe" auswählen. Dort klickt ihr in der Mitte auf "Erweiterte Freigabe" und markiert: "Diesen Ordner freigeben". Jetzt klickt ihr auf "Berechtigungen". In dem neuen Fenster müsst ihr bei den Berechtigungen für "Jeder" jetzt den Haken bei "Vollzugriff" machen ansonsten kann derjenige nur kopieren aber nichts schreiben.
Dann drei mal "Ok" klicken bis alle Fenster geschlossen sind.

Schritt 4.: Geht in das Netzwerk und Freigabecenter. Dort sind einige Einstellungen und der Überschrift: Freigabe und Erkennung.
Die ersten Beiden ("Netzwerkerkennung" und "Freigabe von Dateien") müssen aktiviert sein.
Die Einstellung "Kennwortgeschütztes Freigeben" muss deaktiviert werden.

Hast du Zusatzprogramme (sog. Tuning-Tools) installiert?
Nein - keine Tuningtools. Allerdings einen Virenscanner und eine nicht-MS Firewall. Windows-Defender ist bei mir ebenfalls deaktiviert.

Was hast du nach "und zu anfang..." installiert/verändert, außer den berechtigungen?
Hmm - natürlich so einige Programme, wie das bei einem frisch aufgesetzten System so ist. Eigentlich fiel keines großartig auf. Lediglich "Force Shtudown" lief nicht unter Vista und ich hab es wieder runtergeschmissen (ermöglichte Runterfahren mit Tastenkombination). Dann hatte ich noch kurzzeitig mittels "Tweak UAC" (nur eine Exe, installiert sich nicht) die UAC abgeschaltet, um im Startmenu aufzuräumen. Dabei habe ich den Autostartordner etwas demoliert, aber das dürfte eine andere Geschichte sein, die auch gelöst ist.
Zu guter Letzt habe ich natürlich im Nebel gestochert was die freigaben angeht, bevor ich obige Anleitung fand - was ich da probiert habe kann ich nicht mehr rekonstruieren...
 

KS_2007

nicht mehr wegzudenken
PC Praxis ist echt ne super Zeitung mit vielen guten Tipps. Schreib ja schon seit fast 2 Jahren für PC Praxis Programme
 

Speed Pete

Herzlich willkommen
Soll das nun ein Tipp sein? Ich sehe nicht wie mir das weiterhelfen soll... :mad:

[Edit:] Sorry für die harschen Worte - sah aus wie Werbung. Sehe aber jetzt den Bezug im ersten Artikel auf die Zeitschrift :). Hilft mir also dennoch nicht weiter, aber ich bin auch wieder lieb! :D

Noch eine Ergänzung zu meinem Problem: in einen solchen Ordner den ich nicht umbenennen kann, kann ich zwar Dateien hinein verschieben, aber wohl keine Ordner. Was aber sehr wohl geht ist den Ordner hinein zu KOPIEREN und dann am ursprünglichen Ort zu löschen.
Kurios, oder? Bin nach wie vor für alle Ideen dankbar...
 
Zuletzt bearbeitet von einem Moderator:

Franz

Moderator
Teammitglied
Hmm,

falls du es noch nicht durchgeführt hast:
Start -> Systemsteuerung -> Offlinedateien -> 'Offlinedateien deaktivieren' -> PC-Neustart.
Ist die Vistainstallations-DVD manuell erstellt worden?
 

Speed Pete

Herzlich willkommen
Dabei habe ich den Autostartordner etwas demoliert, aber das dürfte eine andere Geschichte sein, die auch gelöst ist.

Und doch lag hier der Hase begraben. Also ich habe das Problem gelöst!

Das Problem mit dem Autostart war folgendes: beim Verschieben einiger Startmenu-Ordner wurden auch die Autostartordner von meinem Benutzer und der für "Alle" vermischt. Alles was im Autostart lag wurde zwei mal aufgerufen, und wenn ich es einmal löschte, startete es gar nicht mehr. Es lag daran, dass in der Registry die Verweise für den Benutzer wie auch für alle auf den gleichen Ordner zeigten.
Daher nahm ich folgende Änderungen vor:

1)
HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Explorer/User Shell Folders/Startup
%USERSPROFILE%\Microsoft\Windows\Start Menu\Programs\Startup

2)
HKEY_CURRENT_USER/Software/Microsoft/Windows/Current/Version/Explorer/Shell Folders/Startup
C:\Users\Chris\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup

3)
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/CurrentVersion/Explorer/User Shell Folders/Common Startup
%ProgramData%\Microsoft\Windows\Start Menu\Programs\Startup

4)
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/CurrentVersion/Explorer/Shell Folders/Common Startup:
C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup

Dies führte auch bei einem älteren Backup reproduzierbar zu dem beschriebenen Problem, wenn gleich ich keinen Zusammenhang erkennen kann. Dieses rekannt, habe ich den Schlüssel unter 1 geändert auf
%USERPROFILE%\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup
die anderen beließ ich so, wie sie im Backup noch vorhanden waren. Und siehe da: Autostart wird nur einmal ausgeführt und ich kann wieder meine Ordner umbenennen! :)
 

Knarfy

gehört zum Inventar
Prima das Du es hinbekommen hast und Danke für die ausführliche Rückmeldung. Würde ich mir öfters wünschen.
 

Ralf.S

Herzlich willkommen
Hallo zusammen!

Wer kann mir noch helfen? Der Patch hilft bei mir nicht. Ebensowenig einige andere Registry-Patches die ich gefunden habe wie zB FD32.reg. Ich finde per Google massenhaft zu dem Problem - teils exakt wie bei mir, teils in Varianten. Vielen hilft solch ein Patch, aber vielen auch nicht. Eine Lösung konnte ich bislang für mich nicht finden.

Das genau Symptom:
- ich lege zB auf D:\ per Rechtsklick->neuer Ordner einen neuen Ordner an
- Vorgegeben ist der Name "Neuer Ordner", der sogleich zum Überschreiben markiert wird.
- Egal was ich nun tippe: sobald ich ich mit Enter bestätige steht da wieder "Neuer Ordner.
- Ebenso lassen sich anscheinend andere Ordner nciht dort hinein ziehen - Dateien schon.

- Bei dem Ganzen Prozedere wird niemals eine Fehlermeldung ausgegeben (a la Ordner sei nicht vorhanden, was es wohl oft gibt)
- Über die Commandozeile per ren-Befehl ist es kein Problem den Ordner umzubennen.
- Ich habe meinem Benutzer, der eh schon Adminrechte hat, nochmal explizit Vollzugriff auf den Ordner gegeben und ihn zum Besitzer gemacht. Hilft alles nichts. .....

Hallo Forenmember,
ich habe das gleiche Problem. Habe der Benutzergruppe "Jeder" sämtlich vergebbare Rechte gegeben und kann dennoch nichts ändern.

Der PC ist eigentlich neu, Vista Home Premium 64bit original drauf. Das einzigste is, dass ich mich als Admin und einen weiteren Standardnutzer angelegt habe. Ich nehme an, dass hier der Wurm drin liegt, da es ja offensichtlich um Berechtigungen geht.

Zudem wird mir bei Installationen gesagt dass mein %APPDATA%\-Pfad nicht gefunden wird.

Der Patch hat mir nicht geholfen, genauso wenig wie verschiedene andere Registy-Änderungen die zu besagtem Thema zu finden sind. :mad:

Kann mir jemand helfen?
 

Martin

Webmaster
Teammitglied
Hallo Ralf!
Öffne mal bitte eine Kommandozeile und gib dort folgenden Befehl ein:

cd %appdata%

Normalerweise sollte der Pfad jetzt nach

c:\users\<username>\AppData\Roaming

wechseln. Wenn das nicht der Fall ist, schau mal bitte in der Registry unter

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders

und unter

HKEY_CURRENT_USER\Volatile Environment

Welche Werte dort dem Schlüssel "AppData" zugewiesen sind.
Wenn das verbogen sein sollte, stellt sich allerdings sofort die Frage, wie es dazu kommen konnte.

Bezüglich der Ordnerrechte gib doch bitte mal genau den Namen des Ordners an, auf den Du keinen Zugriff hast.
 

Ralf.S

Herzlich willkommen
Hallo Martin,
vielen Dank für deine Antwort.

Ich habe mich gestern nicht mehr in meinen (Admin-) Account einloggen können. Er hat mir dann angezeigt, dass mein eingeloggter Account eine Sicherheitskopie wäre - die wurde aber bei jedem Einloggversuch völlig zurückgesetzt. Deswegen habe ich die Sicherheitskopie gelöscht und daraufhin bin ich ganz normal in einen neuen Account mit meinem Namen reingekommen. Jetzt scheint er stabil zu laufen. Ich habe keine Ahnung was da passiert ist.

Jetzt kann ich ganz normal Ordner umbenennen und Programme installieren.

%appdata% verweist auf c:\Users\Ralf.Ralf-PC\AppData\Roaming\

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
und
HKEY_CURRENT_USER\Volatile Environment
verweisen beide auch auf C:\Users\Ralf.Ralf-PC\AppData\Roaming

Nochmal vielen Dank für die Hilfe!
 

Ralf.S

Herzlich willkommen
Ja, werde ich machen.
 
Anzeige
Oben