Papierkorb Größe individuell einstellen

Roberto

gehört zum Inventar
Wenn man z.B. eine 500GB Fesplatte hat, so kann die Größe des Papierkorbs schon mal ca 25GB betragen. Wird automatisch so eingestellt.
Soviel Speicherplatz braucht es dafür aber nicht obwohl das bei den heutigen Festplatten eigentlich keine Rolle mehr spielt.
Folgendermaßen geht man nun vor.

Rechtsklick auf den Papierkorb auf dem Desktop > Eigenschaften.



Hier nun die entsprechende Partition oder das Laufwerk markieren.



Nun kann man unter Benutzerdefinierte Größe in Megabyte (MB) festlegen, wieviel Speicherplatz dem Papierkorb zugewiesen werden soll.
 
Anzeige

edv.kleini

Win10 Registry-Fummler
Ich hab da mal noch was vorbereitet

Es geht auch mit diesem Powershell Script

Administrative Rechte sind dabei allerdings erforderlich!

Einfach die Datei

Bitbucket_enabled.txt in Bitbucket_enabled.bat umbenennen

und

Capacity_Bitbucket.txt in Capacity_Bitbucket.ps1 umbenennen.

Der Wert wird in Megabyte einfach eingetippt und ist global für alle Laufwerke der selbe.

 

Anhänge

  • Bitbucket_enabled.txt
    133 Bytes · Aufrufe: 92
  • Capacity_Bitbucket.txt
    7,2 KB · Aufrufe: 97
  • Bitbucket.JPG
    Bitbucket.JPG
    62,6 KB · Aufrufe: 369
Zuletzt bearbeitet:

ThorstenBerlin

gehört zum Inventar
@ edv.kleini

Danke für Deine Anleitung.

Ich musste nur die "Capacity_Bitbucket.txt" etwas bearbeiten: Umstellung auf "Alle Dateien" und "Codierung" auf ANSI beim Speichern, da sonst für Umlaute "fehlerhafte" Zeichen angezeigt wurden (jedenfalls bei mir):

PS1.JPG

Die Anpassung der Papierkorbgröße funktioniert einwandfrei.
 

edv.kleini

Win10 Registry-Fummler
Danke Dir Thorsten
Das ist das Problem mit ANSI und UTF8.BOM...
Ich habe die Datei gerade ausgetauscht... jetzt sollte es funktionieren!
Ich würde mich über ein weiteres Feedback von Dir freuen!!!
 

ThorstenBerlin

gehört zum Inventar
@edv.kleini

Ich habe eben die von Dir ausgetauschte(n) Datei(en) heruntergeladen und noch im Download-Ordner umbenannt:

DL ORDNER.JPG

Danach habe ich probeweise die "Capacity_Bitbucket.ps1" gestartet, jetzt wird es richtig angezeigt.

Eine Bearbeitung - wie von mir in Post #3 genannt - ist mMn. somit hinfällig:

PS1 Umbenennung.JPG

Danke für's Bearbeiten und Austauschen der Datei(en).

ot:
Bin heute nicht mehr am Laptop, habe mehrere Termine (Fernseher, Festplattenrecorder und Stereoanlage anschließen und einstellen)


Ich wünsche allen ein

Schönes Wochenende!
 

skorpion68

gehört zum Inventar
Hallo edv.kleini,
mein Feedback wie folgt:

BitBucket.jpg BitBucket_Hex.jpg

Das Script Bitbucket_enabled.cmd hat bei mir folgenden Inhalt:
PHP:
@ECHO OFF
TITLE Papierkorb Größe individuell einstellen
CD /D "%~dp0"
POWERSHELL -NoProfile -ExecutionPolicy Bypass -File "Capacity_Bitbucket.ps1"
PAUSE

Wie du siehst sind sowohl Eingaben in Dezimal als auch Hexadezimal möglich. Außerdem ist eine Angabe in Megabyte höher als 9999 möglich. Eine globale Änderung finde ich nicht sinnvoll, es sollte eine Abfrage erfolgen für welches Laufwerk man die Kapazität des Papierkorbes ändern möchte.

Deine Scripts enthalten unnötige Leerzeilen und wenn du viel Text ausgeben möchtest dann wie folgt:
PHP:
Write-Host ('
Text
Text
Text
')
 
Zuletzt bearbeitet:

edv.kleini

Win10 Registry-Fummler
@ skorpion68

Tja man merkt halt, dass ich in der Powershell nicht mehr ganz so bewandert bin.

Die Leerzeilen sind halt auch nur drin,

damit man es auf einem kleinen Bildschirm auch einigermaßen lesen kann.

Natürlich kann man höhere Werte für den Papierkorb angeben,

aber ich wollte das meine Freunde, denen ich den PC eingerichtet habe keinen zu hohen Wert eingeben.

Was nützt z.B. bei einer 2 TB Festplatte ein Papierkorb von 5% sprich 125 GB???

Setze doch mal bitte das geänderte PS Script hier als Text Datei im Anhang rein!

Dann kann ich noch ein bisschen experimentieren!
 

skorpion68

gehört zum Inventar
@edv.kleini
An deine Absätze habe ich mich mittlerweile gewöhnt, meinte aber im Script Bitbucket_enabled.txt die Zeilen 1 und 4 sowie im Script Capacity_Bitbucket.txt die Zeilen 158 bis 261.

Script Bitbucket_enabled.cmd:
PHP:
@ECHO OFF
TITLE Papierkorb, benutzerdefinierte Größe einstellen
CD /D "%~dp0"
PowerShell.exe -NoProfile -ExecutionPolicy Bypass -File "Capacity_Bitbucket.ps1"
PAUSE >NUL

Script Capacity_Bitbucket.ps1:
PHP:
Write-Host ('
Mit diesem Script können Sie auf Ihren Laufwerken die maximale Größe in Megabyte (MB) für den Papierkorb festlegen.')

$Letter = Read-Host -Prompt ('
Geben Sie hier den Laufwerksbuchstaben mit Doppelpunkt an')

$Volume=MountVol $Letter /L 
$SubKey=[RegEx]::Matches($Volume,'{([-0-9a-f].*?)}')
$RegPath="HKCU:\Software\Microsoft\Windows\CurrentVersion\Explorer\BitBucket\Volume\"+$SubKey
$Name=Get-ItemProperty $RegPath

Write-Host ('
Die derzeitig festgelegte Größe des Parpierkorbes beträgt in Megabyte (MB):')$Name.MaxCapacity

$Size = Read-Host -Prompt ('
Geben Sie hier die Größe in Megabyte (MB) an')

Set-ItemProperty -Path $RegPath -Name MaxCapacity -Value $Size
$Name=Get-ItemProperty $RegPath

Write-Host ('
Die neue festgelegte Größe des Parpierkorbes beträgt in Megabyte (MB):')$Name.MaxCapacity

Write-Host ('
Fertig, drücken Sie eine beliegige Taste um das Script zu beenden.')

Ergebnis:

BitBucket_neu.jpg -> BitBucket_new.jpg
 
Zuletzt bearbeitet:

muvimaker

kennt sich schon aus
Den Papierkorb gibt es ja auch unter Windows 10 - mit diversen Einstellungen. Ich möchte jedoch den Papierkorb grundsätzlich nicht verwenden - auch nicht mit einer Minimalbelegung. Der Grund ist folgender: Ich arbeite sehr oft mit externen Laufwerken (HDD, SSD), auf denen mehr oder weniger umfangreiche Dateioperationen durchgeführt werden, wobei die "Altdateien" nicht im Papierkorb landen dürfen. Deshalb muss ich jedesmal vor der Verwendung einstellen, dass die Daten sofort gelöscht werden sollen (bitte jetzt keine Kommentare, dass die Daten trotzdem auf dem Datenträger verbleiben, der Begriff "wipen" ist mir sehr geläufig). Das funktioniert auch tadellos, nur bei einem neu hinzugefügten Datenträger geht das wieder von vorne los.

Meines Wissens gab es unter Windows 7 einmal eine Art "Globaleinstellung", über die man das regeln konnte. Ich bin mir allerdings nicht sicher, ob diese Einstellung nicht auch nur für die aktuelle Windows-Sitzung galt. Da ich mit der PowerShell leider nichts am Hut habe, ergeht die Frage an die Experten/Programmierer hier im Forum:

Kann man so etwas realisieren, dass Windows quasi beim Systemstart so eingestellt wird, dass kein Papierkorb zum Einsatz kommt? Weder für bestehende noch für neu hinzugefügte Laufwerke.

Danke bereits im Voraus für die Hilfe.
 

skorpion68

gehört zum Inventar
Kann man so etwas realisieren, dass Windows quasi beim Systemstart so eingestellt wird, dass kein Papierkorb zum Einsatz kommt? Weder für bestehende noch für neu hinzugefügte Laufwerke.
Selbstverständlich ist dies möglich, siehe wie folgt:

1. Entweder per Gruppenrichtlinie bearbeiten

GPEDIT_Datei-Explorer.jpg

2. Oder gleich per Registry

REG_Datei-Explorer.jpg

  • REG-Datei
Code:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoRecycleFiles"=dword:00000001
  • Befehl in der Eingabeaufforderung (cmd.exe) mit erhöhten Rechten
Code:
REG ADD HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer /v NoRecycleFiles /t REG_DWORD /d 1
3. Ergebnis bei beiden Varianten

Papierkorb_No.jpg
 

muvimaker

kennt sich schon aus
Danke an alle für das rasche Feedback. Die Einstellungen über Gruppenrichtlinien sowie im Papierkorb-Dialog waren mir natürlich bekannt. Den Registry-Eintrag lese ich zum ersten Mal. Meine Einstellungen waren jedoch genauso wie im letzten Screenshot von Skorpion68 dargestellt (Dateien sofort löschen mit Sicherheitsabfrage). Im Feld "Benutzerdefinierte Größe" befand sich der Wert 0.

Ich habe mittlerweile das System neu gestartet und ein Laufwerk wieder neu verbunden.

Nun scheint in der Liste der Laufwerke (Papierkorbpfad) nicht einmal mehr das soeben angesteckte Laufwerk auf - die übrigen allerdings schon. Weiters ist mir aufgefallen, dass auf sämtlichen Laufwerken kein Papierkorb-Ordner mehr zu sehen ist (bisher war dies trotz der eingangs erwähnten Einstellungen so), obwohl im Explorer sämtliche Dateien auf sichtbar gesetzt wurden (auch versteckte und Systemdateien).

Doch ich möchte nicht spammen, man muss nicht alles ganz genau wissen. Es funktioniert und ich bin Euch dankbar, wenngleich sich an den Einstellungen nichts geändert hat. Der Papierkorb ist weg und ich kann vernünftig arbeiten.

Nochmals vielen Dank und beste Grüße.
Muvimaker
 
Oben