Anzeige

Am Puls von Microsoft

Anzeige

PC-Absturz- Ntoskrnl.exe +1d41e9

tenforce

Herzlich willkommen
Deine Devolo - irgendwas hat den Absturz verursacht. Der Zeitstempel des Treibers ist nicht verifizierbar.!

Hallo allerseits,

wo der Thread noch so frisch ist, muss ich gerade mal noch aufspringen. Ich erhalte nämlich des öfteren genau den gleichen Bluescreeen, auch mit einem sehr frischen Windows 10 System, allerdings mit einem AMD Ryzen anstatt Intel.

Nun versuche ich Anhand eurer Analyse der vorliegenden .dmp Datei, den Fehler auch in meiner .dmp Datei ausfindig zu machen.

Meine Frage an tkmopped: Woran erkennst du, dass der Devolo Treiber Schuld war, bzw. dass der Zeitstempel nicht verifizierbar ist? BlueScreenView zeigt mir folgendes zum Devolo Treiber in OP's .dmp:

Anmerkung 2020-03-12 103340.png

Woran erkennt man da den Fehler? Wenn ich das verstanden habe, bin ich vielleicht inder Lage in meiner .dmp Datei den Fehler zu finden.

Danke im Vorraus!
 
Anzeige

Jürgen

Moderator
Teammitglied
ot:
Hallo tenforce und willkommen :)

Ich habe für Dich besser ein neues Thema aufgemacht, schon wegen dem Prozessor ;)


Die automatische Speicherabbilddatei wird standardmäßig in C:\Windows\Minidump\.dmp geschrieben.
Diese Dateien bitte auf den Desktop kopieren und als Archiv packen und bei uns als rar oder zip Datei hochladen
 
Zuletzt bearbeitet:

Ari45

gehört zum Inventar
Oh, Henry, die Memory.dmp kann man bei uns nicht hochladen, auch nicht gepackt. die ist zwischen 500 MB und 1,5 GB groß.

@tenforce, willkommen im Forum! :)
Bitte gehe nach C:\Windows\Minidump. Dort liegen die Minidumpfiles, die man wegen der geringeren Größe hier hochladen kann.
Kopiere die 3 bis 5 neuesten Dumpfiles auf den Desktop und packe sie dort zusammen in ein RAR- oder ZIP-Archiv.
Dieses Archiv hänge bitte an deine nächste Antwort an. Wir werden versuchen, sie zu analysieren.
 

build10240

gehört zum Inventar
wo der Thread noch so frisch ist, muss ich gerade mal noch aufspringen. Ich erhalte nämlich des öfteren genau den gleichen Bluescreeen, auch mit einem sehr frischen Windows 10 System, allerdings mit einem AMD Ryzen anstatt Intel.
Das heißt nichts. Ntoskrnl.exe ist ein zentraler Bestandteil von Windows und immer irgendwie in solche Abstürze involviert. Die Zahlen sind eine Speicheradresse. Alleine daraus kann man i.d.R. nichts ablesen, insbesondere nicht von der gleichen Ursache für den Bluescreen ausgehen.

Nun versuche ich Anhand eurer Analyse der vorliegenden .dmp Datei, den Fehler auch in meiner .dmp Datei ausfindig zu machen.

Meine Frage an tkmopped: Woran erkennst du, dass der Devolo Treiber Schuld war, bzw. dass der Zeitstempel nicht verifizierbar ist? BlueScreenView zeigt mir folgendes zum Devolo Treiber in OP's .dmp:
Wenn Du selbst in die Analyse von Bluescreens einsteigen willst, beschäftige Dich mit einem der vielen im Internet zum WinDbg oder anderen Debuggern vorhandenen Tutorials, Anleitungen, usw. Eine gegebene Bluescreen-Analyse kann zwar hilfreich sein, ist aber eher kein guter Einstieg in des Thema.

Ansonsten wie hier schon im Thread steht, die passenden dmp-Dateien im nächsten Beitrag hochladen, damit sie jemand anderes mit dem Debugger analysieren kann.
 

tenforce

Herzlich willkommen
Hallo ihr beiden,

danke für die schnellen Antworten. Ich hatte zunächst versucht, die Lösung in Bluescreen Ntoskrnl.exe +1d41e9 zu verstehen. Mein obiger Post bezieht sich daher auf den Minidump aus genanntem Thread. Mit dem gewonnen Wissen hätte ich mir dann vielleicht selbst helfen können.

Wenn ihr es aber schon so nett anbietet, sende ich euch hier gerne meine Minidumps.

Sobald ihr darin Unstimmigkeiten bzw. die Fehlerursache feststellt, wäre es sehr nett wenn ihr erklärt, woran ihr das genau erkennt. Dann lerne ich sogar was davon. :angel
 

Anhänge

  • minidumps.zip
    617,2 KB · Aufrufe: 13

Ari45

gehört zum Inventar
Hallo @tenforce! :)
Ich habe mir die neueste Dumpfile (031220-7437-01.dmp) angesehen.
Beim Dereferenzieren wurde aus dem Speicher Müll ausgelesen, wodurch es zur Zugriffsverletzung kam.
Hier die wichtigsten Passagen aus dem Debuggerlog
Code:
SYSTEM_SERVICE_EXCEPTION (3b)
An exception happened while executing a system service routine.
Arguments:
Arg1: 00000000c0000005, Exception code that caused the bugcheck
Arg2: fffff80635b131d6, Address of the instruction which caused the bugcheck
Arg3: fffff288f5e52f30, Address of the context record for the exception that caused the bugcheck
Arg4: 0000000000000000, zero.
....
ONTEXT:  fffff288f5e52f30 -- (.cxr 0xfffff288f5e52f30)
rax=0000000000022000 rbx=ffffffffffffffff rcx=0000000000200000
rdx=0000000079517350 rsi=0000000000200000 rdi=ffff8a85cc7ac080
rip=fffff80635b131d6 rsp=fffff288f5e53920 rbp=0000000000000001
 r8=ffff8a85c74c7080  r9=4542e63d60407fff r10=ffffc3816a1ff6a0
r11=ffff8bf9ff400000 r12=0000000000000000 r13=0000000000000000
r14=ffff8a85c74c7080 r15=0000000000000001
iopl=0         nv up ei pl zr na po nc
cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00050246
nt!ObfDereferenceObjectWithTag+0x26:
fffff806`35b131d6 f0480fc15ed0    lock xadd qword ptr [rsi-30h],rbx ds:002b:00000000`001fffd0=[COLOR="#FF0000"]????????????????[/COLOR]
[COLOR="#008000"]// Das ist der Kontext, der zu Absturz geführt hat. 
Beim erniedrigen des Referenzählers wurde aus dem Datensegment Speichermüll ausgelesen[/COLOR]
....
PROCESS_NAME:  smartscreen.exe
[COLOR="#008000"]// der aktive Prozess war zwar SmartScreen, aber der Referenzzähler wird durch einen Dienst bzw ntoskrnl gesetzt.[/COLOR]
FAILURE_BUCKET_ID:  0x3B_c0000005_nt!ObfDereferenceObjectWithTag
....
[COLOR="#008000"]// und hier der letzte Thread[/COLOR]
# Child-SP          RetAddr           Call Site
00 fffff288`f5e525f8 fffff806`35bd41e9 nt!KeBugCheckEx
01 fffff288`f5e52600 fffff806`35bd363c nt!KiBugCheckDispatch+0x69
02 fffff288`f5e52740 fffff806`35bcb1b2 nt!KiSystemServiceHandler+0x7c
03 fffff288`f5e52780 fffff806`35afa2d5 nt!RtlpExecuteHandlerForException+0x12
04 fffff288`f5e527b0 fffff806`35afe86e nt!RtlDispatchException+0x4a5
05 fffff288`f5e52f00 fffff806`35bd431d nt!KiDispatchException+0x16e
06 fffff288`f5e535b0 fffff806`35bd0505 nt!KiExceptionDispatch+0x11d
07 fffff288`f5e53790 fffff806`35b131d6 nt!KiPageFault+0x445
08 fffff288`f5e53920 fffff806`36207660 nt!ObfDereferenceObjectWithTag+0x26
09 fffff288`f5e53960 fffff806`360cf253 nt!PspExitThread+0x136868
0a fffff288`f5e53a70 fffff806`360cf1da nt!PspTerminateThreadByPointer+0x53
0b fffff288`f5e53ab0 fffff806`35bd3c18 nt!NtTerminateThread+0x4a
0c fffff288`f5e53b00 00007fff`bb7fcb24 nt!KiSystemServiceCopyEnd+0x28
0d 00000034`b0a7f838 00000000`00000000 0x00007fff`bb7fcb24
Bei Stack #0b wird ein Thread beendet
Bei Stack #08 wird der zugehörige Referenzzähler gesetzt
Bei Stack #07 kommt es zum Speicherseitenfehler
Die Stack #06 bis #01 sind Versuche, den Stoppfehler abzufangen, was schließlich bei #00 doch zum Stoppfehler führt.

Ich würde empfehlen:
-> überprüfe deine Systemdateien mit sfc /scannow in einer Eingabeaufforderung (Administrator)
-> wenn das Fehler feststellt, lasse sfc noch mal laufen (bis zu 3 mal)
-> überprüfe deinen RAM mit Memtest86 MemTest86 - Download now!
-> setze die Energieoptionen auf "AMD Ryzen ausbalanciert"

Anmerkung:
Du kannst nicht das Debuggerlog aus dem anderen Thread für dich als Behebungsrichtlinie nehmen, allein schon deshalb, weil du gar keinen Devolo-Treiber hast.

Nachtrag:
Auch in Dumpfile 022320-7328-01.dmp war die Absturzursache eine Speicherzugriffsverletzung (0xc0000005 )
nt!RtlSplay+0x19:
fffff805`226a4349 498b4008 mov rax,qword ptr [r8+8] ds:002b:00000000`00000008=????????????????

In Dumpfile 022220-6875-01.dmp wurde falscher Speicher referenziert.
nt!CmpReportNotifyHelper+0xfc:
fffff801`3f84beec 8b4a08 mov ecx,dword ptr [rdx+8] ds:ffffcb03`4b6553a8=????????

Es ist zu sehen, dass in beiden Fällen die Datensegmente Speichermüll (?????) enhielten.
 
Zuletzt bearbeitet:

Mark O.

gehört zum Inventar
zusätzlich wäre auch noch eine Systemübersicht des laufenden Rechners mittels HWiNFO v6.22 in der portablen Version wichtig, die man nicht installieren braucht:

HWINFO v6.14 Downloadübersicht

Das Ganze möglichst so abbilden, dass wir eine komplette Systemübersicht als Screenshot erhalten

konkrete Angaben zum Netzteil, CPU Kühler und PC Gehäuse wären ebenso wichtig
 

tenforce

Herzlich willkommen
Danke für die ausführliche Analyse.

sfc und MemTest86 haben keine Fehler festgestellt.

Die Option "AMD Ryzen ausbalanciert" habe ich jetzt installiert und ausgewält, seitdem keine Bluescreens. (Aber auch davor gab es die nur unregelmäßig). Ich werde mal so weiterfahren, vielleicht hat es sich ja dadurch erledgit. Falls nicht, werde ich nochmal die HWINFO nachreichen, @Mark O.

Danke soweit!
 

tenforce

Herzlich willkommen
Hallo liebe Leute,

ich muss mich leider zurückmelden, da es zu weiteren Abstürzen kam. Die zwei neusten Minidumps hänge ich an.

Ich hatte bisher vergessen zu erwähnen, dass die Bluescreens ausschließlich beim Hoch- oder Herunterfahren auftreten!

Im Anhang auch die von @Mark O. angeforderte HWINFO.
Netzteil: 600 Watt be quiet! Pure Power 11 CM Modular 8
CPU Kühler: be quiet! Pure Rock Tower Kühler
Gehäuse: Sharkoon Rebel 9

Danke und LG
 

Anhänge

  • Minidumps2.zip
    143,8 KB · Aufrufe: 10
  • HWINFO_results.zip
    88,4 KB · Aufrufe: 19

Silver Server

gehört zum Inventar
Die letzte Dumpfile von heute habe ich mir angesehen
MODULE_NAME: hardware

IMAGE_NAME: memory_corruption

STACK_COMMAND: .thread ; .cxr ; kb

FAILURE_BUCKET_ID: MEMORY_CORRUPTION_ONE_BIT

OS_VERSION: 10.0.18362.1
Es ist ein Speicherfehler aufgetreten.
Arbeitsspeicher und Festplatte überprüfen.
 

tenforce

Herzlich willkommen
Bzgl. Arbeitsspeicher: Die Windows Speicherdiagnose lieferte keine fehler, und auch mehrere intensive Durchläufe von MemTest86 waren fehlerfrei. Ist es denkbar dass man MemTest86 gar tagelang laufen lassen muss um Fehler zu provozieren?

Bzgl. Festplatte: sfc /scannow meldet keine Fehler. Die SMART Info, ausgelesen mit DHDriveInfo, siehe Foto, scheint mir auch unauffällig (soweit ich das beurteilen kann).

DHDriveInfo.png
 

Mark O.

gehört zum Inventar
ich hab mal einen Blick in HWInfo geworfen

das BIOS ist aktuell, das ist gut

Netzteil und CPU Kühler sind brauchbar, das sollte ebenso wie das Gehäuse passen, das einen ganz passablen Airflow liefert

was weniger gut ist ist der RAM, Gigabyte führt den nicht in seiner QVL und G.skill wiederum listet das Mainboard nicht in seiner QVL, keine gute Basis

Abgesehen davon sollten aktuelle Chipsatztreiber installiert sein, da kommen am 7. April neue die sich besser installieren lassen: AMD-Chipsatztreiber: Neuer Installer bereitet noch Probleme - ComputerBase

aktuelle Nvidia Grafikkartentreiber sind natürlich auch Pflicht, die installierten stammen aus Februar

- den Energiesparplan auf AMD Ryzen Balanced stellen, die Leistungsverluste dadurch sind gering, die Vorteile gleichen das locker aus, das System arbeitet stabiler

- sollte auf dem System ein Virenscanner installiert sein, der nicht von Microsoft stammt, sollte der entfernt werden, der Windows Defender erzeugt im Vergleich nicht mal ansatzweise größere Probleme
 

tenforce

Herzlich willkommen
@makodako: SSD Firmware ist auf dem neusten Stand.
@Mark O.: Grafiktreiber habe ich nun aktualisiert, Ryzen Balanced benutze ich seit längerem, Virenscanner hab ich keinen außer Defender. Danke für den Tipp mit dem neuen Chipsatztreiber, den werde ich nächste Woche direkt installieren.
 

Mark O.

gehört zum Inventar
@tenforce

hast du auch den Schnellstart in den Energieoptionen deaktiviert?

Windows 10: Schnellstart deaktivieren/aktivieren

danach dann Win+r Tasten drücken, shutdown.exe /s /t 0 eintippen, mit Enter abschließen


Poste doch bitte mal die Screenshots von CrystalDiskInfo (die portable Version ohne Installation) für die beiden SSDs, ziehe aber bitte das Fenster soweit auf, dass alle Attribute und auch die Rohwerte vollständig sichtbar sind, also keine Scrollbalken mehr erscheinen. Bitte mache den Screenshot aus Windows und nicht mit einer Kamera vom Bildschirm und nur den Screen von CrystalDiskInfo, mit Alt+Druck erzeugt Windows einen Screenshot des aktiven Fensters in der Zwischenablage oder probiere mal die Tastenkombination: 'Windows Taste + Shift + S'.

CrystalDiskInfo - Download - ComputerBase
 

Mark O.

gehört zum Inventar
du hast CRC Fehler laut CDI, da solltest du sicherheitshalber das SATA Datenkabel ersetzen
 
Anzeige
Oben