System: Probleme bei der Erstellung von Energiesparplänen

Chang

Computerversteher
Noch mal in die Runde gefragt, denn ich habe mir gerade die Energieoptionen auf meinem Surface 3 mit demselben Patchstand des Dell 9500 angeschaut:

Das sieht genau so aus, wie auf dem Screenshot in dem ersten Beitrag: Wesentliche Optionen fehlen.

Liegt es eventuell doch an Windows und nicht an Dell Treibern?
 
Anzeige

.Manfred

It's me
Ich bin der Meinung es liegt an Windows und der einzige stimmige Beitrag kommt von @Mark O.
Hast diesen Tipp schon ausprobiert?
Der Admin-Befehl "powercfg -restoredefaultschemes" gilt natürlich auch für andere Geräte.
Sollte der Befehl nichts bewirken kann man davon ausgehen das die fehlenden Einstellungen durch irgendetwas blockiert werden.
 
Zuletzt bearbeitet:

Chang

Computerversteher
@Mark O. wie ich schon in meinem Eingangsposting schrieb:

Ich habe also versucht mit „powercfg -restoredefaultschemes“ die üblichen Energieschemata wiederherzustellen. Leider läuft dieser Versuch genauso ins Leere (es werden keine neuen Schemata angelegt, es bleibt bei dem einzigen Energiesparplan "Ausbalanciert"), wie der Versuch die Energiesparpläne mittels der Befehle:

powercfg -duplicatescheme a1841308-3541-4fab-bc81-f71556f20b4a (für den Energiesparmodus)

powercfg -duplicatescheme 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c (für die Höchstleistung)

zu erstellen. Die Energiesparpläne werden nicht erstellt (cmd als Administrator ausgeführt) und es bleibt bei dem Energiesparplan „Ausbalanciert“ in dem wesentliche Einstellungen nicht vorgenommen werden können.
Das sind ja genau die Lösungsvorschläge die Dell im von dir verlinkten Dokument anbietet.


@all Windows 10 Pro ist auf allen Geräten im Einsatz. Die Problemstellung tritt nicht nur auf meinem Dell XPS 15 9500 und dem Surface 3 auf, auch ein Dell XPS 13 9300 zeigt dasselbe Verhalten.

Testweise habe ich den Hypervisor auf dem Dell XPS 15 abgeschaltet da dieser in der Vergangenheit immer wieder für Probleme mit dem connected Standby sorgte, dies schafft aber keine Abhilfe.

Kurioserweise sind aber sämtliche Standard-Energiesparpläne in einer Virtuellen Maschine, die auf dem Dell XPS 15 gehostet wird, vorhanden.

test.jpg
 

PeteM92

gehört zum Inventar
Nur eine Zwischenbemerkung:
ich habe gerade Windows neu installiert (alle Partitionen komplett gelöscht und ohne Internetverbindung) auf einem Dell Inspiron 17-7706 (diese Woche geliefert).
Es sind nur die in Post #1 gezeigten Energiesparpläne vorhanden.
Meine Vermutung: da spielt etwas herein, das Dell im BIOS festgelegt hat.
 

Chang

Computerversteher
@PeteM92 deiner Vermutung widerspricht ja, das sich die Energieoptionen auf meinem Surface 3 genauso darstellen wie auf dem Dell.

Wenn du Zeit und Lust hast und die aktuelle Windows Version als Verursacher ausgeschlossen werden soll, könntest du mal eine altere Windows 10 Version (ggf. 1909 oder älter) auf dem Dell Inspion installieren und gucken, wie sich die Energieoptionen dann darstellen.
Ich arbeite kaum mit Gruppenrichtlinien und kenne mich auf diesem Feld nicht besonders gut aus. Eventuell gibt es dort eine Richtlinie, die solche kastrierten Einstellungen vorgibt. Ironischerweise ist ja, wie oben geschrieben, auf einer Virtuellen Maschine alles in Ordnung mit den Energieoptionen obwohl der Host die erwähnten Einschränkungen zeigt.

Wie das Internet zeigt, bin ich nicht der einzig Betroffene, Dell Nutzer scheinen aber weit häufiger betroffen.
 

PeteM92

gehört zum Inventar
Ältere Windows-Versionen installieren ist gerade schwierig (Zeitmangel, ich muß schauen, daß ich den Laptop nach speziellen Wünschen einrichte).
Daß DEll-Nutzer häufiger betroffen sein sollen liegt vielleicht auch an der Zahl der Dell-Nutzer ;)
 

.Manfred

It's me
Ich rudere mal zurück, eine Fehlinterpretation meinerseits.
Ich war der Meinung es geht ausschließlich um die erweiterten Energieoptionen.
Bei mir gibt es auf dem Asus 14 UM431 auch keinen Energiesparmodus und Höchstleistung, aber ich habe in den erweiterten Energieoptionen alle bekannten Einstellungen zur Verfügung.

Könnte es einen Zusammenhang mit einer installierten NVME oder SSD geben?
Bei mir ist eine Samsung NVME 970 EVO PLUS verbaut ebenso ist im Dell eine NVME verbaut.
Bei diesen Platten wären der Energiesparmodus und Höchstleistung paradox.
Energiezustände.png
 
Zuletzt bearbeitet:

Chang

Computerversteher
Ich bin ein Stück weiter gekommen, aber der Reihe nach.

mag ja sein, aber was sagt denn der Dell Support zu deinen Problemen?

Für Dell findet dieses Problem mit der Installation des Dell Power Managers seine Erledigung. Leider ist das deutsche Dell Forum seit rund einem Jahr vollkommen unmoderiert, im amerikanischen Dell Forum kann man mit viel Glück und Zeit eventuell eine Antwort bekommen.

@Labersack05, nach deinem letzten Posting habe ich mich noch einmal mit den Sleep states meines Dells beschäftigt:

S0.jpg


Ich habe die Vermutung, das der S0 modus die erweiterten Energieeinstellungen nicht mehr zulässt. Nun ließe sich der S0 Modus mit dem Setzen des RegKeys "CsEnabled = 0" in “HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power“ abschalten, auf meinem System war dieser Key jedoch nicht vorhanden.
Offenbar wurde diese Option jedoch mit dem Mai 2020 Update von Microsoft entfernt. Gleichzeitig verzichtet Dell darauf, den S3 Modus im BIOS ihrer Geräte forcieren zu können. Somit wird bei einer Windows Neuinstallation lediglich der Energiesparplan "Ausbalanciert" installiert. Installiert man mittels Dell Recoveryimage, kommt zusätzlich noch der "Dell" Energiesparplan hinzu.

Die fehlenden Optionen in den Energiesparplänen erkläre ich mir damit, das das Gerät nur noch im "connected Standby" läuft und weitere Optionen nicht mehr verstellt werden sollen um das Aufwecken des Gerätes nicht zu verhindern.

In diesem reddit Thread wird über die Möglichkeiten diskutiert den S3 state auf den betroffenen Geräten wiederherzustellen.

Das Hinzufügen des RegKeys "HKLM\System\CurrentControlSet\Control\Power /v PlatformAoAcOverride" mit dem Wert "0" hat auf meinem Dell XPS 15 9500 den S3 state zurück gebracht.

S3.jpg


Zwar finde ich in den Energieoptionen nach wie vor nur den Modus "Ausbalanciert", "powercfg -restoredefaultschemes" bringt zwar die anderen Energiesparpläne nicht wieder zurück (die könnte man ggf. mit "powercfg -import *.pow" importieren) aber, nun sind die Optionen wieder vollständig zu ändern:

all options.jpg






Ich markiere diesen Thread bewusst nicht als gelöst, da der auf reddit beschriebene work-around in meinem Fall zwar momentan funktioniert, aber mit jedem update wieder zunichte gemacht werden kann.
 
Zuletzt bearbeitet:

.Manfred

It's me
Danke für deine ausführliche Erläuterung.
 
Oben