Anzeige

Am Puls von Microsoft

Anzeige

[gelöst] Server 2016 x64 Build14393 für Insider Installation, Features, Gedankenaustausch

edv.kleini

Win11 Registry-Fummler
So ich habe neues zu berichten
Zum Testaufbau: Wichtig ... Alles doppelt vorhanden und absolut baugleich.
Asus Striker 2 Formula, Q9650 CPU @3,75 GHz, Corsair DDR2 RAM 4 * 2 GB
2 SAMSUNG EVO 840er 120 GB SSDs im RAID 0
2 Grakas Nvidia Geforce 560 GTX im SLI
Auf dem einen (Board 1) habe ich Server 2016 installiert, alle Sicherheitspatches und Updates gemacht
und das Produkt ordnungsgemäß aktiviert (Server Evaluation Version 2016 180 Tage gültig).
Dann habe ich mit Drive Snapshot ein Image davon erstellt.
Dieses Image habe ich per Drive Snapshot dann auf Board 2 zurück gespielt.
Da die Maschinen absolut baugleich sind, und MS bei der Evaluation Version auf die
Hardware wohl nicht so genau schaut, ist das Produkt immer noch aktiviert!

Cloning leicht gemacht!

Microsoft fragt zwar bei Windows 10 und Server 2016 so einiges an Hardware ab, wenn man es clont.
Aber ich nehme mal an, daß das Funktionieren des Clonens unter Server 2016 auch damit zu tun hat,
daß die Festplatten mit dem in Windows vorhandenen
Befehl unter diskpart "uniqueid disk id=11111111" die selbe ID zugewiesen bekommen.
 
Zuletzt bearbeitet von einem Moderator:
Anzeige

edv.kleini

Win11 Registry-Fummler
Auf Server 2016 ist zwar Cortana und MS Edge als App auf der Festplatte hinterlegt,
aber diese Apps sind nicht aktiviert.
Ich habe herausgefunden, daß bei deaktivierter Benutzerkontensteuerung ein Eintrag im Ereignisprotokoll
erfolgt. Dieser lautet wie folgt:
"Die App Microsoft.Windows.Cortana_cw5n1h2txyewy konnte mit dem integrierten Adminitsratorkonto nicht
aktiviert werden" usw.
Aktiviert man die Benutzerkontensteuerung wieder auf das normale Standard-Level mit dem Schieberegler,
gibt es bezüglich Cortana und MS-Edge keine Eintäge mehr im Ergeinisprotokoll!
Aberwitzig, eine App, die unter dem BS Server 2016 standardmäßig nicht zur Verfügung steht, wird im
Ereignisprotokoll angemeckert, in Abhängigkeit der Benutzerkontensteuerung!

Die wege des Herrn sind schon so ziemlich unergründlich, aber die Wege von Microsoft???

Man merkt halt schon, daß einige Teile von Windows 10 einfach übernommen wurden!

Die KB 3197954 habe ich ja schon länger drauf.
Der Download von KB 3199986 und die Installation davon gingen ratzfatz.
Bei allen drei Maschinen mit Server 2016 EV!
 
Zuletzt bearbeitet von einem Moderator:

edv.kleini

Win11 Registry-Fummler
Zu früh gefreut???

Die KB 3197954, die ich vor ca. ´ner Woche bei Deskmodder runterlud, kann man zwar
auf Server 2016 installieren und diese wird dann auch bei installierte Updates angezeigt.
Diese scheint wohl doch nicht ganz zu Server 2016 zu passen!
Windows Server bekommt dann zwar die Build 14393.351, aber:

Geht man manuell auf Updates suchen, dann zeigt Windows an:
KB 3197954 x64 für Server 2016 gefunden,
Dann lädt Windows es runter, installiert es automatisch und dann hat man wohl erst die richtige KB drauf!
Driiiiieeeet sät Schiller!
 

edv.kleini

Win11 Registry-Fummler
Erst mal Danke Henry

Jetzt haben wir den Salat...

Klemmt man z.B. ´nen USB Memory Stick oder USB-to SATA Adapter mit Festplatte an,

benutzt das Teil dan für ´ne gewisse Zeit und meldet es wieder ab, dann kommt keine Nachricht:

"Sie können das Gerät jetzt sicher entfernen".

Wenn kein anderes Gerät mehr dran angeschlossen ist, welches das Symbol in der Taskleiste
benötigt bzw. anzeigt, dann verschwindet dieses USB-Symbol Gott Lob noch...
So kann man wenigstens noch sauber erkennen, ob man das Gerät jetzt abdocken kann!

Das Fehlen der Nachricht hattest Du ja schon bei Windows 10 Build 14393.351 für Normalanwender erwähnt.
 

edv.kleini

Win11 Registry-Fummler
So auf beiden Servern Updates drauf, incl. Defender-Updates.
Keine Build-Anhebung aber es hat sich auch nix entscheidendes verändert...
Das waren wohl nur ein paar kleinere Bugfixes...
 

edv.kleini

Win11 Registry-Fummler
So jetzt habe ich es auch mit den DirectX Sachen hinbekommen.

Guckst Du hier:
 

Anhänge

  • Serv2016.jpg
    Serv2016.jpg
    117 KB · Aufrufe: 106

edv.kleini

Win11 Registry-Fummler
Doch, Netz habe ich, aber er/es ist nur neu aufgesetzt!
Und ich sage Dir auch warum...
Folgendes habe ich entdeckt:

Die mit NTLite bearbeiteten Iso´s für die NFORCE RAID Geschichte haben eine kleine Macke.

Schließt man zur Installation einen USB Memory Stick oder USB-to-SATA Adapter mit SSD HDD an,
dann habe ich ja schon mal erwähnt, daß der Bootvorgang von USB sehr lange braucht!
Das liegt wohl unter Anderem am Handshake zwischen dem USB Gerät und dem Nforce Chipsatz für USB.
Soweit aber kein Problem.
Davon funktioniert die Installation ja reibungslos.
Jetzt habe ich die besagte ISO mal auf eine DVD gebrannt.
Diese bootet auch davon.
Kein Problem.
Ist das DVD-ROM bzw. der DVD-Brenner jedoch über ein SATA PORT angeschlossen, geht es wegen der
Datei Disk.inf nicht weiter. Das Setup-Programm verlangt nach einem Treiber.
Da diese Nforce Chipsatz Boards ja nur zum Testen dienen, und schon etwas ;););) betagter sind,
habe ich ein PATA, sprich ein IDE DVD ROM angeschlossen.
Und siehe da, davon funzt die Installation reibungslos!:D:D:D
Naja und dann habe ich den Server halt noch mal neu augesetzt und bei MS wieder aktiviert!
Guckst Du in der Miniaturansicht der angehängten Grafik!

Frage ist halt nur:
Wie lange macht MS den Schmu mit?!?!;););)
 

Anhänge

  • Server2016 aktiviert.PNG
    Server2016 aktiviert.PNG
    411,9 KB · Aufrufe: 132

edv.kleini

Win11 Registry-Fummler
Der Ordner "Systempflege" auf dem Desktop wird auch immer größer! ;):cry:;):D

Neue Informationen zu Server 2016 von "Speccy"...

Ein paar Fragen habe ich da noch...

1. Soweit ich weiß wurde die Firma Microsoft im Jahre 1975 gegründet...Richtig?
2. Am 01.01.1970 also vor mehr als 46 Jahren hätte Billyboy Gates davon noch nicht mal geträumt,
so ein Betriebssystem zu haben!...Richtig?
3. Habe ich wirklich am 01.01.1970, damals war ich gerade 4 Jahre alt, schon mit Server 2016 gespielt???
Muß ich mal meine Mama fragen...


Siehe Bild im Anhang mit rotem Pfeil!

Hurrrrrraaahhhh

Der Server lädt zum ersten mal automatisch ein kumulatives Update
KB3200970 ganz von alleine runter...unbelieveable

I´m so impressed ... ich bin so eingedrückt

So... auf Server 1 ist das Update problemlos durchgelaufen!!!
Guckst Du hier...

Jetzt muß ich mal den 2. Server ran nehmen

Auf dem 2. Server ist das Update auch problemlos durchgelaufen und installiert worden...

Bei der Laufwerkbereinigung fiel mal wieder das bekannte Problem der 3,99 TB großen Partition auf,

die real nur 40 GB hat! Modern Art-> moderne Kunst!

Was soll ich sagen
Ich bin lieber mit Server 2016 unterwegs, als mit Windows 10 x64 prof...

Bei Server 2016 ist das Wenige was im Hintergrund läuft oft mehr!
Kein Cortana, kein Geo-Caching meines Gerätes, kein Maps (Karten) usw.
Die Liste ließe sich bestimmt noch verlängern.

So zum Surfen mit Mozilla FiFo und dem Wenigen, was im Hintergrund läuft...echt ideal!!!

Toller Server

Guckst Du hier: (Ein Scherz, aber der mußte einfach sein)

Bei Server 2016 funktionieren Apps, wie Rechner usw.,
auch bei deaktivierter Benutzerkontensteuerung (UAC).
Die Apps funktionieren auch bei "normalen" Benutzern mit administrativen Rechten und
nicht nur beim Administrator-Konto ...

Bei Windows 10 funktionieren Apps, wie Rechner usw., bekanntermaßen ja nun mal eben
nicht, wenn die Benutzerkontensteuerung (UAC) deaktiviert wird.
 

Anhänge

  • Systempflege_Teil_1.PNG
    Systempflege_Teil_1.PNG
    70,1 KB · Aufrufe: 109
  • Systempflege_Teil_2.PNG
    Systempflege_Teil_2.PNG
    42,4 KB · Aufrufe: 116
  • Installationsdatum.PNG
    Installationsdatum.PNG
    451,1 KB · Aufrufe: 137
  • Server_Neu.PNG
    Server_Neu.PNG
    45,3 KB · Aufrufe: 108
  • Server 2016_in_Vorbereitung.png
    Server 2016_in_Vorbereitung.png
    32,7 KB · Aufrufe: 148
Zuletzt bearbeitet von einem Moderator:

edv.kleini

Win11 Registry-Fummler
Die Abfrage der Build-Version über Winver läßt sich manipulieren...
In der Registry unter dem Pfad
HKLM\Software\Microsoft\Windows NT\CurrentVersion
den Eintrag UBR verändern
und unter
HKLM\Software\WOW6432Node\Microsoft\Windows NT\CurrentVersion
den Eintrag UBR verändern
Geht auch mit Windows 10
Beispiel gefällig: links modifiziert, rechts original
 

Anhänge

  • Super-Build.PNG
    Super-Build.PNG
    275 KB · Aufrufe: 139
  • Original-Build.PNG
    Original-Build.PNG
    411,9 KB · Aufrufe: 138
Zuletzt bearbeitet:

edv.kleini

Win11 Registry-Fummler
War halt nur ein Scherz, menno, genau wie in Beitrag #49 von mir

Gönn mir den doch, ich brauch´ sowas gerade am frühen Morgen!

Trotzdem guten morgen der Herr...ausgeschlafen?
 

edv.kleini

Win11 Registry-Fummler
Ich trinke keinen Kaffee, davon bekomme ich immer Herzrythmusstörungen:rofl

Ich nehme lieber ein :bier....:saufduo.....;););)

Alllohohl am Morgen vertreibt Kummer und Sorgen

und

Alllohohl macht Birne hohl

Desweiteren

Der dritte Server ist jetzt auch upgedatet auf Build 14393.447...und zwar problemlos!
 

Anhänge

  • Server03.PNG
    Server03.PNG
    121,8 KB · Aufrufe: 106

edv.kleini

Win11 Registry-Fummler
Ich weiß gar nicht wie das passieren konnte?
Aber ich hatte einfach Bock drauf...

Ich hatte diese Woche jede Menge neue Batchfiles und Registry-Einträge geschrieben.
Diese wollte ich natürlich testen.
Am Schnellsten geht das mit Server 2016...
Da dafür auch einige Batchdateien und Registry-Einträge gemacht wurden,
hat sich die Installation und der Feinschliff des Systems drastisch verkürzt!
Betreffend Rollen, Domäne, Treiber usw.
In weniger als einer Stunde war es fertig! Tutti kompletti!

Microsoft hat folgende Infos zum KB 3200970 für Server 2016 herausgegeben:

Zusammenfassung
Dieses Sicherheitsupdate enthält Verbesserung und Updates die Funktionalität der Windows 10 Version 1607 und Windows Server 2016. Es behebt außerdem die folgenden Sicherheitslücken in Windows:

3198467 MS16-142: Kumulatives Sicherheitsupdate für Internet Explorer: 8 November 2016
3193479 MS16-140: Sicherheitsupdate für Boot-Manager: 8 November 2016
3199647 MS16-138: Sicherheitsupdate für Microsoft virtuelle Festplatte: 8 November 2016
3199173 MS16-137: Sicherheitsupdate für Windows-Authentifizierungsmethoden: 8 November 2016
3199135 MS16-135: Sicherheitsupdate für Kernelmodustreiber: 8 November 2016
3193706 MS16-134: Sicherheitsupdate für allgemeine Protokoll Dateisystemtreiber: 8 November 2016
3199120 MS16-132: Sicherheitsupdate für Microsoft Graphics Komponente: 8 November 2016
3199151 MS16-131: Sicherheitsupdate für Microsoft Videosteuerelement: 8 November 2016
3199172 MS16-130: Sicherheitsupdate für Microsoft Windows: 8 November 2016
3199057 MS16-129: Kumulatives Sicherheitsupdate für Microsoft Edge: 8 November 2016

Updates für Windows 10 und Windows Server 2016 sind kumulativ. Daher enthält dieses Paket alle zuvor veröffentlichten Updates.

Wenn Sie frühere Updates installiert haben, werden nur neue Updates, die in diesem Paket enthalten sind, heruntergeladen und auf Ihrem Computer installiert. Bei der Installation von Windows 10 oder Windows Server 2016 Update-Paket zum ersten Mal das Paket für die x86 Version ist 467 MB und das Paket für die x64 Version ist 871 MB.
 

Anhänge

  • Server_NEU_4.PNG
    Server_NEU_4.PNG
    201,8 KB · Aufrufe: 108
Zuletzt bearbeitet von einem Moderator:

edv.kleini

Win11 Registry-Fummler
In den letzten Tagen funktionierte teilweise das Update des Windows Defenders für Server 2016 nicht.
Heute morgen habe ich es dann noch einmal probiert, jetzt funktioniert es wieder...
Was auch immer das war?!?
 

edv.kleini

Win11 Registry-Fummler
So jetzt habe ich mal wieder diverse Prozesse bei der Installation von Server 2016
automatisieren können.
1. Kennwortrichtlinien, Kennwortkomplexität und Kennwortdauer/alter
2. Lokale Sicherheitsrichtlinien importieren und exportieren
3. Windows Defender per Batch aktivieren/deaktivieren
4. Windows Audio Dienst ein/ausschalten
5. Beim Herunterfahren/Neu starten von Server 2016 keinen Grund mehr
für das Herunterfahren/Neu starten von Server 2016 angeben zu müssen...

Eben kleine Dinge, die das "Leben" sprich installieren von Server 2016 erleichtern!

Guckst Du hier:
 

Anhänge

  • Für_Server_2016.zip
    7 KB · Aufrufe: 50

edv.kleini

Win11 Registry-Fummler
Ich habe mir mal die Mühe gemacht und eine Batchdatei verfasst, um Benutzerkonten
einfach und schnell anlegen zu können.
Diese sieht wir folgt aus:

@echo off
cls
net user Klein2 rapunzel /add
net user Klein2 /Active:YES
net user Klein2 /Fullname:"Klein2"
net user Klein2 /usercomment:"Klein2"
net user Klein2 /comment:"Klein2"
net localgroup Administratoren KLEIN2 /add
net localgroup Benutzer KLEIN2 /delete
wmic UserAccount where Name="KLEIN2" set PasswordExpires=False

Zeile 1 verhindert die Anzeige der ausgeführten Befehle
Zeile 2 löscht den Bildschirminhalt
Zeile 3 fügt einen Benutzer mit Namen Klein2 und das Passwort "rapunzel" hinzu
und zwar auf dem lokalen PC, wenn keine Domain angegeben wird!
Zeile 4 setzt das Benutzerkonto Klein2 auf aktiviert
Zeile 5 fügt dem Benutzerkonto Klein2 einen vollen Namen hinzu...hier Klein2
Zeile 6 fügt den Benutzerkommentar hinzu...
Zeile 7 fügt den Administrativen Kommentar hinzu...
Zeile 8 fügt den Benutzer Klein2 der Gruppe der Administratoren hinzu
Zeile 9 enfernt den Benutzer Klein2 von der Gruppe der Benutzer
Zeile 10 setzt das Passwort auf unendliche Gültigkeit

Der Name "Klein2" soll hier neben dem Passwort "rapunzel" nur als Beispiel dienen!

Wichtig ist, daß bei den Zeilen 5, 6, 7 und 10 Anführungszeichen " " gesetzt werden!

Die 10zeilige Batchdatei funktioniert ab Windows Vista bis rauf zu Server 2016,
wobei bei Server Installationen auf die Kennwortkomplexität geachtet werden muß,
wenn man diese nicht schon vorher deaktiviert hat!
Desweiteren sind solche Batchdateien natürlich nur mit administrativen Rechten ausführbar!

Da habe ich ganz schön lange dran "gestrickt", aber es funktioniert tadellos!
 
Zuletzt bearbeitet:

edv.kleini

Win11 Registry-Fummler
Bei Server 2016 habe ich 2 Drucker über Standard TCP/IP-Port installiert.
Problem war der SNMP-Status.
Gelegentlich hat mir Windows gemeldet der Drucker sei Offline.
Das stimmt so nicht. Die Drucker sind online und beim HP LJ 2014
ist der davorgeschaltete Print-Server immer online und aktiviert!
Nach dem ich den Haken entfernt hatte, war das Problem gelöst. Siehe Bild.
Das geht aber auch über Registry - Einträge. Diese funktionieren auch bei Windows Vista
bis Windows 10 und eben auch bei Server 2016!

Beispiel:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\Standard TCP/IP Port\Ports\PS1]
"Protocol"=dword:00000001
"Version"=dword:00000002
"HostName"="192.168.238.51"
"IPAddress"=""
"HWAddress"=""
"PortNumber"=dword:0000238c
"SNMP Community"="public"
"SNMP Enabled"=dword:00000000
"SNMP Index"=dword:00000001
"PortMonMibPortIndex"=dword:00000001
 

Anhänge

  • SNMP-Status.PNG
    SNMP-Status.PNG
    17,8 KB · Aufrufe: 127
Anzeige
Oben