Anzeige

Am Puls von Microsoft

Anzeige

Sichern und Wiederherstellen: Interner Fehler Falscher Parameter (0x80070057)

yellow

Moderator
Teammitglied
Wenn Sie bei einer Sicherung oder Wiederherstellung Ihrer Dateien oder des gesamten Systems die Fehlermeldung erhalten:
"Interner Fehler Falscher Parameter 0x80070057"
liegt das meist daran, dass ein falscher Wert in der Repositry (eine System-Ablage) ausgelesen wurde.

fehler.JPG


Klicke Sie auf Start und geben Sie in die Suche cmd ein.
Machen Sie anschließend einen Rechts Klick auf cmd und wählen Sie "Als Administrator ausführen" aus.

cmd2.jpg


Geben Sie nun die folgende Befehle nacheinander ein und bestätigen Sie jede Zeile mit "Enter":

net stop winmgmt
cd /d %windir%\system32\wbem
ren repository repository.old
net start winmgmt
exit

Führen Sie dann einen PC-Neustart durch.
Durch neu erstellen des Ordners C:\Windows\System32\wbem\Repository konnte somit
dieses Problem behoben werden.

Credits to Franz und prinblac;)

Nachtrag:
ihr könnt auch mal den Tipp von dafri testen:
http://www.drwindows.de/173624-post29.html

Nachtrag 2:
nach der Ausführung dieser Lösung, wird im Wartungscenter die
Sicherheitssoftware nicht mehr erkannt, obwohl sie auf dem aktuellen
Stand ist. Man kann nun die Meldung vom Wartungscenter deaktivieren
oder aber man installiert sie Neu.

Lösung zu Nachtrag 2:
Sie müssen die WMI Repository-Datenbank auf Ihrem Computer durchsuchen und reparieren, um dieses Problem zu beheben.
Führen Sie dazu die folgenden Schritte aus:
1. Klicken Sie auf Start
geben Sie im Feld Suche starten den Befehl cmd ein. Machen Sie anschließend einen Rechts Klick auf cmd und wählen Sie
"Als Administrator ausführen" aus.
2. Geben Sie an der Eingabeaufforderung nun folgende Befehle ein. Drücken Sie nach jeder Befehlszeile die EINGABETASTE:
winmgmt /verifyrepository
winmgmt /salvagerepository
3. Starten Sie den Computer neu.
Quelle
werde das bei der nächsten Gelegenheit mal selber testen :D
 
Zuletzt bearbeitet:
Anzeige

rentni

rentni
Super Beitrag!!!! Hat mir eben gerade geholfen.

Ich hatte das externe Laufwerk mit der alten Sicherung plattgemacht und dann hat es nach Aufrufen der Sicherung den oben beschriebenen Fehler gegeben.

Ich wollte meine Sicherung nur wiederholen. Ohne diesen Beitrag hätte ich total auf dem Schlauch gestanden.

Ganz toll, vielen Dank!
rentni
 

Hochzeiter

Herzlich willkommen
Falscher Parameter 0x80070057 Systemreparaturdatenträger

Frohe Weihnachten und Hallo zusammen,

ich bin hier komplett neu bei Dr.Windows und habe den Beitrag zu 'Falscher Parameter' gelesen.
Ich möchte einen Systemreparaturatenträger erstellen ,bekomme jedoch diesen Fehlercode 'Falscher Parameter 0x80070057'. Kann ich genau die Anleitung von yellow zur Beseitigung des Fehlers verwenden?
Ich hatte damit schon angefangen, bekomme aber nach Eingabe der ersten Zeile und return folgende Meldung:

C:\Windows\system32>net stop winmgmt
Die folgenden Dienste hängen vom Dienst Windows-Verwaltungsinstrumentation ab.
Das Beenden des Dienstes Windows-Verwaltungsinstrumentation beendet auch diese Dienste.
Sicherheitscenter
IP-Hilfsdienst
Intel<R> Matrix Storage Event Monitor
Möchten Sie diesen Vorgang fortsetzen? <J/N> [N]:

Vielen Dank für Eure Hilfe

Grüße
Hochzeiter
 

yellow

Moderator
Teammitglied
@Hochzeiter,
ob das auch bei deinem Problem funktioniert, kann
ich dir nicht sagen, aber du kannst damit auch
nichts kaputt machen.
Möchten Sie diesen Vorgang fortsetzen? <J/N> [N]:
hier einfach J eingeben und mit den restlichen Eingaben
einfach weiter machen, wie ich es beschrieben habe.
wünsche dir gutes Gelingen und Frohe Weihnachten :)
 

Hochzeiter

Herzlich willkommen
Fehlercode 0x80070057

Hallo yellow,

herzlichen Dank für Deine schnelle Antwort. Nach Durchführung der einzelnen Schritte hat es dennoch leider nicht geklappt - na ja, ich warte halt ab, bis ich dazu mehr Info bekomme. Ist halt dumm, wenn man ohne Wiederherstellungs-CD (Systemreparaturdatenträger) dasteht. Aber: kommt Zeit, kommt Rat :)

Nochmals Danke und Grüße
Hochzeiter
 

nixrosta

Herzlich willkommen
Hallo alle zusammen,

ich bin auch absolut neu in diesem Forum und habe dasselbe Problem wie Hochzeiter.
Wenn ich in der Eingabeaufforderung die Frage des Systems mit J bestätige kommt sofort die Meldung: "Systemfehler 5 aufgetreten Zugriff verweigert"
Kann mir da jemand weiterhelfen?
Vielen Dank im Voraus und alles Gute fuer das neue Jahr.
LG Nixrosta
 

Lukas V

Herzlich willkommen
Hat bei mir auch super geklappt. Aber noch eine Frage bei mir war das selbe wie bei Hochzeiter (das einige Dienste beendet wurden). Muss man diese Dienste irgendwie wieder aktivieren. Oder wird das automatisch gemacht? Danke schonmal im vorraus^^.
 

yellow

Moderator
Teammitglied
Hallo und Willkommen @Lukas V,
diese Dienste werden ja mit dem Befehl net start winmgmt
wieder gestartet:)
 

nixrosta

Herzlich willkommen
Hallo Martin,
vielen Dank fuer die kompetente Antwort. Ich konnte danach den restlichen Code ausführen, leider kam nach dem Neustart dann wieder die gleiche Fehlermeldung mit falscher Parameter.
LG Nixrosta
 
J

Jens-Jonny

Gast
Hallo, hab da auch noch eine Frage dazu.
Wenn ich "ren repository repository.old" eingebe kommt "Zugriff verweigert"!
Was mache ich falsch?
Gruß Jens
 

yellow

Moderator
Teammitglied
@Jens-Jonny,
mache mal auf den Ordner repository einen Rechts Klick -->Eigenschaften
--> Reiter Sicherheit und schaue nach, ob dort alle Berechtigungen
gesetzt sind :)
 

Anhänge

  • repository.JPG
    repository.JPG
    52,7 KB · Aufrufe: 5.887

SirLoseALot

Herzlich willkommen
Hallo alle,

ich hatte das im Artikel besprochene Problem und bin den angegebenen Schritten gefolgt. Zwar hat soweit alles funktioniert, allerdings lässt sich jetzt die Sicherung komplett nicht mehr starten. Egal welchen Weg ich da versuche, das Sicherungsprogramm lässt sich nicht mehr aufrufen. Eine Systemwiederherstellung (ja, der traue ich seit Win7 einigermaßen) hat da leider auch nicht geholfen. Was könnte schief gelaufen sein?
 

yellow

Moderator
Teammitglied
@SirLoseALot,
:eek: das ist eine gute Frage :unsure:
mit diesem Problem bist du der erste.
Hast du mal versucht eine Komplett Sicherung zurück zu spielen ?
 

SirLoseALot

Herzlich willkommen
Hallo yellow,

leider existiert keine entsprechende Sicherung, da das ursprüngliche Problem beim ersten Versuch, eine Sicherung anzulegen auftrat. Insofern bleibt a) Neuinstallation (neeeee) oder b) heraus finden, woran das liegen könnte. Ich persönlich vermute einen nicht gestarteten Dienst...?
 

yellow

Moderator
Teammitglied
@SirLoseALot,
das mit dem Dienst könnte durchaus möglich sein.
Dann schaue doch mal nach, ob der Dienst "Windows-Sicherung"
gestartet ist und auf Manuell steht. Auch würde ich mal das
ganze wiederholen, aber vorher den Ordner "repository.old"
im Verzeichnis "C:\Windows\System32\wbem" löschen.
 
Anzeige
Oben