Anzeige

Am Puls von Microsoft

Anzeige

Treiberinstallation unmöglich?

Joker818

bekommt Übersicht
Hey,
nachdem ich bereits dank Dr. Windows Windows 7 auf meinen neuen Office-Rechner installieren konnte, zeigt sich das nächste Problem: Ich kann keine Treiber installieren
Da dieser PC kein internes Laufwerk hat kann ich nicht die MB-DVD einwerfen und so die Treiber installieren. Ein externes Laufwerk wird auch über USB 2.0 nicht erkannt. Auch USB-Sticks werden nicht erkannt. Für die Treiberinstallation braucht man halt Internet und damit den LAN-Treiber... Ich hoffe ihr versteht mein Problem.
Das System:
MB: ASRock H110M DGS
CPU: Intel Celeron G3900 (so. 1151, Skylake)
RAM: 4GB DDR4
Festplatte: 250GB Crucial BX200
 
Anzeige

build10240

gehört zum Inventar
Da dürfte bei der Erstellung der Iso-Datei mit den USB3-Treibern etwas schief gelaufen sein, so daß die USB-Treiber zwar ins Windows-Setup (Windows PE) integriert wurden, aber nicht in das Image, das während dem Setup auf die Festplatte kopiert wurde. In dem Zustand kannst Du im laufenden Windows keinerlei USB-Ports verwenden.

Lade Dir bei Intel https://downloadcenter.intel.com/de...8-9-100-und-C220-C610-Chips-tze?product=46644 oder bei ASRock ASRock > H110M-DGS die USB3-Treiber herunter. Dann kopierst Du die heruntergeladene Treiberdatei auf den USB-Stick, bootest nochmal vom Stick, öffnest mit Strg+F10 die Eingabeauforderung und kopierst die Treiberdatei auf die Festplatte. Die Buchstaben der Laufwerke sind im Windows-Setup evtl. andere. Du kannst auch in der Eingabeaufforderung einen Editor öffnen, dann hast Du einen rudimentären Datei-Explorer. Alternativ kannst Du auch irgendein Live-Linux vom USB-Stick booten, um die Treiberdatei auf die Festplatte zu kopieren. Nach dem Ausführen des Treibersetups in Windows sollten die USB-Port funktionieren.
 

Joker818

bekommt Übersicht
Soll ich den Stick vorher leeren oder können die Windows-Installationsdateien draufgelassen? Wenn ich Strg + F10 gedrückt habe kommt eine Art Konsole... Was muss ich da machen?
Danke im Voraus
 

build10240

gehört zum Inventar
Du mußt wieder vom Stick booten, also sollten die Installationsdateien natürlich darauf bleiben. Die Treiberdatei von Intel kopierst Du vorher zusätzlich auf den Stick.

In der Konsole (Eingabeaufforderung) kopierst Du die Treiberdatei mit dem Befehl copy vom Stick auf die Festplatte. Der Stick sollte Laufwerk X: sein und das Laufwerk mit Windows sollte C: sein. Der Befehl lautet dann - vorausgesetzt die Treiberdatei liegt direkt im Wurzelverzeichnis des Sticks - copy x:\Treiberdatei c:
 

Joker818

bekommt Übersicht
Also wenn ich über den Stick boote oder über die erstellte UEFI Partition, bringt Strg+F10 nichts und mir wird angezeigt Windows is loading files... + Ladebalken (wie bei ner Windows-Installation). Wenn ich über die Festplatte, auf der Windows installiert ist boote, komme ich mit der Tastenkombi in diese Konsole und wenn ich da copy x:\Intel_USB3(v4.0.2.42) c: eingebe passiert nix. Außerdem muss ich, das ist ein >Fehler< des MBs, im UEFI den PS2 Simulator aktivieren um in Windows normal meine Maus und Tastatur nutzen zu können. Um in der Konsole zu schreiben muss ich dies jedoch deaktivieren.
 

build10240

gehört zum Inventar
Wenn Runterladen wegen fehlender Netzwerkverbindung nicht möglich ist, ist der einzige Weg, die Treiberdatei anderweitig auf die Festplatte zu kopieren. Dazu gibt es mehrere Wege:
- Ein System von USB-Stick booten, das die Treiber schon integriert hat, und damit die Treiberdatei auf die interne Festplatte kopieren.
Ob das System das Windows-Setup oder ein Live-Linux ist, ist egal. Das Windows-Setup hast Du schon auf dem Stick, ein Live-Linux müsstest Du erst herunterladen und auf einen USB-Stick bootfähig auf einen USB-Stick schreiben. Für das Kopieren der Datei auf den Stick bzw. die Erstellung eines Live-Linux-Sticks benötigst Du natürlich einen anderen PC.
- Die Festplatte ausbauen, an einen anderen Rechner anschließen, das dortige System starten und die Treiberdatei kopieren.

Also wenn ich über den Stick boote oder über die erstellte UEFI Partition, bringt Strg+F10 nichts und mir wird angezeigt Windows is loading files... + Ladebalken (wie bei ner Windows-Installation).
Hatte mich vertippt. Ist Shift+F10 und das darfst Du erst drücken, wenn Du im Windows-Setup die Spracheinstellungen bestätigt hast.

Wenn ich über die Festplatte, auf der Windows installiert ist boote, komme ich mit der Tastenkombi in diese Konsole und wenn ich da copy x:\Intel_USB3(v4.0.2.42) c: eingebe passiert nix.
Kann auch nichts passieren, die Buchstaben gelten nur im Windows-Setup und nicht im laufenden Windows, das wie geschrieben sowieso nicht auf die USB-Sticks zugreifen kann.

Außerdem muss ich, das ist ein >Fehler< des MBs, im UEFI den PS2 Simulator aktivieren um in Windows normal meine Maus und Tastatur nutzen zu können.
Das ist kein Fehler, sondern auch eine Folge des fehlenden USB-Treibers. USB-Eingabegeräte können ohne die PS/2-Simulation im installierten Windows ohne den USB-Treiber nicht funktionieren.

PS: Es gibt auch noch einen anderen Weg, nämlich ein moderneres Betriebssystem als Windows 7 zu verwenden. Sowohl Windows 8.1 als auch Windows 10 und Linux haben diese Probleme mit USB-Treibern nicht.
 

Joker818

bekommt Übersicht
Danke,
Du sprichst davon, die Festplatte in einen anderen PC einzubauen...
Wieso bin ich nicht darauf gekommen xD
Also nur an anderen PC anschließen, normal hochfahren und dann sollte die Festplatte erkannt werden richtig?
Dann kann man ja ganz einfach die Treiber rüberkopieren...
 

Joker818

bekommt Übersicht
Oder hat Windows Probleme, wenn man 2 Festplatten mit installiertem Windows hat? Eigentlich sollte das ja funktionieren wenn man von der richtigen bootet
 
Anzeige
Oben