Anzeige

Am Puls von Microsoft

Anzeige

Unerwünschte Autostarts unterbinden

Martin

Webmaster
Teammitglied
Wie in den vorangegangenen Windows-Versionen werden sowohl in der Registrierung
als auch im Startmenü Autostart-Verknüpfungen angelegt.

Man kann wie gewohnt per msconfig einzelne Einträge deaktivieren, aber dann nervt
der Windows-Defender bei jedem Systemstart mit dem Hinweis, dass Autostarts
geblockt wurden. Eine Möglichkeit, das abzustellen, habe ich bisher nicht gefunden.

Der Software-Explorer (im Defender unter Extras) bietet die Möglichkeit,
Autostart-Programme anzeigen zu lassen und zu entfernen.
Leider musste ich jedoch feststellen, dass dort längst nicht alle Programme
angezeigt werden.

Also ist wieder Handarbeit angesagt.
In der Registrierung gibt es mehrere Stellen, wo sich Autostarts einnisten können.
Das hier sind die Pfade:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run
HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Run
HKEY_USERS\S-1-5-18\Software\Microsoft\Windows\CurrentVersion\Run
HKEY_USERS\S-1-5-19\Software\Microsoft\Windows\CurrentVersion\Run
HKEY_USERS\S-1-5-20\Software\Microsoft\Windows\CurrentVersion\Run
HKEY_USERS\S-1-5-21-3965892557-840090770-1349758376-1000
\Software\Microsoft\Windows\CurrentVersion\Run

Wow6432Node gibt es nur unter Vista 64-Bit, die Pfade unter HKEY_USERS heißen wohl
auf jedem System anders, weil sie an zweiter Stelle die Benutzer-ID enthalten.

Wie immer empfiehlt es sich, vor Änderungen an der Registry eine Sicherung
der entsprechenden Schlüssel anzulegen. Einfach mit der rechten Maustaste
anklicken und "exportieren" wählen.



Die Pfade zu den Autostart-Verknüpfungen im Startmenü haben sich, wie viele andere
Systempfade auch, geändert.
Zusätzliche Verwirrung stiftet, dass die Ordnernamen im Explorer Deutsch erscheinen,
in alternativen Dateimanagern wie z.B. dem Total Commander jedoch in Englisch.
Daher sind hier beide Versionen aufgelistet.

Autostart-Verknüpfungen für den aktuellen Benutzer

\User\<username>\AppData\Roaming\Microsoft\Windows\Startmenü\Programme\Autostart
bzw.
\User\<username>\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup


Autostart-Verknüpfungnen für alle Benutzer

\ProgramData\Microsoft\Windows\Startmenü\Programme\Autostart
bzw.
\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup

Möglicherweise ist das noch nicht vollständig, für Ergänzungen bin ich daher
dankbar :).
 

Anhänge

  • 837.jpg
    837.jpg
    71,5 KB · Aufrufe: 144
Zuletzt bearbeitet:
Anzeige
@Martin
Man kann wie gewohnt per msconfig einzelne Einträge deaktivieren, aber dann nervt
der Windows-Defender bei jedem Systemstart mit dem Hinweis, dass Autostarts
geblockt wurden.
(y)(y)

Eine Möglichkeit, das abzustellen, habe ich bisher nicht gefunden.
Aber ich.:D

Start>>Alle Programme>>Windows Defender,

Extras>>Software-Explorer, anzeigen klicken,
Kategorie: "Autostartprogramme",
weiter unten,
"Für alle Benutzer anzeigen" klicken
UAC abnicken und warten.
Dateiname "msconfig.exe" im "linken Fenster" raus suchen unterlegen und auf "entfernen" klicken.
Sicherheitsabfrage mit "Ja" bestätigen und Rechner neustarten.

Schon nervt die msconfig nicht mehr.:D

Anmerkung:
Dieser Vorgang muss nach jeder selbst vorgenommener Änderung in der "msconfig" wiederholt werden.;)

Hierzu wie (fast) immer nun die Bildchen.
Alles ohne Kommentar.:):)
 

Anhänge

  • msconfig nervt 1.JPG
    msconfig nervt 1.JPG
    22,2 KB · Aufrufe: 669
  • msconfig nervt 2.JPG
    msconfig nervt 2.JPG
    74,1 KB · Aufrufe: 893
  • msconfig nervt 3.JPG
    msconfig nervt 3.JPG
    123 KB · Aufrufe: 808
  • msconfig nervt 4.JPG
    msconfig nervt 4.JPG
    124,4 KB · Aufrufe: 857
  • msconfig nervt 5.JPG
    msconfig nervt 5.JPG
    112,8 KB · Aufrufe: 745
Zuletzt bearbeitet:
Es funktioniert auch, wenn man die Aktion einmal zulässt, dann bietet msconfig eine Option "Diese Nachricht nicht mehr anzeigen" an. Aber auch da kommt es nach der nächsten Änderung wieder.
 
Guter Tipp!
Aber bei mir wird die "msconfig.exe" nicht angezeigt.
Auch nicht unter Anzeige "Anzeige für alle Benutzer".

Was tun?
 
Guter Tipp!
Aber bei mir wird die "msconfig.exe" nicht angezeigt.
Auch nicht unter Anzeige "Anzeige für alle Benutzer".

Was tun?
 
Leider auch dann nicht! "Userinit.exe, WMPNSCFG.exe, sidebar, div. rundll32.exe, explorer.exe"! Nur keine "msconfig.exe".
Auch Systemdateiein sichtbar ist eingestellt!
 
Macht es einfach so:
Windows-Taste+R drücken und dann in die Zeile eingeben:
C:\Windows\System32\msconfig.exe
 
hi leute,

um autostarts anzuzeigen und auch abzustellen verwende ich "autoruns" von microsoft / systernals.

das funktioniert ab win2k sp4.

und um unerwünschte autostarts gar nicht aufkommen zu lassen verwende ich "startup-spy", das bei jedem programm, das sich in eine der autostart möglichkeiten eintragen will, nachfragt ob man das erlauben will.

echt geil :p


greetz


dj farwest
 
Zuletzt bearbeitet:
Anzeige
Oben