[gelöst] USB Port funktioniert nicht mehr (Windows 7)

henry123

nicht mehr wegzudenken
Hallo,

von jetzt auf gleich erkennt mein USB-Port keine USB-Sticks mehr.
Es geht um meinen Zweit-PC, darum stimmen die Systemangaben links unter "Meinem System" hier nicht.

Es ist egal welchen Stick ich einstecke, er wird bei
"Geräte in Wechselmedien" nicht angezeigt
(manchmal hört man aber den kurzen Signalton, der üblicherweise kommt wenn man einen Stick einsteckt, aber keine Anzeige unter Computer).

Im Gerätemanager wird unter USB-Contoller bei beiden USB-Massenspeichergerät ein Ausrufezeichen im Gelben Warndreieck angezeigt.

Wäre nett wenn ich Ratschläge bekäme, wie man das wieder hinbekommt.

Grüße
 
Anzeige

henry123

nicht mehr wegzudenken
@ Silberlocke
Ja, aber es sind ja verschiedene USB-Stick, da gezielt nach dem jeweiligen Treiber zu suchen
ist wohl unmöglich denn ich weiß ja noch nicht mal welchen Treiber dieser oder jener Stick braucht.

@ Robert Carven
- kann ich da nix schrotten?
- wie deinstalliere ich?

Grüße
 
E

Elloh

Gast
Abend henry123 :)
Zuerst bitte betreffendes USB Gerät/ oder auch USB Geräte aus den/dem USB Port(s) ausstöpseln.
Dann bitte den Gerätemanager aufrufen - über
WindowsTaste + r > devmgmt.msc eintippen > ENTER Taste

Oben, in der Menüleiste des Geräte-Managers auf > Ansicht > Ausgeblendete Geräte anzeigen anwählen (um die USB Geräte sehen zu können, die derzeit nicht mehr an den Computer angeschlossen sind, also auch Jenes was dieses evtl Treiberproblem aufweist).
Deinstalliere die unter dem Gruppen-Eintrag "USB-Controller" angezeigten aber ausgegrauten USB Einträge.
Geräte Manager USB Controller.png
(Rechtsklick auf den jeweiligen Eintrag > darunter dann "Deinstallieren" anwählen). Am besten alle ausgegrauten...sind bestimmt auch einige Treiberleichen dabei, welche nicht mehr benötigt werden & somit gleich weg sind/wären.
Danach den Gerätemanager schließen. Neustart des PCs. Auf dem Desktop angekommen,
betreffendes "Problem-USB Gerät" erneut einstöpseln & Windows etwas Zeit geben, den Treiber für den Port bzw. das erneut eingesteckte USB Gerät zu finden und nachzuinstallieren. Meist ist dies ein windowseigener USB Treiber, der dazu genutzt wird.

Jegliches deinstalliertes USB Gerät wird nach dem Neustart, erneut eingestöpselt, von Windows mit einem Treiber versehen eingebunden...du kannst also damit so nichts zerschießen ;).
Sollte dies nicht funktionieren, kann auch ein Defekt des USB Gerätes (oder auch ein Defekt des USBControllers bei einer externen HDD), Verursacher sein.
Demnach dann dieses USB Gerät an einem anderen PC austesten.

LG
 
Zuletzt bearbeitet:

henry123

nicht mehr wegzudenken
Hallo, super Beschreibung, leider hatte ich keinen Erfolg.

Beim einstöpseln kommt der Ton, das ein Gerät anzeigt,
aber sonst passierte erstmal nix.

Dann habe ich das ganze nochmal wiederholt und dabei vergessen die
beiden Stick´s vorher zu entfernen, dann begann zwar nach dem einstöpseln
der beiden Stick´s eine Treibersuche, aber die wurde als erfolglos beendet.
(Sind zwei unterschiedliche Stick´s und ich glaube nicht das die beim ersten Auftretn des Problem´s gleichzeitig den Geist aufgegeben haben).
Habe ich durch das vergessene ausstöpslen die Stick´s nun ruiniert, oder war das nicht schlimm?
 

Anhänge

  • Bild1.PNG
    Bild1.PNG
    52,5 KB · Aufrufe: 2.442
  • Bild 2.PNG
    Bild 2.PNG
    28,2 KB · Aufrufe: 2.475
E

Elloh

Gast
Nein - ruiniert hast du sie definitiv damit nicht, lediglich (bei laufendem Betrieb, bzw dem Versuch) deinstalliert, aber das macht so den Sticks gar nichts.
Hängen diese Sticks an einem USB Hub - also einem USB Mehrfach-Verteiler? Wenn dem so ist, diesen mal weglassen und versuche die Sticks an den/die bisherigen oder einem der anderen möglichen USB Port direkt anzuschließen.

Ggf, sofern keine unwiederherstellbaren wichtigen Dateien darauf liegen, könnte auch eine Formatierung des Sticks dem Einbinden ins System wieder auf die Beine helfen. Gibt es leider mal ab und an. Hab hier leider auch so einen Stickkandidaten, der des öfteren etwas zickig ist.

LG
 
Zuletzt bearbeitet:

henry123

nicht mehr wegzudenken
Sticks werden direkt am jeweiligen USB Port eingestöpselt.

Die Daten auf den jeweiligen Sticks sind schon wichtig,
glaube auch nicht das es an den Sticks hängt.

Habe anbei nochmal ein Bild, nachdem ich unabhängig von den Sticks mal versuchete die USB Porttreiber zu aktualisieren

Zu dem Problem mit Fehler 52 habe ich was gefunden, aber keine Ahnung wie es durchgeführt wird.
Wäre das eine Lösung, denn wie bei mir wird in dem Problem der Treiber als aktuell angezeigt und daher nicht erneuert,
aber anscheinend ist die Signatur abgelaufen.

https://www.cc-community.net/threads/win7-usb-massenspeicher-treiber-code52.97784/
usbstor.sys war die fehlerhafte Datei
Nach löschen aus dem drivers-Ordner und rüberkopieren aus ...\DriverStore\FileRepository\usbport.inf... wo eine andere Dateiversion vorhanden war läufts nun doch wieder.
 

Anhänge

  • Bild 3.PNG
    Bild 3.PNG
    23,7 KB · Aufrufe: 3.383
Zuletzt bearbeitet:
E

Elloh

Gast
Hmmm? Da bin ich leider soweit mal am Ende meines Lateins angekommen. Evtl die Systemwiederherstellung bemühen, in der Hoffnung, dass in der Nähe des Datums des Erstauftretens ein Systemwiederherstellungspunkt hinterlegt worden ist.
Evtl meldet sich noch ein Mitexperte, der noch eine weitere Idee dazu hat.

Mein vorläufig letzter Lösungsansatz wäre der, den Chipset Treiber/ ggf sogar den eigenständigen USB Treiber für dein Board versuchen zu aktualisieren, worüber der evtl beschädigte Treiber ersetzt würde. Doch das ist zu spekulativ, als dass ich dies mit Gewissheit sagen könnte. Sorry.
Besteht die Möglichkeit, die Sticks an einem anderen PC zu testen?

Ich stimme dir aber auf jeden Fall zu, dass es ist höchst unwahrscheinlich ist, dass beide Sticks zur selben Zeit den Geist aufgeben.

LG
 

henry123

nicht mehr wegzudenken
Schein wohl das die Signatur das Problem ist

Ach ja nochmal von vorhin, wie bekomme ich auf "aufgeraute " Geräte angezeigt, da war ja nix bei mir wie das Bild oben zeigt.
 

Anhänge

  • Bild4.PNG
    Bild4.PNG
    18 KB · Aufrufe: 3.199
E

Elloh

Gast
Wenn keine unnützen Einträge, resp. derzeit nicht benutzen USB Teile Einträge im Gerätemanger vorhanden sind, werden diese auch nicht angezeigt. Das heißt dann aber auch, das alle USB Teile angeschlossen sind und keine anderen angeschlossen waren. Ansonsten sieht man diese, in dem man über die Menüleiste Ansicht > Ausgeblendete Geräte anzeigen, wie oben beschrieben.
Aufnahme8.png
hier im Screen kann man den Unterschied sehr gut erkennen.

LG
 
C

chris02

Gast
Hallo henry123

Um eine genauere Ansicht des Gerätemanagers, ähnlich wie von Elloh in Beitrag 11 (Bild) zu bekommen, ist es notwendig einige Schritte durchzuführen.

Bitte öffne die Systemsteuerung > System > Erweiterte Systemeinstellungen > Umgebungsvariablen

Gerätemanager Umgebungsvariablen.png

Im unteren Abschnitt (Systemvariablen) bitte den Button Neu anklicken und in das Feld >Name der Variablen< folgendes eingeben: devmgr_show_nonpresent_devices und danach ins untere Feld: 1
Mit Okay bestätigen.

Nun ein zweites Mal wieder auf Neu klicken. In das obere Feld diesmal: devmgr_show_details und unten wieder die Zahl Eins.
Mit Okay abschliessen.

Umgebungsvariablen.png

Bitte die einzelnen Wörter ohne Leerzeichen schreiben, nur mit Unterstrich verbinden.

Vor und während dieses Vorgangs bitte den Gerätemanager geschlossen halten.
Nach der Fertigstellung kann der Gerätemanager gestartet werden und nun werden wie schon von Elloh beschrieben (Ansicht > Ausgeblendete Geräte anzeigen), alle ausgegrauten Elemente angezeigt.
Bitte nicht erschrecken, es kann sehr viel mehr sein, als zuvor.

LG
 

henry123

nicht mehr wegzudenken
Hallo chris02,

habe es so gemacht und waren dann tatsächlich ergraute dabei. Ich habe die alle gelöscht, sowie den Eintrag mit dem Ausrufezeichen im gelben Warndreieck.

Nach dem Neustart habe ich wieder Stick´s eingesteckt und das gleiche Spiel, der PC merkt das ein Stick eingesteck wurde und versucht Software zu installieren, aber es gibt dann an, das es nicht geklappt hat.

Ich frage mich immer noch ob das ersetzen der Datei usbstor.sys mit einer älteren Version bringen wurde. Datei usbstor.sys finde ich und auch zwei Pfade DriverStore\FileRepository\usbport.inf_amd64 finde ich, jedoch keine Datei darunter die usbstor.sys heißt.

Komisch finde ich auch das ich genau darunter eine komplett blaues Verzeichnis habe (alle anderen sind schwarz) mt dem Namen DRVSTORE. mit Ordnern hotcorex64 und USB Filter. Das nur nebenbei bemerkt, weil eben alle anderen Ordner schwarz sind.
 

henry123

nicht mehr wegzudenken
Den USB 3.0 Host Controller habe ich schon aktualisiert.
Bei mir ist es der Gerätemanager, der spinnt.
Wenn ich updaten will, sagt er mir das der Treiber aktuell ist (vom 21.06.2006!),
und ich finde keine alte Version zum zurück spielen.
=> wenn das überhaupt die Lösung ist.

Die Datei c:\Windows\System32\drivers\USBSTOR.SYS ist nicht zerfifiziert,
kann wohl daran liegen, wenn man Fehler 52 liest.
Und oben habe ich beschrieben das mit dem Austausch dieser Datei einer
das Prob. vom Haken bekommen hat, leider finde ich die Kopie nicht auf meiner Festplatte...

Up-Date:

Nachfolgend einen Weg, wie ich es hinbekommen habe. Sicher ist es wohl nicht der einzige und evt. auch nicht perfekt, aber besser als keine Rückmeldung (mich ärgert immer wenn Leute nach Erledigung ihres Problem sich nicht mehr melden).
Kurzversion:
Datei c:\windows\system32\drivers\USBSTOR.SYS von groß auf Kleinschreibung umbenennen.
problematischer USB-Massenspeicher im Gerätemanager deinstalliert.
Datei: c:\windows\system32\driverstore\INFCACHE1 löschen.
Langversion:
Also das Problem war das der USB-Massenspeicher einen Treiber hat, der offensichtlich kein Zertifikat mehr hatte.
Und zwar c:\Windows\system32\drivers\USBSTOR.SYS kam dann mit Fehlercode 52 (siehe oben).
Diese Datei habe ich, nachdem ich mir die Adminrechte vollständig gegeben habe ich umbenannt in ...USBSTORSalt.SYS. und kopiert.
Dann die Ursprungsdatei wieder umbenannt ..usbstors.sys (also das gleiche wie vorher nur klein geschrieben). Und dann unter Gerätemanager den fehlerhaften Eintrag komplett deinstalliert.
Weiter habe ich unter c:\Windows\system32\driverStore die Datei INFCACHE.1 (nachdem ich mir die Adminrechte vollständig gegeben habe) komplett gelöscht.

Dann Neustart und nachdem der Desktop erscheint wird nach Gerätesoftware gesucht und im Gegensatz zu den Versuchen vorher, wird dann richtig installiert.

Danach ist die INFCACHE.1 wieder neu da und die Datei USBSTOR.SYS erscheint wieder in Großbuchstaben und nun statt mit 89 kB mit 90 kB, und nicht mehr mit Datum 12.05.2010. sondern mit Datum 11.02.2011.
Das gelbe Warnschild mit Ausrufezeichen ist im Gerätemanager beim USB-Massenspeicher verschwunden und die Treiber-Datei c:\Windows\system32\drivers\USBSTOR.SYS wird nun als zertifiziert angezeigt. USB-Stick wird erkannt.

Ich habe mir nun die Dateien c:\Windows\system32\drivers\USBSTOR.SYS und c:\Windows\system32\driverStore\ INFCACHE.1 extra kopiert und wenn da Problem wieder auftritt versuche ich einfach mal mit diesen Kopien die Dateien am Ursprungsort zu überschreiben.

Tja, das war es. Hoffe ich konnte anderen mit dem gleichen Problem etwas helfen.

Nachtrag: Medion hatte vorgeschlagen den Chipsatztreiber, der unter D: zu finden ist, neu zu installieren, das hat bei mir nichts gebracht, zum einen weil ich bereits einen aktuelleren installierte hatte (und er dann den alten nicht wieder einspielt) und auch das keine Lösung war.
 
Zuletzt bearbeitet:
E

Elloh

Gast
Danke für dein Feedback und deine Lösungsbeschreibung. Bin mir sicher, dass diese Vorgehenweise das ein oder andere Mal auch ein Problemlöser sein wird, der das Problem mit fehlerhaften USB Treibern im Kontext Fehler 52 lösen kann. Gerade dann, wenn USB Geräte zuvor immer problemlos liefen aber fast auszuschließen ist, dass der USB Controller des USB Gerätes defekt ist. (y) Super

LG
 
Zuletzt bearbeitet:

StefanKlenke

Erster Beitrag
Du bist mein HELD!!! Du hast es echt geschafft auch mein Problem zu loesen! DAAAAAANKEEEE!!!



Den USB 3.0 Host Controller habe ich schon aktualisiert.
Bei mir ist es der Gerätemanager, der spinnt.
Wenn ich updaten will, sagt er mir das der Treiber aktuell ist (vom 21.06.2006!),
und ich finde keine alte Version zum zurück spielen.
=> wenn das überhaupt die Lösung ist.

Die Datei c:\Windows\System32\drivers\USBSTOR.SYS ist nicht zerfifiziert,
kann wohl daran liegen, wenn man Fehler 52 liest.
Und oben habe ich beschrieben das mit dem Austausch dieser Datei einer
das Prob. vom Haken bekommen hat, leider finde ich die Kopie nicht auf meiner Festplatte...

Up-Date:

Nachfolgend einen Weg, wie ich es hinbekommen habe. Sicher ist es wohl nicht der einzige und evt. auch nicht perfekt, aber besser als keine Rückmeldung (mich ärgert immer wenn Leute nach Erledigung ihres Problem sich nicht mehr melden).
Kurzversion:
Datei c:\windows\system32\drivers\USBSTOR.SYS von groß auf Kleinschreibung umbenennen.
problematischer USB-Massenspeicher im Gerätemanager deinstalliert.
Datei: c:\windows\system32\driverstore\INFCACHE1 löschen.
Langversion:
Also das Problem war das der USB-Massenspeicher einen Treiber hat, der offensichtlich kein Zertifikat mehr hatte.
Und zwar c:\Windows\system32\drivers\USBSTOR.SYS kam dann mit Fehlercode 52 (siehe oben).
Diese Datei habe ich, nachdem ich mir die Adminrechte vollständig gegeben habe ich umbenannt in ...USBSTORSalt.SYS. und kopiert.
Dann die Ursprungsdatei wieder umbenannt ..usbstors.sys (also das gleiche wie vorher nur klein geschrieben). Und dann unter Gerätemanager den fehlerhaften Eintrag komplett deinstalliert.
Weiter habe ich unter c:\Windows\system32\driverStore die Datei INFCACHE.1 (nachdem ich mir die Adminrechte vollständig gegeben habe) komplett gelöscht.

Dann Neustart und nachdem der Desktop erscheint wird nach Gerätesoftware gesucht und im Gegensatz zu den Versuchen vorher, wird dann richtig installiert.

Danach ist die INFCACHE.1 wieder neu da und die Datei USBSTOR.SYS erscheint wieder in Großbuchstaben und nun statt mit 89 kB mit 90 kB, und nicht mehr mit Datum 12.05.2010. sondern mit Datum 11.02.2011.
Das gelbe Warnschild mit Ausrufezeichen ist im Gerätemanager beim USB-Massenspeicher verschwunden und die Treiber-Datei c:\Windows\system32\drivers\USBSTOR.SYS wird nun als zertifiziert angezeigt. USB-Stick wird erkannt.

Ich habe mir nun die Dateien c:\Windows\system32\drivers\USBSTOR.SYS und c:\Windows\system32\driverStore\ INFCACHE.1 extra kopiert und wenn da Problem wieder auftritt versuche ich einfach mal mit diesen Kopien die Dateien am Ursprungsort zu überschreiben.

Tja, das war es. Hoffe ich konnte anderen mit dem gleichen Problem etwas helfen.

Nachtrag: Medion hatte vorgeschlagen den Chipsatztreiber, der unter D: zu finden ist, neu zu installieren, das hat bei mir nichts gebracht, zum einen weil ich bereits einen aktuelleren installierte hatte (und er dann den alten nicht wieder einspielt) und auch das keine Lösung war.
 

Dersa

Herzlich willkommen
:) Muss auch noch mal ein manuelle Dankeschön an die Beschreibung von Elloh auf Seite 1 los lassen. Die USB Geräte wurden bei mir auch allesamt nicht mehr erkannt. Habe sehr langen herumgegooglelt, nur nutzlose Beschreibungen auf Seiten wie CHIP gefunden. Auf einer stand sogar, wenn xxx nicht der Fall, dann sind die USB Sticks defekt. Und dann bin ich auf das alte gute Dr. Windows Forum zurückgekommen und hab zum Glück durchs googeln diesen Beitrag gefunden

Ich muss sagen dieses Forum ist echt genial - und die Leute, die sich hier engagieren sind einfach klasse :) (y)

Ohne Euch hätte ich das nicht hinbekommen :).
 
Oben