Anzeige

Am Puls von Microsoft

Anzeige

Frage Verzögerter Downloadstart seit Version 103 - Probleme mit PDF-, Word- und Excel-Dokumenten in Verbindung mit Proxy-Server

Dietmarr

Herzlich willkommen
Hallo zusammen,

seit dem Update auf die Version 103 haben wir ein Problem mit dem Download von PDF, Word und Excel Dokumenten in Verbindung mit unserem Proxy Server. Klickt man den Link zu einem dieser Dokumententypen an, dauert es ziemlich genau 20sec. bis oben rechts angezeigt wird, dass der Download startet. Das Problem besteht sowohl bei Dateien die wir aus unserem internen Intranet herunterladen wie auch bei Dateien aus dem Internet. Lädt man eine andere Datei, z.B. eine exe Datei herunter startet der Download sofort.

Der Edge scheint beim Download dieser Dateitypen mit „zuhause telefonieren“ zu wollen, was aber über unseren Proxy Server scheinbar nicht durch geht. Öffnet man testweise einen direkten Internetzugang für den PC, gibt es keine Verzögerung. Auch besteht das Problem mit den Versionen vor der 103 definitiv nicht. Auch mit dem Chrome besteht das Problem nicht.

Weiß zufällig jemand, was Microsoft da in Verbindung mit Office und PDF Dokumenten da neues eingebaut hat und wie man das dem Edge wieder abgewöhnen kann? Dauerhaft eine direkte Internetverbindung freizugeben ist natürlich keine Option und über die Firewall sieht man nur, das der Edge mit irgendwelchen Azure IP Adressen auf Port 443 kommunizieren will.

Gruß Dietmar
 
Zuletzt bearbeitet von einem Moderator:
Anzeige

Shurik

nicht mehr wegzudenken
Hallo Dietmarr,

versuche bitte testweise diese Optionen zu deaktivieren. Wenn danach die Downloads unverzögert geladen werden, kann man das Problem auf Defender eingrenzen.
1656934548078.png

Gruß
Shurik
 

PeterK

eben noch da
Oder verwendet einfach einen anderen Browser der eben nicht nach hause Telefoniert, wo ist das Problem?

Um da ganze Geschrei unserer Mitarbeiter zu umgehen habe ich mittlerweile sämtlichen Rechnern neben Edge, Firefox, Google Chrome und LibreWolf hinzugefügt, jeder kann nun verwenden was er möchte oder wonach im der sinn steht.
 

Dietmarr

Herzlich willkommen
Hallo Shurik,

Volltreffer! Die Einstellung "SmartScreen für Microsoft Edge" verursacht das Problem, da muss man auch mal drauf kommen, danke Dir!!

Da wir über unsere Endpoint Protection Software auch einen Webfilter haben, können wir meiner Meinung nach auf diese Einstellung verzichten. Kennt zufällig jemand die GPO Einstellung, mit der man diesen abschalten kann?

@PeterK
Das ist in meinen Augen eine ganz schlechte Lösung. Denn erstens muss man dann auch dafür sorgen, dass alle Browser auch immer schon ihre Update machen und außerdem pflegen wir für Edge und Chrome Gruppenrichtlinien, das für alle Browser machen zu müssen ist dann doch ein ziemlicher Aufwand.

Gruß Dietmar
 

PeterK

eben noch da
Denn erstens muss man dann auch dafür sorgen, dass alle Browser auch immer schon ihre Update machen und außerdem pflegen wir für Edge und Chrome Gruppenrichtlinien, das für alle Browser machen zu müssen ist dann doch ein ziemlicher Aufwand.
Mit irgendwas muss ich mich ja auch beschäftigen.
 

Shurik

nicht mehr wegzudenken
[...] Kennt zufällig jemand die GPO Einstellung, mit der man diesen abschalten kann?
[...]

GPEDIT.msc
Computer Configuration > Administrative Templates > Windows Components > Windows Defender SmartScreen > Microsoft Edge
--> Configure Windows Defender SmartScreen: Disabled
1656936594932.png



Bitte spreche es im Vorfeld mit deinem IT-Administrator ab.
 

PeterK

eben noch da
Computer Configuration > Administrative Templates > Windows Components > Windows Defender SmartScreen > Microsoft Edge
--> Configure Windows Defender SmartScreen: Disabled
Das kann man zwar machen, kann aber nie im Leben Sinn und Zweck sein den Windows Defender SmartScreen auf Disabled zu setzen!
Da warte ich doch lieber die 20sec. bin aber auf der sicheren Seite.
 

Dietmarr

Herzlich willkommen
@Shurik
Die Einstellung habe ich gefunden. Wir haben allerdings auch die Edge Richtlinien installiert und dort gibt es noch weitere Einstellungen zu dem Smart Screen. Die Lösung war für uns jetzt unter:
"Computerkonfiguration - Richtlinien - Administrative Vorlagen - Microsoft Edge - SmartScreen-Einstellungen-Konfigurieren Sie die Liste der Domänen, für die Microsoft Defender SmartScreen keine Warnungen auslöst"
Da haben wir unsere Intranet Domäne angegeben und siehe da, die 20 Sekunden sind Geschichte.
Vielen Dank nochmal für Deine Hilfe, Du hast uns auf die richtige Spur gebracht.

@PeterK
Wenn Du diese 20 Sekunden in z.B. dem ERP System 50 mal am Tag hast, weil bei jeder AB, Lieferschein, Rechnung etc. oder zig mal im Intranet wegen jedem Formular oder Dokument welches Du benötigts, dann willst Du nicht mehr! Und wie geschrieben, bis zur Version 102 war das Problem nicht vorhanden, ist erst mit der 103 aufgetaucht. Was auch immer Microsoft da geändert hat.
 

PeterK

eben noch da
Wenn Du diese 20 Sekunden in z.B. dem ERP System 50 mal am Tag hast, weil bei jeder AB, Lieferschein, Rechnung etc. oder zig mal im Intranet wegen jedem Formular oder Dokument welches Du benötigts, dann willst Du nicht mehr!
Kann ich komplett verstehen, wir hatten auch so ein ähnliches Problem, weil da wieder mal was geändert wurde und anschließend wiedermal der Edge zur bearbeitung von PDF Dokumenten gestartet wurde, wir machen das halt seit jeher mit Adobe und deshalb hatte ich nun auch den Firefox zum herunterladen des Fertigen PDF Dokuments eingestellt.

Wir sind es mittlerweile so leid das nach jedem Edge Update, jedes Mal auf neue nachgefragt wird, ich war schon kurz davor den Edge in der GPO komplett zu sperren.
 

dagobert1984

Herzlich willkommen
Hallo zusammen,
wir haben das gleiche Probleme. Scheinbar kommt der SmartScreen mit dem Proxy nicht zurecht und läuft in einem TimeOut. Ohne Proxy start der Download sehr zeitnah.

Hat bei euch das Eintragen der Domäne in der GPO
"Configure the list of domains for which Microsoft Defender SmartScreen won't trigger warnings" geholfen?
Wenn ja, in welchem Format habt ihr das eingetragen?
Ich habe jetzt domäne / *domäne / *.domäne / .domäne - Das Verhalten ändert sich dadurch nicht.
 

Dietmarr

Herzlich willkommen
Ja in den Computerrichtlinien. Hier mal ein Screenshot was ich alles aktiviert habe

1657111106463.png


und beim 4. Punkt natürlich noch den Domainnamen der internen Webserver eintragen.

Hast Du Dir die neuesten Richtlinien für Edge bei Microsoft heruntergeladen?
 

dagobert1984

Herzlich willkommen
Hab die Policy mal genauso gesetzt inkl. aktuellster Edge Templates - hilft nicht.
Wir haben die Smartscreen Funktion im Edge jetzt bei allen Deaktiviert.
 
Anzeige
Oben