Anzeige

Am Puls von Microsoft

Anzeige

System Wiederherstellung funktioniert nicht

mirovb

nicht mehr wegzudenken
Hallo zusammen.

Habe grosse Probleme. Und zwar funktioniert die System Wiederherstellung bei mir nicht. Ich kann zwar manuelle Sicherungspunkte erstellen. Aber sonst werden keinerlei Sicherungspunkte wie zb bei Installationen oder automatische Punkte gesetzt.

Des Weiteren läuft die Windows Update Funktion auch nicht mehr richtig. Sie sucht gar keine Updates mehr. Manuell findet Sie aber was.

Ich habe Windows 8 jetzt bereits 2 mal komplett neu installiert.

Ganz am Anfang hat es noch funktioniert. Ich denke irgend ein Update von Windows hat das verursacht. Ich konnte es jedoch nicht eingrenzen oder beheben.

Habt ihr auch so etwas festgestellt? Für mich sind diese beiden Funktionen sehr wichtig.
 
Anzeige

mirovb

nicht mehr wegzudenken
Ich habe festegestellt, das der Dienst System Restore bzw. Systemwiederherstellung bei mir gar nicht starten kann. Er fehlt in den Diensten völlig. Also taucht er auch nicht in der MSConfig als gestarter Dienst auf.

Des Wegen geht es nur manuell einen System Wiederherstellungspunkt zu erstellen. Damit ruft man einfach die rstui.exe im Windows32 System Ordner auf. Die steht ja dafür.

Aber wie und wann ist das passiert und wo ist der Dienst hin ?! Habt Ihr diesen in Euren Diensten am laufen ?!

Er wird zwar von mir als zu startender Dienst im Aufgabenplaner angezeigt, läuft aber natürlich nicht da nicht vorhanden. Protokoll natürlich auch leer ?!

Habt Ihr den Dienst System Restore oder Systemwiederherstellung in Windows 8 Pro 64 Bit ?!
 

Franz

Moderator
Der Dienst nennt sich "Volumenschattenkopie". Dieser sollte auf "Automatisch" gesetzt sein.
Wieviel GB hast du Windows für die Wiederherstellung eingeräumt?
 

mirovb

nicht mehr wegzudenken
Volumenschattenkopie steht auf manuell. In den meisten Listen im Internet soll dieser standardmäßig auch so stehen. Hatte ihn versuchsweise auf auto gestellt. Es macht keinen Unterschied. Egal, ob ich etwas installiere oder deinstalliere. Es werden keine Punkte gesetzt. Auch nicht automatisch. Also die Punkte, die fast täglich gesetzt werden.

Nur die manuell erstellten tauchen auf.

Kurz nach der Neuinstallation, als ich die ersten Windows Updates installiert hatte, wurde ein automatischer Punkt erstellt. Wichtiges Update installiert. Danach nichts mehr. Doch zu dem Wiederherstellung Punkt kann ich nicht zurück. In der Zwischenzeit habe ich alle meine Programme installiert. Habe gehört, das software von auslogics auch Probleme in der Hinsicht macht. Habe diese jedoch nicht installiert. Ich tippe auf ein Problem mit einem Windows Update oder mit dem Framework.

Edit ca. 10 gb stehen für die Wiederherstellung auf c: zur Verfügung.
 
Zuletzt bearbeitet:

Franz

Moderator
Hmm,

10 GB sind in meinen Augen reichlich wenig für Sicherungsdateien. Erhöhe den Speicherplatz testweise auf 25% des Gesamtvolumens.
 

Franz

Moderator
Hmm,

wir sollten uns die Einstellungen von SystemRestore in der Aufgabenplanung detailliert anschauen, wenn du den Dienst auf "Manuell" gesetzt lassen möchtest. Kannst du uns diese bitte posten (auch Trigger, Allgemein, Aktionen, Bedingungen, Einstellungen, etc.)?

task1.jpg

Hinsichtlich automatische Windows Updates - um welche Updates handelt es sich, die du manuell installieren mußt?
Z.B. werden Defender/Security Essentials-Updates generell nur als optionale Updates angeboten.
 

McC.

gehört zum Inventar
@mirovb
zu den updates : wenn du in der systemsteuerung nachschaust, dauert es ein wenig bis die anzeige von ''...zuletzt gesucht'' aktuallisiert wird.es wird nicht mehr sofort der zeitpunkt , wann windows zuletzt nach updates gesucht hat , angezeigt...

mfg McC.
 

mirovb

nicht mehr wegzudenken
OK. Danke. Windows Updates scheint jetzt - endlich - wieder nach 4 Tagen automatisch nach Updates zu suchen. Das zeigt mir die letzte Suche mit Datum und Uhrzeit an. Aber - und obwohl Ich nicht gemacht habe - sind gar keine Verläufe mehr über alle installierten Updates zu sehen. Irgend wann ist das ganze gelöscht worden.

Bezüglich System Wiederherstellung: es geht einfach nicht. Ich habe ein Image meines Systems erstellt, und dann diverse Dinge installiert und deinstalliert (Virenscanner Avast, Geforce Treiber, etc.). Es werden keine Wiederherstellungspunkte gesetzt.

Ich habe versuchsweise den Dienst Volumenschattenkopie mal auf "Auto" gestellt. Es hat auch nicht gebracht.

Habe mein System mal auf einen Virus hin überprüft. Weder AVAST noch AVG zeigen etwas an.

Dann habe Ich Windows noch einmal aufgesetzt. Ohne Treiber etc. Nur WLAN.

Und habe erneut das erste Windows Update eingspielt. Davor hat er den einzigen Wiederherstellungspunkt gesetzt. Danach wieder weiter installiert. Und dann wurden wieder keine Wiederherstellungspunkte gesetzt.

Ich denke, dieses erste Update ist der Schlüssel. Obwohl Ich mir nicht wirklich sicher bin.

Mein System sollte schon Up-To Date sein. Und meine Software brauche Ich auch.

@FRanz, Ich post mal heute abend meine Einstellungen in der Aufgabenplanung.

Danke für Eure Super Hilfe.
 

hansjorg71

gehört zum Inventar
Hallo,
Z.B. werden Defender/Security Essentials-Updates generell nur als optionale Updates angeboten.
Bei Win 8 werden die Updates für den Defender bei "Wichtig" angezeigt ! ;)

Gruß :)
Ps. habe meinen SystemRestore in der Aufgabenplanung so eingestellt,dass er bei jedem Systemstart einen Wiederherstellungspunkt erstellt ! ;)
(Da ich Multiboot mit Win 7 habe und beim Start von Win 7 alle Punkte ja gelöscht werden.)
 
Zuletzt bearbeitet:

mirovb

nicht mehr wegzudenken
Ich habe das Problem einkreisen können. In der Aufgabenplanung ist alles richtig eingestellt für System Restore bzw SR. Es wird vom System wohl auch versucht automatisch System Punkte zu erstellen. Jedoch steht in der Statuszeile der Aufgabenplanung ständig "die Aufgabe wurde vom vom Operator oder Administrator zurück gewiesen". Im Verlauf kann man deutlich sehen, das dauernd diese Aufgabe startet. In den Einstellungen ist aber auch eingestellt, das die Aufgabe unabhängig vom User bzw. Anmeldung starten soll. Also vom System.

Ich bin doch als User Administrator registriert.

Na ja. Jedenfalls sind die Einstellungen alles Standard. Ein anderer User hat mir die Einstellungen gemailt.

Ich hab mal versucht per Trigger was zu ändern. Aber es steht dort immer die gleiche Meldung. Ich vermute hier ein Rechte Problem durch ein Update. An dem Rechner sind 2 User registriert. Beide als Administrator. Aber egal. Es funktioniert bei beiden nicht.
 

hansjorg71

gehört zum Inventar
Hallo, schaue doch mal ob du auch wirklich Administrator bist ! ;)

Die Windows-Taste und die Taste R, im Dialogfenster cmd eingeben und bestätigen mit OK. In das Fenster der Eingabeaufforderung folgendes eingeben whoami /groups und die Enter-Taste. Nun wird angezeigt, bei welchen Gruppen der aktuelle Benutzer Mitglied ist. Der Inhalt des Fensters lässt sich mit Hilfe der Bildlaufleiste komplett betrachten. Das aktive Anwenderkonto verfügt über Administratorrechte, wenn in den Gruppeninformationen der Gruppenname „Administrators“ aufgeführt ist. (Bild)
administrator.JPG

Gruß :)
Ps.
Ein anderer User hat mir die Einstellungen gemailt.
Zeige uns doch diese Einstellungen ! ;)
Ps. nimm mal dieses Tool Quick Restore Maker , QRM3.exe starten und es wird sofort ein Wiederherstellungspunkt erstellt ! :D
 

Anhänge

  • QRM3.zip
    46,5 KB · Aufrufe: 157
Zuletzt bearbeitet:

mirovb

nicht mehr wegzudenken
User.jpg
Allgemein SR.jpg
Bedingungen SR.jpg
Einstellungen SR.jpg
Trigger SR.jpg
Verlauf SR.jpg
Statuszeile SR.jpg

So, hier meine Einstellungen. Laut denen habe Ich Administrator Rechte. Der PC Name ist dort hinterlegt, aber nicht mein User Name. In den Benutzereinstellungen sind aber beide User als Admin definiert. Wir können ja auch sonst alles ausführen, rechtemässig.

Wie schon gesagt, Ich habe jetzt auch mal probiert für den Task auf einen anderen User zu switchen, es brachte aber nichts.

Im Verlauf sieht man, das der Task gestartet wird. Aber erscheint immer die "zurückgewiesen vom Operator oder Admin..." Fehlermeldung.

Ach ja, der QuickRestoreMaker funktioniert, geht ja auch so manuell.

P.S. Zwei Screenshots habe Ich versehentlich hochgeladen, habe da probiert den Task nicht von "System", sondern als "User" auszuführen. Was auch nicht brachte. Es steht aber wieder alles auf "SYSTEM".
 

Anhänge

  • Aktion SR.jpg
    Aktion SR.jpg
    59,1 KB · Aufrufe: 333
  • Allgemein SR.jpg
    Allgemein SR.jpg
    90,5 KB · Aufrufe: 323
  • Statuszeile SR.jpg
    Statuszeile SR.jpg
    263,3 KB · Aufrufe: 269
Zuletzt bearbeitet:

McC.

gehört zum Inventar
...es scheint , als erfülle das System nicht die nötigen Leerlaufbedingungen (z.B. ''idle for ?? min'') und der Task wird deshalb zurückgewiesen(manuelles Erstellen scheint ja zu funktionieren??) , geänderte kritische Systemeinstellungen oder ständig laufende Hintergrundprozesse (inkl. Malware) können, meiner Meinung nach , auch in Frage kommen.

mfg McC.
 

mirovb

nicht mehr wegzudenken
Das könnte eine Möglichkeit sein. Unter Windows 7 hat ein und dasselbe noch einwandfrei funktioniert. Ich werde mal ein paar Dienste abstellen (3d Party) und dann mal probieren, ob es funzt. Jedoch, es ging ja schon nach dem ersten Update nicht mehr. Und da war keine Software ausser Windows 8 drauf. Und wenn ich an den Parametern für Leerlauf oder ähnlichen was andere, geht es auch nicht.
 

mirovb

nicht mehr wegzudenken
Okay, Reinhold. Ich hab zwar schon nach Viren und Malware gescannt. Probiere das aber auch noch. Danke für die Super Hilfe.
 

mirovb

nicht mehr wegzudenken
Ne. Ich komme nicht weiter.
Keine Malware gefunden, Dienste habe Ich alle Drittanbieter deaktiviert.
Im Leerlauf war keinerlei Prozess aktiv, habe das kontrolliert. Er setzt automatisch keine Punkte.
Ich habe den Ordner System Volume Information mal probeweise umbenannt und den Inhalt gelöscht (nachdem Ich mir die Rechte gegeben habe). Vorher habe Ich den Dienst Volumenschattenkopie und Systemwiederherstellung und Task deaktiviert. Anschliessend neu gestartet und nochmals alle wieder eingeschaltet.

Es bringt alles nichts. Bei keinem Installations-oder Deinstallationsvorgang werden weiterhin keine Punkte gesetzt. Ebenso auch sonst nicht. Die Liste bleibt leer.

So langsam weiss Ich nicht mehr weiter. Ich muss wohl mit den manuellen Punkten leben. Eine dritte Neuinstallation kommt für mich nicht in Frage.
 

hansjorg71

gehört zum Inventar
@mirovb schaue doch mal in den Gerätemanager ob dort die Schattenkopien existieren ! ;)
Gerätemanager>>Ansicht>>Ausgeblendete Geräte anzeigen>>Speicher-Volumeschattenkopien dort werden alle Standard-Volumeschattenkopien angeführt ! :) (Bild)

Was ich bei meinem Win 8 bemerkt habe ist folgendes, mache ich manuell einen Punkt wird dieser auch voll erzeugt und gespeichert ! Nach einer Std. mache ich wieder manuell einen Punkt, dieser wird auch gestartet aber nicht gespeichert ! :ROFLMAO:
Ich bin Überzeugt Win 8 überwacht dieses und findet, dass keinerlei Systemänderungen in dieser Zeit erfolgten, brauche daher keinen neuen Punkt erstellen ! :D (Speicherplatz sparen) ;)

Gruß :)
 

Anhänge

  • speicher-volumeschattenkopie.JPG
    speicher-volumeschattenkopie.JPG
    66,8 KB · Aufrufe: 229

mirovb

nicht mehr wegzudenken
Ich werde das mal checken, sobald Ich daheim bin. Es klingt ganz logisch und vernünftig, was Du sagst.

Bei mir ist es aber so, das Ich so viele manuelle Punkte erstellen kann, wie Ich möchte. Auch wenn nichts geändert wurde, diese tauchen bei mir in der Liste auf.

Das Wiederherstellen der Punkte läuft auch einwandfrei.

Aber: Die Systemwiederherstellung ist ja nicht nur für die Geräte System Treiber zuständig, sondern es sollten auch automatisch Punkte vor Wichtigen Updates oder Software (DE-) Installationen gesetzt werden. Wie zB Office 2010, Antivirus, Image Programme wie Acronis oder Paragon Festplatten Manager, etc, etc. Diese Programme greifen ins System ein. Aber die Wiederherstellung speichert NICHTS bei mir. Das ist es, was mich ärgert.

Und in Windows 7 lief das einwandfrei.

Wie ist das in der Hinsicht bei Euch, wenn Ihr etwas de- und installiert, werden da Speicherpunkte erstellt ?! Bei mir leider weder in diesen Situationen, noch überhaupt welche automatisch.

Es wäre ja auch unlogisch, wenn Ich vor 5 Tagen einen Punkt manuell erstellen, sich zwar seitdem an den Gerätetreibern nicht geändert hat, jedoch zig Sachen de-und installiert wurden.

Da würde es mir überhaupt nicht helfen, auf einen alten Punkt wiederherzustellen, wenn Ich danach bereits 6 neue Programme drauf habe. Da müsste man ja alles danach neu installieren.
 
Anzeige
Oben