Anzeige

Am Puls von Microsoft

Anzeige

System Windows Desktop nicht anklickbar

formmue

Herzlich willkommen
Hallo!

Ich habe seit kurzem ein Problem, zu dem ich zwar in der Suche schon viel ähnliches finden konnte, aber noch keine Lösung, die bei mir passt.

Ab und zu (unbregelmäßig, genau den Grund/Auslöser suche ich!) kommt es vor, dass nach dem Öffnen eines Fensters plötzlich alle anderen Fenster einschl. Desktop, Taskbar und Charms mit der Maus nicht mehr erreichbar sind.

Bsp. gestern Abend:
  • Ich habe zwei Fenster geöffnet: Explorer und Win-8-Taskmanager
  • Ich starte im Explorer-Fenster den SysInternals ProcessExplorer. Das mache ich mit der Tastatur, weil's schneller geht: mit Tasten p-r-o auf die Datei gelangen und dann mit Eingabetaste starten.

Da passierte es:
  • Ich kann mit der Maus nichts anderes mehr bedienen, als dieses letzte, "oberste" Fenster.
  • Desktop und Taskbar sind nicht mehr erreichbar, auch Hovern (Maus über ein Icon) bringt keine Reaktion.
  • Mit der Tastatur (Alt-Tab) komme ich an alle anderen Programme und kann diese auch Bedienen
  • Sobald ich aber mit der Maus klicke, verliert das Fenster den Focus, der Rahmen wird grau, das Programm geht in den Hintergrund.
  • Ich habe aber keine Ahnung, was jetzt im Vordergrund ist, was diesen Mausklick abgefangen hat
  • Nur das zuletzt gestartete Programm, in diesem Fall der Prozess-Explorer, lässt sich mit der Maus anklicken, in den Vordergrund holen (Focus) und problemlos bedienen

Die Tastatur funktioniert nach wie vor problemlos mit allen Fenstern, d.h. ich kann obiges Spiel beliebig wiederholen:
Mit Alt-Tab ein anderes Programm in den Vordergrund holen und soweit es geht bedienen, bis ich irgendwo mit der Maus klicke:
Wenn ich auf den Desktop oder das Programm selbst oder ein drittes Programm, das nicht das zuletzt gestartete ist, klicke, verliert das Programm den Focus, ohne dass ein anderes erkennbares Programm in den Vordergrund kommt.

Es fühlt sich an, als würde beim Start des "letzten" Programms sich eine "Glasscheibe" unter dieses Programm, aber über alle anderen Elemente legen und jeden Mausklick abfangen.

Problem:

Es lässt sich nicht an einem Programm fest machen, sondern es kannn jeder beliebige Prozess sein, der gerade beim Auftreten des Fehlers aktiv ist:
Es kann ein Programm-Fenster sein, es kann aber auch die Taskbar sein, die gerade der "oberste" Prozess ist. In dem Fall kann ich dann aus der Taskbar auf ein Programm umschalten oder neu starten, dies ändert aber nichts am Verhalten. D.h. auch neue Programme kommen "unter die Glasscheibe" und lediglich der eine erreichbare Prozess ist weiterhin für die Maus erreichbar.

Meine bisherige Workaround-Lösung:

Wenn ich zuerst alle Programme schließe (über Tastatur), den Explorer-Prozess des Desktops kille und dann über "Win+R" den Explorer und damit den Desktop neu starte, dann ist der Fehler scheinbar behoben. (Ich habe noch keine große Zahl an Tests gemacht, aber bisher funktionierte es so.)

Aber das ist natürlich nur eine schlechte Lösung. Ich wüsste viel lieber die Ursache, um diese zu beseitigen.

Hat jemand eine Idee?


Mein System:

Windows 8.1 64 Bit auf GIGABYTE H87-HD3, Intel Xeon E3-1230 v3 @ 3.30GHz.

Mein Benutzer-Account ist nach der Installation, zum normalen Arbeiten übrigens Standard, kein Admin.
Aber auch beim Admin-Account kommt der Fehler vor.

Das System ist frisch aufgesetzt (Admin-Account), weil ich den Fehler durch eine Neu-Installation vertreiben wollte. Das hat auch eine Zeit lang funktioniert, insbesondere nach Einspielung aller Updates und Hardware-Treiber (aktuellste Versionen von Windows Update oder vom Hersteller geladen).

Dann habe ich die ganzen Anwendungen, Spiele, Tools installiert und erfolgreich (problemlos) einige Zeit damit gearbeitet (als Standard-User), bis der Fehler wieder kam.

Was beim ersten Mal den Fehler ausgelöst hat, weiß ich nicht, aber es werden ja leider etliche Programme automatisch oder nur mit einem kurzen Klick auf eine neue Version gebracht. Das kann ich jetzt leider nicht mehr nachvollziehen.

Die zuletzt installierte Software war Libre-Office 4.4.4.3 und HWInfor 5.02-2575.

Die mir vertrauten Anti-Virus-Tools (Avira Free, MBAM free, immer mit aktuellester Datenbank) finden nichts.

Und ach ja, die Maustreiber (Logitech Wireles Bundle K520 + M310, Thermaltake Volos USB Maus) habe ich im Geratemanager bereits gelöscht und neu installieren lassen.

- - -

Ah, halt, neue Erkenntnisse:

Jetzt ist es gerade wieder passiert: Jetzt ist dieses Firefox Fenster, in dem ich gerade schreibe, das "oberste" und alle anderen Fenster sind für die Maus nicht mehr ereichbar.

Ich habe übrigens zwei FF Fenster offen. Beide sind für die Maus erreichbar, aber alle anderen Fenster (Thunderbird, Total Commander, Windows Explorer) sind "hinter der Glasscheibe". Und auch wenn ich mit der Tastatur über Win+R oder das Startmenü ein Programm starte (Windows Rechner), kommt dies "hinter die Glasscheibe" und ist für die Maus nicht erreichbar.

Aber nachdem ich jetzt noch ein paar mal das Startmenü aktivierte, das eine oder andere Programm startete (Calculator, Paint, Notepad) war die Störung wieder verschwunden. Aber wieder habe ich keine Ahnung, weshalb.


Kennt jemand dieses Symptom und seine mögliche Ursache?
Ich bin für jede Hilfe dankbar!

Viele Grüße, Martin
 
Zuletzt bearbeitet:
Anzeige
G

Gelöschtes Mitglied 78250

Gast
Wenn sich alle anderen Prozesse bis auf den im Vordergrund nicht mehr anwählen lassen, ist auf jeden Fall der Explorer betroffen, der wird von irgendwas blockiert.
Was beim ersten Mal den Fehler ausgelöst hat, weiß ich nicht,
Und genau das ist die Krux - einerseits möchtest du mit dem System arbeiten und benötigst diverse Software, andererseits kannst du den Fehler nur finden, wenn du zwischen den einzelnen Installationen soviel Abstand lässt (in Tagen bemessen), um festzustellen, welche Software den Fehler auslöst. Du musst dich entscheiden.

Beim Process Explorer ist sehr wichtig, die aktuellste Version zu nutzen, eine ältere Ausgabe hat hier sogar zum BlueScreen geführt. Und das gilt für fast alle Software. Und es ist mit Sicherheit eine, die sich tief im System einträgt oder wie PE einen Treiber installiert. Von daher lässt es sich recht gut vorsortieren.

MfG
 

formmue

Herzlich willkommen
Danke für den Tipp.


Noch eine Frage:

Wenn ich auf ein Hintergrundfenster klicke, verliert das aktive Programm den Focus, jedoch das angeklickte Programm erhält ihn nicht.
Gibt es denn ein Tool oder einen einfachen Weg, mit dem ich sehen kann, welcher Prozess gerade den Focus hat?

Ansonsten: Für ein systematisches, Tage dauerndes Austesten fehlt mir die Zeit. Ich werde also mit dem Fehler (und der Notlösung) weiter arbeiten, bis ich eine Ursache gefunden habe. Oder vielleicht bis der Fehler durch ein zwischenzeitliches Background-Update von alleine so verschwindet, wie er auch aufgetaucht ist...

Viele Grüße,
Martin
 
Zuletzt bearbeitet:

Win8Frager

treuer Stammgast
Hatte ich noch nie! Sind denn Deine Programme alle Windows 8.1 und 64 Bit geeignet? Zeigt die Ereignisanzeige etwas an? Gibt es eine erhöhte Systemauslastung während der kritischen Zeiten? Schon mal nur Windows Standard-Maustreiber probiert?

Wie Bernd schon schrieb würde ich auch danach Schritt für Schritt die Software, vielleicht durch Nutzung von Wiederherstellungspunkten testen...
 

formmue

Herzlich willkommen
Ich spiele zwar schon recht gerne mit unbekannten Programmen herum, aber nachdem das System noch sehr frisch ist, sind wirklich nur die lange bekannten Programme drauf.

Wobei ich natürlich nicht weiß, ob nicht vielleicht Acrobat, Flash, Mozilla und Chrome irgendwelche buggy Updates eingespielt haben. Oder besser gesagt, ob vielleicht irgend welche Update Installationen unterbrochen und nicht vollständig ausgeführt wurden und dadurch dieses Problem entstanden ist.

Mit der Ereignisanzeige kenne ich mich nicht genug aus. In welchem Protokoll-Stapel müsste ich denn da suchen?

Beim Betrieb ist nichts zu merken: Keine hängenden Programme, mit der Tastatur lassen sich alle problemlos bedienen, neue Programme starten und beenden.
Allein die Mäuse werden auf ein einziges Programm (-Fenster) beschränkt und die anderen Fenster reagieren nicht mehr.
Keine außergewöhnliche CPU Last, keine außergewöhnliche Speicher Nutzung. (Im Task Manager oder SysInternals ProcExp)


Beide Mäuse (s.o.) laufen übrigens mit Standard-Treibern. Logitech Setpoint benutze ich sowieso nicht und die TT Volos hat eine eigene Software zur internen Makro-Programmierung, die aber noch nicht installiert ist.

Aber na ja: Als Test kann ich ja mal die Hersteller-Sofware installieren. Habe ich noch nicht probiert - mal sehen, was wird...

Der Windows-System-Wiederherstellung traue ich diesbezüglich nicht genug. Dieses "Zurücksetzen" hat mich schon einmal im Stich gelassen, so dass ich das Problem, welches ich mit der System-Wiederherstellung beseitigen wollte, dann doch durch Neu-Installation beheben musste...

Also werde ich (wenn die Maustreiber nix bringen) wohl wirklich alle benötigten Programme auf meinem Laptop installieren (schnarch langsam) und dann mit dem PC ganz von vorne beginnen und Schritt für Schritt testen...


Ich würde mir halt wünschen, dass ich eine Hilfe finde, die mich vor dieser nervigen Arbeit bewahrt. Ein Problem zu erkennen und zu lösen ist schließlich immer besser, als es durch Neu-Installation zu umgehen.


Viele Grüße,
Martin
 
Zuletzt bearbeitet:
G

Gelöschtes Mitglied 78250

Gast
Dieses "Zurücksetzen" hat mich schon einmal im Stich gelassen,
Ungewöhnlich, aber möglich. Ich erstelle eh immer vollständige System-Images. Wäre auch für dich jetzt nützlich gewesen. Ansonsten habe ich alles gesagt - fast. Schau in die Ereignisanzeige > Windows-Protokolle > Anwendungen, ob sich zum passenden Zeitpunkt ein Eintrag mit "Fehler" oder "Warnung" zum Explorer findet. Manchmal ist es schneller, ein System neu aufzubauen, Images zu erstellen vor diversen Schritten, statt so einen Fehler mit wesentlich mehr Zeitaufwand zu suchen.

MfG
 

formmue

Herzlich willkommen
Aktueller Stand: Ich geb's auf!

Nach vielen Tips in verschiedenen Foren habe ich auf dieses spezielle Problem leider keine Lösung gefunden.

Das Problem kommt nach wie vor unregelmäßig nach ca. 5 - 30 Minuten Arbeit.
Workaround: Benutzer abmelden und neu anmelden. Dann geht wieder alles.

Nächster Schritt:
Ich werde jetzt Windows 8.1 komplett neu aufsetzen und v.a. alle Treiber und Software frisch aktualisieren (neueste Versionen manuell laden) und langsam Schritt für Schritt austesten. Auf das Auffrischen (Danke @RobertfH) verzichte ich, damit ich bei einem erneuten Fehler besser erkennen kann, bei welchem Schritt der auftritt.
 
Anzeige
Oben