Netzwerk/Internet: Zugriff auf Sambashare

redgelini

kennt sich schon aus
Hallo,

ich habe einen Raspberry bei mir im Netz welcher standardmäßig diverse Order ohne Authentifizierung im Netz bereitstellt. Interessanterweise, kann ich von meinem PC aber nicht auf Diese Zugreifen, sondern erhalte die vielsagende Melden:
05-11-_2016_23-12-43.jpg

Ich habe die Konfiguration vom Samba geprüft und keine Fehler gefunden. Von einem anderen (Windows 10 PC) kann ich aus dem selben Netz ohne Schwierigkeiten auf die Shares zugreifen. Daher vermute ich schon stark einen Fehler bei meinem PC.

Der Rechner läuft im aktuellen Insider Release (Build 14959) Ich weiß, dass es schon einmal funktioniert hat. Mir scheint, als müsse ich irgendwo noch "Anmeldedaten" zu dem Share hinterlegt haben. An der bekannten Stelle in der Benutzerkonfiguration war aber auch nix zu finden.

Wäre cool, wenn noch Ansätze kommen würden.

Viele Grüße,
André
 
Anzeige

redgelini

kennt sich schon aus
Hallo Henry,

wenn Du die folgende Einstellung damit meinst - die hatte ich auch schon geprüft:
06-11-_2016_11-29-47.jpg

Mir ist noch eingefallen, dass ich nicht erwähnt habe, dass ich von meinem PC aber trotzdem auf die Freigabe meiner NAS, und auf die Freigabe von dem anderen PC zugreifen kann. In beiden Fällen sind aber Anmeldedaten hinterlegt. Während bei dem Raspberry keine Authentifizierung notwendig ist.

Viele Grüße,
André
 

redgelini

kennt sich schon aus
Ich bin mir nicht sicher ob ich Dich richtig verstehe. Wenn ich bspw. von dem Raspberry eine Freigabe als Netzlaufwerk hinzufügen möchte, wird mir zwar das Gerät noch angezeigt, sobald ich aber die verfügbaren Freigaben sehen will, kommt wieder der Fehler. Die Freigabe vom NAS (Synology) wurde ja dort entsprechend eingerichtet und bedarf einer zusätzlichen Authorisierung. Ich habe jetzt eben mal auf dem Raspberry auch nochmal eine Kennwortabfrage eingerichtet, doch scheine ich mit meinem PC gar nicht so weit zu kommen.
 

Franz

Moderator
Teammitglied
Hmm,

evtl. liegt es doch an der smb.conf.
Überprüfe einmal in den [global]-Einstellungen, welcher Wert bei "max protocol" eingetragen ist.
Hab' noch nicht nachgelesen, aber Microsoft baut sein SMB-Protokoll massiv um und im Moment sind wir bei Version 50.0 angekommen.
Deswegen sollte obg. Wert bei "SMB3" stehen. Wenn nicht, nachtragen, speichern und den kompletten Samba-Server neu starten.

Falls der Wert schon vorhanden ist, bitte poste die Werte der Kategorien [global], [homes] & [public] aus der smb.conf.

Desweiteren, überprüfe nochmals die Kennwortgeschützte Freigabe auf dem Windows-Client und deaktiviere & ggf. sie.
Danach meldest Du dich bitte am Windows-Client ab und wieder an.
 

redgelini

kennt sich schon aus
Hallo Franz,

war diese Woche viel unterwegs... "max protocol" hatte ich auch schon auf SMB3 angehoben.
[global]
server string = Raspberry
workgroup = AVALON
netbios name = %h server
security = share
guest account = root
socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=65536 SO_SNDBUF=65536
smb ports = 445
max protocol = SMB3
min receivefile size = 16384
deadtime = 30
os level = 20
mangled names = no
syslog only = yes
syslog = 2
name resolve order = lmhosts wins bcast host
preferred master = auto
domain master = auto
local master = yes
printcap name = /dev/null
load printers = no
browseable = yes
writeable = yes
printable = no
encrypt passwords = true
enable core files = no
passdb backend = smbpasswd
smb encrypt = disabled
use sendfile = yes



Ansonsten beinhaltet die Config nur die jeweiligen Abschnitte für die einzelnen Shares. Exemplarisch:

[Update]
path = /storage/.update
available = yes
browsable = yes
public = yes
writable = yes
root preexec = mkdir -p /storage/.update

Kennwortgeschützte Freigabe hab ich auch schon geprüft und hat auch nichts gebracht. Hatte auch zwischenzeitlich ein Kennwort gesetzt, was auch nicht wirklich was gebracht hat.

Ich gebe halt immer noch zu bedenken, dass der Zugriff von anderen Clients ohne Probleme funktioniert.

Viele Grüße,
André
 
Zuletzt bearbeitet von einem Moderator:

Franz

Moderator
Teammitglied
Leider war ich die letzten Tage nicht onboard.
Besteht denn das Problem immer noch?

Ansich sieht die global-Section nicht so schlecht aus, scheint aber ein vorkonfiguriertes Script zu sein.
Etwas umständlich und doppelt gemoppelt, ehrlich gesagt.

Um das ganze Konstrukt nicht zu kippen, würde ich vorschlagen, Du legst zumindest einen User, den Windows Home Benutzer, in der smbpasswd (im Vi: smbpasswd -a windowsbenutzername) an und vergibst das Windows-Passwort des Benutzers.

In der smbconf setzt Du bei den Globals noch die Anweisung:
Code:
force user = windowsbenutzername
force group = windowsbenutzername

Alles abspeichern und den Server neu starten.

Was Du am Windows-PC noch ausprobieren kannst, wäre bei der Verbindung mit dem Netzlaufwerk, die Option 'Verbindung mit anderen Anmeldeinformationen herstellen' zu aktivieren.

netzlaufwerk1.jpg

Falls beides nicht klappen sollte, bitte nochmals posten, und, falls angelegt, bitte mit der [homes]-Section der smbconf.
 
Zuletzt bearbeitet:

redgelini

kennt sich schon aus
Hallo Franz,
die Anlage des Windowsusers mittels smbpasswd ist fehlgeschlagen:

Raspberry:~ # smbpasswd -a [email protected]
New SMB password:
Retype new SMB password:
Failed to add entry for user [email protected]

Die Variablen hab ich dann erst gar nicht gesetzt.
Ich habe aber daraufhin direkt eine Freigabe gemapped (Update) Mit Angabe von Benutzername und Kennwort hat das auch funktioniert.

Wenn ich mir aber alle Freigaben anzeigen lassen will, kommt wieder der Fehler. Aktuell muss ich also zum einen Wissen, wie die Freigaben heißen, und ich müsste mir für jede Freigabe ein Laufwerk mappen.

Gruß,
André
 
Oben