Anzeige

Am Puls von Microsoft

Anzeige

Frage [gelöst] IE Probleme auf Terminalserver

Jabba-deHut

kennt sich schon aus
Hallo,
ich hab hier ein sehr obskures Problem auf einem Terminalserver mit dem IE und hoffe ihr könnt mir einen Tipp geben.

Einige Seiten funktionieren sporadisch im IE nicht, da kann der User dann die Seite so oft aktualisieren wie er möchte, nichts geht. Auch ein beenden/neustarten des IE oder der RDP-Sitzung bringt nichts.
Startet der User aber eine 2. RDP-Sitzung mit den selben Anmeldedaten auf dem selben Server, kann er plötzlich auf die Seite zugreifen die in der anderen Sitzung nicht läuft.
Andere User haben mit der Seite zur selben Zeit keinerlei Probleme!
Wie ist das möglich und wie kann ich das korrigieren?

Wir setzen hier den IE6 auf einen Windows Terminalserver 2003 ein. Ja, ich weiß, ist total veraltet aber im FireFox7 scheint das Problem permanent zu bestehen.
Alle User auf dem TS nutzen den gleichen IE und niemand hat Recht dort etwas zu installieren. Löschen des Caches bringt auch nichts und ein neu Aufsetzen des Profils ist sinnlos, da es ja das selbe Profil ist, bei dem es dann mal geht und mal nicht.
Eine der Seiten ist von einer großen, ausländischen Bank, also nichts ungewöhnliches.
 
Anzeige

Franz

Moderator
AW: IE Probleme auf Terminalserver

Hast du schon die Ereignisanzeige auf dem Server überprüft?
Interessant wäre sicher auch die Fehlermeldung des Browsers.
Welches BS läuft auf dem Client?

Vermutlich gibt es Probleme mit der HTTPS-Auflösung, da es sich eine Bank-Website handelt, mit dem Internet Explorer 6 selbst oder, falls ihr mit TS RemoteApp arbeitet,
der IE6 ist nicht in der Liste der RemoteApp-Programme enthalten, die bei einer ersten Anmeldung gestartet werden können.

Wenn du ein neues Benutzerkonto anlegst, ist das zwar das gleiche Profil, aber nicht dasselbe. ;)
Jedes Benutzerkonto hat eine individuelle SID, das Profil ist zwar identisch, aber die SID nicht.
Von daher kannst du es auch mit einem neuen Benutzerkonto incl. Kopie der Benutzerdaten versuchen.
Das bisherige Benutzerkonto bitte dann nur deaktiveren und nicht löschen.
Zu guter Letzt solltet ihr wirklich ein Upgrate des IE6 auf wenigstens IE7 durchführen.
 

Jabba-deHut

kennt sich schon aus
AW: IE Probleme auf Terminalserver

Danke für die Antwort,

das Ereignislog ist leer, der IE schmiert ja auch nicht ab, es lassen sich nur einfach Menüpunkte auf der Seite nicht auswählen. Nun würde ich ja sagen, dass der IE zu alt ist, oder Javascripte nicht funktionieren, aber in anderen Sitzungen und bei anderen Usern läufts ja, das ist das, was mich wurmt!
Es greifen ja alle Clients auf den selben IE zu, da sie auf einem TS in der Remotesitzung arbeiten. Also nicht nur Remote-App.
 

Franz

Moderator
AW: IE Probleme auf Terminalserver

Hui,

jetzt etwas langsamer, denn von "Abschmieren" hatte ich nie geredet.
Die Ereignisanzeige protokolliert u.a. auch nicht gestarteten Elemente, die normalerweise gestartet werden,
wenn sich ein Benuzter anmeldet.
Wenn du von "Seiten funktionieren sporadisch nicht" sprichst, gehe ich zuerst davon aus,
daß die Seiten nicht angezeigt werden, deswegen die Nachfrage zu Fehlermeldungen.
Wenn es so ist, wie du nun schreibst, daß sich Menüpunkte auf der Site (bei der ersten Anmeldung)
nicht ausführen lassen, stimmt etwas mit dem HTTPS-Protokoll oder mit einem ActiveX-, bzw. Scripting-Element,
das die Site benötigt, nicht.
Daher auch meine Frage, ob der IE6 in der RemoteApp-Programmliste aufgeführt ist, aber letztlich ist das nicht mehr relevant.

Versuche aber folgendes:
Starte mit dem betroffenen Benutzerkonto zuerst ein anderes Remote-Programm als den IE6, z.B. Word.
Ist das ausgeführt, starte nun den IE und überprüfe, ob du in https-Sites navigieren kannst.
Funktioniert das, liegt es ziemlich sicher an einem ActiveX- oder ein Scripting-Element, daß nicht gestartet werden konnte.
Funktioniert es nicht, setze die TCP/IP-Einstellungen auf dem Client zurück und lösche dessen DNS-Cache.
Code:
netsh int ip reset c:\resetlog.txt
Code:
ipconfig /flushdns
Hinsichtlich des Alters des IE6, mir geht es lediglich darum, daß diese Versoin so ziemlich die löchrigste
der Internet-Explorer-Reihe ist und heutzutage auf einem Server, wieder nur aus Sicherheitsgründen,
auf einem Server nichts mehr zu suchen hat.

Hast du das Problem schon mit einem Testbenutzer mit identischen Profil überprüft?
Und leider wissen wir immer noch nicht, welches BS auf dem Client arbeitet.

-edit-
Befindet ihr euch eigentlich in einem Citrix-Netzwerk?
 
Zuletzt bearbeitet:

Jabba-deHut

kennt sich schon aus
AW: IE Probleme auf Terminalserver

Ahh, da habe ich mich wohl etwas missverständlich ausgedrückt.
Die Clients melden sich über einen Wyse ThinClient (Linux) direkt auf dem TS an. Sie arbeiten, ganz und gar nur in der MS-Remotesitzung und haben auf dem TS ihren eigenen Benutzer samt Desktop, also kein Citrix oder dergleichen, nur Oldschool-TS. Daher ja mein erstaunen darüber, dass es in der einen Sitzung geht und in der anderen nicht (bei gleichen Anmeldedaten).
Der TS ist wie gesagt ein Win2k3 mit IE6.

Was versteht Du unter "identischem Profil"? Neuen user erstellen und über die Kontenverwaltung das Profiel kopieren, oder gehts Du einen anderen Weg?

Und bei aller experimentierfreude werde ich sicherlich auf einem TS mit ca 50-100Usern kein "ip reset" im Livebetrieb machen. ;) (zumal es ja bei allen anderen geht). Und das Ereignislog ist wie gesagt komplett Ereignislos. :(

Das der IE6 der letzte Müll ist, weiß ich nur zu gut, ein Austausch der kompletten Server steht auch bevor, aber solange muss es noch mit dem alten gehen, da einige der Uraltprogramme sonst nicht laufen und Arbeitsspeicher Hardwarebedingt absolute Mangelware ist (mehr geht nicht) und sonst kein Browser an den Speicherbedarf ran kommt, aber das ist ein anderes Problem...
 

Franz

Moderator
AW: IE Probleme auf Terminalserver

Den IP-Reset machst du auch auf dem Client, nicht auf dem Server, genauso wie das Leeren des Cache, steht aber auch oben. ;)
Die Nachfrage hinsichtlich der Netzwerk-Umgebung ist rein vorsorglich, um evtl., wie z.B. Citrix- oder Linux-Modalitäten, auszuschließen oder zu berücksichtigen.

Das Kopieren des Benutzerprofils hast du genau richtig erklärt.
Nur den Benutzernamen wurde ich anders setzen.
Doch vorab prüfe und teste bitte die Geschichte mit dem TCP/IP-Reset.

Nur solltest du auf keinen Fall das Original-Benutzerkonto löschen, auch wenn das andere funktionieren sollte, sondern lediglich deaktivieren.
das erspart einen Haufen Ärger, auch in Blick auf den neuen Server.
 

Jabba-deHut

kennt sich schon aus
AW: IE Probleme auf Terminalserver

Was soll es denn bitte bringen irgendetwas auf dem Client zu machen? Der Client macht nichts außer sich mit dem TS zu verbinden, alles andere geht von dem TS aus. Der Client hat rein gar nichts mit dem Web zu tun, der darf da noch nicht mal hin, der kommt nur auf den TS und sonst nirgends. Und der Teil der Verbindung klappt ja bestens.
 

Franz

Moderator
AW: IE Probleme auf Terminalserver

Jaja,

da gebe ich dir komplett recht, nur besitzt der Client auch einen DNS-Cache, ob er nun im Internet war oder nicht, auch den der Remote-Sitzungen.
 

Jabba-deHut

kennt sich schon aus
AW: IE Probleme auf Terminalserver

Klar, aber den gesamten TCP-Unterbau teilen sich die User doch. Daher darf ein einfacher User ja auch nicht einfach was daran ändern.
Ich werde heute in der Mittagspause mal probieren das Profil zu kopieren, glaub aber nicht dass das was bringt. Falls aber doch, gibt es einen sauberen Weg den alten User zu löschen und anschließend einen neuen mit den selben Anmeldedaten anzulegen? (Ansonsten muss ich in etlichen Uraltprogrammen einen neuen User anlegen und die Daten mit unschönen Tricks kopieren (da die teils den Windows-Anmeldenamen nutzen und teils sehr verstrickt Daten herum reichen....
 

Franz

Moderator
AW: IE Probleme auf Terminalserver

Wenn auf allen PCs alles gleich wäre, gäbe es sicher nie Trouble im Netzwerk,
ist leider nur Theorie und Wunschvorstellung.

Wie gesagt, DNS benutzt ihr vermutlich schon im Intranet, allein deswegen
führe ich obg. Befehle als erstes auf dem Client durch,
um eben eine saubere Ausgangslage für evtl. weitere Fehlersuche zu haben.

Schade die die Ereignisanzeige im Server nichts hergibt.
Sollte der Testbenutzer funktionieren, poste bitte nochmals.
Aber ein Benutzerkonto löschen - den Fehler macht man bestimmt nur einmal. ;)
 

Jabba-deHut

kennt sich schon aus
AW: IE Probleme auf Terminalserver

Die Profilkopiererei hab ich auf Morgen verschieben müssen, da meine User es nicht einmal hin bekommen Bescheid zu sagen, wenn sie zu Tisch gehen.

Wie gesagt, sind es Wyse ThineClients. Da steckt zwar irgendwo ganz tief unten ein Linux, aber da kommt man nicht ran und die ganze "Config" ist bei jedem Restart resettet, lediglich die Abgespeicherten RDP Einstellungen werden gespeichert.

Aber an was für Fehler denkst Du wenn Du an das Löschen eines Benutzers denkst? Mir würden da spontan nur verweiste Dateiberechtigungen und ggf. Probleme mit dem Exchange einfallen, was bei mir mit 1-2 Clicks behoben wäre.
 

Franz

Moderator
AW: IE Probleme auf Terminalserver

Es geht eigentlich nur um die Berechtigungen.
Bei vielen PGP-Verschlüsselungen kommt die SID zum Tragen, u.a auch bei VPN
(s.a SSH Protokoll, Authentifizierung).
Wenn eine SID Bestandteil der Verschlüsselung ist, aber dann gelöscht wurde, kommt kein Mensch an diese Daten.
Schlimm wird es, z.B. bei Firmendaten auf einem Laufwerk.
Mit der lediglichen Konten-Deaktivierung bist du auf der sicheren Seite.

Aber wenn du dir zu 100% sicher bist, daß nur Dateileichen von der Löschung betroffen sind, aufhalten tu' ich dich nicht.

Was meinst du mit
aber da kommt man nicht ran und die ganze "Config" ist bei jedem Restart resettet, lediglich die Abgespeicherten RDP Einstellungen werden gespeichert.
Welche Config wird warum und wo zurückgesetzt?
 

Jabba-deHut

kennt sich schon aus
AW: IE Probleme auf Terminalserver

Ich hab das Problem zufällig weiter eingrenzen können.
Scheinbar hat sich Java auf dem Server zerlegt.
Gemerkt hab ich dies als ich auf Java.com testen wollte, welche Javaversion installiert ist "Hab ich Java bereits?" Dort hat sich der Explorer sofort selbst geschlossen und der FireFox wollte die Seite nicht anzeigen ohne Java zu aktualisieren.

Wieso sich das Problem nur bei bestimmten Usern in Bestimmten Kombinationen äußert, weiß ich aber immer noch nicht.
Heute Abend wird Java komplett neu aufgespielt,
hoffentlich hat der Spuk dann ein Ende. ;)


@Franz:
Gemeint war die Config auf den ThinClients. Da läuft ein Embedded Linux drauf, außer einer Liste mit RDP-Servern die der Use speichern darf, lernt die Kiste bei jedem Neustart die Welt aufs neue kennen. ;)
Einziger Fehler den wir bis jetzt mit den Dingern hatten: Nach etwa 5Jahren ist die Biosbatterie leer und er vergisst die Uhrzeit. :D
 
Anzeige
Oben