Anzeige

Am Puls von Microsoft

Anzeige

Netzwerkadapter schnell deaktivieren & wieder aktivieren

Roberto

gehört zum Inventar
Manchmal ist es sinnvoll wenn man bei Netzwerk- Internetproblemen mit dem Modem oder dem Router den Netzwerkadapter schnell mal deaktiviert und in sofort wieder aktiviert.
Am schnellsten geht es über die Eingabeaufforderung.

Folgendermaßen geht man dabei vor:

Zuerst einmal muss man herausfinden, welche Bezeichnung die LAN- oder WLAN Verbindung hat.

Start > Ausführen > cmd > Enter

Im darauffolgenden Fenster gibt man den Befehl netsh interface show interface ein

netzdeakt01.jpg


Entertaste drücken.

Unter Schnittstellenname sieht man nun, wie die Bezeichnung des Netzwerkadapters lautet.
In meinem Fall LAN-Verbindung

netzdeakt02.jpg


Das Fenster bleibt geöffnet.

Um jetzt den Adapter zu deaktivieren gibt man den Befehl netsh interface set interface LAN-Verbindung disabled ein.
Entertaste drücken.

netzdeakt03.jpg


Wie man an dem Icon im Systray an dem roten Kreuz sieht, ist der Adapter deaktiviert.

netzdeakt04.jpg


Überprüfen kann man das auch zusätzlich im Gerätemanager.

netzdeakt05.jpg


Das Aktivieren erfolgt nun durch den Befehl netsh interface set interface LAN-Verbindung enabled.
Entertaste drücken.

netzdeakt06.jpg


Wie man nun im Systray sehen kann, ist der Adapter wieder aktiv.

netzdeakt07.jpg


Nun kann man das Fenster durch exit oder durch den Klick oben auf das rote Kreuz schließen.

Auch hier zeigt uns der Gerätemanager, dass der Adapter wieder aktiviert ist.

netzdeakt08.jpg


Hinweis: Für die netsh Befehle braucht man Adminrechte.
 
Zuletzt bearbeitet:
Anzeige

olminger

Erster Beitrag
Bei mir kommt dann immer folgende Fehlermeldung :

"Eine Schnittstelle dieses Namens wurde noch nicht für den Router registriert."

Den Namem habe ich genauso rausgesucht wie du es beschrieben hast
:mad:

Gruß Olmi
 

wolf22

nil
"LAN-Verbindung" muss durch den Namen Deiner Verbindung ersetzt werden!

Die "Antwort" habe ich auch bekommen aber eine andere Lösung weil ich den "Namen" nicht gefunden habe trotz Einsatz verschiedenster Möglichkeiten - wurde alle abgelehnt.
Auch bei mir stand als Schnittstellenname "LAN-Verbindung" der jedoch abgelehnt wurde.

Systemsteuerung - Netzwerk und Internet - Adaptereinstellungen ändern - Dann wird die LAN-Verbindung angezeigt und nun rechte Maus und Verknüpfung auf den Desktop anlegen.
Dann können alle Fenster wieder geschlossen werden.
Mit dem Icon und rechte Maus kann nun beliebig deaktiviert und aktiviert werden ohne über "CMD" gehen zu müssen.

ot:
Einzige Möglichkeit, dass es heute nicht mehr so geht wie noch 2009 wäre, dass es durch die inzwischen aufgelaufenen Updates und SP1 andere Bedingungen herrschen. Mehr als den bei CMD angezeigten Namen kann man eigentlich nicht eingeben und damals scheint es ja geklappt zu haben.
 

Anhänge

  • 20111015 Netzwerkverbundung deaktivieren_1.jpg
    20111015 Netzwerkverbundung deaktivieren_1.jpg
    56,2 KB · Aufrufe: 2.451
  • 20111015 Netzwerkverbundung deaktivieren_1a.jpg
    20111015 Netzwerkverbundung deaktivieren_1a.jpg
    5,7 KB · Aufrufe: 1.662
  • 20111015 Netzwerkverbundung deaktivieren_1b.jpg
    20111015 Netzwerkverbundung deaktivieren_1b.jpg
    21,4 KB · Aufrufe: 1.930
  • 20111015 Netzwerkverbundung deaktivieren_1c.jpg
    20111015 Netzwerkverbundung deaktivieren_1c.jpg
    8,6 KB · Aufrufe: 1.774
Zuletzt bearbeitet:

Roberto

gehört zum Inventar
Also bei mir funktioniert es.

netsh interface set interface Drahtlosnetzwerkverbindung disabled

netsh interface set interface Drahtlosnetzwerkverbindung enabled

netsh interface set interface LAN-Verbindung disabled

netsh interface set interface LAN-Verbindung enabled
 

wolf22

nil
Das ist dann mal wieder eins von den unerklärlichen "Eigenleben" auf/in diesem Gebiet. Durch die nun aufgezeigte zweite Möglichkeit müsste nun auch der "störrischte" PC das annehmen und schnell hin und her schalten können wenn Bedarf besteht.
Danke für die Nachkontrolle.
wolf22
 

Bridge

Herzlich willkommen
Einen schönen Sonntag Euch allen,

leider ist der Thread schon ganz schön alt,hoffentlich gibt es trotzdem noch Antworten :)

Die beiden Befehle :
netsh interface set interface LAN-Verbindung disabled
und
netsh interface set interface LAN-Verbindung enabled
funktionieren auf meinem System mit Win 7 Ultimate x64 in der Eingabeaufforderung völlig normal,
versuche ich aber eine Batchdatei mit:
@echo off
echo netsh interface set interface LAN-Verbindung disabled
oder
@echo off
echo netsh interface set interface LAN-Verbindung enabled
auszuführen passiert rein gar nichts,außer natürlich,dass das Fenster kurz aufgeht.

Ich habe mich jetzt dumm und dusselig durchs Netz gewühlt und ausprobiert aber ich komme einfach nicht weiter.
Könnte mir jemand,oder sogar DU Ikaros,bitte zeigen,wie und was genau in der jeweiligen Batchdatei stehen muß,damit die beiden Befehle funktionieren ?!
Ist mir schon peinlich,das ich überhaupt jetzt fragen muß,normalerweise geht irgendwann alles auch ohne Fragen,doch mein Brett vorm Kopf ist gerade echt größer und stärker als meine Geduld :)
Mir ist klar,das es andere Möglichkeiten gibt oder auch zwei Programme die ich versucht habe ( Avanquest und Routerkontrol )
Jedoch funzen die nur Teilweise bei mir.
Aber die Idee mit einer Batch,wo wirklich jeweils nur ein Klick reicht um das Ergebnis zu sehen,ist im Grunde das was ich mir wünsche.
Mit Devcon&co möchte ich gar nicht erst anfangen.

Wäre sowas von toll,wenn mir jemand helfen könnte - vielen Dank dafür !

Allen einen guten Wochenstart
Bridge

Edit : Habe es nun nach probieren geschafft mit den 2 Batchdateien......ausführen geht aber nur,wenn man sie als Administrator ausführt,wenn nicht steht im Fenster " Eine schnittstelle dieses namens wurde noch nicht für den router konfiguriert ".
NUR,jetzt muß ich aber trotzdem noch einmal bestätigen,was sich natürlich durch deaktivieren der Benutzerkontensteuerung verhindern lasssen würde,aber das will ich natürlich auch nicht machen.
Es muß doch noch einen anderen Weg geben,um das alles mit nur einem Klick zu erledigen ?!
Menno :)
Schlaft gut !
bridge
 
Zuletzt bearbeitet:

Martin

Webmaster
Teammitglied
Hallo und herzlich willkommen bei uns, Bridge :)
Da man die entsprechenden Befehle immer mit Adminrechten ausführen muss, muss natürlich auch ein Batch-Script mit Adminrechten gestartet werden, damit es funktioniert.
 

Marco1976

Bin (fast) immer da
Hallo Bridge, herzlich willkommen:).

Mach von der Batch-Datei eine Verknüpfung, geh mit Rechtsklick auf die Verknüpfung -> Eigenschaften im Reiter "Verknüpfung" auf "Erweitert" und dort den Haken bei "Als Administrator ausführen" setzen:D.
Die Batch starteste dann immer mit der Verknüpfung, dann sollte das gehen.

Ich hab meine Batches immer in dem Programme-Ordner und die Verknüfungen lege ich dahin, wo ich sie brauche, ggf. auf dem Desktop.
 

Bridge

Herzlich willkommen
Vielen lieben Dank Euch beiden,für DAS WIllkomen !.

@Martin,also diese beiden Batschdateien lassen sich,wie du schom sagst,nur als Administrator öffnen aber dein Satz "....muss natürlich auch ein Batch-Script mit Adminrechten gestartet werden, damit es funktioniert " ,macht ich etwas stutzig...bzw vestehe ich nicht wirlich - wie solle die dann darin aussehen,wie komplett geschrieben werden ?
....DENN...
@Marco1976 und die Möglichkeit mit der Verknüfung in der dann ja Admin ein/auszuschalten ist habe ich schon probiert,leider will UAC such dort eine Bestätigung haben.
KOmmt es darauf an,wo die oroginalen Batches stehen ? Habe sie bei mir einfach mal auf c: gelassen und die Verknüpfungen auf d:...dennoch wird immer nach der Bestätigung gefragt.
Mein UAC steht auf Windowsdtandard,2.von oben)
wo liegt mein Denkfehler ?
Vielen Dank für Eure Mühe
Bringe
 

Marco1976

Bin (fast) immer da
Nein, wahrscheinlich kein Denkfehler; ich hab die UAC deaktiviert (geht mir tierisch auf den Keks, das dauernde Rumgefrage, wegen jedem Mist; brain.exe ist immer up to date:D), war daher n unausprobierter Vorschlag.

Was ich dazu gefunden habe, ist das Programme ohne UAC-Abfrage starten , ist zwar n Bissel aufwändig, aber versuchen kannste es ja mal, wenn's nicht gerade 100 Sachen sind.
 

Martin

Webmaster
Teammitglied
Wenn man eine cmd-Datei mit der rechten Maustaste anklickt, kann man sie auch direkt als Administrator ausführen.
Und bitte an dieser Stelle keine Diskussion über UAC, da führt am Thema vorbei.
 

Bridge

Herzlich willkommen
Hallo Ihr beiden,
danke für Eure Ausführungen !
Mir bleibt also nichts anderes übrig als die UAC kompett abzuschalten und damit leben müssen,gefährdet zu sein,und auf Sicherheit zu verzichten,warauf ich natürlich wenig wert lege.Also führt auch bei der Batchdatei kein Weg daran vorbei 2 Klicks zu machen.
Welche ich natürlich auch mit anderen Möglichkeiten hätte.
Oder ich verstehe Euch komlett falsch......wäre schön,wenn man trotz UAK noch einen gewissen Spielraum hätte wie zb einer Firewall hätte....so 100% trustet Programmen dann eben ohne UAC.
Wie gesagt,die beiden Batshes funktionierern in der Einfabeauforderung wie die sollen......ohne Abfrage oder dergleichen...nur eben bei einen verknüpfung mit Adminrechten kommt die anfrage.
Ich verste nur bahnof :)
Ist wohl doch ein Denkfehler !

Gute nacht Euch beiden !
bridge
 
Zuletzt bearbeitet:

Martin

Webmaster
Teammitglied
Nein, Du musst UAC nicht abschalten, Du kannst das ganz normal auf den Standardeinstellungen belassen.
Es sei denn, die zwei Klicks sind Dir wirklich zu viel, dann bleibt Dir tatsächlich keine andere Wahl. Musst Du selbst entscheiden, was für Dich wichtiger ist. Zwischen Sicherheit und Komfort muss man immer Kompromisse machen.
 

Bridge

Herzlich willkommen
Huhu Ihr beiden,

vielen Dank für Eure Rat/vorschläge,die eierlegende Wollmilchsau ist mal wieder nicht oder nur unter größeren Anstrengungen zu finden,also ziehe ich die Sicherheit dem Komfort vor und benutze das free Programm Avanquest Connection Manager,damit läßt sich die Verbindung auch de/aktivieren plus ein paar nette Zusatzinfos und das ganz ohne UAC.Schade eigentlich,denn ich hatte mich schon so schön und anstrengend in die Materie versucht einzuarbeiten,aber anyway...bin auf jeden Fall wieder etwas schlauer.
Danke noch einmal und einen schönen Abend für Euch.
bridge
 

willhaben

Herzlich willkommen
Hallo zusammen!

Auch ich habe diesen Thread wieder ausgegraben. Meine Problemstellung ist eine etwas andere: Bei einem alten Gericom-Notebook muss das W-Lan erst über FN + F10 aktiviert werden. Ich würde das gerne per Script oder Batchfile beim Hochfahren automatisch durchführen lassen, habe aber bisher kein probates Mittel gefunden.

Das Tool devcon.exe von Microsoft habe ich ebenfalls bereits versucht, jedoch leider erfolglos. Der Adapter ist im Geräte-Manager nicht deaktiviert sondern bis zum Drücken von FN + F10 gar nicht sichtbar. Das aktuellste Bios hat leider ebenfalls keine Abhilfe geschaffen. Evtl. weiß jemand Rat.

Vielen Dank im Voraus für Eure Antworten.

LG

Will
 

willhaben

Herzlich willkommen
Hallo build10240!

Danke für deine Einschätzung. Wenn das so ist, würde es bedeuten, dass ich softwareseitig eher schlechte Karten habe, das Einschalten zu automatisieren, oder? Das Notebook ist übrigens ein Gericom Phantom Design+ U50SA mit Windows Vista Home Premium 64 Bit drauf.

LG

Will
 

build10240

gehört zum Inventar
Wenn das so ist, würde es bedeuten, dass ich softwareseitig eher schlechte Karten habe, das Einschalten zu automatisieren, oder?
Der Schalter scheint dann die Verbindung zwischen Gerät und Mainboard zu trennen. Ist es tatsächlich so wie vermutet, müßtest Du von Windows aus der Firmware das Kommando, das Fn+F10 entspricht, senden. Das dürfte nicht möglich sein. Gibt's im Bios keine Einstellung, daß der WLAN-Adapter immer angeschaltet bleibt?

Solange das Gerät gar nicht in Windows vorhanden ist, läßt es sich auch nicht steuern. Ein vorhandener Netzwerkadapter läßt sich jedoch über sein Kontextmenü bzw. im Gerät-Manager deaktivieren. Das entspricht dann den hier im Thread im Beitrag #1 vorgestellten Befehlen.
 

[email protected]

Ergonomiker
Ich hab mir jetzt auch Batchdateien angelegt zum schnellen Abschalten und wieder Anschalten des Ethernet (der zugehörige Adapter heißt bei mir "Ethernet 2", ermittelt mit ipconfig).

Die Batchdateien haben den folgenden Inhalt:

Code:
REM Netzwerkadapter namens "Ethernet 2" deaktivieren
@echo off
netsh interface set interface "Ethernet 2" disabled
exit

Code:
REM Netzwerkadapter namens "Ethernet 2" aktivieren
@echo off
netsh interface set interface "Ethernet 2" enabled
exit

Die beiden Batchdateien funktionieren, wenn man sie direkt per Rechtsklick mit "Als Administrator ausführen" startet.

Ebenso wenn man Verknüpfungen zu den Batchdateien erstellt, und diese per Rechtsklick mit "Als Administrator ausführen" startet.

Alternativ kann man in den Dateieigenschaften der jeweiligen Verknüpfung unter "Erweitert" -> "Als Administrator ausführen" dauerhaft aktivieren:

C1J949h.png


Dann genügt ein Doppelklick auf die jeweilige Verknüpfung, um den Netzwerkadapter zu deaktivieren oder wieder zu aktivieren.

Wollte das hier nur mal festgehalten haben, da ich ziemlich lang rumgemacht habe und es mir anfänglich genauso ging wie @Bridge im Beitrag #7.

Momentan das einzige verbleibende Problem ist, dass die Batchdateien manchmal schlicht gar nichts bewirken, egal auf welche der drei oben genannten Möglichkeiten man sie (als Administrator) startet. Noch seltener schließt sich das CMD-Fenster nicht von alleine, während die Funktion jedoch gegeben ist. Hier habe ich noch nicht herausgefunden, woran das liegt.

--
PS: Benutzerkontensteuerung steht bei mir auf "Nie benachrichtigen", was - wie weiter oben schon mal von Martin angesprochen - nicht Gegenstand der hiesigen Diskussion sein soll.
 
Anzeige
Oben