Anzeige

Am Puls von Microsoft

Anzeige

Tastaturproblem Code 39

holly_d

Herzlich willkommen
Hallo zusammen,

seit gestern habe ich ein recht eigenartiges Problem mit meinem Vista-Rechner.

Meine Tastaturen (mehrere ausprobiert, zwei Wireless USB, eine normale kabelgebundene USB) funktionieren nicht mehr! :confused:

Ansonsten (scheint) mit dem Rechner alles in Ordnung zu sein, die Maus funktioniert einwandfrei und zum Glück habe ich UltraVNC drauf, so dass ich zumindest mal drauf schauen kann, was hier faul ist.

Der Gerätemanager sagt mir folgendes:
"Der Gerätetreiber für diese Hardware kann nicht geladen werden. Der Treiber ist möglicherweise beschädigt oder nicht vorhanden. (Code 39)"

Schaue ich auf den Reiter "Treiber" sehe ich:
- Treiberanbieter: Microsoft
- Treiberdatum: 21.06.2006
- Treiberversion: 6.06000.20734
- Signaturgeber: microsoft windows

Bei den Treiberdetails steht dann:
- Anbieter: Microsoft Corporation
- Dateiversion: 6.0.6000.16386 (vista_rtm.061101-2205)
- Copyright: Microsoft Corporation. Alle Rechte vorbehalten
- Signaturgeber: Microsoft Windows

So rein gefühlsmäßig scheint mir das schon nicht zusammenzupassen....

Schaue ich in Windows\system32\drivers, dann tragen die Treiberdateien als Datum den 13.02.2008 (was mir wiederum bzgl. des im Gerätemanager genannten Treiberdatums komisch vorkommt).

Fazit: Hier ist mächtig was faul! Aber was?!

Das einzige was ich an dem System meines Wissens nach geändert hat war, dass durch einen Stromausfall die Kiste einmal runtergefahren und dann neu gebootet worden ist.

Hardwareseitig scheint übrigens alles OK zu sein. Sowohl mit wireless als auch mit kabelgebundenen Tastaturen komme ich ins BIOS.

Hat jemand eine Idee?

Normalerweise hätte ich versucht über "Treiberupdate" einfach einen neuen Treiber zu installieren, aber.... das funktioniert nicht. Windows sagt mir immer, dass der Treiber der aktuellste sei.

Zwischenzeitlich habe ich auch schon mal einen Wiederherstellungspunkt von vor dem Stromausfall aufgesetzt - keine Veränderung im Verhalten. Das ganze ist echt frustrierend. :rolleyes:

Was meiner Meinung nach zur Lösung führen sollte ist es, dem Vista einen aktuellen Treiber "manuell" unterzujubeln, aber dazu fehlt mir das Vista-KnowHow und vor allem das Wissen, wo ich den aktuellen Treiber finde.
Im Verzeichnis Windows\winsxs sind zwar reichlich kbdclass.sys (anscheinend für unterschiedliche Länderkodierungen?!), aber wie bekomme ich die so eingespielt, dass Vista sie als neuen Treiber akzeptiert?

Gruß,
Holger D.
 
Anzeige

holly_d

Herzlich willkommen
....und jetzt habe ich doch die Lösung gefunden, nachdem ich noch mal ein bisschen nachgedacht habe...

Die Ursache war ein falscher Tastaturtreiber, den ich vergangene Woche Samstag eingespielt hatte!!! Das Vista hat die Installation ohne Fehler quittiert,
aber ich hatte den Rechner seitdem nicht mehr gebootet!

Der Stromausfall hat dann zum Zwangsreboot geführt und damit war es dann geschehen. Jetzt gerade als ich den Artikel gepostet habe, habe ich mal einen älteren Wiederherstellungspunkt gewählt - und sie da, schaut gut aus.

Mein Verdacht, dass der Stromausfall Datenfehler auf der Festplatte produziert hat, hat mich die ganze Zeit auf eine falsche Fährte gesetzt.

Das ist jetzt schon das zweite Mal, dass ich mit einer Treiber-Installation auf die Nase gefallen bin (beim ersten mal war es ein Pinnacle DVB-T Stick) - danach waren die CD/DVD-Laufwerke nicht mehr erkannt worden.

...und ich hatte mir so geschworen, demnächst IMMER darauf zu achten, dass explizit VISTA in den Release Notes erwähnt wird und nicht nur "Windows".

Trotzdem würde mich mal interessieren, ob man Vista "manuell" Treiber unterjubeln kann - oder anders gesagt: Hätte ich das Problem auch ohne "Wiederherstellungspunkte" lösen können?!

Gruß,
Holger D.
 

mummpi

Lernt gerne dazu ...
Trotzdem würde mich mal interessieren, ob man Vista "manuell" Treiber unterjubeln kann - oder anders gesagt: Hätte ich das Problem auch ohne "Wiederherstellungspunkte" lösen können?!

Gruß,
Holger D.

:) holly_d

Klar geht das,du hättest nur den Treiber im Gerätemanager deinstallieren müssen!;)
 

holly_d

Herzlich willkommen
Hallo Mummpi,

ich habe mehrfach versucht, die Treiber im Gerätemanger zu
entfernen - hat nie funktioniert.

Später habe ich die Dateien (kbdclass.sys und kbdhid.sys) von
Hand gelöscht. Nach Einstecken der Tastatur waren sie nach
einem Reboot wieder da... :eek:
 
Anzeige
Oben