[gelöst] USB-Treiber löschen/deinstallieren

foxx12

lernt immer gern dazu
Hallo zusammen,

wenn ich eine bestimmte externe HDD an einen bestimmten USB 2.0 Anschluss stöpsele, kommt die Meldung "Dieses Gerät kann eine höhere Leistung erzielen usw.". Natürlich ist sie dann so lahm, dass ein Arbeiten damit nicht möglich ist. Stöpsele ich sie an einen anderen Anschluss, ist alles paletti.

Andere Geräte/HDD´s funktionieren an dem Anschluss ganz normal.

Beim erstmaligen Anschließen installiert sich doch für jedes Gerät automatisch ein USB-Treiber. Bei dieser Installation scheint wohl irgendwas schief gelaufen zu sein. Und Windows merkt sich das ja.

Gibt es eine Möglichkeit den betreffenden bzw. alle USB-Treiber zu löschen, so dass dieser/diese sich beim Anschließen des/ der Geräte neu installieren?

Grüße
foxx
 
Anzeige

foxx12

lernt immer gern dazu
Vielen Dank zunächst einmal.

Jetzt ist nur das Problem, dass im Gerätemanager keine Geräte/Treiber halb transparent erscheinen????

Möchte mir jetzt nicht unbedingt einen Treiber weglöschen (z.B. Drucker), der noch gebraucht wird.
 

McC.

gehört zum Inventar
Um wirklich alle Geräte im Gerätemanager anzuzeigen , mussst diesen erweitern . Dazu musst du eine neue Benutzervariable in den Erweiterten Systemeinstellungen anlegen .

Klicke dazu in der Systemsteuerung auf ''System'' und dann auf ''Erweiterte Systemeinstellungen'' , dort dann auf ''Umgebungsvariablen''. Hier angelangt , klickst du bei den Benutzervariablen auf ''Neu'' , im folgenden Fenster tippst du folgenden Namen für die Variable ein ( Copy&Paste von hier funzt auch ) : devmgr_show_nonpresent_devices , und als Wert fügst du 1 ein , danach auf ''OK'' klicken und den Rechner neu starten ... dann werden Dir alle Geräte ( auch die momentan nicht angeschlossenen ) angezeigt .

( wenn du den obigen Tipp , den @hansjorg71 in Post#2 verlinkt hat befolgt hast und als Administrator ausgeführt hast , dann sollten Dir aber die Geräte eh alle angezeigt werden ... und nicht vergessen : In der ''Ansicht'' des Gerätemanagers die Anzeige der ausgeblendeten Geräte aktivieren !! )

p.s. : achte auch unbedingt auf Tipp- oder Eingabefehler ! ... es müssen auch die Striche mit eingegeben werden . Und Neustart des Rechners nicht vergessen !!

mfg McC.
 
Zuletzt bearbeitet:

foxx12

lernt immer gern dazu
Ok, werde ich versuchen.

Ich habe den Tip von hansjörg ausprobiert, aber leider wurden mir keine ausgegrauten Geräte angezeigt. Ich habe mir aber nur im Gerätemanager die Anzeige der ausgeblendeten Geräte aktiviert, ohne die Kommandozeile. Dachte, das reicht auch.

Also werde ich Eure Tips so wie beschrieben abarbeiten. Hoffentlich klappt´s. Leider komme ich erst am WE dazu. Ich werde dann eine Rückmeldung geben.

Vielen Dank!
 

McC.

gehört zum Inventar
@foxx12

... du kannst auch ganz auf die Komandozeile verzichten , alle nötigen Schritte kannst du auch manuell durchführen ;) ( siehe Post#4 )
Was den Gerätemanager angeht , einfach oben im Fenster auf ''Ansicht'' klicken und dann auf ''Ausgeblendete Geräte anzeigen'' , wichtig ist aber , das du die neue Benutzervariable genau nach der Anleitung anlegst .

mfg McC.
 

foxx12

lernt immer gern dazu
So, nun bin ich endlich dazu gekommen, die Anleitung auszuführen. Ich habe die Umgebungsvariable so wie beschrieben eingerichtet, damit mir immer alle inaktiven Geräte angezeigt werden.

Hat super geklappt.

Ich habe die USB-Massenspeichergeräte deinstalliert und dann die "zu langsame" HDD wieder angeschlossen. Siehe da, der Treiber wurde neu installiert. Wenn ich sie jetzt an den entsprechenden USB-Anschluss anstöpsele funktioniert sie ganz normal und die Meldung "USB-Gerät kann eine höhere Leistung erzielen..." kommt nicht mehr.

Vielen Dank!!!:)
 
Oben