Perflib 1017+1018+3003

VT12

gehört zum Inventar
Hallo liebe Windows10 Kenner.
Wie der Titel schon sagt gehts um diesen Fehler. Er wird mehrmals täglich mit div. ID gemeldet.
Aufmerksam geworden bin ich darauf weil ich einige Abstürze von MS Access zu verzeichnen hatte.
Der Perflib Fehler ist aber recht neu bei mir, weil meine Installation recht sauber ist was diese üblichen Fehler betrifft.
Dieser ist jedoch sehr hartnäckig. Ob er die Ursache ist für die Access Abstürze weiß ich nicht.
Auch Updates könnten die Ursache sein.
Was ich bisher darüber gelesen habe ist frustrierend. Weil keiner den Fehler wirklich eleminieren konnte.
Die Empfehlungen sind breit gefächert, von ScanSfc / od. lodctr / über Inplace bis Neuinstallation.
Ein Nutzer berichtete sogar das dieses durchgeführte Inplace so ziemlich alles zerschossen hatte, das er ein Backup zurückspielen musste.
Was bei mir immer gemeldet wird ist: Der Open Prozedurname für den Dienst BITS wurde nicht gefunden usw.
Dieser ist tatsächlich in der Registry nicht an der erforderlichen Stelle.
Möglicherweise läßt sich der Fehler beheben in dem jemand einen Screenshot von diesem Schlüssel hier postet.
Dann könnte ich das versuchen um die Meldung loszuwerden.
Oder.- so lassen wie es ist. In der Fehlermeldung ist allerdings zu lesen das dieser Fehler beseitigt werden sollte.
Wäre jemand mal so nett?
Vielen dank.
Ansonsten läuft Windows rund.
 
Anzeige

.Manfred

It's me
Ein ähnliches Problem mit Perflib gab es hier im Forum schon einmal, da hat eine Neuinstallation geholfen.
Da wirst du wohl auch nicht drum rum kommen.
 

IngoBingo

gehört zum Inventar
Ansonsten läuft Windows rund.

Dann würde ich nicht zu viel Zeit in die Jagd von Eventlog-Meldungen investieren.
Meldungen zu den Performance Countern gibts immer mal wieder und sie sind normalerweise harmlos. Solange das System einwandfrei läuft, muss man sich damit nicht wirklich herumschlagen.

Die Hinweise auf lodctr, die im von Teddy verlinkten Artikel genannt werden, haben die Meldungen meistens hier nicht verschwinden lassen.
 

VT12

gehört zum Inventar
@Teddy26
Die vielfältigen lodctr Möglichkeiten lösen das Problem nicht und die Meldungen bleiben. Steht auch überall so zu lesen.
Es gibt 2 Optionen die wirken offenbar. 1. Nicht beachten, wie IngoBingo auch sagt, sagen auch viele andere.
2. Neuinstallation. Das wäre allerdings ziemlich flach, weil man sich damit nicht nur eine Menge Arbeit einhandelt sondern auch ne Menge neuer Fehler. Das weiß inzwischen jeder.

@Tatantula-X
Dein Kommentar ist so überflüssig wie ein Kropf. Tut nichts zur Sache und ist nichts anderes als Hetze.
Du spielst auf das Nachsehen im EventLog an, was hier mal ein Thema von mir war, das ist längst Schnee von gestern.
-
Das EventLog juckt mich nicht die Bohne. Da hätte ich tagelang zutun.- umsonst. Die Updates spielen alle Fehler wieder ein.
Nur.- wenn ein Windows/Office Prog. unerklärlich abschmiert (Access)
sucht man sinnigerweise auch mal im EventLog um evtl. Fehler aufzuspüren. Das wird auch überall so empfohlen.
Nur aus Jux schau ich da nicht rein. Hier hat aber sogar die Zuverlässigkeitsanzeige die Abstürze gemeldet. Ist auch richtig so.
Den/Die Gründe für die Access Abstürze konnte auch ein anderes (FACH) Forum nicht lösen, es wurde dort von einigen User genauso gemeldet. Dieselben Fehler. (aber anderes Thema)
Wenn man freundlich fragt bekommt man auch häufig vernünfitge Antworten.. Dachte ich.
-
Ich glaube auch den Grund für die Perflib Meldungen zu kennen. Es fehlt der Open Prozess
Der liegt normal im Reg. Schlüssel HKLM\CurrentControlSet\Services usw.
Bei administrator.de wurde das löschen dieser Prozedur als Lösung empfohlen, stimmt aber nicht, wie so viele andere Tips.
-
Ein Versuch, den fehlenden Schlüssel wieder einzufügen, scheitert daran, weil ich nicht weiß wie er genau lauten muss.
Dummerweise hatte ich dem Autor des Artikels vertraut und ausnahmsweise den Org. Schlüssel nicht gesichert.
Vielleicht kann ja doch noch jemand netterweise den Schlüssel / Dword Wert bezeichnen.

Dankesehr an alle.
 

Jürgen

Moderator
Teammitglied
Hallo VT12, bevor man in der Registry was ändert macht man doch vorher eine Sicherung der Registry oder des Systems, oder einen Wiederherstellungspunkt oder ein anderes Backup von Drittherstellern

Dann den Schlüssel eben neu erstellen und der Wert ist meistens 0 oder 1
 
Zuletzt bearbeitet:

VT12

gehört zum Inventar
Stimmt Jürgen,
mache ich auch sonst. Leider diesmal in der Euphorie vergessen, weil ich dem Autor bei Administrator.de Bin aber fast nie in der Registry. Zu riskant.
Es gibts ne Reihe Schlüssel mit 0 oder xx das weiß ich ja.
Hab das Netz schon abgesucht, aber genau den Wert dieses Schlüssels nicht gefunden.
Ich habe natürlich ein Backup von davor, aber damit bin ich schon einmal furchtbar baden gegangen.
Neulich musste ich etwas bez. Garmin in der Reg anpassen, da konnte ich die Änderung zurückspielen, weil ich halt den Schlüssel gesichert hatte. NUR diesmal nicht. Doof, ich weiß.
 

Gismon

treuer Stammgast
Mache mal Folgendes:

1) Windowstaste + R
2) services.msc
3) folgende vier Dienste starten:

Benachrichtigungsdienst für Systemereignisse
COM+-Ereignissystem
Windows-Verwaltungsinstrumentation
Intelligenter Hintergrundübertragungsdienst (BITS)
 

VT12

gehört zum Inventar
Kurzes Feedback.
zu #9
alle Dienste liefen schon.
Gefunden und probiert hatte ich bevor ich gepostet habe:
alles mit lodctr
sfc /scannow
letztendlich noch Dism /Online /Cleanup-Image / CheckHealth (Es wurde keine Komponentenspeicherbeschädigung erkannt)

Ich gebe mal davon aus das weitere Zeit zu investieren nicht lohnt. Weil keiner der angeblichen Fehler-Lösungen die im Netz in den Fachforen zu finden sind zum Ziel führen. Möglicherweise verschwindet diese Meldung genauso wie sie gekommen ist, wie viele andere auch.
Ich denke das dies im Sinne aller ist. Ignorieren.
Wenn der Aschenbecher im Auto voll ist? Kauft man eben ein neues Auto. So der Autofachmann.;)
(Sprich Neuinstallation)
Was ich natürlich auf keinen Fall tun werde, warum auch.
Schöne Ostern euch allen.
 

Anhänge

  • alle perflib fehler.JPG
    alle perflib fehler.JPG
    112,4 KB · Aufrufe: 19

VT12

gehört zum Inventar
Hallo Scorpion68
Die dll ist genau da wo sie sein soll/muss. Auch so eine blöde Fehlmeldung.
Ich werd sie mal de/registrieren. Vielleicht hilfts. Glaube aber die o.g. Open Anweisung wieder einzusetzen wäre ne Option.-
Mal sehen wo ich den exakten Schlüsselwert herbekomme. Versuch macht kluch:)

Der Schlüssel sollte hier zu finden sein:
Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BITS\Performance

Hallo VT12,
die Anwendungserweiterung rasctrs.dll sollte aber im Verzeichnis C:\Windows\System32 vorhanden sein, siehe wie folgt:

Anhang anzeigen 232478

Vielleicht sollte sie auch nur mal neu registriert werden, siehe dazu hier DLL registrieren und deregistrieren - Tipps & Tricks.
Beim Registrierversuch kommt sinngemäß: DllRgisterServer-Eingangspunkt nicht gefunden. Laut Wintotal muss die dll dann nicht registriert werden.
 
Zuletzt bearbeitet:

Jürgen

Moderator
Teammitglied
Wenn Du uns mal sagst welcher genaue Schlüssel jetzt gemeint ist, ich habe mal die genannte reg-Datei unten angehängt wie sie bei mir z.Zt ist,

Vorher die Registry aber sichern

img_054.png
 

Anhänge

  • VT12.reg
    966 Bytes · Aufrufe: 6
Zuletzt bearbeitet:

VT12

gehört zum Inventar
Danke Jürgen, das ist sehr nett. Es ist der vorletzte Schlüssel. OPEN.
Dieser Perflib Fehler tritt immer nach einem Neustart bzw. auch nach dem Aufwachen des Ruhemodus auf, sowie
auch zwischendurch, täglich mehrmals.
Werde deine Reg testen, dann berichten.

Auffällig ist auch folgendes:
Der IntelligenteHintergrundÜbertragungsDienst (Post#9) stand auf MANUELL.
Habe das mal geändert auf Automatisch. Nach Neustart steht er aber wieder auf MANUELL.
Vermutlich regelt Windows das selbst und startet den Dienst wenn nötig.
 

VT12

gehört zum Inventar
Bad News::
zu früh gefreut. Fehler steht wieder drin mit Code 1008 bez. der fehlenden rasctrs.dll. Die man aber nicht neu registrieren kann.
Zweitens ein ganz neuer Fehler, PerfProc, ID 2002. Den hatte ich noch nie.
Verändert habe ich im Grunde nichts, ausser den Schlüssel wie Post#15 eingetragen.
::
Das Auftragsobjekt "\BaseNamedObjects\WmiProviderSubSystemHostJob" kann nicht für Abfragezugriffe geöffnet werden. Der aufrufende Prozess besitzt möglicherweise keine Berechtigung zum Öffnen dieses Auftrags. Die ersten vier Bytes (DWORD) des Datenabschnitts enthalten den Statuscode.
::
Damit kann ich nichts anfangen. Hab aber noch nicht ernsthaft danach recherchiert. Diese Meldung wurde generiert nach einem Neustart mit shutdown -g -t 0.
Möglicherweise etwas zum ignonieren?

Hm, der Perflib Fehler ist bisher mit keiner Methode wehzubekommen. Was meinst du Jürgen? So lassen wie es ist?
Inplace ist mir zu unsicher, alles neu aufsetzen aus verständlichen Gründen sowieso nicht.
Ot.
Ein hier bekannter Autor hat sich im Parallel Forum vor Jahren mit dem Perflib stark beschäftigt, aber dem Hilfesuchenden fiel am Ende auch nichts ein als BITS mit lodctr zu deaktivieren.
 

areiland

Computer Legastheniker
Hab ich schon so oft erwähnt: Werden diese "Fehler" im Sekundentakt protokolliert? Wenn hier ein klares "Nein" zu vermelden ist, dann sind es nur temporäre Ereignisse, die nur deshalb auftreten, weil die zugehörigen Dienste gerade anderweitig beschäftigt sind und deshalb auf eine weitere Anfrage nicht sofort antworten können. Wenn ich diese Meldungen provozieren möchte, frage ich diese Dienste einfach mit drei vier Scripten gleichzeitig ab, schon hab ich dieses Ergebnis.

Und wenn das nur gelegentlich oder im Abstand von Stunden protokolliert wird, dann funktionieren diese Dienste dazwischen ja ganz offensichtlich problemlos.
 

VT12

gehört zum Inventar
Ah. Okay. Hatte ich so nicht mehr auf dem "Schirm". Dann bin ich beruhigt.
Komisch ist halt nur das der "fehler" sehr regelmäßig drin steht. Nicht im Sekundentakt.
Ausser dieser Access Macke läuft ja alles super, auch die Updates usw.
In einem anderen Forum hast du allerdings geschrieben das man der Sache besser nachgehen sollte.
Vermutlich aber nur dann, wenn die Häufigkeit zu hoch sein sollte, wie du hier sagst.
Wie man die Meldungen provoziert, weiß ich nicht, die kommen von alleine.
Wie gesagt, gelernt hab ich ja das dieses EventLog System jeden Furz aufzeichnet.
Dann lass ich es mal so laufen. Wenn es Probleme gibt kann ich immer noch versuchen etwas zu ändern.
Danke Alex und noch schöne Ostern
 
Oben